Rhino 視窗

下面這張圖片是 Rhino 視窗的主要界面功能。

標題列

標題列顯示目前模型的檔案名稱與檔案大小。

顯示完整的檔案路徑...

功能表列

功能表列依功能將 Rhino 指令分組。大多數常用的指令可以在功能表上找到。

查看完整的指令列表...

指令視窗

指令視窗分為指令行歷史記錄和指令行提示。

指令視窗中的文字可以複製並貼上到 Rhino 或文字編輯應用程式的文字對話框中。

  • 按右鍵可開啟快顯功能表,用於執行文字操作或重複最近使用的指令。
指令行歷史記錄

顯示先前的指令和提示。

  • 在快顯功能表選擇「清除」即可刪除所有指令行歷史記錄。
指令行提示

顯示指令操作的提示並允許輸入指令名稱和選項。當 Rhino 視窗處於使用狀態時,您輸入的內容將輸入到指令行,若是在面板上的值方塊中輸入則除外。

指令選項會改變指令的操作方式。例如,繪製圓時,預設會將圓繪製在使用中的工作平面上。按一下選項名稱,或輸入選項中加底線的字母,即可變更指令的操作方式。

執行 Circle 指令

  1. 輸入 "Circle"。

    當輸入的字母足夠過濾出您想執行的指令時,Circle 指令的名稱會自動完成,按 Enter 或在自動完成清單選擇您想要執行的指令。自動完成清單會根據您的輸入過濾掉可能的指令。常用指令會列在頂部。

  2. Circle 指令的選項出現。

  3. 要建立與使用中工作平面垂直的圓,可以使用垂直選項。

模糊比對自動完成

當您輸入指令名稱時,會出現自動完成清單,自動完成清單使用模糊比對。列出的指令分為兩個群組,第一個群組包含以您輸入的字串為開頭的精確符合項目。第二個群組包含非精確符合的項目,依據這些指令與輸入的字串的符合程度排序。

工具列容器

工具列容器是工具列的集合。容器中的每個工具列都顯示為一個標籤。按一下標籤可在工具列之間切換。

工具列包含用於啟動指令的圖示,許多圖示有第二個指令,可以按滑鼠右鍵執行。將滑鼠游標停留在圖示上時顯示的工具提示會說明滑鼠左鍵與右鍵分別執行什麼指令。

按滑鼠左鍵隱藏物件,按滑鼠右鍵顯示物件。
  • 按 按鈕可以自訂容器。

  • 按「+」按鈕可顯示或隱藏工具列。

如何使用和管理工具列?

邊欄

"邊欄"是一種特殊的容器,它可以根據目前使用的工具列標籤顯示現有的容器。在預設的工作環境時,如果點擊曲線工具標籤,繪製曲線邊欄容器將顯示在側邊欄中。

將容器連結到標籤作為邊欄

  1. 在工具列標籤上按右鍵,並選擇內容。
  2. 在容器內容對話框按邊欄區域的 按鈕。

物件鎖點面板

包含物件鎖點的切換選項。

選取過濾器面板與物件鎖點面板群組在同一個容器中。

如何使用物件鎖點...

右側容器

右側容器包含一系列面板,可快速設定某些全域選項、文件內容,或開啟指令對話框。

  • 按 按鈕可以自訂容器。

  • 按「+」按鈕可顯示或隱藏面板。

作業視窗區域

作業視窗顯示 Rhino 模型的工作環境,包括:物件顯示、作業視窗標題、背景、工作平面格線、世界座標軸圖示。

當未選取任何物件時,內容面板將顯示作業視窗內容。

作業視窗標題

每個作業視窗的左上角都有一個作業視窗標題。

  • 點擊三角形按鈕或右鍵點擊作業視窗標題可以顯示視圖管理指令的功能表。大多數指令都可以在功能表列的"檢視"功能表找到。

  • 按一下作業視窗的標題可啟用該作業視窗而不會取消選取物件。

  • 在作業視窗標題上按兩下可將作業視窗最大化,或還原多作業視窗配置。

  • 拖曳作業視窗標題可以移動作業視窗。

作業視窗標籤

預設情況下,作業視窗標籤位於主作業視窗框架的底部。每個模型和圖紙配置作業視窗都有一個標籤。這些標籤可讓您在作業視窗之間切換,尤其是在作業視窗最大化時。

ViewportTabs 指令可管理標籤的外觀。

快顯功能表

在作業視窗中按住滑鼠右鍵再放開時,會出現三種快顯功能表的其中一種。

在快顯功能表中選擇將項目加到此功能表...可以自訂的方式將選項對話框中的特定功能表上的項目加入。

狀態列

狀態列位於 Rhino 視窗的底部。它會顯示目前的座標系統、游標所在的位置與各種狀態列面板。

工作平面

x

y

z

英吋

■ 圖層

鎖定 格點

正交

平面的

物件鎖點

智慧軌跡

自動工作平面

操作軸

記錄 建構歷史

反鋸齒

資訊

切換左側邊欄的顯示

點擊 按鈕可展開或折疊左側邊欄。

折疊後,按一下圖示可暫時顯示容器。

功能表項目的說明

滑鼠游標停留在功能表項目上時,狀態列會顯示該項目的說明。

工作平面 / 世界

切換工作平面座標與世界座標。

x/y/z

滑鼠游標位置的 x/y/z 座標。

單位 / 差值

目前使用的單位設定。

執行繪圖指令時,顯示從上一個指定點到目前位置的距離。

圖層面板

有選取物件時,圖層面板會顯示選取物件所在的圖層。

沒有選取物件時,圖層面板會顯示目前的圖層。

  • 點擊圖層面板可設定快速控制,設定所選物件的圖層或變更圖層的可見性和狀態。在彈出的圖層清單中,右鍵點擊可以顯示快顯功能表。

    快顯功能表

    選取物件

    選取圖層上的所有物件,子圖層上的物件除外。

    變更物件圖層

    將選取的物件移動至該圖層。

    複製物件至圖層

    將選取的物件複製至該圖層。

  • 在圖層面板上按滑鼠右鍵可以彈出圖層面板視窗。

  • 在進階設定搜尋 StatusBarLayerPaneWidth 可以使圖層面板更寬 (顯示更多圖層資訊) 或更窄 (佔用更少的空間)。
鎖定格點面板
  • 按一下鎖定格點面板可切換格點鎖定。

    當模式開啟時,該面板會亮起。

  • 在面板上按滑鼠右鍵可以設定選項。

格點鎖定選項

開啟/關閉 格點 鎖定

切換格點鎖定的狀態,與在鎖定格點面板上按滑鼠左鍵的意思相同。

使用中的作業視窗 / 全部作業視窗選項
顯示格線

切換工作平面格線的可見性。

顯示格線軸

切換工作平面 XY 軸的可見性。

顯示世界座標軸圖示

切換作業視窗左下角的世界座標軸圖示的可見性。

設定鎖定間距<值>

指定格點鎖定間距並顯示目前大小。

設定

開啟文件內容 > 格線頁面。

正交面板
  • 在正交按鈕上按滑鼠左鍵可以切換正交模式的狀態。

    當模式開啟時,該面板會亮起。

  • 在面板上按滑鼠右鍵可以設定選項。

正交選項

開啟/關閉正交

切換正交的狀態,與在正交面板上按滑鼠左鍵的意思相同。

設定正交角度<值>

指定正交角度並顯示目前角度。

啟用正交時,刻度標記會指出目前的正交角度。

  • 如果您想隱藏刻度標記,請在進階設定中停用 ShowOrthoHashMarks。

  • 如果啟用進階設定中的 DominantOrtho,且正交模式為作用中,您可以在鎖點位置周圍移動滑鼠游標,直接鎖定到該位置,或將物件鎖點投影到正交方向。

鎖點於工作平面 Z

當滑鼠游標移動到視圖中先前選取位置的上方或下方時,鎖定到工作平面的 Z 方向。

此功能表項目可切換 Rhino 選項 > 建模輔助中的正交鎖定至工作平面 Z 核取方塊。

設定

開啟選項 > 建模輔助頁面。

平面模式面板
  • 在平面模式按鈕上按滑鼠左鍵可以切換平面模式的狀態。

    當模式開啟時,該面板會亮起。

  • 在面板上按滑鼠右鍵可以設定選項。

平面模式選項

開啟/關閉平面模式

切換平面模式的狀態,與在平面模式面板上按滑鼠左鍵的意思相同。

物件鎖點面板
  • 物件鎖點控制項可讓您選擇目前要使用的物件鎖點。

  • 當物件鎖點面板關閉時,按一下物件鎖點面板會將其開啟。如果面板已開啟,則會切換停用核取方塊。

  • 在面板上按滑鼠右鍵可以設定選項。

物件鎖點選項

開啟/關閉 物件鎖點 列

切換物件鎖點控制項的開啟/關閉狀態。這與按一下物件鎖點面板的作用相同。

鎖點於被遮蔽的物件

開啟後,可以鎖點於被其他物件遮蔽的物件。

鎖點於鎖定的物件

切換是否可以鎖點於鎖定的物件。

只鎖定選取的物件

只有選取的物件可以被鎖定。

鎖定視角交點

切換是否可以鎖點於物件在視角上的交點。

設定

開啟選項 > 建模輔助頁面。

智慧軌跡面板
  • 在智慧軌跡按鈕上按滑鼠左鍵可以切換智慧軌跡的狀態。

    當模式開啟時,該面板會亮起。

  • 在面板上按滑鼠右鍵可以設定選項。

智慧軌跡選項

開啟/關閉智慧軌跡

切換智慧軌跡的狀態,與在智慧軌跡按鈕上按滑鼠左鍵的意思相同。

設定

開啟選項 > 建模輔助 > 智慧軌跡頁面。

操作軸面板
  • 按一下操作軸面板可切換操作軸在選取物件上的顯示。

    當操作軸開啟時,該面板會亮起。

  • 在面板上按滑鼠右鍵可顯示操作軸功能表。

操作軸功能表

重新定位操作軸

將操作軸移動離開預設的位置。

  • SubD 次物件選取集會記住操作軸的位置。

重設操作軸

將操作軸還原為預設的位置與定位。

自動重設操作軸

旋轉物件時,重設操作軸以根據原始對齊方式與工作平面或世界座標軸對齊。

開啟操作軸

在選取的物件上顯示操作軸。

關閉操作軸

停用操作軸。

對齊工作平面

操作軸與工作平面 XYZ 方向對齊。操作軸原點位於物件面向工作平面的邊框方塊中心。

對齊物件

操作軸對齊物件。

對於不同的物件類型,預設的對齊方式是不同的。

  • 選取控制點時,移動控制軸會與其控制多邊形對齊。如果該點沒有 U 或 V 方向,則不會顯示對應的 U 或 V 控制軸。

對齊世界平面

操作軸與世界 XYZ 方向對齊。操作軸原點位於物件面向世界的邊框方塊中心。

對齊視圖

操作軸與目前作業視窗的視圖平面對齊。

可鎖點

拖曳時可使用物件鎖點。

不鎖點

拖曳時不使用物件鎖點。

  • 功能表熱點在不鎖點拖曳時顯示為圓形,在可鎖點拖曳時顯示為正方形。

  • 拖曳控制軸時,可使用指令行的型式選項在平滑與可鎖點模式之間切換。

擠出後合併面

在可能的情況下,合併與擠出操作相關的共面。

視圖繞著操作軸旋轉

當操作軸控制項顯示時,圍繞操作軸原點旋轉視圖,反之則是圍繞中心旋轉視圖。

拖曳強度

設定操作軸的拖曳速度,預設值 100% 時操作軸的移動距離與滑鼠游標一致。

需要以操作軸微調控制點時可以將這個百分比調低一些,讓操作軸的移動距離小於滑鼠游標的移動距離。拖曳強度對話框關閉時,拖曳強度將恢復為 100%。

設定...

開啟操作軸選項頁面。

自動工作平面面板
  • 按一下自動工作平面面板可將其開啟或關閉。

    當模式開啟時,該面板會亮起。

    在 AutoAlignCPlane 指令主題尋找更多資訊。

  • 在面板上按滑鼠右鍵可以設定選項。

自動工作平面選項

固定自動工作平面

工作平面會停留在先前選取的平面物件/次物件上,直到選取另一個平面物件/次物件。

啟用固定模式後 (上方示圖),當選取圓柱體或未選取任何內容時,工作平面會停留在曲面其中之一的平面上。
鎖定 自動 工作平面

將工作平面鎖定在目前位置和方向。

鍵盤快速鍵: Ctrl(CMD)+1

自動工作平面面板上的鎖定/圖示表示目前的鎖定狀態。

  • 按一下鎖定圖示可切換鎖定狀態。

對齊 物件

將工作平面與選取曲線或曲面的平面對齊。

對齊 世界平面

嘗試將工作平面的 X 軸和 Y 軸與世界座標對齊。

對齊 視圖

嘗試將工作平面的 Y 軸與與視圖攝影機的朝上方向對齊。

  • 按 Ctrl(CMD)+R 可透過物件、世界和視圖變更對齊模式。

記錄建構歷史面板
  • 在建構歷史按鈕上按滑鼠左鍵可開啟/關閉記錄建構歷史。

    當記錄建構歷史開啟時,該面板會亮起。

  • 在面板上按滑鼠右鍵可以設定選項。

記錄建構歷史選項

總是 記錄 建構歷史

對所有支援建構歷史的指令開啟建構歷史記錄,直到將其關閉。

更新 子物件

當輸入物件變更時,自動更新子物件。

鎖定 子物件

鎖定以建構歷史建立的物件。

破壞 建構歷史 警告

當父物件與子物件之間的連結中斷時,顯示警告訊息。

過濾器面板
  • 當選取過濾器面板關閉時,按一下過濾器面板會將其開啟。如果面板已開啟,則會切換停用核取方塊。

過濾選項

開啟/關閉 選取過濾器 列

切換選取過濾器列的顯示狀態。

資訊面板
  • 按一下資訊面板可顯示目前 Rhino 工作階段的資訊。資訊面板會輪流顯示所指定的各個類別。

資訊選項

選取的物件數目

選取的物件圖層

相對座標

曲線參數/UV 座標

註解型式

附註

絕對公差

角度公差

目前的圖層

目前圖層的線型

關閉的圖層數目

目前的文字字型

工作平面名稱

工作平面/同步工作平面

平行視圖鏡頭長度

距離上次儲存的時間 (分鐘)

記憶體使用量

切換右側邊欄的顯示

點擊 按鈕可展開或折疊右側邊欄。

折疊後,按一下面板圖示可暫時顯示面板。

相關的指令

ToggleLeftSidebar

工具列 功能表 狀態列

未在工具列上。

未在功能表裡。

ToggleLeftSidebar 指令可顯示/隱藏 Rhino 視窗的左側邊欄。

 

 

ToggleRightSidebar

工具列 功能表 狀態列

未在工具列上。

未在功能表裡。

ToggleRightSidebar 指令可顯示/隱藏 Rhino 視窗的右側邊欄。

請參考

Rhino Wiki: Mac 用戶界面功能