Layer

工具列 功能表

圖層
標準

編輯

圖層 > 編輯圖層

視窗

面板 > 圖層

Layer 指令可開啟管理圖層內容的面板。

圖層是組織物件的一種方式,讓您可以一次操作所有物件,或以某種方式追蹤物件。當物件位於同一個圖層時,您可以一次關閉它們、變更它們的線框顯示顏色,並以一次選取操作選取所有物件。

圖層面板

容器選項

圖層面板會顯示模型裡的圖層。

當有圖紙配置作業視窗時,會顯示一組擴充的欄位。

當有連結的圖塊或分工作業時,這些外部檔案裡的圖層會以樹狀結構顯示在圖塊名稱之下。

圖層面板提供管理模型圖層的工具。

彈出的圖層清單可讓您使用常用的圖層設定:開啟/關閉、鎖定/解除鎖定、顏色與目前的狀態。

彈出快捷視窗

  • 在狀態列的圖層上按滑鼠左鍵。

    您可以使用彈出的圖層清單快速變更圖層的選項。右鍵點擊圖層彈出視窗,可顯示快顯功能表。

    快顯功能表

    選取物件

    選取圖層上的所有物件,子圖層上的物件除外。

    變更物件圖層

    將選取的物件移動至該圖層。

    複製物件至圖層

    將選取的物件複製至該圖層。

附註

  • 沒有物件被選取時,從狀態列彈出的圖層視窗選取圖層,會將該圖層設為目前的圖層。
  • 有物件被選取時,從狀態列彈出的圖層視窗選取圖層,會將選取的物件移至該圖層,目前的圖層不會變更。
  • 除非有物件被選取,否則狀態列的圖層窗格會顯示目前的圖層。有物件被選取時,狀態列的圖層窗格會顯示所選物件的圖層,如果物件位於多個圖層則顯示「varies」。

開啟圖層面板

  • 在狀態列的圖層上按滑鼠右鍵。
    或
  • 從視窗 > 面板功能表啟用圖層。

圖層內容

名稱

圖層名稱。

請參考: Rhino 的命名規則

目前的

打勾與底色表示目前的圖層。

開啟 / 關閉

同時控制模型、圖紙配置和子視圖中圖層的可見性,除非該圖層透過模型開啟、圖紙配置開啟或子視圖開啟進行設定。

鎖定 / 解除鎖定

控制圖層上物件的可選取狀態。

子圖層的狀態

  • 如果父圖層關閉或鎖定,半開燈泡或鎖定圖示會顯示子圖層將由父圖層控制。
  • 如果燈泡或鎖定圖示全部變灰色,那麼子圖層就有自己的控制權,不會隨父圖層變化。
  • 當父圖層關閉或鎖定時,子圖層無法自行開啟或解鎖。
顏色

此圖層上的物件預設的螢幕顯示顏色。

材質

材質用於彩現。

圓形圖示顯示材質縮圖。

RenderAssignMaterialToLayer

線型

指定給圖層的線型。

列印顏色

指定給圖層、僅用於列印的顏色。

列印線寬

開啟「選擇列印線寬」對話框。指定給圖層、僅用於列印的線寬,如果不希望該圖層被列印,請指定「不列印」。

自訂線寬

  • 將線寬值加入 Rhino 支援資料夾中的 printwidths.txt 檔案:

    %AppData%\McNeel\Rhinoceros\<Version>\Localization\<Language>\Support\

在 printwidths.txt 檔案:

  • 行的開頭若是 ; 或 // 將會被忽略。

  • 線寬值必須大於 0。

變更多個圖層的設定

  1. 選取圖層。

  2. 使用 Ctrl(CMD)+點選或 Shift+點選選取更多圖層。

  3. 按燈泡圖示可一次開啟/關閉所選的圖層。

    此操作可與其他圖層設定搭配使用。

斷面型式

設定如何填滿圖層上物件的截斷面。

  • 斷面型式的顏色會覆寫列印顏色。

無

不用剖面線圖案填滿截斷面。

自訂

使用斷面型式對話框裡所選的剖面線圖案填滿截斷面。

開啟新增子視圖

控制新子視圖中子視圖開啟設定的預設狀態。

模型開啟 / 圖紙配置開啟 / 子視圖開啟

當全域可見性設定開啟時,分別控制模型、圖紙配置和子視圖中圖層的可見性。

圖紙配置/子視圖顏色

此圖層上的物件在圖紙配置或子視圖中預設的螢幕顯示顏色。

圖紙配置/子視圖列印顏色

指定給圖紙配置或子視圖圖層、僅用於列印的顏色。

圖紙配置 / 子視圖列印線寬

設定一個圖層的物件在圖紙配置/子視圖的預設列印線寬,也可以設為不列印。Properties 指令可變更個別物件的內容。

描述

輸入圖層的文字備註。

圖層工具列選項

新圖層

點擊以使用新圖層的顏色建立新圖層。

隨機顏色的新圖層

右鍵點擊以建立具有隨機顏色的新圖層。

Tab 和 Insert 鍵

編輯圖層名稱時,按 Tab 或 Insert 鍵可接受名稱編輯並建立新圖層。這使得建立多個圖層變得更加容易。

新子圖層

點擊使用新圖層顏色建立一個屬於所選圖層的新圖層。

隨機顏色的新子圖層

右鍵點擊以建立一個屬於所選圖層並具有隨機顏色的新圖層。

  • 將圖層拖放至其他圖層之下,可使其成為子圖層。
  • 位於同一層級的圖層名稱不可重複。
刪除

如果您要刪除的圖層上有物件,會彈出警告對話框。

預設情況下,在圖層面板中按鍵盤的 Delete 鍵會刪除作業視窗中選取的物件,而不是選取的圖層。若要啟用刪除圖層,請在進階設定中將 EnableLayersPanelDeleteKey 變更為 true。

清除未使用的圖層

刪除所有不含任何物件的圖層。

變更物件圖層

將選取的物件移動至選取的圖層。

複製物件至圖層

將選取的物件複製至選取的圖層。

步驟

  1. 選取一個物件。
  2. 選取目標圖層。
  3. 以左鍵或右鍵點擊按鈕。

請參考:ChangeLayer 指令。

上移

將選取的圖層在清單中往上移。

下移

將選取的圖層在清單中往下移。

上移一層父圖層

將選取的圖層在圖層樹狀結構中上移一個層級。

過濾器

當模型有大量圖層時,圖層清單可能不容易管理。圖層過濾器可讓您調整圖層在面板中的可見性。

圖層過濾器選項

所有圖層
開啟的圖層
關閉的圖層
鎖定的圖層
未鎖定的圖層
有物件的圖層
空的圖層
選取的圖層
  • 點擊核取方塊可啟用或停用該過濾器。

  • 在核取方塊上按右鍵可啟用該過濾器並停用其他所有過濾器。

欄位

顯示標題欄清單以顯示或隱藏圖層設定。

在欄位標題上按右鍵會顯示相同的清單。

工具
圖層狀態管理員

開啟圖層狀態面板。

全選

選取清單中目前顯示的所有圖層。

選取物件圖層

選取目前所選物件所屬的圖層。

反選

反向選取。所有已選取的圖層會變成未選取,所有未選取的圖層會變成已選取。

選取物件

選取目前所選圖層上的物件。

選取子圖層的物件

選取目前所選圖層及其子圖層上的物件。

變更物件圖層

將選取的物件變更至選取的圖層。

請參考:ChangeLayer 指令。

複製物件至圖層

將選取的物件複製到選取的圖層。

開啟全部圖層

開啟所有隱藏的圖層。

全部展開

顯示所有子圖層。

全部摺疊

隱藏所有子圖層。

欄位

選擇圖層面板要顯示的欄位。

欄位排序

允許依欄位排序圖層。取消勾選可避免圖層不小心被重新排序。

搜尋

輸入文字只會列出名稱中包含該文字的圖層。

可使用萬用字元來比對模式:

* = 符合零個或多個字元
? = 剛好一個字元

狀態列

狀態列位於圖層面板的底部,顯示圖層的總數以及目前選取的圖層數量。

圖層清單選項

排序清單

  • 按一下欄位標頭。

    圖層名稱按自然排序順序排序。

    自然排序順序: 1, 2, 3, 10 (10 列在 3 之後)

    字母順序排序順序: 1, 10, 2, 10 (10 列在 2 之前)

隱藏或顯示欄位

  • 在欄位標題上按滑鼠右鍵,勾選或取消欄位名稱。

調整欄位寬度

  • 拖曳欄位標題的分隔線。

編輯圖層的內容

  • 在一個圖層名稱上按滑鼠右鍵,選取快顯功能表中的選項,或從上方的工具列選擇選項。

選取圖層

  • 在圖層清單上按住滑鼠左鍵並拖曳游標,可選取多個圖層。
  • 按住 Shift 可選取連續的圖層名稱。
  • 按住 Ctrl 可選取多個個別的圖層名稱。
  • 若要快速選取除了少數幾個圖層以外的所有圖層,請先全選圖層,再減選較少數的圖層。

圖層快顯功能表選項

彈出圖層快顯功能表

  • 在圖層欄位上按滑鼠右鍵即可啟用。

    在不同的欄位上按右鍵時,快顯功能表可能會顯示不同的項目。

分工作業參考(僅適用分工作業的圖層)

進一步的資訊請參考分工作業。

設為啟用中的模型

切換要編輯的檔案。

目前啟用中的檔案會變為附加檔案,並提示您儲存目前啟用中的檔案。

移除模型

從分工作業管理員移除外部檔案。

更新模型

將選取的附加檔案更新至目前的狀態。

附加模型

附加外部檔案到分工作業管理員。

重設連結圖塊圖層內容

還原連結圖塊中參考圖層的原始內容,包括開啟、鎖定、顏色、列印顏色、列印線寬、新子視圖開啟與模型開啟。這個選項僅在您於連結圖塊的參考圖層名稱上按右鍵時可用。

還原預設值

將按右鍵的欄位重設為預設值。

隨機顏色 (僅適用模型視圖的顏色欄位)

為選取的圖層分配隨機顏色。

混合顏色(僅限模型視圖的顏色欄位)

使用選取的第一個與最後一個圖層的顏色,在所選圖層之間建立漸層色。這個選項在您於模型視圖的顏色欄位中,對圖層的色票按右鍵時可用,且僅在選取三個或更多圖層時才會啟用。

只在選取的子視圖關閉此圖層 (僅適用圖紙配置開啟欄位)
> 此圖紙配置

在選取的子視圖關閉圖層,並在目前圖紙配置中的所有其他子視圖開啟圖層。

> 所有圖紙配置

在選取的子視圖關閉圖層,並在所有圖紙配置中的所有其他子視圖開啟圖層。

只在選取的子視圖開啟此圖層 (僅適用圖紙配置開啟欄位)
> 此圖紙配置

在選取的子視圖開啟圖層,並在目前圖紙配置中的所有其他子視圖關閉圖層。

> 所有圖紙配置

在選取的子視圖開啟圖層,並在所有圖紙配置中的所有其他子視圖關閉圖層。

只在這個子視圖關閉此圖層 (僅適用子視圖開啟欄位)
> 此圖紙配置

在使用中的的子視圖關閉圖層,並在目前圖紙配置中的所有其他子視圖開啟圖層。

> 所有圖紙配置

在使用中的的子視圖關閉圖層,並在所有圖紙配置中的所有其他子視圖開啟圖層。

只在這個子視圖開啟此圖層 (僅適用子視圖開啟欄位)
> 此圖紙配置

在使用中的的子視圖開啟圖層,並在目前圖紙配置中的所有其他子視圖關閉圖層。

> 所有圖紙配置

在使用中的的子視圖開啟圖層,並在所有圖紙配置中的所有其他子視圖關閉圖層。

選取物件

選取所選圖層上的物件。

選取子圖層的物件

選取所選圖層的子圖層上的物件。

變更物件圖層

選取模型中的物件,將其變更至選取的圖層。

複製物件至圖層

選取要複製到選取圖層的物件。

新圖層

建立一個圖層。

新子圖層

建立新的子圖層。

複製圖層

複製圖層及其屬性。

複製圖層與物件

複製圖層及其屬性,以及圖層上的所有物件。

請參考:DupLayer 指令。

只開啟一個圖層

開啟選取的圖層,並關閉所有其他圖層。

請參考:OneLayerOn 指令。

符合內容

選取要符合的圖層。

請參考:MatchProperties。

刪除

刪除選取的圖層。

重新命名

編輯選取圖層的名稱。

展開子圖層

展開所選父圖層的圖層樹狀結構。

摺疊子圖層

摺疊所選父圖層的圖層樹狀結構。

圖層鍵盤快速鍵

標準清單控制項快速鍵

▲

將選取項目上移。

▼

將選取項目下移。

PageUp

將選取項目上移一頁。

PageDown

將選取項目下移一頁。

Home

將選取移至第一個項目。

End

將選取移至最後一個項目。

Ctrl

將個別的圖層加入選取。

Shift

將一段範圍的圖層加入選取。

圖層專用快速鍵

圖層面板必須具有焦點(游標位於圖層面板上方),這些快速鍵才能作用。

F2 / Enter

重新命名選取的圖層。

F5

重新整理圖層清單。

Insert

在選取的圖層下方建立新圖層。

+

展開選取的圖層。

Ctrl 或 
Shift +
數字鍵盤 +

展開選取圖層的所有子圖層。

-

摺疊選取的圖層。

Ctrl 或 Shift + 
數字鍵盤 -

摺疊選取圖層的所有子圖層。

欄位選項

顯示/隱藏圖層對話框中的欄位

名稱

目前的

開啟

鎖定

顏色

材質

線型

列印顏色

列印線寬

有圖紙配置時,會出現其他選項:

圖紙配置開啟

圖紙配置顏色

圖紙配置列印顏色

圖紙配置列印線寬

有子視圖時,會出現其他選項:

子視圖開啟

子視圖顏色

子視圖列印顏色

子視圖列印線寬

相關的指令

ChangeLayer

工具列 功能表

圖層

編輯

圖層 >

變更物件圖層

ChangeLayer 指令可變更選取的物件所在的圖層。

步驟

  1. 選取物件。
  2. 從清單中選取圖層名稱。

物件的圖層選項

可用圖層

名稱

圖層名稱。

  • 雙擊圖層名稱設定目標圖層並關閉對話框。
設為目前的圖層

將目的圖層設為目前的圖層。

選取

在作業視窗選取物件以指定圖層。

新增

建立一個圖層。

ChangeToCurrentLayer

工具列 功能表 面板

圖層

編輯

圖層 >

變更物件至目前的圖層

圖層

在圖層名稱上按滑鼠右鍵 >

變更物件圖層

ChangeToCurrentLayer 指令可將選取的物件移至目前的圖層。

步驟

CopyToLayer

工具列 功能表

圖層

編輯

圖層 >

複製物件至圖層

CopyToLayer 指令可將選取的物件複製到指定的圖層。

步驟

  1. 選取物件。
  2. 從清單中選取圖層名稱。

複製物件的目的圖層

可用圖層

名稱

圖層名稱。

  • 雙擊圖層名稱設定目標圖層並關閉對話框。
設為目前的圖層

將目的圖層設為目前的圖層。

選取

在作業視窗選取物件以指定圖層。

新增

建立一個圖層。

使用指令行的隱藏選項

  • 在指令名稱前加上連字號:-CopyToLayer
指令行選項

NewLayer

建立新圖層。

SelectObject

選取一個物件以指定圖層。

SetCurrent

是/否

HighlightObjectLayers

工具列

功能表

圖層

編輯

圖層 > 醒目提示物件圖層

當圖層面板顯示時,HighlightObjectLayers 指令會選取所選物件的圖層。

LayerStateManager

工具列 功能表

圖層

編輯

圖層 > 圖層狀態管理員

視窗

面板 > 圖層狀態

LayerStateManager 指令可以:

  • 儲存圖層目前的狀態。

  • 還原之前儲存的圖層狀態。

  • 從 .3dm 檔案匯入圖層狀態清單。

步驟

  1. 設定您的圖層。
    圖層狀態管理員會儲存目前的圖層設定。
  2. 在圖層狀態管理員面板中按一下儲存,然後輸入此組態的名稱。

圖層狀態面板

容器選項

工具列按鈕

儲存

儲存新的圖層狀態。

  • 按"名稱"的標題欄,切換遞增和遞減的排列順序。

請參考: Rhino 的命名規則

還原

還原至指定的圖層狀態。

刪除

刪除選取的圖層狀態。

匯入

從 .3dm 檔案匯入圖層狀態清單。

搜尋方塊

輸入文字只會列出名稱中包含該文字的圖層狀態。

右鍵功能表

還原

還原至指定的圖層狀態。

刪除

刪除選取的圖層狀態。

重新命名

編輯選取的圖層狀態名稱。

儲存

儲存新的圖層狀態。

更新

以目前的圖層設定覆蓋選取的圖層狀態。

要還原的圖層設定

還原模型空間中圖層的狀態。

目前的
開啟/關閉
鎖定/未鎖定
顏色
材質
已展開
線型
列印顏色
列印線寬
斷面型式
開啟新增子視圖

要還原的圖紙配置或子視圖的圖層設定

還原圖紙配置或子視圖中圖層的狀態。

開啟/關閉
顏色
列印顏色
列印線寬
  • 當您在圖紙配置作業視窗中儲存圖層狀態,且沒有作用中的子視圖時,會儲存圖紙配置的圖層內容。

  • 圖紙配置與子視圖在圖層狀態中共用相同的圖層內容。這些圖層內容可還原至作用中的子視圖或多個選取的子視圖。如果目前沒有作用中或選取的子視圖,圖層內容會還原至目前的圖紙配置。

  • 如果圖層狀態是在模型作業視窗中儲存的,將圖層狀態還原至圖紙配置或子視圖時,會將整體圖層內容套用到圖紙配置/子視圖的圖層內容。

OneLayerOn

工具列 功能表

圖層

編輯

圖層 >

只開啟一個圖層

OneLayerOn 指令可選取一個圖層,開啟此圖層,並關閉所有其它圖層。

步驟

  1. 點選一個模型作業視窗使其成為作用中。

  2. 從圖層清單中選取要保持開啟的圖層。

    或按選取按鈕,選取目標圖層上的物件。

OneLayerOff

工具列 功能表

圖層

編輯

圖層 >

只關閉一個圖層

OneLayerOff 指令可關閉所選物件的圖層。

步驟

  • 在模型視窗中的圖層上選取一個物件。

RenderAssignMaterialToLayer

工具列 功能表

未在工具列上。

未在功能表裡。

RenderAssignMaterialToLayer 指令可從指令行將材質賦予給圖層。

步驟

  1. 輸入材質的名稱或 ID 以選取材質。

  2. 輸入圖層的名稱或 ID 以選取圖層。

請參考

RenderAssignMaterialToLayersOfObjects

可從指令行將材質賦予給選取物件的圖層。

RenderAssignMaterialToObjects

可從指令行將材質賦予給選取的物件。

RenderAssignMaterialToLayersOfObjects

工具列 功能表

未在工具列上。

未在功能表裡。

RenderAssignMaterialToLayersOfObjects 指令可從指令行將材質賦予給選取物件的圖層。

步驟

  1. 輸入材質的名稱或 ID 以選取材質。

  2. 選取一個或多個物件。

請參考

RenderAssignMaterialToLayer

從指令行將材質賦予給圖層。

RenderAssignMaterialToObjects

可從指令行將材質賦予給選取的物件。

SetLayerToObject

工具列 功能表

圖層

編輯

圖層 >

以物件設定目前的圖層

SetLayerToObject 指令可設定選取的物件所在的圖層為目前的圖層。

步驟

  • 選取要設為目前的圖層的圖層上的物件。

請參考

Snapshots

Snapshots 指令可儲存及還原已命名視圖、位置記錄、圖層狀態、彩現設定,物件設定包含 鎖定/隱藏 狀態、 顯示模式、材質、 位置、 燈光設定、彩現圓管、置換、彩現圓角、裝飾線 以及 彩現厚度。

複製物件

使用圖層

使用圖塊、群組與分工作業

以指令碼管理圖層

McNeel Wiki:匯入的圖層與連結圖塊的圖層名稱