彩現後處理效果

彩現視窗有一些彩現後的功能,例如:通道顯示、色調對應、後處理效果、縮放...等。

工具列

複製彩現視窗

建立目前彩現視窗的複本,便於比較不同的後處理效果設定的差別。

另存新檔

將彩現影像儲存為一般的圖片檔案,使用支援高動態範圍的彩現器時可以儲存特殊的 HDRi 與 OpenEXR 格式。

支援的檔案類型
  • Windows Bitmap (.bmp)
  • JPEG - JFIF Compliant (.jpg, .jpeg, .jpe)
  • Portable Network Graphics (.png)
  • Tagged Image File Format (.tif, .tiff)
  • Truevision Targa (.tga)
  • HDRi 檔案 (.hdr, .hdri)
  • OpenEXR 檔案 (.exr)
  • Rhino 彩現影像 (.rimage)
複製

複製整個按鈕圖示至 Windows 剪貼簿。

放大

放大影像以便更近距離檢視內容。

縮小

縮小影像以便一次看到更多內容。

縮放至符合視窗

調整影像,使所有內容都顯示在視窗內。

顯示 RGB 通道

以所有的顏色通道顯示彩現影像。

請參考:Wikipedia: Channel (digital image)

顯示 RGBA 通道

顯示所有顏色通道並將透明背景顯示為網格。

顯示紅色通道

只顯示彩現影像的紅色通道。

顯示綠色通道

只顯示彩現影像的綠色通道。

顯示藍色通道

只顯示彩現影像的藍色通道。

顯示 Alpha 通道

只顯示彩現影像的 Alpha (透明) 通道。

請參考:Webopedia: Alpha channel

顯示距離通道

以灰階色顯示彩現影像裡每一個像素距攝影機的遠近。

請參考:Wikipedia: Z-Buffering

顯示法線通道

以 RGB 顏色顯示法線方向。

如果平面的法線方向指向世界座標 X 軸正向的方向,則該面會顯示為紅色。

世界 +X=紅色,+Y=綠色,+Z=藍色。
開啟效果面板

效果面板可以設定彩現影像的曝光度及加入各種後處理效果。

停止彩現

終止彩現運算。

暫停

暫停或繼續彩現。

檔案功能表

複製彩現視窗

製作目前彩現視窗的副本。所有通道和後處理效果的設定均保留。

開啟

開啟 Rhino 的彩現影像檔案 (.rimage),這個檔案格式可以儲存所有的通道,檔案重新開啟後可以再加入後處理效果。

另存新檔

將彩現影像儲存為一般的圖片檔案,使用支援高動態範圍的彩現器時可以儲存特殊的 HDRi 與 OpenEXR 格式。

支援的檔案類型

  • Windows Bitmap (.bmp)
  • JPEG - JFIF Compliant (.jpg, jpeg, .jpe)
  • Portable Network Graphics (.png)
  • Tagged Image File Format (.tif, .tiff)
  • Truevision Targa (.tga)
  • HDRi 檔案 (.hdr, .hdri)
  • OpenEXR 檔案 (.exr)
  • Rhino 彩現影像 (.rimage)
最近的彩現影像

開啟最近彩現的影像,這些是彩現時自動儲存的 Rhino 彩現影像檔案格式 (.rimage)。

封閉

關閉彩現視窗。

編輯功能表

複製

複製整個按鈕圖示至 Windows 剪貼簿。

檢視功能表

工具列

顯示/隱藏工具列。

效果面板

效果面板可以設定彩現影像的曝光度及加入各種後處理效果。

顯示彩現影像

顯示/隱藏彩現影像。

縮放

在彩現視窗裡放大、縮小彩現影像,實際的像素不會改變。

通道
預設值 RGB

以所有的顏色通道顯示彩現影像。

請參考:Wikipedia: Channel (digital image)

RGBA

顯示所有顏色通道並將透明背景顯示為網格。

紅色

只顯示彩現影像的紅色通道。

綠色

只顯示彩現影像的綠色通道。

藍色

只顯示彩現影像的藍色通道。

Alpha

只顯示彩現影像的 Alpha (透明) 通道。

請參考:Webopedia: Alpha channel

Z-緩衝

以灰階色顯示彩現影像裡每一個像素距攝影機的遠近。

請參考:Wikipedia: Z-Buffering

法線

以 RGB 顏色顯示法線方向。

如果平面的法線方向指向世界座標 X 軸正向的方向,則該面會顯示為紅色。

世界 +X=紅色,+Y=綠色,+Z=藍色。

說明功能表

開啟目前的彩現器的說明主題。

彩現視窗的效果面板

含有各種彩現後處理效果設定的面板。

從文件載入後處理效果

將後處理效果設定恢復為上次儲存時的狀態。

儲存後處理效果至文件

將目前的後處理效果設定儲存到 3dm 檔案。

預設為顯示這個面板

在新的彩現視窗開啟效果面板。

後處理效果面板

後處理效果面板會列出所有選取的後處理效果。

加入後處理效果

  1. 按 按鈕。

  2. 從清單選擇一個後處理效果。

移除後處理效果

  • 點擊後處理效果後面的 X 按鈕。

啟用或停用後處理效果

  • 點擊後處理效果前面的核取方塊。

重新排序後處理效果

  • 將後處理效果向上或向下拖曳。

    後處理效果是從上到下執行的。

曲線

確定曲線是否顯示在彩現視窗中。

曲面邊緣與結構線

確定曲面邊緣和結構線是否顯示在彩現視窗中。

點物件和點雲

確定點物件和點雲線是否顯示在彩現視窗中。

尺寸標註與文字

確定尺寸標註與文字物件是否顯示在彩現視窗中。

消除雜點

消除雜點後製效果會偵測並減少明顯比周圍更亮的像素 (俗稱螢火蟲雜點),同時保留彩現影像的整體外觀。這些瑕疵通常出現在含有會產生焦散的反射或折射材質的場景中。

泛光

Bloom 後處理效果會羽化影像中明亮的區域,以模擬黑暗場景中的燈光。

有泛光/無泛光後處理效果的發光材質。
亮度臨界值

當像素比該值更亮時,就會產生泛光效果。

向左移動滑桿可以為影像加入更多泛光效果。

半徑

半徑設定控制距明亮區域的羽化距離。

強度

強度設定可變更明亮區域的亮度。強度朝向羽化邊界遞減。

  • 移動滑桿變更數值。

  • 雙擊滑桿輸入數字。

  • 將滑桿拖曳超過右邊末端可增加最大值。

光暈

在特定顏色周圍產生明亮區域。可用來使彩色燈光或物件看起來發光,與霓虹類型的燈光搭配效果很好。

光暈內容

半徑

決定明亮像素周圍的光暈半徑。增加半徑會使光暈效果變得模糊。

  • 移動滑桿變更數值。

  • 雙擊滑桿輸入數字。

  • 將滑桿拖曳超過右邊末端可增加最大值。

強度

更改光暈顏色的亮度。

開啟

開啟該顏色的光暈效果。

顏色
  • 按顏色方塊,在選取顏色對話框指定顏色。
  • 更多顏色相關設定

    按顏色方塊旁的小三角形可進行更多顏色的設定。

    調色盤

    開啟選取顏色對話。

    取色滴管

    擷取螢幕上任何位置的顏色。

    複製

    將目前顏色儲存到剪貼簿。

    貼上

    從剪貼簿貼上顏色。

    臨界值

    控制計算接近選取顏色的像素之光暈時,允許該顏色有多大的變化。

    新增

    新增光暈顏色。最多可以使用 8 種顏色。

    刪除

    刪除最後一個光暈顏色。

    霧氣

    霧氣效果會依深度在影像中加入色彩,可用來加入從濃霧到細微景深提示的各種效果。這與以環境為基礎的霧霾 (Haze) 類似,但不是在光線追蹤時彩現,而是在之後加入,並且可以即時調整。

    霧氣內容

    強度

    決定霧氣的最大濃度。0.0 表示完全沒有霧氣 (因此沒有效果),1.0 表示完全是霧。可以使用大於 1.0 的值,但只有搭配雜訊使用時才有意義。

    霧氣顏色

    調整霧氣的顏色。

    指定

    從彩現影像指定顏色。

    以滴管在彩現影像選取顏色。

    起始距離

    指定從攝影機算起開始出現霧氣的距離。

    指定

    從彩現影像指定深度。

    終止距離

    指定從攝影機算起霧氣達到最大濃度的距離。

    指定

    從彩現影像指定深度。

    指定區域

    指定影像中的區域。

    霧氣背景

    決定背景影像是否也加上霧氣。背景會以最大強度加上霧氣。

    羽化

    設定在邊界範圍之外漸變加入模糊效果的像素數。

    變更對話框裡的設定時,可以在影像上預覽效果。

    景深

    依據與攝影機的距離對影像加上模糊效果。

    景深內容

    模糊強度

    設定模糊量的大小。這是任意值,不同的影像適用不同的數值。

    最大模糊度

    設定高斯模糊使用的最大半徑。由於模糊量極大的區域會讓效果變慢,因此以此值限制效果。

    焦距

    影像不模糊 (即對焦清晰) 處與攝影機的距離。

    指定

    從彩現影像指定距離。

    模糊背景

    設定背景是否模糊。背景將以最大效果進行模糊處理。

    倍率

    倍率後製效果會將所有像素的顏色值乘以指定的數值,以調整彩現影像的整體亮度。

    倍率內容

    量值

    控制套用在像素顏色值上的倍率。大於 1 的值會使影像變亮,小於 1 的值會使影像變暗。

    降噪

    降噪後製效果可減少彩現影像中的顆粒雜訊,產生更平滑、更乾淨的結果。對於以有限取樣數彩現的影像,降低雜訊特別有用。

    曲線

    曲面邊緣與結構線後製效果會在彩現影像上繪製物件線框,包括曲面邊緣與結構線,以及網格與 SubD 邊緣。

    點與點雲

    點與點雲後製效果會在彩現影像上繪製點物件與點雲。

    尺寸標註與文字

    尺寸標註與文字後製效果會在彩現影像上繪製尺寸標註、文字及其他註解物件。

    色調對應標籤

    色調對應是將高動態範圍影像轉換為低動態範圍影像的過程。HDR 表示像素的紅、綠、藍值可以用 32 位元浮點數表示。這些值可能小於 1,因而產生量化誤差 (可使用抖色修正),也可能大於 1.0,表示它們可能比螢幕上顏色通道的最大值還亮 (例如大於 255)。

    當數值「比白色更亮」時,它們在螢幕上會過曝。可以使用色調對應將它們帶回螢幕/點陣圖的色域範圍內,也就是重新對應影像中的顏色,使較亮的區域能得到更好的呈現。這裡的選項提供了幾種不同的做法。

    請參考:Wikipedia: High dynamic range imaging

    黑/白色點

    在指定為黑色與白色的兩點之間進行線性內插。在一般影像中,這兩個值為 0.0 與 1.0。

    黑色點

    設定黑色點的數值。

    白色點

    設定白色點的數值。

    對數

    將響應曲線改為冪函數,使較高的範圍逐漸減弱其突出程度。它根據亮度值的對數壓縮,模仿人眼對光線的反應。

    請參考:Adaptive Logarithmic Mapping For Displaying High Contrast Scenes, by F. Drago, K. Myszkowski, T. Annen and N. Chiba

    色階分布

    數位影像中色調分布的圖形表示,會繪出每個色調值的像素數量。查看特定影像的色階分布,可以一眼判斷整體的色調分布。

    請參考:Wikipedia: Image histogram

    最終處理面板

    中間色

    因為螢幕從暗到亮的變化並非線型的,中間色的顯示會偏暗,所以一般圖片為了要在螢幕上看起來顏色正確會預先做與螢幕相反的中間色修正,把中間色加亮。彩現後的影像如果有中間色偏暗或偏亮的問題可以利用這個數值做修正。

    • 當彩現器不支援線性流程時,中間色後處理效果將被停用。

    中間色小於 1 (左)、等於 1 (中)、大於 1 (右)。

    請參考:Wikipedia: Gamma correction

    遞色

    在某些情況下,彩現可能會出現色階問題,可以打開遞色功能進行固定。

    彩現中的色階。
    經由遞色功能消除色階。

    請參考:Wikipedia: Dither

    無

    不使用遞色。

    Floyd-Steinberg

    繪圖軟體將全彩的相片轉換為有 256 色限制的 GIF 圖片時常用的遞色計算方法。

    簡易雜訊

    加入隨機運算的雜訊。

    浮水印

    在彩現圖像的左下角新增一個文字區塊,說明彩現開始、結束和經過的時間。

    字型

    浮水印文字的字體。

    字型大小

    浮水印文字高度 (像素)。

    字型顏色

    浮水印文字的顏色。

    透明度

    浮水印文字方塊的可見性。

    色調/飽和度/亮度

    色調

    彩現後調整材質的顏色。

    可以用來改變彩現影像裡某個部分的顏色,不必重新彩現整個場景。

    這個功能純粹只是改變彩現影像裡顏色相同的像素的顏色,不會重新計算這個顏色經過物件的反射與折射後得到的顏色。

    飽和度

    設定飽和度的量,數值越小彩現影像越偏灰階色,數值越大越鮮豔。

    亮度

    設定亮度。

    亮度/對比

    亮度

    變更圖片的整體明亮度。

    對比

    增加對比度會使暗像素更暗,明亮像素更亮。圖片中的顏色將更容易區分。

    降低對比度會將顏色變為中性灰色。圖片看起來會不太清晰。

    雜訊

    在彩現影像加入雜訊。雜訊後處理效果預設是將 RGB 通道分開處理,所以純灰階的彩現影像加入的雜訊會是隨機的顏色。

    單色

    只對像素的明暗度做隨機變化。

    高斯模糊

    在彩現影像加入一般平面繪圖軟體常見的高斯模糊效果。

    水平

    只做水平方向的高斯模糊處理。

    垂直

    只做垂直方向的高斯模糊處理。

    兩方向

    平水與垂直方向皆做高斯模糊處理。

    Rhino 彩現影像檔案格式 (.rimage)

    Rhino 彩現器可儲存 .rimage 檔案。這是一種專有的檔案格式,可儲存彩現引擎彩現出的所有資訊,包括顏色、Alpha、深度、法線等通道,每個通道皆為 32 位元解析度。

    彩現視窗會使用這些資訊來執行後處理效果與曝光運算,第三方彩現器實作的自訂控制項也可利用這些資訊來達成其他效果。

    彩現完成後,可立即使用 .rimage 格式儲存資料,以便日後進行後處理、曝光調整或格式變更 (以不同格式儲存而不損失資訊)。

    .rimage 是 Rhino 彩現視窗特有的檔案格式,其它軟體無法開啟。它可以儲存高動態範圍資訊,這些資訊可以無損轉移至 .HDR 與 .EXR 格式。因為它是未壓縮的格式,所以檔案可能非常巨大。

    開啟 .rimage 檔案

    • 從 Rhino 彩現視窗的檔案功能表選擇開啟舊檔。
      或
    • 使用 RenderOpenRenderImage 指令將選取的 .rimage 檔案在彩現視窗開啟。

    每次彩現完成都會自動在暫存檔資料夾儲存一個 .rimage 檔案,以後重新開啟這些檔案仍然可以編輯所有的後處理效果,就像剛才完成的彩現一樣。

    開啟最近的 .rimage 檔案

    • 從 Rhino 彩現視窗的檔案功能表選擇最近的彩現影像,再選擇一個檔案。
      這些暫存的檔案以彩現完成的時間與日期自動命名。

    彩現影像後處理效果的進一步資訊請參考:彩現影像後處理效果

    請參考

    彩現模型場景

    建立彩現的照明燈光

    使用材質與貼圖