Render

Toolbar Menu

Render Tools
Standard

Render

Render

The Render command renders the model using the current renderer producing a color image in a separate display window.

To set the current renderer

  1. On the Render menu, click Current Renderer.
  2. Choose the renderer from the list.

Note

Rendering basics

In addition to shaded previews, Rhino provides full-color rendering with lights, transparency, shadows, textures, and bump mapping.

Objects will render white until you add render color, highlight, texture, transparency, and bumps. These attributes are controlled through the Properties panel, Material page.
Illustration.

The process needed to render scenes consists of four basic steps:

Although the steps do not have to be done in this order, using this method seems to make setting up a scene more efficient. To improve quality, repeat these steps until the image looks right to you.

Lights

In every Rhino rendering there are light sources that Rhino uses to calculate how the objects are to be illuminated. If you do not add any light sources to your scene, the default light is used. The default light is a directional light with parallel rays that acts as though you have a lamp shining over your left shoulder.

Lights command iconAdd indoor lights or sun

Materials

Materials specify the color, finish, transparency, texture, and bump for use by the renderer.

Layer command iconAssign materials to layers

In the Materials panel

Assign to Layers...
  1. Right-click on a material and select Assign to Layers...
  2. In the Choose Layer dialog, select layers.
Assign to Layers of Objects
  1. Right-click on a material and select Assign to Layers of Objects
  2. Select an object in the viewports to assign the material to the object's layer.

In the Layers panel

  1. Select one or more layers by clicking their names.
  2. Click in the Material column of a selected layer.
  3. In the Layer Material dialog, select or create a material.

    Type a letter to navigate to the first material in the list with a name starting with the letter.

By selecting objects

  1. Select one or more objects.
  2. In the Materials panel, right-click on a material and select Assign to layers of Objects.

By drag and drop

Assign materials to objects

In the Materials panel

  1. Select one or more objects.
  2. In the Materials panel, right-click on a material and select Assign to Objects.

In the Properties panel

  1. Select one or more objects.
  2. In the Properties panel, click the Material button.
  3. Select or create a material from the drop-down list.

By drag and drop

Environment

Environments describe the space around the model. This space is reflected in objects and can provide overall lighting.
Illustration.

Set up an environment

The rendering properties include environment settings like background color and image.

  1. Open the Environment Editor panel.
  2. Set up environment properties.

Ground Plane

The ground plane provides an infinite horizontal platform for the image that stretches to the horizon in all directions positioned at a defined elevation. A ground plane renders much faster than using a surface as a background. Any material can be assigned to the ground plane.

GroundPlane command iconSet up a ground plane

  1. Open the Ground Plane panel.
  2. Set up ground plane properties.

Render

Render and save an image.

Render and save the image

  1. On the Render menu, click Render.
  2. In the Render Window, on the File menu, click Save As.

Missing Textures

If there are textures referred to in the model that are not on your system, a dialog box provides a list of the missing textures.

This setting must be enabled by checking the Check for missing textures when rendering box in Rendering Options.

Copy All

Saves the list of missing textures to the Clipboard.

Save As

Saves the list of missing textures to a text file.

Continue

Continue to render without the missing textures.

Abort

Stop the rendering in order to locate the texture files.

Show usage of this resource

Click one of the resources in the list to display usage information.

Don't show me this again

Turns off the dialog display.

To turn the message back on

  • Check the Check for missing textures when rendering box in Rendering Options.

Missing textures: usage information

Shows where the resource is being used.

Browse for replacement

Allows browsing for a different file or folder location.

Rhino Image File Format (.rimage)

Rhino Render can save .rimage files. This is a proprietary file format that stores all of the information rendered by the rendering engine, including color, alpha, depth, normal channels, all with 32-bit per-channel resolution.

This information is used by the render window to execute the post-effects and exposure operators, and can also be used by custom controls implemented by a third-party renderer to achieve other effects.

Immediately after render time, the .rimage format can be used to store the data so that post-processing and exposure adjustments or format changes (saving in a different format without loss of information) can be done later.

The .rimage format is only supported by the Rhino render window. It cannot be loaded into any other software. It is a high-dynamic range format that supports lossless information transfer to .HDR and .EXR formats. It is uncompressed and the files can be huge.

To open an .rimage file

Completed renderings are saved in the .rimage format to a temporary location on your hard disk. Once one of the renderings is re-opened, all post effects and exposure settings are available as if the rendering were just completed.

To open the most recent .rimage file

For more information about post processing the rendered image, see: Post-processing rendered images.

Render command-line/scripting commands

RenderArctic

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderArctic command sets everything to white - materials, skylighting, ground plane and renders the current viewport.

Command-line options
AffectMaterials Turn off to exclude materials from the settings.
AffectLights Turn off to exclude lights from the settings.
AffectGroundPlane Turn off to exclude groundplane from the settings.
AffectBackground Turn off to exclude background from the settings.

See: Wikipedia: Ambient occlusion.

CloseRenderWindow

Toolbar Menu

Not on toolbars.

Not on menus.

The CloseRenderWindow command closes the render display window.

This is useful for doing multiple renderings. When combined with the SaveRenderWindowAs command, you can create multiple renderings and save them to different files from your script.

CopyRenderWindowToClipboard

Toolbar Menu

Not on toolbars.

Not on menus.

The CopyRenderWindowToClipboard command copies the image in the render window to the Clipboard.

RenderBlowup

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderBlowup command renders a selected area of the current viewport in the render window at the resolution specified in the Rendering panel.

RenderInWindow

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderInWindow command renders a selected area of the current viewport in the render window at viewport resolution.

The renderer uses the settings in Mesh Document Properties.

Rendering

Toolbar Menu Panel Gear Menu

Render Tools
Standard

Panels

Rendering

Rendering

The Rendering command opens the Rendering panel that provides quick access to the Render Document Properties.

Current Renderer

Sets the current renderer. This can be the built-in Rhino Render or a plug-in.

View

Specify a source for the view.

Current Viewport

Renders the current viewport.

Specific Viewport

Select a viewport to render from the list.

Named View

Select a named view to render from the list.

Snapshot

Select a snapshot to render from the list.

Resolution and Quality

Dimensions

The aspect ratio displays to the right of the menu.

Viewport (<size>)

Renders the active viewport the active viewport using the pixel size of the viewport.

Custom (<size>)

Renders the active viewport using the custom resolution. Type the custom width and height resolution in pixels.

Preset sizes

Renders the active viewport the selected pixel resolution.

If you add a text file named render_sizes.txt to the folder where the Rhino executable (.exe) resides, Rhino Render and some other renderers will read this text file for custom render sizes.

Example:
// My custom render sizes
500,500
600,600
700,700
800,800
900,900
Lock to viewport aspect ratio

Maintains the aspect ratio of the viewport. When the height or width is changed, the other dimension changes in relation.

Size

Calculates the size of the image in the selected unit system based on the Resolution and DPI ("dots" per inch) settings. This is useful for determining the size of the image for printing.

Units

Sets the image size in pixels, inches, millimeters, or centimeters.

DPI

Image pixels ("dots") per inch.

Quality

The Quality settings help to improve:

Higher quality settings result in more rays being cast per pixel, and as a result the rendering time will increase. Prefer lower quality settings when setting up your scene, but higher settings when producing a final image for presentation purposes.


Quality=Draft quality (left), and Final quality (right).

Rhino calculates each pixel in the rendered image by averaging several samples. This makes the image appear smoother, but also slows down rendering.

Backdrop

The backdrop is what you see directly in front of the camera if there are no objects in the way. The background is not 3‑D — it exists only on the screen.

Solid color

Displays a solid color.

To select the color for the background

Gradient

Displays a two-color gradient. The color for the top of the image background is the Solid color set above.

To select the color for the bottom of the background

360° Environment

Displays the portion of the current environment that the camera sees in the viewport.

New

Creates a new environment using a template from the library.

Edit

Edits the selected environment.

See: Environment Editor.

Duplicate

Copies the selected environment to a new environment with the same settings.

Wallpaper

Displays the current viewport wallpaper.


Wallpaper in perspective viewport.
Stretch to fit

Fits the wallpaper to the rendered view.


Wallpaper at normal aspect ratio (left) and stretched to fit (right).
Transparent background

The background is rendered with an alpha channel for transparency. The image must be saved to a file format that supports alpha channel transparency (.png, .tga, .tif).

Ground plane

Turns on the ground plane.

Ground Plane Settings

Opens the Ground Plane panel.

Use custom environment for reflections

Assigns a custom environment that will be reflected by objects in the scene.

New

Creates a new environment using a template from the library.

Edit

Edits the selected environment.

See: Environment Editor.

Duplicate

Copies the selected environment to a new environment with the same settings.

Default environments
No environment

The No environment setting applies a plain gray background.

Studio

The Studio environment offers soft lighting provided by a high-dynamic range image.


Studio lighting example (left) and hdr background (right).

Lighting

Sun

Turns on the sun.

Sun Settings

Opens the Sun panel.

Skylight

Turns on skylight.


Skylight off (left) and Skylight on (right).
Intensity

Adjusts the skylight intensity.

Use custom environment for skylighting

Sets an environment that is used as sky light.

New

Creates a new environment using a template from the library.

Edit

Edits the selected environment.

See: Environment Editor.

Duplicate

Copies the selected environment to a new environment with the same settings.

Lights

Opens the Lights panel.

Use lights on layers that are off

Controls whether or not spotlights that are on hidden layers or that are hidden with the Hide command are rendered.

Snapshots

The Snapshots command saves and restores Named Views, Named Positions, Layer States, as well as rendering settings, object settings including locked/hidden state, display mode, material, position, light settings, curve piping, displacement, edge softening, shutlining, and thickness.

Wireframe

Render curves

Curve objects are rendered with the surfaces.

Render surface edges and isocurves

Surface isoparametric curves and edges are rendered with the surfaces. Edge thickness set in the Rendered viewport apply.

Render dimensions and text

Dimensions and texts are rendered with the surfaces.

Snapshots

The Snapshots command saves and restores Named Views, Named Positions, Layer States, as well as rendering settings, object settings including locked/hidden state, display mode, material, position, light settings, curve piping, displacement, edge softening, shutlining, and thickness.

Dithering and Color Adjustment

Dithering

The rendered image is usually produced at a higher color depth than monitors and low-dynamic-range file types like bitmaps like JPEG, PNG, BMP can reproduce. The most important effect this causes is banding, which is a quantization error. Dithering reduces quantization errors and so gets rid of banding.

Both dithering methods, generally do the same thing. Sometimes, one might be better than the other, but in general, Simple Noise is the best.

See: Wikipedia: Dither.

None

No dithering.

Floyd-Steinberg

The algorithm achieves dithering by diffusing the quantization error of a pixel to its neighboring pixels.

See: Wikipedia: Floyd-Steinberg dithering.

Simple noise

A random variation of brightness or color information in images.

See: Wikipedia: Image noise.

Gamma

Image files are color corrected so that they can be loaded byte-by-byte into the RGB pixels of a computer screen and look right on a monitor. This means that the color response of a standard image is non-linear, that is, it is gamma corrected. Gamma refers to the power function that is used to correct the image.

The Gamma value changes, and therefore corrects the output of the image.

See: Wikipedia: Gamma correction.

Use linear workflow

The Rendered display mode supports a linear workflow for accurate color, gamma and lighting computation.

Gamma correction for bitmap images that are loaded from disk is removed (by the inverse of the amount in the Gamma edit box) so that they have a linear response before they are passed to the renderer. The renderer renders them in this uncorrected state. The gamma correction is applied to the entire finished image. This can do a better job of processing the color in rendered images.

See: What is linear work flow and how can it help your renders look better.

Snapshots

The Snapshots command saves and restores Named Views, Named Positions, Layer States, as well as rendering settings, object settings including locked/hidden state, display mode, material, position, light settings, curve piping, displacement, edge softening, shutlining, and thickness.

Advanced Rhino Render Settings

Render acceleration grids

Screen grid, cell size

The width and height of each grid cell in pixels.

The smaller the grid cell size, the more memory it takes and the more memory it takes to build, but the faster the final render.

Spotlight shadow grid size

The shadow ray is the ray shot from the scene towards each light when the intersection between the eye ray and the scene is found. Usually the lions share of the render time is spent tracing the shadow rays.

To increase calculation speed for the spotlight shadow rays, the render plug-in divides the spotlight cone into rectangular regions, and again builds a sorted list of the objects within each region. This speed increase only applies to spotlights, because they are very similar to the viewports, the light location is like the camera location, and the light cone defines the viewport.

The spotlight grid is defined in number of grid cells instead of pixels, because there is no pixel size associated with lights.

Self-shadowing prevention

Prevents self-shadowing artifacts. When the intersection between the eye ray and the scene is found, the intersection point is moved (offset) towards each light before calculating the shadow ray. The reason is there's always some numerical fuzz in calculating the intersections, and if the point is not offset, the shadow ray might hit the very same polygon again, putting shadows in wrong places. You can see the self shadowing artifacts if you set the setting to zero, and then render the scene.

Ray offset

The amount of offset.

Object and polygon bounding volume hierarchy

A binary space partitioning (BSP) tree is another way to increase rendering speed. Instead of testing each polygon one-by-one, the objects and polygons are divided into a tree-like hierarchy based on the location in space.

The renderer builds multiple trees, one that contains the whole object bounding boxes, and one per object that contains the polygons for that object.

The BSP tree takes some time to build and takes some memory. A deeper tree may take longer to build, but may render faster. A shallow tree is faster to build, but may take a long time to render.

Max tree depth

Controls how many times the scene can be subdivided when building the tree.

The tree depth defaults to Auto, and node size to 1. There should be no need to change these settings unless you render a scene that is so huge that Rhino runs out of memory using the default settings.

Target node size (objects/polys)

Defines the optimal size for each node that contains the objects or polygons.

Transparency

Max bounces

The transparency bounces setting controls how many times rays that hit transparent objects are traced: 12 means a stack of 12 transparent sheets will render properly, but the 13th sheet will render opaque. To keep the render times reasonable, the limit is 15.

Reflectivity gradient

Max bounces

The reflectivity bounces setting controls how many times rays that hit reflective objects are traced. To keep the render times reasonable, the limit is 15.

Reset To Defaults

Restores all default rendering settings.

Render

Renders the current model.

RenderOpenLastRendering

Toolbar Menu

Not on toolbars.

Render

Open Last Rendering

The RenderOpenLastRendering command opens the last rendering image file (.rimage).

RenderOpenRenderImage

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderOpenRenderImage command opens a browser window with the recent rendering image files (.rimage).

RenderPreview

Toolbar Menu

Render Tools

Render

Render Preview

The RenderPreview command renders the current viewport in the render window at render resolution, optimizing render time.

The renderer uses the settings in Mesh Document Properties.

RenderPreviewInWindow

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderPreviewInWindow command renders a selected area of the current viewport in the render window at render resolution, optimizing render time.

The renderer uses the settings in Mesh Document Properties.

RenderPreviewWindow

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderPreviewWindow command renders a selected area of the current viewport in the viewport at viewport resolution, optimizing render time.

The renderer uses the settings in Mesh Document Properties.

RenderReportMissingImageFiles

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderReportMissingImageFiles command opens the image manager, which can be switched to show all image files in addition to missing ones.

RenderWindow

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderWindow command renders a selected area of the current viewport in the viewport at viewport resolution.

The renderer uses the settings in Mesh Document Properties.

SaveRenderWindowAs

Toolbar Menu

Render Tools

Not on menus.

The SaveRenderWindowAs command saves the image in the render window to a file.

Steps

Save As options

Save alpha channel

Saves an alpha channel if the file type supports transparency.

SetCurrentRenderPlugIn

Toolbar Menu

Not on toolbars.

Render

Current Render

The SetCurrentRenderPlugIn command specifies the current rendering plug-in application.

You can download plug-ins from www.rhino3d.com/resources.

See also

Render your model scene

Add lights for rendering

Use materials and textures

Use the Clipboard

 

 

 

Rhinoceros 6 © 2010-2019 Robert McNeel & Associates. 21-Aug-2019