Toolbars

Toolbar Menu

Properties
Standard
Tools

Tools

Options

Toolbars options manage the toolbars and toolbar buttons.

The Toolbars Options page shows the contents of the toolbar layout. The toolbar layout holds the toolbars, the buttons in them, and the screen position of each toolbar. It also determines whether the toolbar is hidden or showing.

File menu

New

Creates a new toolbar collection file (.rui).

Open

Opens an existing toolbar collection file (.rui).

Close

Closes the selected toolbar collection.

Close All

Closes all toolbar collections.

Save

Saves the selected toolbar collection.

Save As

Saves the selected toolbar collection as a different file.

Save All

Saves all toolbar collections.

Properties

Opens the RUI File Properties dialog box.

Import Toolbars

Import toolbars from another collection.

Export Groups

Export toolbar groups.

Edit menu

New Group

Create new toolbar group.

New Toolbar

Create a new toolbar.

Delete

Deletes the selected toolbar.

Properties

Opens the Toolbar Properties dialog box.

Tools menu

Workspace Editor

Opens the Workspace Editor.

Macro Library

Opens the Macro Library.

Files

Lists the active toolbar collections.

Toolbars

Lists the toolbars in the active toolbar collection.

Toolbar Properties

Group Name

The name of the group the toolbar belongs to.

Tab

The name of the toolbar tab. It is possible to have only one tab in a group.

Text

The text that appears on the toolbar tab.

Edit bitmap

Opens the Bitmap Editor.

Toolbar button appearance

Image only

Displays the image only.

Text only

Displays the text only.

Both image and text

Displays both the image and the text.

Sidebar

Assigns a Sidebar toolbar.

The sidebar is a special group that can populated with any existing group according to the currently active tab.

In the default workspace, if you click the Curve Tools, Solid Tools, Drafting, and other tabs in the Standard group across the top, the Sidebar docked on the left is populated with the contents appropriate to the active tab.

Restore Defaults

Restores the default system values. All custom appearance settings will be lost.

Toolbar Groups

Groups are containers for one or more toolbars that display as tabs. Floating a toolbar automatically makes a group of one.

Single-tab groups can hide the tab.

Related commands

Toolbar

Toolbar Menu

Tools

Tools

Toolbar Layout

The Toolbar command opens the Toolbars Options page.

ShowToolbar

Toolbar Menu

Not on toolbars.

Not on menus.

The ShowToolbar command opens a specified toolbar. See: Toolbars Sizes and Styles Options > Visibility.

Steps

ToolbarLock

Toolbar Menu

Not on toolbars.

Toolbar options menu

Lock Docked Windows

The ToolbarLock command locks docked toolbars and panels. See:Toolbars Sizes and Styles Options > Lock docked windows.

ToolbarReset

Toolbar Menu

Not on toolbars.

Not on menus.

The ToolbarReset command restores toolbars to the default layout.

All toolbar (.rui) files are closed and Rhino must be restarted to complete the process. On restart, a new default toolbar file is unpacked from files installed with Rhino installer and opened.

Save options for use on other computers

OptionsExport

Save Options settings to a file.

OptionsImport

Restore Options settings from a file.

See also

Options

Manage global options.

 

 

 

Rhinoceros 6 © 2010-2019 Robert McNeel & Associates. 16-Sep-2019