Manage toolbars

Rhino opens with the default toolbar layout. The default toolbar layout displays only some of the many Rhino toolbars. Most of the hidden toolbars can be opened from the toolbar buttons in the default toolbar layout. The toolbar displaying in the left Sidebar may change when you click a toolbar tab that has another toolbar linked.

Open toolbars from Rhino Options

  1. On the Tools menu, select Toolbar Layout.

    The Toolbars page in the Rhino Options is opened.

  2. Under Toolbars, select toolbars to open.

Open toolbars from a toolbar group

  1. Click the gear button in a toolbar group.

    Or, right-click anywhere in a toolbar group.

  2. Select Show Toolbar to open toolbars.

  3. Select Show or Hide Tabs to add toolbars in the current toolbar group.

Float a toolbar

  1. Drag the toolbar handle.
  2. Release the mouse button to place the toolbar.
    A tab will appear on the toolbar.

Reshape a floating toolbar group

Toolbar groups

Each free-standing toolbar is actually a toolbar group.

Parts of a toolbar group

Tabs (a), Group handle (b), Scroll control (c), Toolbar menu button (d), Close button (e), Show more (f), and Linked toolbar cascade button (g).

(a) Tabs

Each toolbar docked in a group displays as a tab.

To bring a tab to the top

Tabs can be moved from group to group or made to be free standing.

Move a toolbar tab

Copy a toolbar tab to another group

(b) Group handle

The group handle is the blank area of the group where no tabs appear.

To move a floating toolbar group

Dock a toolbar group

  1. Drag the toolbar group handle to the edge of the Rhino graphics area.
    A blue shape will light up the area where the toolbar will dock.
  2. Release the mouse button to dock the toolbar.
    The toolbar docks.

Prevent a toolbar from docking while being dragged

(c) Scroll control

If the toolbar group is not expanded to show all tabs, a Scroll control appears.

(d) Toolbar menu button

Opens the group Options menu.

See: Customize toolbars.

Options

Show Toolbar

Opens a toolbar as a free-standing group.

New Button

Adds a new button and opens the Button Editor.

New Separator

Inserts a button separator.

Edit Button

Opens the selected button in the Button Editor.

New Tab

Creates a new blank tabbed toolbar.

Show or Hide Tabs

Shows/hides a toolbar tab in the current group.

Size to content

Expands a toolbar to show all buttons.

Properties

Opens the Toolbar Properties dialog box.

(e) Close button

Closes the toolbar group. Only displays on floating toolbar groups.

(f) Show more

If the tab is not expanded to show all buttons, a Show more control appears.

(g) Cascade buttons

Cascades a toolbar linked to that button.

Cascade a linked toolbar

  1. Click the triangle in the lower right of a toolbar button to cascade a linked toolbar.
  2. Drag the title bar of the toolbar to a new position.

Lock the toolbar locations

Sidebars

The sidebar is a special toolbar that is populated with a specified group by the currently active tab. When the tab is active, the contents of the Sidebar toolbar changes to the toolbar tab specified in the Toolbar Properties.

For example

  1. In the Default workspace, notice the contents of the toolbar docked at the left.
    This is the Sidebar displaying the contents of the Main toolbar.
  2. In the Standard toolbar group (usually docked at the top of the workspace, under the command prompt, click the Curve Tools tab.

Notice that the buttons in the Sidebar change to the contents of the Curve Tools toolbar.

Other tabs with Sidebars include Mesh Tools, Solid Tools, Render Tools, and Drafting.

Restoring lost toolbars

If your toolbars are lost or become corrupted, they can be restored with the ToolbarReset command.

Warning

The ToolbarReset command replaces all custom toolbars and groups with the default set that ships with Rhino.

Manage toolbar buttons

Move a button

  1. Move the cursor over the toolbar button.
  2. Press and hold Shift.
  3. Click the left mouse button and drag the toolbar button to a different toolbar or to a different position in the same toolbar.

Copy a button

  1. Move the cursor over the toolbar button.
  2. Press and hold Ctrl.
  3. Click left mouse button and drag the button to another location in the same toolbar or to a different toolbar.

Delete a button

  1. Move the cursor over the toolbar button.
  2. Press and hold Shift.
  3. Click the left mouse button, drag the toolbar button outside the toolbars and drop.

Create a link

  1. Open the parent toolbar that will contain the link button.
  2. Open the child toolbar that will be linked to it.
  3. Press and hold Ctrl.
  4. With the right mouse button down, drag a button from the child toolbar to the parent toolbar.
    A copy of the button appears in the parent toolbar with the white triangle link symbol in its corner.

Unlink a toolbar

  1. Move the cursor over the linked button.
  2. Press and hold Shift.
  3. Click the right mouse button to open the Edit Toolbar Button dialog box.
  4. Under Linked toolbar, click No Link.

See also

Customize toolbars

Toolbar button editor

Edit toolbar bitmap

 

 

 

Rhinoceros 6 © 2010-2019 Robert McNeel & Associates. 19-Aug-2019