SketchUp (.skp) 匯入/匯出

.SKP 是 SketchUp 的原生檔案格式。

Rhino 可讀寫 SketchUp 檔案格式,最高 2021 版本。

匯入

如何開啟、匯入、插入及附加分工作業檔案

  1. 從檔案功能表選擇開啟舊檔、插入、匯入或分工作業 > 附加。

  2. 在對話框裡選擇支援的檔案類型。
  3. 按開啟並進行設定。
    當您開啟非 3dm 的檔案並儲存模型時,其檔案名稱將是預設的 3dm 檔案名稱。

SKP 匯入選項

將面匯入為

修剪過的平面

將網格面匯入為修剪過的平面。

警告:如果 SketchUp 檔案中的網格過多,而電腦記憶體不足時,Rhino 可能會當機。

網格

將物件匯入為網格面。

匯入曲線

設定是否將 SketchUp 檔案中的曲線讀入 Rhino。

匯入時組合

設定是否要組合匯入的物件。

邊緣

組合邊緣。

面

組合面。

熔接角度 ___ 度

設定網格面之間的角度做為是否熔接頂點的依據。

群組

使用群組圖層

可將群組中的物件匯入到群組圖層中。

  • 從 SketchUp 2021 版本開始,"圖層"被稱為"標籤"。
加入物件至群組

遵循 SketchUp 中的群組結構。否則,物件將在沒有群組的情況下匯入。

貼圖

使用 SketchUp 貼圖寫入器建立貼圖
總是使用這些設定,不要再彈出此對話框。

儲存目前的設定,以後不用彈出設定對話框直接匯出檔案。

恢復彈出設定對話框

請參考:ResetMessageBoxes 指令。

匯出

SketchUp 檔案匯出時會以平面的網格建立內部與外圍邊界,使匯出的物件易於使用。

另存或匯出 Rhino 模型

  1. 在檔案功能表選擇匯出選取的物件或另存新檔。
  2. 彈出的對話框的檔案類型欄位清單會列出可以匯出的檔案類型。
  3. 在檔案類型欄位選擇檔案類型。
  4. 在檔案名稱欄位輸入名稱。
  5. 如果匯出的檔案類型有選項設定,可按選項按鈕做設定。
  6. 網格檔案類型使用指定的網格選項或文件彩現網格設定將 NURBS 曲面匯出為網格。

SKP 匯出選項

檔案匯出為

指定要儲存的 SketchUp 檔案版本。

合併共面的相鄰面

將 Rhino 中已熔接的相鄰共面網格面合併為 SketchUp 中的單一面。

若要合併已結合的相鄰共面網格面,請使用可編寫指令碼的 -Save 指令匯出 .skp 檔案,並設定 IncludeUnweldedEdges=Yes。

群組物件

將每個 Rhino 物件匯出為 SketchUp 群組,讓物件在 SketchUp 中更容易選取和管理。

曲線
最大角度

曲線會以多重直線匯出至 SketchUp 檔案。此數值指定相鄰線段之間允許的最大角度偏差。

附註

  • 邊緣和面在 SketchUp 中會標記圖層名稱。

 

總是使用這些設定,不要再彈出此對話框。

儲存目前的設定,以後不用彈出設定對話框直接匯出檔案。

恢復彈出設定對話框

請參考:ResetMessageBoxes 指令。

請參考

SketchUp