寸法関連コマンド

寸法関連コマンドは、長さ、角度、半径などの寸法をアクティブな作業平面に平行に作成します。寸法はヒストリ(履歴)によってオブジェクトに連結されています。

Centermarkマークコマンドは、曲線の中心点に1つの十字線または1つの十字線と複数の中心線を作成します。

中心マークのサイズとスタイルは注釈スタイルと中心マークのプロパティでコントロールできます。

  • 寸法はデフォルトでヒストリが記録されます。このデフォルトのヒストリ記録動作は、Historyコマンドの注釈ヒストリの記録で制御されます。
コマンドラインオプション

スタイル

注釈スタイル名を選択します。

中心マークのプロパティ

中心マークのサイズ

半径と直径寸法の中心マークのサイズです。

中心マークのスタイル

半径と直径寸法の中心マークのスタイルを設定します。

なし

中心マークは作成されません。

マーク

十字マークが半径または直径の中心に作成されます。

マークと線

十字マークとオブジェクトのエッジのすぐ外側まで伸びる線が作成されます。

Dim

ツールバー メニュー

寸法
製図
標準

製図

長さ寸法

 ヒストリが使用可能

Dimコマンドは、水平または垂直長さ寸法を作成します。

ユーザーガイド - 建築図面

操作手順

  1. コマンドを開始します。
  2. 2点をピックします。
  3. 3つ目の点を選択して、寸法線を配置します。

    寸法テキストが寸法補助線の間に収まらない場合は、寸法テキストを左側または右側に配置できます。

  • 寸法はデフォルトでヒストリが記録されます。このデフォルトのヒストリ記録動作は、Historyコマンドの注釈ヒストリの記録で制御されます。
  • オブジェクトを移動しても、長さ寸法の線やテキストは移動しません。オブジェクトと一緒に長さ寸法の線やテキストを移動したい場合は、それらを一緒に移動する必要があります。
コマンドラインオプション

注釈スタイル

注釈スタイル名を選択します。

オブジェクト

寸法を測るオブジェクトを選択します。

直列寸法

同じ寸法線に沿ってより多くの直列(チェーン)寸法を追加します。

元に戻す

1つ前の操作を元に戻します。

並列寸法

基準線寸法です。最初の点から寸法作成を続行します。

垂直

作業平面のY軸に平行な寸法を作成します。

水平

作業平面のX軸に平行な寸法を作成します。

寸法プロパティをオーバーライドするには

寸法は寸法スタイルから設定を適用します。寸法の表示をその注釈スタイルと変える必要がある場合は、寸法のプロパティで設定をオーバーライド(上書き)することができます。

  • 寸法を選択し、プロパティパネルで寸法ボタンをクリックして寸法のプロパティを変更します。

または

  • 寸法をダブルクリックして、寸法を編集ダイアログボックスを開きます。

メモ

注釈スタイルと異なる設定は文字が青で表示されます。

DimAligned

ツールバーメニュー

寸法
製図

製図

その他の注釈 >

平行寸法

 ヒストリが使用可能

DimAlignedコマンドは、指定した2点に平行な長さ寸法を作成します。

操作手順

  1. コマンドを開始します。
  2. 2点をピックします。
  3. 3つ目の点を選択して、寸法線を配置します。

    寸法テキストが寸法補助線の間に収まらない場合は、寸法テキストを左側または右側に配置できます。

  • 寸法はデフォルトでヒストリが記録されます。このデフォルトのヒストリ記録動作は、Historyコマンドの注釈ヒストリの記録で制御されます。
  • オブジェクトを移動しても、長さ寸法の線やテキストは移動しません。オブジェクトと一緒に長さ寸法の線やテキストを移動したい場合は、それらを一緒に移動する必要があります。
コマンドラインオプション

注釈スタイル

注釈スタイル名を選択します。

オブジェクト

寸法を測るオブジェクトを選択します。

直列寸法

同じ寸法線に沿ってより多くの直列(チェーン)寸法を追加します。

並列寸法

基準線寸法です。最初の点から寸法作成を続行します。

元に戻す

1つ前の操作を元に戻します。

寸法プロパティをオーバーライドするには

寸法は寸法スタイルから設定を適用します。寸法の表示をその注釈スタイルと変える必要がある場合は、寸法のプロパティで設定をオーバーライド(上書き)することができます。

  • 寸法を選択し、プロパティパネルで寸法ボタンをクリックして寸法のプロパティを変更します。

または

  • 寸法をダブルクリックして、寸法を編集ダイアログボックスを開きます。

メモ

注釈スタイルと異なる設定は文字が青で表示されます。

DimAngle

ツールバーメニュー

寸法
製図

製図

角度寸法

 ヒストリが使用可能

DimAngleコマンドは、円弧の角度の、または2つの選択された線の間の、または3点から寸法を作成します。

操作手順

  1. 円弧を選択します。

    または
    2つの線、ポリラインセグメント、線形サーフェスまたはポリサーフェスのエッジを選択します。

  2. 寸法の位置をピックします。
  • 寸法はデフォルトでヒストリが記録されます。このデフォルトのヒストリ記録動作は、Historyコマンドの注釈ヒストリの記録で制御されます。
コマンドラインオプション

注釈スタイル

注釈スタイル名を選択します。

点

角度の頂点 (1)、寸法点(2)および(3)をピックします。

寸法プロパティをオーバーライドするには

寸法は寸法スタイルから設定を適用します。寸法の表示をその注釈スタイルと変える必要がある場合は、寸法のプロパティで設定をオーバーライド(上書き)することができます。

  • 寸法を選択し、プロパティパネルで寸法ボタンをクリックして寸法のプロパティを変更します。

または

  • 寸法をダブルクリックして、寸法を編集ダイアログボックスを開きます。

メモ

注釈スタイルと異なる設定は文字が青で表示されます。

DimArea

ツールバーメニュー

寸法

製図

その他の注釈 >

面積寸法

 ヒストリが使用可能

DimAreaコマンドは、閉じた平面曲線、サーフェス、ポリサーフェス、サブサーフェス、メッシュ、またはハッチングの面積を測ります。

操作手順

  1. 閉じた平面曲線、サーフェス、ポリサーフェス、サブサーフェス、メッシュ、またはハッチングを選択します。

  2. テキストまたは引出線の始点をピックします。
    引出線オプションを用いる場合、Leaderコマンドと同じように引出線の点を指定します。
    オブジェクトの面積は自動的に入力されます。

  • 寸法はデフォルトでヒストリが記録されます。このデフォルトのヒストリ記録動作は、Historyコマンドの注釈ヒストリの記録で制御されます。
コマンドラインオプション

タイプ

引出線

オブジェクトを引出線を使って指します。

テキスト

ピックされた位置にテキストを配置します。

寸法は、寸法計算にAreaテキストフィールドを使用します。

既存の寸法を編集するには

  • 寸法を選択し、プロパティパネルで引出線またはテキストを編集します。
  • または、寸法をダブルクリックして、引出線またはテキスト編集ボックスを開きます。

DimCurveLength

ツールバーメニュー

寸法

製図

その他の注釈 >

曲線長さ寸法

 ヒストリが使用可能

DimCurveLengthコマンドは、曲線の長さを寸法として表示します。

操作手順

  1. 曲線を選択します。
  2. テキストまたは引出線の始点をピックします。
    引出線オプションを用いる場合、Leaderコマンドと同じように引出線の点を指定します。
    曲線の長さは自動的に入力されます。
  • 寸法はデフォルトでヒストリが記録されます。このデフォルトのヒストリ記録動作は、Historyコマンドの注釈ヒストリの記録で制御されます。
コマンドラインオプション

タイプ

引出線

オブジェクトを引出線を使って指します。

テキスト

ピックされた位置にテキストを配置します。

寸法は、寸法計算にCurveLengthテキストフィールドを使用します。

既存の寸法を編集するには

  • 寸法を選択し、プロパティパネルで引出線またはテキストを編集します。
  • または、寸法をダブルクリックして、引出線またはテキスト編集ボックスを開きます。

DimCreaseAngle

ツールバーメニュー

寸法

製図

その他の注釈 >

クリース角度寸法

DimCreaseAngleコマンドは、2つの面の間に角度寸法を作成します。

操作手順

  1. 1つ目のサーフェスを選択します。
  2. 2つ目のサーフェスを選択します。
  3. 寸法の位置をピックします。

  • 寸法はデフォルトでヒストリが記録されます。このデフォルトのヒストリ記録動作は、Historyコマンドの注釈ヒストリの記録で制御されます。

寸法プロパティをオーバーライドするには

寸法は寸法スタイルから設定を適用します。寸法の表示をその注釈スタイルと変える必要がある場合は、寸法のプロパティで設定をオーバーライド(上書き)することができます。

  • 寸法を選択し、プロパティパネルで寸法ボタンをクリックして寸法のプロパティを変更します。

または

  • 寸法をダブルクリックして、寸法を編集ダイアログボックスを開きます。

メモ

注釈スタイルと異なる設定は文字が青で表示されます。

DimDiameter

ツールバーメニュー

寸法
製図

製図

直径寸法

 ヒストリが使用可能

DimDiameterコマンドは、選択された曲線の直径寸法を作成します。

操作手順

  1. 曲線を選択します。
  2. 寸法の位置をピックします。
    寸法は常に、オブジェクトが現在の作業平面に投影されているかのような状態で計測されます。

  • 寸法はデフォルトでヒストリが記録されます。このデフォルトのヒストリ記録動作は、Historyコマンドの注釈ヒストリの記録で制御されます。
コマンドラインオプション

注釈スタイル

注釈スタイル名を選択します。

寸法プロパティをオーバーライドするには

寸法は寸法スタイルから設定を適用します。寸法の表示をその注釈スタイルと変える必要がある場合は、寸法のプロパティで設定をオーバーライド(上書き)することができます。

  • 寸法を選択し、プロパティパネルで寸法ボタンをクリックして寸法のプロパティを変更します。

または

  • 寸法をダブルクリックして、寸法を編集ダイアログボックスを開きます。

メモ

注釈スタイルと異なる設定は文字が青で表示されます。

DimOrdinate

ツールバーメニュー

寸法
製図

製図

その他の注釈 >

座標寸法

 ヒストリが使用可能

DimOrdinateコマンドは、基準位置からのXまたはY距離寸法を作成します。

メモ

  • 座標寸法は、原点(基点)からフィーチャ(例えば穴の中心点、またはパーツのフィーチャ)までの水平または垂直距離を表示します。
  • DimOrdinateコマンドは、XまたはY軸での2点間の絶対距離を表示します。これは常に正の値であり、負の値になる可能性のあるベクトルとは異なります。
  • 座標寸法は複数の寸法による乱雑さを最小限に抑えるために、CNCに関係のある製造業界で幅広く使用されています。
  • この種類の寸法は、フィーチャの基点からのXまたはYオフセットを表示することによって、度重なるエラーを防ぎます。
  • 座標寸法引出線は、点を表示して編集することによって、作成後形を変えることができます。(このことによって、ジオメトリに重なり合ってしまう問題を解決することができます。)

座標寸法を作成する

  1. 寸法点をピックします。
    2つ目のピック点が基本的に1つ目のピック点よりも上または下にある場合、X座標寸法が表示されます。
    2つ目のピック点が基本的に1つ目のピック点よりも右または左にある場合、Y座標寸法が表示されます。
  2. 引出線の終点をピックします。
  3. 寸法の作成がすべて終了したら、Enterを押します。

座標寸法を更新する

  1. 座標寸法を選択します。
  2. 座標寸法の制御点を表示します。 (編集 > 制御点 > 制御点表示オン)
  3. 基点 (1)または寸法点 (2)を新しい位置に移動します。
    ヒストリが記録されている場合、寸法テキスト (3)が更新されます。

座標寸法の更新方法

  • 寸法はデフォルトでヒストリが記録されます。このデフォルトのヒストリ記録動作は、Historyコマンドの注釈ヒストリの記録で制御されます。
コマンドラインオプション

注釈スタイル

注釈スタイル名を選択します。

X座標

X軸座標に拘束します。

Y座標

Y軸座標に拘束します。

基点

基点を変更します。DimOrdinateコマンドを再び実行すると、基点はデフォルトの作業平面原点に戻ります。

キンクのオフセット

引出線の終点 (3)の前の2つのキンク (1) (2)のオフセット距離を決定します。このオプションは、1つ目の点を選択した後に表示されます。

寸法プロパティをオーバーライドするには

寸法は寸法スタイルから設定を適用します。寸法の表示をその注釈スタイルと変える必要がある場合は、寸法のプロパティで設定をオーバーライド(上書き)することができます。

  • 寸法を選択し、プロパティパネルで寸法ボタンをクリックして寸法のプロパティを変更します。

または

  • 寸法をダブルクリックして、寸法を編集ダイアログボックスを開きます。

メモ

注釈スタイルと異なる設定は文字が青で表示されます。

DimRadius

ツールバーメニュー

寸法
製図

製図

半径寸法

 ヒストリが使用可能

DimRadiusコマンドは、円弧または円の半径寸法を作成します。

寸法は常に、オブジェクトが現在の作業平面に投影されているかのような状態で計測されます。

操作手順

  1. 曲線を選択します。
  2. 寸法の位置をピックします。

  • 寸法はデフォルトでヒストリが記録されます。このデフォルトのヒストリ記録動作は、Historyコマンドの注釈ヒストリの記録で制御されます。
コマンドラインオプション

注釈スタイル

注釈スタイル名を選択します。

曲線上の点

寸法矢印を開始する曲線上の1点をピックします。

寸法プロパティをオーバーライドするには

寸法は寸法スタイルから設定を適用します。寸法の表示をその注釈スタイルと変える必要がある場合は、寸法のプロパティで設定をオーバーライド(上書き)することができます。

  • 寸法を選択し、プロパティパネルで寸法ボタンをクリックして寸法のプロパティを変更します。

または

  • 寸法をダブルクリックして、寸法を編集ダイアログボックスを開きます。

メモ

注釈スタイルと異なる設定は文字が青で表示されます。

DimRotated

ツールバーメニュー

寸法
製図

製図

その他の注釈 >

回転寸法

 ヒストリが使用可能

DimRotatedコマンドは、XY軸から回転した長さ寸法を作成します。

操作手順

  1. コマンドを開始します。
  2. 数値を入力して、寸法線の回転角度を設定します。
    回転角度は2点をピックして設定することもできます。
  3. 2点をピックします。
  4. 3つ目の点を選択して、寸法線を配置します。
    寸法テキストが寸法補助線の間に収まらない場合は、寸法テキストを左側または右側に配置できます。
  • 寸法はデフォルトでヒストリが記録されます。このデフォルトのヒストリ記録動作は、Historyコマンドの注釈ヒストリの記録で制御されます。
  • オブジェクトを移動しても、長さ寸法の線やテキストは移動しません。オブジェクトと一緒に長さ寸法の線やテキストを移動したい場合は、それらを一緒に移動する必要があります。
コマンドラインオプション

注釈スタイル

注釈スタイル名を選択します。

オブジェクト

寸法を測るオブジェクトを選択します。

直列寸法

同じ寸法線に沿ってより多くの直列(チェーン)寸法を追加します。

並列寸法

基準線寸法です。最初の点から寸法作成を続行します。

寸法プロパティをオーバーライドするには

寸法は寸法スタイルから設定を適用します。寸法の表示をその注釈スタイルと変える必要がある場合は、寸法のプロパティで設定をオーバーライド(上書き)することができます。

  • 寸法を選択し、プロパティパネルで寸法ボタンをクリックして寸法のプロパティを変更します。

または

  • 寸法をダブルクリックして、寸法を編集ダイアログボックスを開きます。

メモ

注釈スタイルと異なる設定は文字が青で表示されます。

DimRecenterText

ツールバーメニュー

寸法
製図

製図

寸法テキストを元の位置に戻す

DimRecenterTextコマンドは、寸法テキストを、元の位置に戻します。

操作手順

  • 寸法を選択します。
    寸法線から寸法テキストを移動したい場合は、寸法の制御点を表示して、テキストの制御点を移動します。

DimUserText

Toolbar

メニュー

V9の新機能

寸法

製図

製図

その他の注釈 >

ユーザーテキスト寸法

DimUserTextコマンドは、選択したオブジェクトのプロパティで設定されている属性ユーザーテキストを使用して、注釈引出線を作成します。オブジェクトの属性ユーザーテキストを使って、複数の引き出し線を素早く追加する際に使用できます。

操作手順

  1. DimUserTextコマンドを実行します。

  2. 引き出し線の先端を配置したいオブジェクト上の点をピックします。

    オブジェクトには、少なくとも1つのユーザーテキストエントリが含まれている必要があります。

    反転オプションを使用すると、引出線を配置する側を切り替えることができます。

  3. 注釈に使用するテキストフィールドを選択し、OKをクリックします。

    または、テキストフィールドをダブルクリックします。

  4. 続けて引出線を作成したい場合はオブジェクト上の別の点をピックします。完了したらEnterを押します。

  5. 引出線テキストの位置をピックします。

  6. マウスを動かして引き出し線同士の間隔を調整し、クリックします。

コマンドラインオプション

反転

これから作成する引き出し線を反対側に配置します。

DimVolume

ツールバー

メニュー

寸法

製図

その他の注釈 >

体積寸法

 ヒストリが使用可能

DimVolumeコマンドは、閉じた押し出し、サーフェス、ポリサーフェス、メッシュ、そしてSubDの体積寸法を作成します。

体積寸法が引出線(左)そしてテキスト(右)を使用して追加されました。

操作手順

  1. 閉じた押し出し、サーフェス、ポリサーフェス、メッシュ、またはSubDを選択します。

  2. テキストまたは引出線の始点をピックします。
    引出線オプションを用いる場合、Leaderコマンドと同じように引出線の点を指定します。
    オブジェクトの体積が自動的に入力されます。

  • 寸法はデフォルトでヒストリが記録されます。このデフォルトのヒストリ記録動作は、Historyコマンドの注釈ヒストリの記録で制御されます。
コマンドラインオプション

タイプ

引出線

オブジェクトを引出線を使って指します。

テキスト

ピックされた位置にテキストを配置します。

寸法は、寸法計算にVolumeテキストフィールドを使用します。

既存の寸法を編集するには

  • 寸法を選択し、プロパティパネルで引出線またはテキストを編集します。
  • または、寸法をダブルクリックして、引出線またはテキスト編集ボックスを開きます。

寸法のプロパティ

Style

Style

使用されている注釈スタイルです。

スタイルメニュー

モデルで使用できる注釈スタイルの一覧です。注釈のプロパティにそのスタイルとは異なる設定がある場合、スタイル名の後ろにメニューが表示されます。

オーバーライドを削除

スタイルのデフォルトに加えられた設定の変更をすべてリセットします。

<スタイル>を一致するように更新

変更した設定を注釈スタイルに適用します。

新規スタイルとして保存

プロパティの設定を使用して新規スタイルを作成します。

スタイルを編集...

選択された注釈オブジェクトによって使用されている注釈スタイルを編集します。

モデル空間スケール

表示スケールは、コンポーネントのサイズ(矢印のサイズやテキストの高さなど)とモデル空間スケールの値の積です。

通常これは、印刷スケールの逆の値です。テキスト高さ、寸法補助線の延長部長さ、寸法補助線のオフセット距離、矢印長さの値にこの値がかけられます。

スタイルを編集...

選択された注釈オブジェクトによって使用されている注釈スタイルを編集します。

マッチング

注釈を選択して、そのプロパティを現在の注釈に適用します。

Text

高さ

テキストの高さです。

マスク

不透明の色でテキストを囲みます。

なし

マスクをオフにします。

背景

マスクの色をビューポートの背景色に設定します。

指定色

マスクの色を色の選択ダイアログボックスを使用して選択します。

マスク色

マスクが指定色に設定されている場合に、クリックして色を変更できます。

マスク余白

テキストの周りの空白部分の幅です。

テキストの周りの枠

寸法テキストを囲む形状を設定します。マスク余白設定は 、テキストと形状間の距離を制御します。

下の例で数字を使用しているものはテキストに合わせて形状が伸びています。

  • 枠なし
  • 長方形
  • カプセル形状
  • 円
  • 正方形
  • ひし形
  • 三角形
  • 六角形
  • 六角形カプセル形状
  • 角丸長方形
フォント

テキストの外観です。

  • クリックしてドロップダウンリストを開き、フォントの名前の最初の文字をタイプすると、フォントを素早く探すことができます。

  • プレビューを表示してフォントを選択するには、フォントコントロールを2回クリックし、マウスホイールをスクロールします。

  • 注釈に使用されているフォントがお使いのシステムで見つからない場合:

    モデルを開く際、プロンプトが表示されます。

    警告ダイアログボックスで「今後、このメッセージを表示しない。」チェックボックスを有効にすると、不明なフォントをフォントの検出が停止されます。

    不明なフォントの検出を再度有効にするには、Rhinoオプション > 高度な設定でRhino.Warnings.MissingFontWarningを有効にします。

    注釈がビューポートで代替フォントで表示されます。

    不明なフォントがフォントリストで「(インストールされていない)」と表示されます。

B

フォントスタイルを太字にします。

I

フォントスタイルを斜体にします。

U

フォントスタイルを下線付きにします。

テキストフィールド

テキストフィールドは、Rhinoの実行中に評価される式で、結果はテキストに表示されます。すべてのテキストフィールドの構文は、%<フィールドとオプション>%です。式が評価できない場合は、####というエラー文字列が表示されます。

  • テキストフィールドが長いファイルパスなどの長いテキスト文字列を表示する場合、テキストの制御点をオンにして、右のテキスト点を移動してテキスト文字列を折り返すことができます。
  • テキストフィールドでは、基本的な算術演算を使用できます。
    面積を2倍にする場合、次のように閉じ括弧の後に*2を加えます。
    %<Area("d90815b8...80c59a")*2>%
    2つのテキストフィールドを乗算する場合は、次のようにしてください。
    %<CurveLength("07c73fde...8a5c7b")*CurveLength("296ed593...0472e0")>%
  • テキストフィールドが参照先のオブジェクト一緒にコピーされると、コピーされたテキストフィールドはコピーされたオブジェクトを参照します。
スタック括弧をトグル

「スタック括弧をトグル」ボタンは、編集ボックスで選択したテキストを[[...]]で囲む(または取り除く)ためのショートカット機能です。

分数のスタッキングの構文

分数スタッキングは、先頭と末尾の二重角括弧内のスラッシュで区切られた2つのテキスト文字列を解析するように設計されています。構文は[[x/y]] で、xが上部、yが下部です。例えば、[[Yes/I do.]] は以下のようにスタックされます。

度

度の記号(°)をテキストに追加します。

半径

半径の記号(R)をテキストに追加します。

直径

直径の記号(Ø)をテキストに追加します。

=/-

プラス/マイナスの記号(±)をテキストに追加します。

指数 2

テキストに上付き文字 2 (²)を入力します。

指数 3

テキストに上付き文字 3 (³)を入力します。

編集ボックス
山形括弧 < >

山形括弧 < > は、寸法値を表します。テキストは、この山形括弧の前または後ろにタイプすることができます。また山形括弧を削除することもできます。

複数行に渡るテキストをタイプするには、Altキーを押しながらEnterを押します。

寸法の数式について

寸法表示

現在の寸法値です。

編集ボックスのフォントサイズはコマンドプロンプトのオプションで調整できます。

テキストをフィット
自動

テキストの位置を自動的に決定します。

常に内側

テキストを寸法線の内側になるように強制します。

右

テキストを寸法線の外側そして右側になるように強制します。

左

テキストを寸法線の外側そして左側になるように強制します。

左位置示唆/右位置示唆

左位置示唆と右位置示唆は、寸法線を配置する位置をピックする際に自動的に選択されます。左側をピックすると左位置示唆が選択されます。右側をピックすると、右位置示唆が選択されます。寸法が変更され、寸法テキストが寸法補助線の間に収まらなくなった場合に、寸法テキストが左側または右側に移動します。

左位置示唆
右位置示唆
寸法線
矢印
先端 1 / 2
矢印
黒丸
ティック
短矢印
開矢印
四角
細い矢印
より細い矢印
ユーザー矢印

前もって定義されたブロックを矢印の先端として使用します。

このオプションは、モデルにブロックがない場合は使用できません。

先端になるブロックを作成するには

  1. 先端要素を作成します。
  2. そのジオメトリからブロックを作成します。
メモ
  • 矢印の先形状のブロックの基点が寸法線または引出線の端に先形状がどのように配置されるのかを決定します。下のイメージでは:

    (1) 矢印のブロックの基点は先端に配置されています。寸法線は矢印と重なります。

    (2) 矢印のブロックの基点は底の部分に配置されています。寸法線は矢印と重なりません。

    矢印の先端を正確に希望位置に配置するには、矢印のブロックの基点を先端に置いてください。

  • 先端部分の表示をコントロールするには、Blockコマンドのオブジェクトの設定、レイヤの設定、そして親の設定機能を用います。
矢印なし

矢印は作成されません。

矢印のサイズ

先端形状の長さ(先端から尾部まで)です。

矢印をフィット

矢印に十分な場所がない場合、位置を強制できます。

自動

矢印の位置を自動的に決定します。

常に内側

矢印を寸法線の内側になるように強制します。

外側

矢印を寸法線の外側になるように強制します。

矢印が外にある場合、寸法補助線間に寸法線を引く

矢印が外側にある場合に、寸法線を強制的に作成します。

長さの単位
単位 - 数値表記

注釈スタイルの単位と数値表記です。

長さ係数

寸法の距離はこの値で乗算されます。

直線長さの精度

距離表示の小数点以下の桁数を指定します。

丸め

寸法を一番近い設定値に丸めます。

接頭表記 / 接尾表記

寸法テキストの前後に追加されるテキストです。

接頭表記と接尾表記は、寸法テキスト文字列に「<>」が含まれている場合にのみ表示されます。

0省略

寸法の最初または最後の0の表示をオフにします。

0省略なし

0.560

先頭の0を省略

.560

末尾の0を省略

0.56

先頭と末尾の0を省略

.56

変換単位
変換単位を使用

長さ寸法の2つ目の単位を表示します。

単位 - 数値表記

注釈スタイルの単位と数値表記です。

長さ係数

寸法の距離はこの値で乗算されます。

直線長さの精度

距離表示の小数点以下の桁数を指定します。

丸め

寸法を一番近い設定値に丸めます。

接頭表記 / 接尾表記

寸法テキストの前後に追加されるテキストです。

接頭表記と接尾表記は、寸法テキスト文字列に「<>」が含まれている場合にのみ表示されます。

0省略

寸法の最初または最後の0の表示をオフにします。

0省略なし

0.560

先頭の0を省略

.560

末尾の0を省略

0.56

先頭と末尾の0を省略

.56

変換単位を下に

寸法線の反対側に変換単位を表示します。

許容差
許容差のスタイル

寸法線の許容差の表示と形式をコントロールします。

許容差なし

許容差は追加されません。

対称

±(=/-)の記号と1つの上限値を追加します。

偏差

寸法線上に+記号の後に上限値を、-記号の後に下限値を表示します。負の値を入力すると、許容差の表示が正から負に、負から正に反転されます。

許容限界

寸法長さ + 上限値と寸法長さ - 下限値を表示します。

解像度

許容差値の小数点以下の桁数を指定します。

変換単位の精度

変換単位の許容差値の小数点以下の桁数を指定します。

上限値

最大、つまり上限許容差値を指定します。

下限値

最小、つまり下限許容差値を指定します。

テキスト高さスケール (%)

許容差値の相対テキスト高さを指定します。これはスタック形式の許容差のためだけにある設定です。

その他のプロパティ

注釈: 角度の単位を参照

注釈: 矢印を参照

注釈: 中心マークを参照

注釈: 寸法を参照

注釈: 引出線を参照

注釈: 長さの単位を参照

注釈: 半径寸法テキストを参照

注釈: 許容差を参照

SetDimensionLayer

ツールバー

メニュー

寸法

レイヤ

製図

寸法レイヤを設定

SetDimensionLayerコマンドを使用すると、寸法を作成するレイヤを指定できます。現在のレイヤまたはレイヤを指定します。

寸法のレイヤを設定するには

  1. 寸法のレイヤを使用オプションを有効にします。

  2. レイヤ名を入力します。

    または、リストオプションを選択してリストからレイヤを選択します。

    • 入力したレイヤが存在しない場合は、レイヤが作成されます

コマンドラインオプション

寸法のレイヤを使用

寸法レイヤを有効にします。

寸法レイヤ

寸法オブジェクトのレイヤを設定します。

  • 寸法レイヤを削除すると、寸法レイヤオプションは「現在」にリセットされます。
  • 寸法レイヤの名前を変更すると、寸法レイヤオプションも更新されます。
リスト

既存のレイヤのリストからレイヤを選択します

リセット

寸法レイヤを「現在」に設定します。

寸法は現在のレイヤに作成されます。

次もご覧ください。

スマートトラックを用いて寸法を配置する方法

注釈にテキスト、寸法を使用する