BlockContent
|
Toolbar |
Menu |
|---|---|
|
|
Windows Panels > Block Content |
The BlockContent command opens the Block Content panel for browsing and inserting blocks.
Hidden command-line options
Prefix the command name with a hyphen, -BlockContent, to access the hidden command-line options.
ShowPanel
Select Yes to open the Block Content panel, No to close it, or Toggle to switch its visibility.
The Block Content panel only lists 3dm files. For other file types, use the File Explorer panel.
Go back
Go to the previously selected folder.
Go forward
Go to the next folder after using "Go back".
Search box
Enter a query string to filter items in the current folder and its sub-folders.
Quick search
Shows a list of query strings. The list is split into two sections.
- The upper section collects the words from the names of the currently selected items. For example, when an item named "Matte Silver" is selected, "Matte" and "Silver" will be listed.
- The lower section contains the search query records.
Clear search history
Deletes the search query records in the upper section.
Filters
Use regular expression
Allows using Regular expressions in the search query string.
Thumbnail size slider
The thumbnail size slider is located at the bottom of the Libraries panel. Moving the slider to 0% lists the items without thumbnails.
Grid view
Shows items in rows and columns.
List view
Stacks items vertically in a single column.
Options menu
Render Content
Opens the Render Content folder.
Documents
Opens the Documents folder.
Custom folders
The folders added in Rhino Options > Block Content.
Add current folder
Adds the current folder to the menu.
Settings
Opens the Rhino Options > Block Content page.
Help
Opens the help topic.
Right-click context menu
Right-click a 3dm file in the Block Content panel to select actions.
Edit
Edits the item in a new Rhino window.
Cut
Copies the selected item to the Clipboard for moving it to a different folder.
Copy
Copies the selected item to the Clipboard.
Paste
Creates a new item based on the contents of the Clipboard.
Duplicate
Creates a new item from the selected item.
Delete
Deletes the selected item.
Rename
Edits the item name.
Tiny
Sets the thumbnail size to the smallest size.
Small
Sets the thumbnail size to the smaller size.
Medium
Sets the thumbnail size to medium size.
Large
Sets the thumbnail size to large size.
Select All
Selects all items in the current folder.
Open containing folder
Opens the current folder in File Explorer.
Properties
Views the file's detailed information in the file properties dialog.
Block Content Options
Tools > Options > Block Content
Folders
Show "Blocks" folder
Displays the "Blocks" folder in the Options menu of the Block Content panel.
Use default library location
Opens the following folder by default.
%AppData%\McNeel\Rhinoceros\<Version>\Localization\<Language ID>\Blocks
Custom
Opens a custom folder by default.
Click the Browse button to select a folder.
Show "Documents" folder
Displays the current user's "Documents" folder in the Options menu of the Block Content panel.
Show custom folders
Displays the folders listed below in the Options menu of the Block Content panel.
New
Adds a new folder to the list.
-
Windows environment variables can be used in the paths.
Delete
Deletes the selected folder from the list.
Move Up
Moves the selected folder up in the list.
Move Down
Moves the selected folder down in the list.
Initial folder
Displays one of these folders in the new Rhino window.