Manage toolbars

Rhino opens with the default toolbar layout. The default toolbar layout displays only some of the many Rhino toolbars. Most of the hidden toolbars can be opened from the toolbar buttons in the default toolbar layout. The toolbar in the left Sidebar may change when you click a toolbar tab that has another toolbar linked.

Open toolbars floating

  1. Select the Window menu > Toolbars.

  2. Select a Library.

    The Library drop-down menu lists the default and linked rui files.

  3. Select a toolbar name.

    The toolbar will be opened in a floating container with the same name.

Add or remove toolbars on a container

  1. Click the gear icon of a container > Show Toolbars.

  2. Select a rui file.

    The RUI Files drop-down menu lists the default and linked rui files.

  3. Check or uncheck the boxes in front of the toolbar names.

Open a toolbar from a button

When a toolbar is linked to a button, the button shows a black triangle on the lower-right corner. The linked toolbar opens as a flyout toolbar when you:

Float a container

Dock a floating container

  1. Drag the title bar of a floating container to a docked container.

    Dock sites (blue squares) appear around the target container.

  2. Drop the floating container on one of the dock sites.

Re-size a container

  1. Move the mouse cursor to an edge or a corner of a container.

    Notice that the cursor changes to an arrow icon.

  2. Drag to re-size the container.

Containers

A container may include multiple toolbars or panels as tabs. When a toolbar or panel is made floating, a new container is created with the same name.

Components of a container

Container name

The name of the container.

When a toolbar or panel is made floating, a new container is created with the name of the toolbar or panel.

The container name can be changed in Container Properties.

Title bar

Drag the title bar to move the container to float at any position on the screen, or dock to an edge of the Rhino window or next to another docked container.

Options menu button

Open the container options menu.

Close button

Close the container.

Closed containers can be opened again using the Containers command.

Tab

Tabs show the toolbar or panel names.

Right-click to open the tab menu.

Properties

Opens the Container Properties dialog box.

Close Tab: <Name>

Removes the tab from the container.

Closed tabs can be added back by:

Hover the mouse cursor over a tab and scroll through the tabs with the mouse wheel.

Tabs can be re-ordered or moved to another container by drag and drop.

Linked toolbar cascade button

When a toolbar is linked to a button, the button shows a black triangle on the lower-right corner. The linked toolbar opens as a flyout toolbar when you:

Show more button

When a container is not large enough to show all the buttons on a toolbar, the >> button appears.

Lock docked containers

Prevents the docked containers from being accidentally moved.

The Lock Docked Containers setting can be found in the container options menu, or in Containers options.

Sidebar

"Sidebar" is a special container that displays an existing container according to the currently active toolbar tab. In the default workspace, if you click on the Curve Tools tab, the Curve drawing sidebar container will display in Sidebar.

To link a container to a tab as a sidebar

  1. Right-click on a toolbar tab and select Properties.
  2. In the Container Properties dialog box, click the button in the Sidebar section.

Restoring lost toolbars

If your toolbars are lost or become corrupted, they can be restored with the Reset command.

Warning

The Reset command replaces all custom containers and toolbars with the default set embedded in the Rhino APP.

Manage toolbar buttons

Move a button

  1. Press and hold Shift.
  2. Click and drag the button to a different toolbar or to a different position on the same toolbar.

Copy a button

  1. Press and hold Ctrl(CMD).
  2. Click and drag the button to a different toolbar or to a different position on the same toolbar.

Delete a button

  1. Press and hold Shift.
  2. Click and drag the button off the toolbar.

Create a linked button

  1. Press and hold Ctrl(CMD).
  2. Right-click and drag the button from a toolbar (a) to another toolbar (b) in a different container. A copy of the button appears on the toolbar (b) with the toolbar (a) as a linked toolbar.

Unlink a toolbar

  1. Press and hold Shift.
  2. Right-click the button with a linked toolbar.
  3. In the Button Editor dialog box, click the unlink button .

Add a new button

  1. Click the container options icon .

  2. Select New Toolbar Button.

  3. In Macro Library, select an existing macro item.

    Or, click the New button to create a new macro item.

Edit a button

  1. Press and hold Shift.
  2. Right-click the button to open Button Editor.
  3. Click the button image to open Macro Library.
  4. Click the Edit button.

See also

Customize containers

Edit toolbar button

 

 

 

Rhinoceros 8 © 2010-2024 Robert McNeel & Associates. 07-Jun-2024