Layer

ツールバー メニュー

レイヤ
標準

編集

レイヤ > レイヤを編集

ウィンドウ

パネル > レイヤを編集

Layerコマンドは、レイヤプロパティを管理します。

レイヤはオブジェクトをまとめる手段の一つで、すべてを同時に操作したり、操作の進行過程を記録しておくことができます。オブジェクトが同一のレイヤ上にある場合、それらすべてを一度に非表示にしたり、ワイヤフレーム表示の色を変更したり、一度の選択操作ですべてを選択したりすることができます。

レイヤパネル

コンテナのオプション

レイヤパネルには、モデルのレイヤが表示されます。

レイアウトビューがある場合、列の表示内容が変わります。

リンクされたブロックまたはワークセッションがある場合、これらの外部ファイルからのレイヤはブロック名の下にツリーで表示されます。

レイヤパネルには、モデルのレイヤを管理することができるツールが搭載されています。

レイヤポップアップメニューには、オン/オフ、ロック/ロック解除、色、現在の状態などの一般的なレイヤ設定オプションが表示されます。

ショートカットウィンドウを表示するには

  • ステータスバーのレイヤペインをクリックします。

    レイヤのポップアップには、レイヤオプションを素早く設定できる項目が表示されます。レイヤのポップアップを右クリックすると、コンテクストメニューが表示されます。

    コンテクストメニュー

    オブジェクトを選択

    そのレイヤのすべてのオブジェクトを選択します。サブレイヤのオブジェクトは除外されます。

    オブジェクトのレイヤを変更

    選択されているオブジェクトをそのレイヤに移動します。

    オブジェクトをレイヤにコピー

    選択されているオブジェクトをそのレイヤにコピーします。

メモ

  • オブジェクトが何も選択されていない場合、ステータスバーのレイヤポップアップウィンドウからレイヤを選択すると、選択されたレイヤが現在のレイヤとして設定されます。
  • オブジェクトが選択されている場合、ステータスバーのレイヤポップアップウィンドウからレイヤを選択すると、オブジェクトが選択されたレイヤに変更されます。現在のレイヤは変更されません。
  • オブジェクトが何も選択されていない限り、ステータスバーのレイヤペインは現在のレイヤを表示します。オブジェクトが選択されている場合、ステータスバーのレイヤペインは選択されているオブジェクトのレイヤを表示します。複数のオブジェクトが複数のレイヤにある場合は、「混在」と表示されます。

レイヤパネルを開くには

  • ステータスバーのレイヤペインを右クリックします。
    または
  • ウィンドウ > パネルメニューで「レイヤ」を有効にします。

レイヤのプロパティ

名前

レイヤ名です。

参照: Rhinoでの命名規則

現在

現在のレイヤには、チェックマークと薄い色が付きます。

オン / オフ

レイヤがモデルオン、レイアウトオン、または詳細オンの設定で特にオフにされていない限り、モデルビュー、レイアウトビュー、および詳細ビューでのレイヤのグローバル表示を同時に制御します。

ロック / ロック解除

レイヤ上のオブジェクトの選択可能状態を制御します。

子レイヤの状態

  • 親レイヤをオフまたはロックした場合、子レイヤの「半分電気がついた状態の」電球 またはロック アイコンは、子レイヤが親レイヤによって制御されることを示します。
  • 電球またはロック アイコンがすべてグレー表示されている場合、子レイヤは独自のコントロールを持ち、親レイヤによって変更されません。
  • 親レイヤをオフまたはロックしている場合、子レイヤを単独でオンまたはロック解除することはできません。
色

デフォルトでこのレイヤのオブジェクトに割り当てられた色を表示します。

マテリアル

レンダリングに使用するマテリアルです。

円状のアイコンはマテリアルのサムネイルを表示します。

RenderAssignMaterialToLayer

線種

このレイヤに割り当てられた線種です。

印刷色

このレイヤに割り当てられた印刷用の色です。

印刷幅

印刷幅を選択ダイアログを開きます。印刷用のみにレイヤに割り当てられた線幅を指定するか、レイヤを印刷したくない場合は印刷なしを指定します。

独自の線幅を定義する

  • Rhinoサポートフォルダのprintwidths.txtファイルに線幅値を追加します :

    %AppData%\McNeel\Rhinoceros\<バージョン>\Localization\<言語>\Support\

printwidths.txtファイルでの注意事項:

  • ;または//で始まる行は無視されます。

  • 線幅の値は0より大きくなければなりません。

複数のレイヤの設定を変更するには

  1. レイヤを選択します。

  2. Ctrl(CMD)+クリックまたはShift+クリックで更にレイヤを選択します。

  3. 電球アイコンをクリックすると選択したレイヤを一度にオン/オフにすることができます。

    その他のレイヤ設定もこの操作で変更できます。

断面スタイル

レイヤのオブジェクトのクリッピング断面の塗りつぶし方法を設定します。

  • 断面スタイルの色は印刷色に優先されます。

なし

クリッピング断面をハッチングパターンで塗りつぶしません。

カスタム

断面スタイルダイアログで選択されたハッチングパターンでクリッピング断面を塗りつぶします。

新規詳細オン

新しい詳細ビューの詳細オン設定のデフォルトの状態を制御します。

モデルオン / レイヤオン / 詳細オン

グローバルの表示設定がオンになっている場合、モデルビュー、レイアウトビュー、および詳細ビューでのレイヤの表示を個別に制御します。

レイアウト / 詳細の色

デフォルトでレイアウトまたは詳細のこのレイヤのオブジェクトに割り当てられた色を表示します。

レイアウト / 詳細の印刷色

印刷用のみにレイアウトまたは詳細レイヤに割り当てられた色です。

レイアウト / 詳細の印刷幅

印刷用のみにレイアウトまたは詳細レイヤに割り当てられた線幅です。印刷用のみにレイヤに割り当てられた線幅を指定するか、レイヤまたは詳細を印刷したくない場合は印刷なしを指定します。それぞれのオブジェクトのプロパティを変更するには、Propertiesコマンドを使用します。

説明

レイヤに関する説明をテキスト入力できます。

レイヤツールバーオプション

新規レイヤ

クリックして、新規レイヤ色を使用して新規レイヤを作成します。

新規レイヤ(ランダム色)

右クリックして、ランダムな色で新規レイヤを作成します。

TabとInsertキー

レイヤ名を編集中、TabまたはInsertを押すと、 その名前の編集が確定し、その次に新規レイヤが作成されます。この方法を使うと、複数のレイヤをより簡単に作成できます。

新規サブレイヤ

クリックすると、選択したレイヤの下に新規レイヤ色を使用して新規レイヤを作成します。

新規サブレイヤ(ランダム色)

右クリックすると、選択したレイヤの下にランダムな色を使用して新規レイヤを作成します。

  • レイヤは他のレイヤの下にドラッグして、サブレイヤにすることができます。
  • 同じ階層にあるレイヤの名前は一意でなければなりません。(同じ名前があってはなりません。)
削除

削除したいレイヤにオブジェクトが存在している場合、警告ダイアログが表示されます。

デフォルトでは、レイヤパネルでキーボードのDeleteキーを押すと、選択したレイヤではなく、ビューポート内の選択されたオブジェクトが削除されます。レイヤの削除を有効にするには、高度な設定でEnableLayersPanelDeleteKeyをTrueにします。

未使用のレイヤをパージ

オブジェクトをなにも含まないすべてのレイヤを削除します。

オブジェクトのレイヤを変更

選択されたオブジェクトを選択レイヤに移動します。

オブジェクトをレイヤにコピー

選択されたオブジェクトを選択レイヤにコピーします。

操作手順

  1. オブジェクトを選択します。
  2. ターゲットのレイヤを選択します。
  3. ボタンを左クリックまたは右クリックします。

参照: ChangeLayer

上へ移動

リストで選択されたレイヤを1つ上に移動します。

下へ移動

リストで選択されたレイヤを1つ下に移動します。

階層を1つ上へ移動

レイヤツリー構造で、選択されたレイヤを1つ上のレベルに移動します。

フィルタ

モデルにたくさんのレイヤがある場合、レイヤリストが見難くなることがあります。レイヤフィルタを使用すると、レイヤの表示をパネルでコントロールすることができます。

レイヤフィルタオプション

すべてのレイヤ
オンレイヤ
オフレイヤ
ロックレイヤ
ロックされていないレイヤ
オブジェクトのあるレイヤ
オブジェクトのないレイヤ
選択レイヤ
  • チェックボックスをクリックすると、そのフィルタが有効または無効になります。

  • チェックボックスを右クリックすると、そのフィルタが有効になり、その他すべてのフィルタは無効になります。

列

列のヘッダのリストを表示して、レイヤ設定を表示または非表示にできます。

列のヘッダを右クリックしても同じリストが表示されます。

ツール
レイヤステートマネージャ

レイヤステートパネルを表示します。

すべて選択

現在リストに表示されているすべてのレイヤを選択します。

オブジェクトのレイヤを選択

現在選択されているオブジェクトのレイヤを選択します。

選択を反転

選択状態を反転します。選択されているすべてのレイヤは選択が解除され、選択されていないレイヤがすべて選択されます。

オブジェクトを選択

現在選択されているレイヤにあるオブジェクトを選択します。

サブレイヤのオブジェクトを選択

現在選択されているレイヤとそのサブレイヤにあるオブジェクトを選択します。

オブジェクトのレイヤを変更

選択されたオブジェクトを選択レイヤに変更します。

参照: ChangeLayer

オブジェクトをレイヤにコピー

選択されたオブジェクトを選択されたレイヤにコピーします。

すべてのレイヤをオン

すべての非表示レイヤをオンにします。

すべて展開

すべての子レイヤ非表示にします。

すべて折りたたむ

すべての子レイヤを非表示にします。

列

レイヤパネルでどの列を表示するのかを選択します。

列の並べ替え

列でレイヤを並べ替えることを可能にします。うっかり並べ替えることを防ぐには、チェックマークを外します。

検索

テキストを入力すると、名前にそのテキストが含まれるレイヤだけを表示することができます。

パターンの一致にはワイルドカード文字を使用できます:

* = 0個以上の文字
? = 1文字

ステータスバー

ステータスバーは、レイヤパネルの下部に配置されています。レイヤの総数と、現在選択されているレイヤの数を表示します。

レイヤリストのオプション

リストを並べ替えるには

  • 列のヘッダをクリックします。

    レイヤ名は自然な並べ替え順序で並べ替えられます。

    自然な並べ替え順序: 1, 2, 3, 10 (10が3の後に来る。)

    アルファベットでの並べ替え順序: 1, 10, 2, 3 (10が2の前に来る。)

列を非表示または表示するには

  • 列名を右クリックします。表示したい列にはチェックマークを付け、非表示にしたい列はチェックマークを外します。

列の幅を変更するには

  • 列名の境界線をドラッグします。

レイヤのプロパティを編集するには

  • レイヤのプロパティを編集するには、レイヤ名を右クリックし、コンテクストメニューからオプションを選択するか、レイヤツールバーからオプションを選択します。

複数のレイヤを選択するには

  • 複数のレイヤのリストの上でカーソルをクリック、ドラッグして選択します。
  • 複数の隣接するレイヤ名を選択するには、Shiftキーを押しながら選択します。
  • 複数の個々のレイヤ名を選択するには、Ctrlキーを押しながら選択します。
  • 2、3のレイヤ以外のレイヤを素早くすべて選択するには、選択したくないレイヤの選択を解除します。

レイヤコンテクストメニューのオプション

レイヤコンテクストメニューを開くには

  • レイヤの列を右クリックします。

    異なる列の右クリックでは、コンテクストメニューに別の項目が表示される場合があります。

ワークセッション参照 (ワークセッションレイヤのみ)

詳細に関しては、ワークセッションをご覧ください。

アクティブモデルを設定

選択したモデルを編集用に開きます(アクティブにします)。

その際アクティブだったモデルは閉じられ、アタッチされたモデルとなります。アクティブだったモデルが閉じられる際は、変更を保存するかどうかメッセージが表示されます。

モデルをデタッチ

ワークセッションリストから外部ファイルを削除します。

モデルを更新

選択されたアタッチファイルを更新します。

モデルをアタッチ

外部ファイルをワークセッションリストにアタッチします。

リンクされたブロックのレイヤプロパティをリセット

リンクされたブロック内の参照レイヤの元のプロパティを復元します。プロパティには、オン、ロック、色、印刷色、印刷幅、新規詳細オン、そしてモデルオンが含まれます。このオプションは、リンクされたブロックの参照レイヤ名を右クリックした場合にのみ使用できます。

デフォルトに戻す

右クリックしている列をデフォルト設定にリセットします。

ランダムな色 (モデルビューの色の列のみ)

選択されたレイヤにランダムな色を割り当てます。

選択された詳細のみのレイヤをオフ (レイアウトオンの列のみ)
> このレイアウト

選択した詳細ビューでレイヤをオフにし、現在のレイアウトの他のすべての詳細ビューではオンにします。

> すべてのレイアウト

選択した詳細ビューでレイヤをオフにし、すべてのレイアウトの他のすべての詳細ビューではオンにします。

選択された詳細のみのレイヤをオン (レイアウトオンの列のみ)
> このレイアウト

選択した詳細ビューでレイヤをオンにし、現在のレイアウトの他のすべての詳細ビューではオフにします。

> すべてのレイアウト

選択した詳細ビューでレイヤをオンにし、すべてのレイアウトの他のすべての詳細ビューではオフにします。

この詳細のみのレイヤをオフ (詳細オンの列のみ)
> このレイアウト

アクティブな詳細ビューでレイヤをオフにし、現在のレイアウトの他のすべての詳細ビューではオンにします。

> すべてのレイアウト

アクティブな詳細ビューでレイヤをオフにし、すべてのレイアウトの他のすべての詳細ビューではオンにします。

この詳細のみのレイヤをオン (詳細オンの列のみ)
> このレイアウト

アクティブな詳細ビューでレイヤをオンにし、現在のレイアウトの他のすべての詳細ビューではオフにします。

> すべてのレイアウト

アクティブな詳細ビューでレイヤをオンにし、すべてのレイアウトの他のすべての詳細ビューではオフにします。

オブジェクトを選択

選択レイヤのオブジェクトを選択します。

サブレイヤのオブジェクトを選択

選択レイヤのサブレイヤにあるオブジェクトを選択します。

オブジェクトのレイヤを変更

モデルの選択されたオブジェクトのレイヤを選択レイヤに変更します。

オブジェクトをレイヤにコピー

オブジェクトを選択されたレイヤにコピーします。

新規レイヤ

新規レイヤを作成します。

新規サブレイヤを作成

新規サブレイヤを作成します。

レイヤを複製

レイヤを属性と一緒にコピーします。

レイヤとオブジェクトを複製

レイヤを属性とそのレイヤのすべてのオブジェクトと一緒にコピーします。

参照: DupLayer

1レイヤのみ表示

選択した1つのレイヤを表示状態に、残りを非表示にします。

参照: OneLayerOn

プロパティをマッチング

マッチングするレイヤを選択します。

参照: MatchProperties

削除

選択レイヤを削除します。

名前を変更

選択したレイヤの名前を編集します。

サブレイヤを展開

選択した親レイヤのレイヤツリーを展開します。

サブレイヤを折りたたむ

選択した親レイヤのレイヤツリーを折りたたみます。

レイヤのキーボードショートカット

標準のリスト表示のコントロールのショートカット

▲

選択を上へ移動します。

▼

選択を下へ移動します。

PageUp

選択を1ページ上へ移動します。

PageDown

選択を1ページ下へ移動します。

Home

選択を最初のアイテムへ移動します。

End

選択を最後のアイテムへ移動します。

Ctrl

選択に個々のレイヤを追加します。

Shift

選択にレイヤの範囲を追加します。

レイヤ特定のショートカット

これらのショートカットを動作させるにはレイヤパネルにカーソルが置かれている状態でなければなりません。

F2 / Enter

選択レイヤの名前を変更します。

F5

レイヤリストを更新します。

Insert

選択レイヤの下に新規レイヤを作成します。

+

選択レイヤを展開します。

Ctrlまたは 
Shift +
テンキー +

選択レイヤのすべての子レイヤを展開します。

-

選択レイヤを折りたたみます。

CtrlまたはShift + 
テンキー -

選択レイヤのすべての子レイヤを折りたたみます。

列のオプション

レイヤパネルの列を表示/非表示します。

名前

現在

オン

ロック

色

マテリアル

線種

印刷色

印刷幅

レイアウトビューがある場合、より多くのオプションが表示されます。

レイアウトオン

レイアウト色

レイアウト印刷色

レイアウト印刷幅

詳細ビューがある場合、より多くのオプションが表示されます。

詳細オン

詳細色

詳細印刷色

詳細印刷幅

関連コマンド

ChangeLayer

ツールバー メニュー

レイヤ

編集

レイヤ >

オブジェクトのレイヤを変更

ChangeLayerコマンドは、選択されたオブジェクトのレイヤを変更します。

操作手順

  1. オブジェクトを選択します。
  2. リストからレイヤ名を選択します。

オブジェクトのレイヤのオプション

選択できるレイヤ

名前

レイヤ名です。

  • レイヤ名をダブルクリックすると、ターゲットレイヤ設定し、ダイアログを閉じることができます。
現在のレイヤを切り替え

ターゲットレイヤを現在のレイヤにします。

選択

ビューポートのオブジェクトを選択してレイヤを指定します。

新規作成

新規レイヤを作成します。

ChangeToCurrentLayer

ツールバー メニュー パネル

レイヤ

編集

レイヤ >

オブジェクトを現在のレイヤに移動

レイヤ

レイヤ名を右クリック >

オブジェクトのレイヤを変更

ChangeToCurrentLayerコマンドは、選択されたオブジェクトのレイヤを現在のレイヤに変更します。

操作手順

  • オブジェクトを選択します。

CopyToLayer

ツールバー メニュー

レイヤ

編集

レイヤ >

オブジェクトをレイヤにコピー

CopyToLayerコマンドは、選択されたオブジェクトを指定のレイヤにコピーします。

操作手順

  1. オブジェクトを選択します。
  2. リストからレイヤ名を選択します。

オブジェクトのコピー先のレイヤ

選択できるレイヤ

名前

レイヤ名です。

  • レイヤ名をダブルクリックすると、ターゲットレイヤ設定し、ダイアログを閉じることができます。
現在のレイヤを切り替え

ターゲットレイヤを現在のレイヤにします。

選択

ビューポートのオブジェクトを選択してレイヤを指定します。

新規作成

新規レイヤを作成します。

隠しコマンドラインオプションを表示するには

  • コマンド名の前に次のようにハイフンを付けてタイプします: -CopyToLayer
コマンドラインオプション

新規レイヤ

新規レイヤを作成します。

オブジェクトを選択

オブジェクトをピックしてレイヤを指定します。

現在のレイヤを切り替え

はい/いいえ

HighlightObjectLayers

ツールバー

メニュー

レイヤ

編集

レイヤ > オブジェクトのレイヤをハイライト

HighlightObjectLayersコマンドは、レイヤパネルが表示状態の時に選択されたオブジェクトのレイヤを選択します。

LayerStateManager

ツールバー メニュー

レイヤ

編集

レイヤ > レイヤステートマネージャ

ウィンドウ

パネル > レイヤステート

LayerStateManagerコマンドを使うと次のことが行えます:

  • レイヤの現在の状態を保存します。

  • 以前に保存したレイヤ状態を呼び出します。

  • .3dmファイルからレイヤ状態のリストをインポートします。

操作手順

  1. レイヤを設定します。
    レイヤステートマネージャは、現在のレイヤの設定を保存します。
  2. レイヤステートマネージャパネルで保存をクリックし、レイヤ状態に付ける名前を入力します。

レイヤステートパネル

コンテナのオプション

ツールバーボタン

保存

新規のレイヤ状態を保存します。

  • 「名前」の列のヘッダをクリックすると、リストを昇順または降順に並べ替えることができます。

参照: Rhinoでの命名規則

呼び出し

指定されたレイヤ状態に変更します。

削除

選択されたレイヤ状態を削除します。

インポート

.3dmファイルからレイヤ状態のリストをインポートします。

検索ボックス

テキストを入力すると、名前にそのテキストが含まれるレイヤ状態だけを表示することができます。

右クリックコンテクストメニュー

呼び出し

指定されたレイヤ状態に変更します。

削除

選択されたレイヤ状態を削除します。

名前を変更

選択されたレイヤ状態の名前を編集します。

保存

新規のレイヤ状態を保存します。

更新

選択されたレイヤ状態を現在のレイヤの設定で上書きします。

呼び出すレイヤ設定

モデル空間にレイヤ状態を呼び出します。

現在のレイヤ
オン/オフ
ロック/ロック解除
色
マテリアル
展開
線種
印刷色
印刷幅
断面スタイル
新規詳細オン

呼び出すレイアウトまたは詳細レイヤ設定

レイアウトまたは詳細にレイヤ状態を呼び出します。

オン/オフ
色
印刷色
印刷幅
  • レイアウトビューポートでレイヤ状態を保存する際、アクティブな詳細ビューがない場合は、レイアウトのレイヤプロパティが保存されます。

  • レイアウトと詳細ビューは、レイヤ状態で同じレイヤプロパティを共有します。レイヤプロパティは、アクティブな詳細ビューまたは複数選択した詳細ビューに復元できます。現在アクティブまたは選択されている詳細ビューがない場合、レイヤプロパティは現在のレイアウトに復元されます。

  • モデルビューポートでレイヤ状態を保存した場合、そのレイヤ状態をレイアウトまたは詳細ビューに復元すると、グローバルなレイヤプロパティがレイアウト/詳細ビューのレイヤプロパティに適用されます。

OneLayerOn

ツールバー メニュー

レイヤ

編集

レイヤ >

1レイヤのみ表示

OneLayerOnコマンドは、指定した1つのレイヤを表示状態に、残りを非表示にします。

操作手順

  1. モデルビューポートをアクティブにします。

  2. リストからオン(表示状態)にしたいレイヤを選択します。

    または、選択ボタンをクリックしてターゲットレイヤのオブジェクトを選択します。

OneLayerOff

ツールバー メニュー

レイヤ

編集

レイヤ >

1レイヤのみ表示オフ

OneLayerOffコマンドは、選択したオブジェクトのレイヤをオフにします。

操作手順

  • モデルビューポートのレイヤのオブジェクトを選択します。

RenderAssignMaterialToLayer

ツールバー メニュー

ツールバーにはありません。

メニューにはありません。

RenderAssignMaterialToLayerコマンドは、コマンドラインからマテリアルをレイヤに割り当てます。

操作手順

  1. マテリアルを名前またはIDを入力して選択します。

  2. レイヤを名前またはIDを入力して選択します。

次もご覧ください。

RenderAssignMaterialToLayersOfObjects

コマンドラインから選択したオブジェクトのレイヤにマテリアルを割り当てます。

RenderAssignMaterialToObjects

コマンドラインから選択したオブジェクトにマテリアルを割り当てます。

RenderAssignMaterialToLayersOfObjects

ツールバーメニュー

ツールバーにはありません。

メニューにはありません。

RenderAssignMaterialToLayersOfObjectsコマンドは、コマンドラインから選択したオブジェクトのレイヤにマテリアルを割り当てます。

操作手順

  1. マテリアルを名前またはIDを入力して選択します。

  2. 1つまたは複数のオブジェクトを選択します。

次もご覧ください。

RenderAssignMaterialToLayer

コマンドラインからマテリアルをレイヤに割り当てます。

RenderAssignMaterialToObjects

コマンドラインから選択したオブジェクトにマテリアルを割り当てます。

SetLayerToObject

ツールバーメニュー

レイヤ

編集

レイヤ >

選択したオブジェクトのレイヤを現在のレイヤにする

SetLayerToObjectコマンドは、選択されたオブジェクトのレイヤを現在のレイヤにします。

操作手順

  • 現在のレイヤにしたいレイヤにあるオブジェクトを選択します。

次もご覧ください。

Snapshots

Snapshotsコマンドは、名前の付いたビュー、名前の付いた位置、レイヤステート、レンダリング設定、そしてロック/非表示の状態、表示モード、マテリアル、位置、光源設定、曲線パイプ、ディスプレイスメント、ソフトエッジ、シャットライン、厚みを含むオブジェクトの設定の保存、呼び出しを行います。

オブジェクトをコピー/複製する

レイヤを使用する

ブロック、グループ、ワークセッションで作業を行う

レイヤのスクリプト化

McNeel Wiki: Imported and linked block layer names