Macros de comandos y scripts

Todos los comandos de Rhino se pueden utilizar en macros de comandos. Las macros de comandos se pueden ejecutar escribiendo el comando en la línea de comandos desde los botones de la barra de herramientas, las teclas de acceso directo, los alias de comandos, desde el comando LeerArchivoDeComandos o usando el comando Pegar para pegar un script a la secuencia de comandos de Rhino.

Escribir macros de comandos

Las macros de comandos se escriben igual que las secuencias de comandos en la línea de comandos.

Caracteres especiales

Significado en la macro

(espacio)

Un carácter de espacio en las macros actúa como si se pulsara Intro.

Cuando en un script se introduce un nombre (o una cadena de texto) que contiene espacios, es necesario ponerlo entre comillas dobles para evitar que se produzca un error en el script.

Por ejemplo:

-SelNombre "Tabla 01" ✔

-SelNombre Tabla 01 ✘

*
(asterisco)

Hace que el comando se repita automáticamente sin pulsar la tecla Intro para reiniciar.

!
(signo de exclamación)

Cancela el comando anterior.

Un signo de exclamación (!) al principio de cada macro cancelan cualquier comando anterior. En otras posiciones, se cancela la macro. Si es necesario, el signo de admiración se puede utilizar al final de la macro.

-
(guión)

Suprime el cuadro de diálogo.

Básicamente, todos los comandos se pueden convertir en macros para usar en la línea de comandos (incluso los comandos que tienen cuadros de diálogo por defecto). Para suprimir el cuadro de diálogo y usar las opciones en la línea de comandos, añada un guión (-) delante del nombre del comando. Algunos comandos (por ejemplo, SupDes) tienen opciones que solo están disponibles en la línea de comandos.

_
(guión bajo)

Ejecuta los comandos y las opciones en inglés.

Rhino está traducido a varios idiomas. Los comandos y las opciones se traducen de forma diferente según el idioma. Para que las macros funcionen en todo el mundo, le recomendamos que las escriba en inglés con un guión bajo delante de cada comando y opción.

Por ejemplo:

Cerchio 3Punti 0,0,0 1,1,0 0,3,0 ❗

Esta macro solo funciona en la versión de Rhino en italiano.

 

_Circle _3Point 0,0,0 1,1,0 0,3,0 ✔

Esta macro funciona en la versión de Rhino en todos los idiomas.

'
(apóstrofe)

El siguiente comando es un comando anidable.

La manipulación de vistas y planos de construcción y las referencias a objetos son anidables. Los comandos de creación de geometría no son anidables.

Las referencias a objetos de una sola designación y los filtros de designación de subobjetos son automáticamente anidables y no requieren apóstrofe.

\
(barra inversa)

Si el último carácter de una macro de botón de la barra de herramientas es "\", la macro se ejecuta sin poner un Intro al final.

Por ejemplo:

Cree un botón de barra de herramientas con una macro "5\". Hacer clic en el botón introduce 5 en la línea de comandos y se detiene ahí para seguir con la introducción de datos. Esta función se puede utilizar para crear una barra de herramientas que funcione como teclado numérico en pantalla.

~
(tilde)

Suprime las opciones de comando para evitar desorden en las respuestas del comando. Las opciones siguen funcionando como siempre.

;

(punto y coma)

Comentario:

Las líneas que empiezan con un punto y coma (;) no forman parte de la macro, sino que permiten documentar la macro o probar entradas alternativas.

Por ejemplo:

; Macro de prueba
_Circle 0,0,0 15
_Line 0,0,0 pause ;15,0,0
; Line 0,0,0 0,15,0
_Line 0,0,0 -15,0,0

::
(dos puntos dobles)

El anidado de capas se indica mediante dos puntos dobles "::" entre los nombres de las capas. Con el comando -Capa, agregue una nueva capa anidada debajo de la Capa 01 utilizando la siguiente macro:

! _-Layer New "Layer 01:: New Layer" Enter

#
(almohadilla)

Activa la grabación de historial del siguiente comando.

Por ejemplo: #ArcBlend

%
(porcentaje)

Desactiva la grabación de historial del siguiente comando.

Por ejemplo: %ArcBlend

!&

(signo de exclamación + y)

Desactiva el Bloqueo del historial en una sesión de comandos.

Por ejemplo: !&_Delete y !&_Join

Ejemplos

Dibujar un círculo

Esta macro crea un círculo centrado en el punto 5,5 con un radio de 10:

! _-Circle 5,5 10

Los espacios entre las entradas equivalen a pulsar la tecla Intro cuando escribe el comando manualmente.

Anular la selección de objetos y ejecutar el comando Mover

Esta macro inicia el comando Mover, pero se asegura de que no haya objetos seleccionados antes de solicitar los objetos a mover:

! _SelNone _Move

Crea una curva a través de puntos

Esta macro crea un grupo de tres puntos, los selecciona todos y crea una polilínea a través de los puntos:

! _SelAll _Points _Pause _Pause _Pause _Enter _Invert _CurveThroughPt _EnterEnd

Funcionamiento de este script:

! _SelAll

Cancela todos los comandos previos y selecciona todos los objetos del modelo.

_Points

Ejecuta el comando Puntos.

_Pause

_Pause

_Pause

Permite designar tres posiciones de puntos.

_Enter

Simula pulsar Intro, lo que detiene la creación de objetos de puntos.

_Invert

Invierte la selección. Todos los objetos visibles se seleccionaron al inicio de la secuencia de comandos, de manera que después del comando Invert sólo se seleccionarán los objetos de puntos recién creados.

_CurveThroughPt

Crea una polilínea a través de objetos de puntos.

_EnterEnd

Completa el comando.

Evitar un cuadro de diálogo

! -_Rebuild _Pause _Points=10 _Degree=3 _Enter

Seleccione una curva y luego ejecute esta macro. Todas las opciones serán definidas por la macro.

Para probar estas macros

  1. Seleccione la macro desde este mismo tema de la Ayuda.
  2. Pulse Ctrl + C para copiarlo en el portapapeles.
  3. Haga clic en la línea de comandos de Rhino y pulse la tecla Ctrl + V para pegar la macro.
Comandos especiales para scripts

Pausar

Detiene una macro para que el usuario introduzca información.

Ejemplo:

! _Circle _Pause 50

Esta macro solicita un punto y luego dibuja un círculo centrado con un radio de 50 unidades.

MultiPausa

Detiene un script durante múltiples selecciones, por ejemplo en Unir, Polilínea y EmpalmarBorde.

Intro

Simula pulsar Intro dentro de una macro.

Este comando no repite el comando anterior como lo hace la tecla Intro.

IntroFin

Completa el comando.

DesactivarRedibujado

Evita volver a dibujar en la pantalla o hacer cambios en el plano de construcción o en la cámara durante las macros.

ActivarRedibujado

Vuelve a activar la pantalla para dibujar después del comando DesactivarRedibujado.

DesactivarEco

Desactiva la copia de los comandos de las macros en la ventana de historial de comandos.

Eco

Copia los comandos de las macros en la ventana de historial de comandos.

Si no sabe qué debe escribir en una macro, ejecute la versión del comando con guión. Seleccione y copie la secuencia del comando y péguela en su texto de macro como punto de inicio.

EditorDeMacros

Barra de herramientas Menú

Herramientas

Herramientas

Comandos > Editor de macros

Ventana

Paneles > Editor de macros

El comando EditorDeMacros abre una ventana de edición para crear y comprobar macros.

Panel Editor de macros

Opciones de contenedor

Pasos

  1. Introduzca los comandos y opciones en la ventana Editor de macros.

  2. Haga clic en el botón para probar la macro.

BarraDeHerramientas

Ejecutar

Ejecuta toda la macro o la parte resaltada de la macro.

Eliminar

Borra el contenido del cuadro de edición.

Menú contextual

Cortar

Copia el texto seleccionado al portapapeles y elimina el texto.

Copiar

Copia el texto seleccionado al portapapeles.

Pegar

Inserta el texto del portapapeles en la posición del cursor.

LeerArchivoDeComandos

Barra de herramientas Menú

Herramientas

Herramientas

Comandos >

Leer desde archivo

El comando LeerArchivoDeComandos lee y ejecuta una macro de comandos desde un archivo de texto.

Pasos

  • En el cuadro de diálogo Abrir archivo de texto, seleccione el archivo.
    El contenido del archivo se copiará en la línea de comandos, y las líneas del archivo de comandos se interpretarán como si se hubiera escrito en la línea de comandos.

Notas

  • Cuando cree archivos de comandos, utilice el comando Intro, que equivale a pulsar la tecla Intro para ejecutar los comandos.
  • Si suele leer un archivo en particular bastante a menudo, asigne el comando LeerArchivoDeComandos a un botón de la barra de herramientas con el nombre del archivo. Por ejemplo: -LeerArchivoDeComandos miarchivo.txt
  • Si el nombre del archivo tiene espacios, ponga el texto entre comillas. Por ejemplo: -LeerArchivoDeComandos "mi archivo.txt".

Ejemplo

Cree un archivo de texto como el siguiente ejemplo que tiene comandos para crear todas las curvas, y luego cree todas las curvas de una vez con el comando LeerArchivoDeComandos.

! _interpcrv
23,5,0
23,2,5,0
23.7,5.2,1
_Enter
_interpcrv
26.1,4.9,1,1
26.8,4.9,1,0
27.1,4.8,0,9
_Enter

etc&.

Eco

Barra de herramientas Menú

No está en las barras de herramientas.

No está en los menús.

El comando Eco copia los comandos de las macros en la ventana de historial de comandos.

Para desactivar la copia de comandos, utilice el comando DesactivarEco.

DesactivarEco

Barra de herramientas Menú

No está en las barras de herramientas.

No está en los menús.

El comando DesactivarEco desactiva la copia de los comandos de las macros en la ventana de historial de comandos.

  • Para activar la copia de comandos, utilice el comando Eco.

DesactivarEco o _DesactivarEco tiene que ser la primera palabra de la macro para que funcione correctamente. Todo lo demás, incluido el punto de exclamación, debe seguir separado por un espacio en blanco.

Intro

Barra de herramientas Menú

No está en las barras de herramientas.

No está en los menús.

El comando Intro funciona como pulsar la tecla Intro para usar en scripts o en programación de botones de las barras de herramientas.

Ejemplo

Este script define un plano de construcción mediante tres puntos designados:

'_CPlane _3Point

_Pause _Pause _Pause _Enter

El comando Intro no repite el comando anterior como lo hace la tecla Intro.

IntroFin

Barra de herramientas Menú

No está en las barras de herramientas.

No está en los menús.

El comando IntroFin funciona como pulsar la tecla Intro para usar en macros o en programación de botones de las barras de herramientas.

IntroFin es útil cuando un comando tiene muchas opciones, como Opciones o PropiedadesDeDocumento, y quiere salir del comando sin contar los Intro necesarios para volver a la solicitud de comando inicial. Por ejemplo:

! _-PropiedadesDeDocumento_Malla _Personalizada_MáxAristaDeSup .01

requiere al menos dos o tres Intro para salir del comando. Con IntroFin, el comando permite salir directamente cuando quiera.

Ejemplo

! _-PropiedadesDeDocumento_Malla _Personalizada_MáxAristaDeSup .01

Salir

Barra de herramientas

Menú

Acceso directo

No está en las barras de herramientas.

Archivo

Salir

Ctrl (Comando)+Q

El comando Salir cierra la sesión actual de Rhino.

Para acceder a las opciones de la línea de comandos

  • Introduzca un guión delante el nombre del comando -Salir.
Opciones de la línea de comandos

Sí

 

No

 

Cancelar

 

Pausar

Barra de herramientas Menú

No está en las barras de herramientas.

No está en los menús.

El comando Pausa detiene una macro para introducir datos.

Ejemplo

Esta macro solicita un punto y luego dibuja un círculo centrado con un radio de 50 unidades.

! _Circle _Pause 50

MultiPausa

Barra de herramientas Menú

No está en las barras de herramientas.

No está en los menús.

El comando MultiPausa detiene una macro para introducir datos.

Ejemplo

Este macro solicita que los objetos se unan.

! _Unir _MultiPausa

Ejecutar

Barra de herramientas Menú

No está en las barras de herramientas.

No está en los menús.

El comando Ejecutar ejecuta otra aplicación desde Rhino.

Pasos

  • Introduzca un nombre y una ruta del archivo a ejecutar.

DesactivarRedibujado

Barra de herramientas Menú

Vista

No está en los menús.

El comando DesactivarRedibujado desactiva el redibujado en la pantalla, en el plano de construcción o en la cámara durante los scripts.

Para activar el redibujado de pantalla

ActivarRedibujado

Barra de herramientas Menú

Vista

No está en los menús.

El comando ActivarRedibujado activa el redibujado en la pantalla, en el plano de construcción o en la cámara durante los scripts.

Para desactivar el redibujado de pantalla

Scripts

RhinoScript es un plug-in para ejecutar scripts. Los lenguajes de script permiten bucles, nombres variables, búsqueda de archivos, peticiones y mucho más.

Puede utilizar los siguientes comandos:

Los pasos básicos son

  1. Escriba una función de script.
    Los scripts de Rhino utilizan la extensión de archivo .rvb.
  2. Ejecute el comando CargarScript para cargar un script en la memoria.
  3. Utilice el comando EjecutarScript para ejecutar el nombre de la función.

Si arrastra un archivo .rvb a la ventana de Rhino, se cargará y ejecutará el script.

Para obtener más ayuda sobre scripts

  • En el menú Ayuda de Rhino, haga clic en Plug-ins y luego en RhinoScript.

Para más información sobre scripts específicos de Rhino, consulte la página: http://wiki.mcneel.com/es/rhino/basicmacros.

CargarScript

Barra de herramientas Menú

No está en las barras de herramientas.

Menú Herramientas

Script de Rhino >

Cargar

El comando CargarScript lee un archivo de script del disco, lo carga en el interpretador de scripts y lo ejecuta.

Si arrastra un archivo .rvb a la ventana de Rhino, se cargará y ejecutará el script.

Pasos

  • En el cuadro de diálogo Cargar archivo de script, haga clic en el botón Añadir.
  • El comando de script, -CargarScript, admite variables de entorno de Windows en la ruta del archivo rvb a cargar.

  • Los programadores de RhinoScript pueden consultar la siguiente referencia en línea:

    https://developer.rhino3d.com/guides/rhinoscript

EjecutarScript

Barra de herramientas Menú

No está en las barras de herramientas.

Menú Herramientas

Script de Rhino >

Ejecutar

El comando EjecutarScript ejecuta un script previamente cargado.

Si arrastra un archivo .rvb a la ventana de Rhino, se cargará y ejecutará el script.

Pasos

  • En el cuadro de diálogo Ejecutar subrutina de script, haga clic en el menú Ayuda.

EditarScript

Barra de herramientas Menú

Herramientas

RhinoScript > Edición

El comando EditarScript abre un editor de texto para la edición de archivos de RhinoScript.

Pasos

  • En el cuadro de diálogo Editor de RhinoScript, haga clic en el botón Ayuda.

EjecutarScriptDePython

Barra de herramientas

Menú

No está en las barras de herramientas.

El comando EjecutarScriptDePython ejecuta un script de Python.

Los programadores de Rhino.Python pueden consultar la siguiente referencia en línea: http://developer.rhino3d.com/guides/rhinopython.

-EjecutarScriptDePython

Opciones

ReiniciarMotor

Fuerza el reinicio del motor Python. Este comando solo sirve cuando se escriben y prueban scripts de Python que abarcan varios archivos.

EditarScriptDePython

Barra de herramientas

Menú

No está en las barras de herramientas.

El comando EditarScriptDePython permite editar un script de Python.

Para obtener más información sobre scripts específicos de Rhino, consulte la página http://developer.rhino3d.com/guides/rhinopython.

EditorDeScripts

Barra de herramientas

Menú

Herramientas

Novedades V8

Herramientas

Script > Editar

El comando EditorDeScripts abre la ventana Editor de scripts para programar en Python y C#.

Guías del Editor de scripts

Opciones de la línea de comandos

Ejecute el comando con script -EditorDeScripts para acceder a las opciones de la línea de comandos.

Editar

Abre la ventana del Editor de scripts.

Ejecutar

Ejecuta un archivo de script.

Para ejecutar un archivo de script con una macro

Puede utilizar varias formas de especificar la ruta del archivo de script.

  • Utilizar una ruta de archivo completa:

    _-ScriptEditor _Run "D:\Mis archivos\Mi script.py"

  • Usar una variable de entorno en la ruta:

    _-ScriptEditor _Run "%USERPROFILE%\Documentos\Mi script.py"

    Esta macro ejecuta el archivo "Mi script.py" de la carpeta Documentos.

    Ejecute el comando "Set" en el símbolo del sistema de Windows para listar todas las variables de entorno.

  • Busque el archivo en las carpetas definidas en Opciones de Rhino > Rutas de búsqueda de archivos:

    _-ScriptEditor _Run "Mi script.py"

Abrir

Carga un archivo de script en la ventana del Editor de scripts.