WindowLayout

Toolbar

Menu

New in V8

Tools

Window

Window Layouts >

Manage Window Layouts

The WindowLayout command opens the Window Layouts dialog box to list, save, restore, export, or import arrangement of containers.

Including:
  • Docking and floating locations
  • Width and height of docked containers
  • Floating and docking status
  • Visibility of containers
  • Visibility of tabs
  • Order of tabs
Not including:
  • Toolbar buttons
  • Toolbar option settings
  • Viewport arrangement

Window Layouts

Save the current window layout

Saves the current arrangement of containers.

Restore selected window layout
  • Or double-click the window layout you want to restore.
  • Restoring a workspace simply modifies the current UI component states. It does not make the workspace "current".
Delete selected window layout

Delete the selected window layout.

Update selected window layout with the current layout
  • The default window layout is embedded in the Rhino app that cannot be updated.
Export the selected window layout
  • Only custom window layouts can be exported to a Rhino window layout file (*.rhw).
Import window layout

Imports a window layout from a Rhino window layout file (*.rhw).

Options menu
Expand all

Expands all window layouts in the list.

Collapse all

Collapses all window layouts in the list.

Context menu

  • Right-click on a window layout item to show the context menu.

New toolbar system in Rhino 8

Containers

Toolbar

Menu

New in V8

Tools

Window

Containers > Manage Containers

The Containers command opens the Containers dialog box to manage the panels or toolbars in containers.

Containers

Containers

The list of existing containers in the Rhino window.

Expand a container to see the panels or toolbars in it.

Buttons

Create new container
  • Click to add a new container to the list.

    The new container will be added to the end of the list.

    When a tab (panel or toolbar) is detached from a container, a new container is created with the tab name.

Delete selected container
  • Select a container and then click the delete button.

Import container definition

Imports a container from a Container Definition (.rhc) file.

Context menu

Right-click on the container list to show the context menu.

Create new container

Adds an empty container to the end of the list.

When a tab (panel or toolbar) is detached from a container, a new container is created with the tab name.

Delete container

Deletes the selected container.

To delete a toolbar or a panel in a container

  1. Select a toolbar or a panel in a container.

  2. Right-click on the same toolbar or panel, and select Remove item from container.

Export Container Definition

Saves the selected container to a Container Definition (.rhc) file.

To rename a container

  • Click the container name to edit the name.

To show or hide a container

  • Click the checkbox of the container to toggle its visibility in the Rhino window.

    Visibility of containers can also be toggled from the Window menu > Containers.

To restore default containers

  1. Run the Reset command.

  2. Select "Delete toolbar customizations".

Libraries

The list of toolbars in the default or linked rui files.

Panels

The list of default panels in Rhino.

Plug-ins may add custom panels to the list.

To add a toolbar or panel to a container

  • Drag the toolbar or panel and drop it onto the container on the left.

New toolbar system in Rhino 8

Macros

Toolbar

Menu

New in V8

Tools

Window

Macros

The Macros command opens the Macro Library dialog box to manage the macros in the default toolbars or linked rui files.

Macro Library

Library

Lists the default macro library and linked rui files.

Filter

The filter box allows entering a text string to only list the macros that contain the text string in the macro Name, Command, Button Text, Menu Text, Help Text, or Tooltip fields.

Macro list

Lists the macros in the selected library.

New

Adds a new macro to the current library.

Duplicate

Makes a copy of the selected macro.

Delete

Deletes the selected macro from the library.

Edit

Edits the selected macro in the Edit Macro dialog box.

Create New Macro / Edit Macro

Name

The name of the macro.

Image
Light image

The toolbar button displays the light image when the system uses a light theme.

Import

Imports a .svg file for the button image.

Export

Exports the button image to a .svg file.

Standard Rhino image

Chooses an image from the ones being used by macros.

Dark image

The toolbar button displays the dark image when the system uses a dark theme.

Export

Exports the button image to a .svg file.

Use light image for dark modes

Forces the toolbar button to display the light image when the system uses a dark theme.

Recolor light image for dark modes

Converts the light image to dark image.

Use a different image

Uses a separate .svg file for the dark image.

Command

The command or script run by the macro.

Button Text

The text displayed when a toolbar button is set to display Text only or Both image and text in the Button Editor.

Menu Text

When a container is not big enough to show all the command buttons of a toolbar, a small >> button appears. Clicking the button brings up a menu to list the rest command buttons as menu text items.

Help Text

When a macro is added to a menu, the Help Text displays on the status bar when you point the mouse cursor to the macro on the menu.

Tooltip

The text displayed as a tooltip when the macro is used on a toolbar button.

See Also

New toolbar system in Rhino 8

ExportRuiFile

Toolbar

Menu

Toolbars

Tools

Tools

Export RUI File

The ExportRuiFile command merges the original toolbars of the selected .rui file and its customized toolbars into a new rui file.

Steps

New toolbar system in Rhino 8

SaveWindowLayout

Toolbar

Menu

New in V8

Tools

Window

Window Layouts >

Save Window Layout

The SaveWindowLayout command saves the current arrangement of containers, panels, and toolbars to a new custom Window Layout.

To save a window layout

  1. Arrange containers, panels, or toolbars.

  2. Run the SaveWindowLayout command.

  3. Type a name for the Window Layout.

To restore a window layout

  • Select the name from the Window menu > Restore Window Layout.

    Or use the WindowLayout command.

ShowToolbar

Toolbar Menu

Not on toolbars.

Window

Toolbars

The ShowToolbar command opens a specified toolbar.

Steps

Toolbar

Toolbar Menu

Tools

Toolbars

Window

Toolbars

The Toolbar command provides an easy way to display toolbars on the screen.

 

Toolbars

Libraries

Lists the default or linked rui files.

Toolbars

Lists the toolbars in the selected rui file.

If there is container with a single toolbar and it is visible, the checkbox of the toolbar will be checked.

Create new toolbar

Add a new toolbar to the list.

The Create Toolbar dialog box leads you through the steps of:

  1. Name the toolbar.
  2. Add command buttons to the toolbar.
  3. Setup the toolbar tab properties.
Delete selected toolbar

Delete the selected toolbar.

ToolbarLock

Toolbar Menu

Not on toolbars.

Toolbar options menu

Lock Docked Containers

The ToolbarLock command locks or unlocks docked containers.

This command toggles the checkbox of Lock docked containers in Rhino Options.

 

Reset

Toolbar

Menu

New in V8

Tools

The Reset command restores the window layout, toolbars, or all settings to the initial state of the Rhino app.

Options

Restore default Window Layout

Restores the default read-only Window Layout.

You will be prompted to save the current Window Layout.

More information about Window Layout

Delete toolbar customizations

Restores the original toolbars in the default and linked rui files.

More information about toolbars

Restore default Rhino application settings

Resets all the Rhino app and command settings.

The setting file will be reset.

Factory Reset, includes all of the options above

Resets Rhino to the state of a fresh installation.

Save settings for support

Compresses the support folder and setting file into a zip file.

The zip file can be sent to the Rhino support team for analyzing a problem.

Save option settings for use on other computers

OptionsExport

Save Options settings to a file.

OptionsImport

Restore Options settings from a file.

See also

Options

Manage global options.

 

 

 

Rhinoceros 8 © 2010-2024 Robert McNeel & Associates. 16-May-2024