Licenses

Toolbar Menu

Layout
Properties
Standard

Tools

Options

The License options display the license status of the current Rhino license.

Licenses

Change your license key

Opens the Licensing dialog box.

Login

Use a license stored in the Cloud Zoo. More information...

Enter your license key

Enter your license to a single computer and use the license on the computer only. More information...

Use the Zoo

Use a license stored in the Zoo license server on your network. More information...

Check Out

Checks out a license from the Zoo license server. The license is saved to your computer. It allows you to use the license without connecting to the Zoo server. Other users won't have access to this license until you check in (return) the license to the license pool.

Check In

Returns the checked out license to the license pool. The license can be shared again by users.

Buy a license key

Opens the sales page on the Rhino website.

Related commands

CheckOutLicense

Toolbar Menu

Not on toolbars.

Tools

License Manager >

Check Out License

The CheckOutLicense command opens the Licenses page in Options. When you check out a license from the Zoo license server, the license is saved to your computer. It allows you to use the license without connecting to the Zoo server. Other users won't have access to this license until you check in (return) the license to the license pool.

CheckInLicense

Toolbar Menu

Not on toolbars.

Tools

License Manager >

Check In License

The CheckInLicense command opens the Licenses page in Options. A license can be checked in if it was checked out from the Zoo license server. When a license is checked in, it returns to the license pool and can be shared again by users.

Network License Manager (The Zoo)

Manages assignment of Rhino licenses among members of a network.

To script the installation process and allow more efficient use of Rhino licenses, network administrators now have the option of installing Rhino as a network node. Network nodes obtain license keys at run time from the Zoo, unlike standalone Rhino, which requires that a license key be entered on each system.

When a Rhino network node starts, a request for a license key is sent to the Zoo. If the number of available keys has not been exceeded, the Zoo assigns a key to the workstation, and the number of available licenses is reduced by one. When a node shuts down, the license is added back to the available license pool.

The Zoo will run on any system in a network. All of the nodes must be in the same network. The Zoo uses an inter-process communications mechanism that is used by several networking services. Thus, the Zoo should operate reliably in both Microsoft Network and Domain networking environments. For details on setting up a network, contact your network administrator.

The Zoo can be downloaded free of charge.

Features include:

To use the Zoo

To switch from a stand-alone license

  1. On the Tools menu, click Options.
  2. In the Options dialog box, click the Licenses page.
  3. Click the Change your license key button.
  4. In the Licensing dialog box, click Login as <your name>.
  5. Log in to your Rhino Account when prompted, and grant access for Rhino to access the requested information from your account.

If you don't have license key for Rhino

  1. In the Licensing dialog box, select Zoo.
  2. Log in to your Rhino Account when prompted, and grant access for Rhino to access the requested information from your account.
  3. To check that you are logged in, on the Help menu, click About Rhinoceros.
    You will see your avatar and username in the splash screen.

Change license or user

What if I want to switch back to standalone

  1. On the Tools menu, click Options.
  2. In the Options dialog box, click the Licenses page.
  3. Click the Change your license key button.
  4. In the Licensing dialog box, select Standalone, and enter your license details.

Login

Toolbar Menu

Not on toolbars.

Not on menus.

The Login command logs you into Rhino using your Rhino account. If you are already logged in, your credentials will be refreshed.

Logout

Toolbar Menu

Not on toolbars.

Not on menus.

The Logout command logs you out and returns any licenses borrowed from a Rhino account.

If Rhino’s license is from a Rhino account, returning your license will cause all sessions of Rhino to close on your computer. You will be given a chance to save your work if there are any unsaved changes on any of the open sessions.

Save options for use on other computers

OptionsExport

Save Options settings to a file.

OptionsImport

Restore Options settings from a file.

See also

McNeel Wiki: Zoo License Manager

Work with files

 

 

 

Rhinoceros 6 © 2010-2019 Robert McNeel & Associates. 18-Mar-2019