Render

Toolbar Menu

Render Tools
Standard

Render

Render

The Render command renders the model using the current renderer producing a color image in a separate display window.

To set the current renderer

  1. On the Render menu, click Current Renderer.
  2. Choose the renderer from the list.

Note

Rendering basics

In addition to shaded previews, Rhino provides full-color rendering with lights, transparency, shadows, textures, and bump mapping.

Objects will render white until you add render color, highlight, texture, transparency, and bumps. These attributes are controlled through the Properties panel, Material page.

The process needed to render scenes consists of four basic steps:

Although the steps do not have to be done in this order, using this method seems to make setting up a scene more efficient. To improve quality, repeat these steps until the image looks right to you.

Lights

In every Rhino rendering there are light sources that Rhino uses to calculate how the objects are to be illuminated. If you do not add any light sources to your scene, the default light is used. The default light is a directional light with parallel rays that acts as though you have a lamp shining over your left shoulder.

Lights command iconAdd indoor lights or sun

Materials

Materials specify the color, finish, transparency, texture, and bump for use by the renderer.

Layer command iconAssign materials to layers

In the Materials panel

Assign to Layers...
  1. Right-click on a material and select Assign to Layers...
  2. In the Choose Layer dialog, select layers.
Assign to Layers of Objects
  1. Right-click on a material and select Assign to Layers of Objects
  2. Select an object in the viewports to assign the material to the object's layer.

In the Layers panel

  1. Select one or more layers by clicking their names.
  2. Click in the Material column of a selected layer.
  3. In the Layer Material dialog, select or create a material.

    Type a letter to navigate to the first material in the list with a name starting with the letter.

By selecting objects

  1. Select one or more objects.
  2. In the Materials panel, right-click on a material and select Assign to layers of Objects.

By drag and drop

Assign materials to objects

In the Materials panel

  1. Select one or more objects.
  2. In the Materials panel, right-click on a material and select Assign to Objects.

In the Properties panel

  1. Select one or more objects.
  2. In the Properties panel, click the Material button.
  3. Select or create a material from the drop-down list.

By drag and drop

Ground Plane

The ground plane provides an infinite horizontal platform for the image that stretches to the horizon in all directions positioned at a defined elevation. A ground plane renders much faster than using a surface as a background. Any material can be assigned to the ground plane.

GroundPlane command iconSet up a ground plane

  1. Open the Ground Plane panel.
  2. Set up ground plane properties.

Environment

Environments describe the space around the model. This space is reflected in objects and can provide overall lighting.

Render with and without an environment.

Set up an environment

The rendering properties include environment settings like background color and image.

  1. Open the Environment Editor panel.
  2. Set up environment properties.

Render

Render and save an image.

Render and save the image

  1. On the Render menu, click Render.
  2. In the Render Window, on the File menu, click Save As.

Rhino Image File Format (.rimage)

Rhino Render can save .rimage files. This is a proprietary file format that stores all of the information rendered by the rendering engine, including color, alpha, depth, normal channels, all with 32-bit per-channel resolution.

This information is used by the render window to execute the post-effects and exposure operators, and can also be used by custom controls implemented by a third-party renderer to achieve other effects.

Immediately after render time, the .rimage format can be used to store the data so that post-processing and exposure adjustments or format changes (saving in a different format without loss of information) can be done later.

The .rimage format is only supported by the Rhino render window. It cannot be loaded into any other software. It is a high-dynamic range format that supports lossless information transfer to .HDR and .EXR formats. It is uncompressed and the files can be huge.

To open an .rimage file

Completed renderings are saved in the .rimage format to a temporary location on your hard disk. Once one of the renderings is re-opened, all post effects and exposure settings are available as if the rendering were just completed.

To open the most recent .rimage file

For more information about post processing the rendered image, see: Post-processing rendered images.

Render command-line/scripting commands

BatchRenderNamedViews

Toolbar

Menu

Not on toolbars.

Render

Batch Render Named Views

The BatchRenderNamedViews command renders all the named views in the model and saves the renderings as image files to a folder.

Steps

  1. Save the views to render as named views.

  2. Set the rendering settings.

  3. Start the BatchRenderNamedViews command.

  4. Select a folder.

    The named views are rendered with the list order and saved with their names.

See Also

NamedView

Manage the named views.

RenderArctic

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderArctic command sets everything to white - materials, skylighting, ground plane and renders the current viewport.

Command-line options
AffectMaterials Turn off to exclude materials from the settings.
AffectLights Turn off to exclude lights from the settings.
AffectGroundPlane Turn off to exclude groundplane from the settings.
AffectBackground Turn off to exclude background from the settings.

See: Wikipedia: Ambient occlusion.

CloseRenderWindow

Toolbar Menu

Not on toolbars.

Not on menus.

The CloseRenderWindow command closes the render display window.

This is useful for doing multiple renderings. When combined with the SaveRenderWindowAs command, you can create multiple renderings and save them to different files from your script.

CopyRenderWindowToClipboard

Toolbar Menu

Not on toolbars.

Not on menus.

The CopyRenderWindowToClipboard command copies the image in the render window to the Clipboard.

RenderBlowup

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderBlowup command renders a selected area of the current viewport in the render window at the resolution specified in the Rendering panel.

RenderInWindow

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderInWindow command renders a selected area of the current viewport in the render window at viewport resolution.

The renderer uses the settings in Mesh Document Properties.

Rendering

Toolbar Menu Panel Gear Menu

Render Tools
Standard

Panels

Rendering

Rendering

The Rendering command opens the Rendering panel that provides quick access to the Render Document Properties.

Current Renderer

Sets the current renderer. This can be the built-in Rhino Render or a plug-in.

View

Specify a source for the view.

Current Viewport

Renders the current viewport.

Specific Viewport

Select a viewport to render from the list.

Named View

Select a named view to render from the list.

Snapshot

Select a snapshot to render from the list.

Resolution and Quality

Dimensions

The aspect ratio displays to the right of the menu.

Viewport (<size>)

Renders the active viewport the active viewport using the pixel size of the viewport.

Custom (<size>)

Renders the active viewport using the custom resolution. Type the custom width and height resolution in pixels.

Preset sizes

Renders the active viewport the selected pixel resolution.

If you add a text file named render_sizes.txt to the folder where the Rhino executable (.exe) resides, Rhino Render and some other renderers will read this text file for custom render sizes.

Example:
// My custom render sizes
500,500
600,600
700,700
800,800
900,900
Lock to viewport aspect ratio

Maintains the aspect ratio of the viewport. When the height or width is changed, the other dimension changes in relation.

Size

Calculates the size of the image in the selected unit system based on the Resolution and DPI ("dots" per inch) settings. This is useful for determining the size of the image for printing.

Units

Sets the image size in pixels, inches, millimeters, or centimeters.

DPI

Image pixels ("dots") per inch.

Quality
Low quality

Render 15 samples.

Draft quality

Render 50 samples.

Good quality

Render 500 samples.

Final quality

Render 1500 samples.

Low quality (left) and Final quality (right).

Backdrop

The backdrop is what you see directly in front of the camera if there are no objects in the way. The background is not 3‑D — it exists only on the screen.

Solid color

Displays a solid color.

To select the color for the background

Gradient

Displays a two-color gradient. The color for the top of the image background is the Solid color set above.

To select the color for the bottom of the background

360° Environment

Displays the portion of the current environment that the camera sees in the viewport.

New

Creates a new environment using a template from the library.

Edit

Edits the selected environment.

See: Environment Editor.

Duplicate

Copies the selected environment to a new environment with the same settings.

Wallpaper

Displays the current viewport wallpaper.


Wallpaper in perspective viewport.
Stretch to fit

Fits the wallpaper to the rendered view.


Wallpaper at normal aspect ratio (left) and stretched to fit (right).
Transparent background

The background is rendered with an alpha channel for transparency. The image must be saved to a file format that supports alpha channel transparency (.png, .tga, .tif).

Ground plane

Turns on the ground plane.

Ground Plane Settings

Opens the Ground Plane panel.

Use custom environment for reflections

Assigns a custom environment that will be reflected by objects in the scene.

New

Creates a new environment using a template from the library.

Edit

Edits the selected environment.

See: Environment Editor.

Duplicate

Copies the selected environment to a new environment with the same settings.

Default environments
No environment

The No environment setting applies a plain gray background.

Studio

The Studio environment offers soft lighting provided by a high-dynamic range image.


Studio lighting example (left) and hdr background (right).

Lighting

Sun

Turns on the sun.

Sun Settings

Opens the Sun panel.

Skylight

Turns on skylight.


Skylight off (left) and Skylight on (right).
Intensity

Adjusts the skylight intensity.

Use custom environment for skylighting

Sets an environment that is used as sky light.

New

Creates a new environment using a template from the library.

Edit

Edits the selected environment.

See: Environment Editor.

Duplicate

Copies the selected environment to a new environment with the same settings.

Lights

Opens the Lights panel.

Use lights on layers that are off

Controls whether or not spotlights that are on hidden layers or that are hidden with the Hide command are rendered.

Snapshots

The Snapshots command saves and restores Named Views, Named Positions, Layer States, as well as rendering settings, object settings including locked/hidden state, display mode, material, position, light settings, curve piping, displacement, edge softening, shutlining, and thickness.

Wireframe

Render curves

Curve objects are rendered with the surfaces.

Render surface edges and isocurves

Surface isoparametric curves and edges are rendered with the surfaces. Edge thickness set in the Rendered viewport apply.

Render dimensions and text

Dimensions and texts are rendered with the surfaces.

Snapshots

The Snapshots command saves and restores Named Views, Named Positions, Layer States, as well as rendering settings, object settings including locked/hidden state, display mode, material, position, light settings, curve piping, displacement, edge softening, shutlining, and thickness.

Dithering and Color Adjustment

Dithering

The rendered image is usually produced at a higher color depth than monitors and low-dynamic-range file types like bitmaps like JPEG, PNG, BMP can reproduce. The most important effect this causes is banding, which is a quantization error. Dithering reduces quantization errors and so gets rid of banding.

Both dithering methods, generally do the same thing. Sometimes, one might be better than the other, but in general, Simple Noise is the best.

See: Wikipedia: Dither.

None

No dithering.

Floyd-Steinberg

The algorithm achieves dithering by diffusing the quantization error of a pixel to its neighboring pixels.

See: Wikipedia: Floyd-Steinberg dithering.

Simple noise

A random variation of brightness or color information in images.

See: Wikipedia: Image noise.

Gamma

Image files are color corrected so that they can be loaded byte-by-byte into the RGB pixels of a computer screen and look right on a monitor. This means that the color response of a standard image is non-linear, that is, it is gamma corrected. Gamma refers to the power function that is used to correct the image.

The Gamma value changes, and therefore corrects the output of the image.

See: Wikipedia: Gamma correction.

Use linear workflow

The Rendered display mode supports a linear workflow for accurate color, gamma and lighting computation.

Gamma correction for bitmap images that are loaded from disk is removed (by the inverse of the amount in the Gamma edit box) so that they have a linear response before they are passed to the renderer. The renderer renders them in this uncorrected state. The gamma correction is applied to the entire finished image. This can do a better job of processing the color in rendered images.

Snapshots

The Snapshots command saves and restores Named Views, Named Positions, Layer States, as well as rendering settings, object settings including locked/hidden state, display mode, material, position, light settings, curve piping, displacement, edge softening, shutlining, and thickness.

Render Channels

Automatic

Automatically enables the required render channels.

Custom

Manually select the render channels to include in the rendering.

RGBA

Represents Red, Green, Blue, and Alpha transparency. It is mainly used for presentations.

Distance

Uses grayscale colors to represent the distance from the camera. The farthest pixel in the rendering is black. the nearest pixel is white.

Normal

Uses RGB values to represent the XYZ coordinates of normal directions. Red=X, Green=Y, and Blue=Z.

Albedo

The unshaded colors. It is the result of rendering a scene with totally uniform lighting and without shadows.

Advanced Rhino Render Settings

Seed

Change the seed value to vary the noise pattern.

Session

Samples

Amount of samples taken per pixel in the Raytraced viewport. More samples means better convergence, thus better quality.

Override Production Render Quality

When enabled, the Render command will use the samples above to render the scene. Render quality settings will be ignored.

Ray Bounces

Maximum bounces

Maximum number of light bounces. For best quality, this should be set to a high value. However, in practice, it may be good to set it to lower values for faster rendering. Setting the maximum to 0 bounces results in direct lighting only.

Diffuse

Maximum number of diffuse bounces. The ray is generated by a diffuse reflection or transmission (translucency).

Glossy

Maximum number of glossy bounces. The ray is generated by a glossy specular reflection or transmission.

Transmission

Maximum number of transmission (light that is transmitted throughout a volume) bounces.

Volume

Maximum number of volume scattering bounces.

Transparency

Maximum number of transparency bounces.

Texture Baking

Texture Bake Quality

When decal textures, multi-channel textures, procedural textures, or textures using custom mappings are rendered by Rhino Render or in the Raytraced viewport, these texture types are converted into bitmap textures. Baking qualities control the bitmap texture resolution:

Low: 2048 x 2048 pixels

Standard: 4096 x 4096 pixels

High: 8192 x 8192 pixels

Ultra: 16384 x 16394 pixels

When you zoom in close to an object, the types of textures may look pixelated in the rendering if the baking quality is less than required. Using a higher baking quality will fix the problem, but memory usage of the rendering will increase exponentially.

A Dot procedural texture looks pixelated in rendering when zooming in. A higher baking quality will be required.
Reset To Defaults

Restores all default rendering settings.

Render

Renders the current model.

RenderOpenLastRendering

Toolbar Menu

Not on toolbars.

Render

Open Last Rendering

The RenderOpenLastRendering command opens the last rendering image file (.rimage).

RenderOpenRenderImage

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderOpenRenderImage command opens a browser window with the recent rendering image files (.rimage).

RenderPreview

Toolbar Menu

Render Tools

Render

Render Preview

The RenderPreview command renders the current viewport in the Render window with a rough quality for a fast preview.

RenderPreviewInWindow

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderPreviewInWindow command renders a selected area of the current viewport in the Render window with a rough quality for a fast preview.

RenderPreviewWindow

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderPreviewWindow command renders a selected area in the viewport with a rough quality for a fast preview.

RenderReportImageFiles

Toolbar

Menu

Not on toolbars.

Not on menus.

The RenderReportImageFiles command opens a dialog box to manage external image files.

This command is an alias of the RenderReportMissingImageFiles command with the Only show missing image files checkbox disabled by default.

See: RenderReportMissingImageFiles

RenderReportMissingImageFiles

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderReportMissingImageFiles command opens a dialog box to manage missing external image files.

Options

Only show missing image files

Enable to list only missing images, otherwise to include non-missing images.

Remove

Exclude the selected image from the list. It will not be reported as missing again.

Replace

Select an image to replace the selected missing image.

Or, double-click a missing image to replace.

Gather

Collect the selected images to a new folder. The paths to the images will update.

Search Online

Find the selected missing images from the online libraries.

Edit

Edit the selected render content (material, texture, or environment) that uses the selected missing image.

Or, double-click a render content to edit.

Bulk Replacement

Relocate the folder that includes the missing images.

Copy All

Copy the file paths of all the missing images to the clipboard.

Save As

Save the file paths of all the missing images to a text file.

Continue

Close the dialog box.

RenderWindow

Toolbar Menu

Not on toolbars.

Not on menus.

The RenderWindow command renders a selected area of the current viewport in the viewport at viewport resolution.

The renderer uses the settings in Mesh Document Properties.

SaveRenderWindowAs

Toolbar Menu

Render Tools

Not on menus.

The SaveRenderWindowAs command saves the image in the render window to a file.

Steps

Save As options

Save alpha channel

Saves an alpha channel if the file type supports transparency.

SetCurrentRenderPlugIn

Toolbar Menu

Not on toolbars.

Render

Current Render

The SetCurrentRenderPlugIn command specifies the current rendering plug-in application.

You can download plug-ins from www.rhino3d.com/resources.

See also

Render your model scene

Add lights for rendering

Use materials and textures

Use the Clipboard

 

 

 

Rhinoceros 7 © 2010-2021 Robert McNeel & Associates. 24-Sep-2021