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Chapter 1 - Introduction
This course guide was complied to accompany the Rhinoceros Level 1 instructor-lead training session.
Level 1 training shows you how to produce 3-Dmodels using NURBS geometry and arrange models for export,
annotation and plotting.
In class, you will receive information at an accelerated pace. For best results, practice at a Rhino workstation between
class sessions, and consult the online Help resources for additional information.

Software
The training guide was designed for use with Rhinoceros 6 or later.
The training files have been updated to open with Rhinoceros 6 or later.

Using with Rhino for Mac
The training guide was written with Rhino for Windows, and therefore there will be slight differences if you use Rhino
for Mac.
The main differences are:

o Any instructions in the training guide that include the Control key, can be replace with the Command key to work
on Rhino for Mac.

o SystemOptions command on Windows is found on the Mac under the Rhinomenu and Settings or Preferences
depending on Mac OS.

o Document Options on Windows is found on the Mac under the Filemenu and it is called Settings.
o When a command is active, the command window opens and overlays the left sidebar.

Commands names, menu locations and general Rhino modeling techniques apply equally whether Rhino is running on
a Windows or a Mac operating systems.

Target audience:
The training guide presents topics, commands, and procedures that are important for every Rhino user.
The training guide will offer exercises and examples with common objects that allow the concepts to be thoroughly
covered for all students, regardless of field or industry.

Duration:
l The training guide consists of more than 24 hrs of training.
l The training can be presented in three full-day, six half-day sessions or adapted for a custom schedule.
l Instructor should prepare by choosing which exercises are to be presented during class and which exercise work
will be assigned as homework.

l High schools or secondary schools may present the materials over a full semester. For a curriculum guide and
other ideas on teaching Rhino, go to Rhino in Education web site for support.

1
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Objectives
In Level 1, you learn how to:

l Use the features of the Rhino user interface
l Customize your modeling environment
l Create basic graphic objects—lines, circles, arcs, curves, solids, and surfaces
l Model with precision using coordinate input, object snaps, and SmartTrack™ tools
l Modify curves and surfaces with edit commands and gumball
l Use control point editing to modify curves and surfaces
l Analyze your model
l Display any portion of the model
l Export and import models to and from various file formats
l Render the model using Rhino Render
l Dimension and annotate model with text and hatch
l Use layouts to arrange views of model on paper for printing

Schedule A: Three classroom days
Day 1 Topic
8:00 am – 10:00 am Introduction, Rhino interface
10:00 am – 12:00 pm Rhino interface, panning, and zooming
12:00 pm – 1:00 pm Lunch
1:00 pm – 3:00 pm Creating geometry
3 :00 pm – 5:00 pm Creating geometry
Day 2 Topic
8:00 am – 10:00 am Editing
10:00 am – 12:00 pm Editing
12:00 pm – 1:00 pm Lunch
1:00 pm – 3:00 pm Editing
3:00 pm – 5:00 pm Control point editing, modeling with solids
Day 3 Topic
8:00 am – 10:00 am Surfacing
10:00 am – 12:00 pm Surfacing
12:00 pm – 1:00 pm Lunch
1:00 pm – 3:00 pm Modeling practice
3:00 pm – 5:00 pm Import / export, rendering, dimensioning, printing, customization
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Schedule B: Six half days (on-line training)

Session 1 Topic
9:00 am – 10:45 am Introduction, Rhino interface
10:45 am – 11:00 am Break
11:00 am – 12:45 pm Rhino interface, panning & zooming

Session 2 Topic
9:00 am – 10:45 am Creating geometry
10:45 am – 11:00 am Break
11:00 am – 12:45 pm Creating geometry

Session 3 Topic
9:00 am – 10:45 am Editing
10:45 am – 11:00 am Break
11:00 am – 12:45 pm Editing

Session 4 Topic
9:00 am – 10:45 am Editing
10:45 am – 11:00 am Break
11:00 am – 12:45 pm Control point editing, modeling with solids

Session 5 Topic
9:00 am – 10:45 am Surfacing
10:45 am – 11:00 am Break
11:00 am – 12:45 pm Surfacing

Session 6 Topic
9:00 am – 10:45 am Modeling practice
10:45 am – 11:00 am Break
11:00 am – 12:45 pm Import / export, rendering, dimensioning, printing, customization

3





Chapter 2 - Getting the Models
To access the models that this training guide uses, there are two primary options.
The first option, Rhino will download each file when you select it from the Tutorials panel.
The second option, you may download all the files as a compressed zip and unzip them into a folder.
Note: You will need basic file management skills to use Rhino effectively on your computer. If you are not familiar with
creating folders, copying, renaming or deleting files, stop now and find training to establish these skills.

Option 1: Download files separately
If you are new to file management on Windows, this is the better option. If you prefer to avoid all the individual file
downloads, then continue with Option 2: Download all files at once.
1. Create a folder on your Desktop or in yourMyDocuments folder, or another location in which you have full

rights.
2. Name the folder Level 1 Training or other name that you will remember.
3. Open the Rhino application.
4. From theHelpmenu, click Learn Rhino, and click Tutorials and Samples.

The Tutorials panel will appear.

5. Navigate to the Level 1 TrainingManual folder, scroll to the modelWhat_is_Rhino.3dm.
6. Double-click to load the contents of the file in the Rhino application.

This will load the contents of the file into a new Rhino model.
7. At the end of each exercise, save the file to the folder you created in the previous steps..
8. Repeat these steps at the beginning of each exercise that directs you to open an existing file.
9. For exercises that require image files, download the required files and save them into the same folder that you

have saved your 3dmmodel file in step 7. You will need to repeat this for each image file.
For example, Render.3dm will require a fileWood .jpg to also be downloaded to complete the exercise. Both are
on the Tutorials panel under Level 1 Training. Keep it simple and save it to the same folder as the model,
however, it can go anywhere that you have rights to save.

Option 2: Download all files at once
You will download a set of existing models and files that are used in this training guide.
Unzip the files in a Training folder. When you are asked to open a file, navigate to that folder.
1. Create a folder on your Desktop or in yourMyDocuments folder, or another location in which you have full

rights.
2. Name the folder Level 1 TrainingManual or other name that you prefer.
3. Open the Rhino application.

1
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4. From theHelpmenu, click Learn Rhino, and click Tutorials and Samples.
The Tutorials panel will appear.

5. Navigate to the Level 1 Training folder.
6. Double-click the Rhino Level 1 Models (.zip) to download it.
7. Unzip the downloaded file into the folder that you created in the previous steps.
8. In the Rhino application, on the Filemenu, click Open.
9. In the Open dialog box, navigate to the Level 1 Training folder and Open the modelWhat_is_Rhino (.3dm)

This model contains all of the objects that we will be introducing you to in this section: surfaces, polysurfaces,
solids, free form curves, circles, arcs, meshes, lights, dimensions and more.
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Chapter 3 - What is Rhino?
Rhinoceros is 3-D modeling software is primarily a surface-modeling tool, but has many related features. Many Rhino
designers use only a small portion of what Rhino has to offer, while others need and use a lot more and even use plug-
ins to extend the functionality; it depends on what the individual user is trying to accomplish with the application.
Even very experienced users will find new and useful tools they were previously unaware of. This introduction provides
a broad overview of various elements that you will encounter while using Rhino to get your work done.

Object types
What does surface modelermean?
Rhino has tools to create and edit various types of objects, of which surfaces are one. A surface in Rhino refers to an
infinitely thin, infinitely flexible, mathematically-defined digital membrane. This is different from a solid modeler that
deals with solid objects or a mesh modeler that deals with polygon meshes.

Surfaces
Surfaces are represented on screen by either some outline curves plus some interior curves, called isocurves, or by a
shaded picture that makes a surface appear to have some substance and to show light and shading. How surfaces are
painted on the screen depends on the display mode in the viewport and does not affect the surface in any way.
The important thing to remember about surfaces is that they are defined with great precision at every point by complex
math formulas; they are not approximations.

A surface, shown in wireframe (left) and shaded (right) views.

Polysurfaces
Rhino also has objects that consist of two or more surfaces joined together. This is possible when the edge of one
surface is located very close to the edge of another surface. We call these joined surfaces polysurfaces. Some
restrictions apply to editing polysurfaces, so Rhino makes it easy to extract the individual surfaces from polysurfaces
and join them back together.

A polysurface in shaded view.
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Solids
If you need your objects to have volume, there are two ways to accomplish this. A single surface can close around itself
to enclose a volume. Spheres and ellipsoids are examples of this type of surface.

Single-surface closed solid objects.

Single surfaces joined to enclose a space also form a solid. A box is an example of this type of object. We call these
objects solid, but it is important to remember that there is nothing inside them. They are volumes in space enclosed by
the infinitely thin surfaces. If you remove one side of a box, and look inside you will see the backs of the surfaces.

Closed (solid) and open polysurface.

Lightweight extrusion objects
Another object type that is related to a polysurface and a solid is the lightweight extrusion object. Lightweight
extrusion objects are defined by a profile curve and a direction and distance. Extrusion objects use less memory, mesh
faster, and save a smaller file size than polysurfaces.
Commands like Box, Cylinder, Pipe, and ExtrudeCrv create lightweight extrusion objects by default.

Lightweight extrusion objects.

Curves
In Rhino terminology, the word curve includes lines, polylines (a series of straight-line segments joined end to end),
arcs, ellipses, circles, or free-form curves that are generally smooth. Polycurves are made up of two or more curves
joined end to end.
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Curves are used as input for creating and editing surfaces. For example, you can trim an object with a curve, but they
may be useful in themselves as well, as in making a 2-D drawing of a 3-D model or as construction geometry. You can
derive and extract curves from surfaces. For example, all surfaces have edges, and it is possible to extract an edge
curve. You can also extract surface isocurves.

Curves.

Polygon meshes
Polygon meshes are sometimes used to depict the same type of objects as surfaces but there are important differences.
Polygon meshes consist of a number of vertex points in space connected by straight lines. These straight lines form
polygons, which are closed loops of three or four sides.
One important thing to know about polygon meshes is that the 3-D data only exists for these vertex points; the space
between these points is not considered. Dense meshes are more accurate than very loose ones, but not as accurate as
surfaces.
Meshes have their place in 3-D NURBS modeling. For example, if you look at a surface in a shaded viewport, what you
see is actually a polygon mesh derived from the surface for the purposes of making an image on screen. You can
export mesh data for rapid-prototyped parts.

A sphere surface and mesh sphere object.

Other Objects

Control points are objects that can be manipulated in order to edit the shape of the parent object- they look like point
objects but are not the same thing. Control points can be turned on and off for eligible objects.

5
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While polysurfaces do not have control points, they can be manipulated with Solid Points.

Point object marks a 3-D location in space. Point clouds are collections of point objects.

Annotation objects such as text and dimensions.

Lights which are used to help create renderings of the objects in the file.
Plug-ins, or add-on programs, can also add their own object types to Rhino.

6



Chapter 4 - The Rhino Interface
Before learning individual tools, we will get acquainted with the Rhino interface. The following exercises examine the
interface elements used in Rhino: the Rhino window, viewports, menus, toolbars, panels and dialog boxes.
There are many ways to access the commands in Rhino—the keyboard, menus, and toolbars. We will focus on the
menus in this class.

Exercise 4-1 The Rhino Interface
On the Windows desktop, double-click the Rhino icon.

The Rhino window
Rhino divides its screen into areas that supply information or prompt you for input.
The image below illustrates some of the major features of the Rhino window.

Window title
Displays the current model's file name and file size.

Menu
Groups Rhino commands by function.
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Command window
Displays the previous commands. Text from this area can be copied and pasted into the command-line prompt, macro
editor, button command, or any application that accepts text. You can dock the command window at the top or the
bottom of the screen or it can float anywhere.
The Commandwindow shows two lines by default. To open a a separate window that displays the command history,
press F2. You can select and copy text in the Command Historywindow to the Clipboard.

Command prompt
Use the command-line to type commands, click command options, type coordinates, type distances, angles, or radii,
type shortcuts, and view command prompts.
To enter information typed at the command-line, press Enter, Spacebar, or right-mouse click over a viewport.

Autocomplete command name
Type the first letter of a command name to activate the autocomplete command list. As you type letters in the
command-line, the command name that includes those letters will autocomplete and display in a drop down menu.
Press Enter to activate the command once the full command name appears or left-click on the command in the list to
start it.

Command options
Command options change how a command acts. For example, when you draw a circle, the circle is normally drawn on
the active construction plane. The Circle command has several options including Vertical and AroundCurve.
To use a command option, click the option name, or type the underlined letter of the option or the whole option name.

Choose a command option

1. Type Circle
As soon as you have typed enough letters to uniquely identify the command, the Circle command automatically
completes at the prompt.

2. Press the Enter key or click the command name in the list.

8
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3. The options for the Circle command appear:
Center of circle: Deformable, Vertical, 2Point, 3Point, Tangent, AroundCurve, FitPoints

4. To draw a circle vertical to the active construction plane, use the Vertical option.
Click Vertical, or type V.

Repeat the last command
Many tasks in Rhino are repetitive. You might want to move or copy several objects, for example. Methods for
repeating commands are provided.

To repeat the last command

Press the Enter key when no command is active.
In addition to pressing the Enter key on your keyboard, you can press the Space bar or click the right mouse
button in a viewport.
These all perform the same function.

Note:

Some commands, such as Undo and Delete do not repeat. Instead, the command prior to these commands is
repeated. This prevents you from accidentally undoing too many commands or deleting objects accidentally.
You can define the list of commands that do not repeat.
For example, you may want to repeat the command that you were using before undoing a mistake with the Undo
command. For this reason, Undo can be added to the list of commands that never repeats.
Commands that you do not want to repeat are added to the text box underNever repeat these commands in
Options on the General page.

Use recent commands

Right-click the command-line to view recently used commands.

To repeat the command, select it from the pop-up menu.
The number of commands listed is set in Rhino Options. The default limit is twenty commands. When you use
your twenty-first command the first one drops off the list.

Cancel a command
To cancel a command, press Esc or enter a new command from a button or a menu.

Toolbar group
A collection of tabbed toolbars.

Toolbar (Sidebar)
Contain graphical icons for initiating commands.

9
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Rhino toolbars contain buttons that provide shortcuts to commands. You can float a toolbar anywhere on the screen,
or dock it at the edge of the graphics area.
Rhino starts up with the Standard toolbar group docked above the graphics area and theMain toolbar as the sidebar
on the left.

Tooltips
Tooltips tell what each button does. Move your pointer over a button without clicking it. A small tag with the name of
the command appears. In Rhino, many buttons can execute two commands. The tooltips indicate which buttons have
dual functions.
For example:

 To access the command on the top line

Click the icon with the left mouse button.

 To access the command on the bottom line

Click the toolbar button with the right mouse button.

Cascading toolbars
A button on a toolbar may include other command buttons in a cascading toolbar. Usually the cascading toolbar
contains variations on the base command.
Buttons with cascading toolbars are marked with a triangle in the lower right corner. To open the cascading toolbar,
hover over the triangle and click. The tooltip [ Cascade "xxx"] appears.
For example, the Lines toolbar is linked to theMain sidebar. After the cascading toolbar is open, you can click any of
the buttons on the toolbar to start a command.

Viewports
The Rhino graphics area includes the viewports. You can customize number and position of the viewports.
Displays the Rhino working environment including object display, viewport title, background, construction plane grid,
world axis icon.
Viewports are windows in the graphics area that show you views of your model. To move and re-size viewports, drag
the viewport title or borders. From the viewport title menu, you can create new viewports, rename viewports, and use
predefined viewport configurations.
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Viewport title and menu
The viewport title appears in the upper left corner of each viewport.
The viewport title offers a shortcut for viewport actions:

Click the title to make the viewport current.

Double-click the title to maximize the viewport or to return it to its previous size. 

Right-click the menu to display the viewport title menu. 

You can also click the down arrow on the viewport title to display the menu.

Viewport tabs
You can also display the viewport titles in tabs. The highlighted tab designates the active viewport. Tabs make it easy to
switch between viewports when using maximized or floating viewports.

The tabs are located below the graphics area.

Osnap control
Contains persistent object snap toggles.

Status Bar
Displays the current coordinate system, the current location and delta of the cursor, and the Status Bar panes.
The Status Bar is located at the bottom of the Rhino window.
Tip: If the Status Bar is not visible, press Alt key. The Alt key toggles the visibility of the status bar.

CPlane x y z Inches Layer Grid Snap Ortho Planar Osnap SmartTrack Gumball Record History Filter Info

Status Bar options

CPlane/World The construction plane/world coordinates toggle.
x The mouse cursor x location.
y The mouse cursor y location.
z The mouse cursor z location.
Units/Delta The current units setting.

During drawing commands, displays the distance from last picked point to the current location.
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Layer If objects are selected, the Layer pane displays the layer of the selected objects.
If no objects are selected, the Layer pane displays the current layer.
Click the Layer pane to access quick controls for setting the selected objects' layer or to change
layer visibility and status.

Grid Snap Click the GridSnap pane to toggle Grid Snap.
Ortho Click the Ortho pane to toggle Orthomode.
Planar Click the Planar pane to toggle Planar mode.
Osnap The Osnap control lets you select which object snaps are currently in effect.

Click the Osnap pane to toggle the display of the Osnap control.

SmartTrack Click the SmartTrack pane to toggle SmartTrack mode.
Gumball Click the Gumball pane to toggle auto Gumballmode.
Record History Click the Record History pane to toggle history recording on/off state.
Filter Click the Filter pane to open the Selection Filter control.
Info Click the Info pane to display information about the current Rhino session. The Info pane cycles

through the list of specified categories.

Panels
Many Rhino controls are contained in tabbed panels. The panels are docked to the right side of the Rhino screen by
default. However, they can be dragged and floated anywhere.

Open panels

On the Panelsmenu, click the name of the panel you want to open.
Or
Right-click a panel tab.

Panels that you will work with in Level 1 training are:
l Display
l Layers
l Help
l Named CPlanes
l Notes
l Properties
l Web browser

Note: Positioning the mouse over the tabs allows the mouse wheel to scroll through the tabs.

Help and Help panel
Press F1 at any time to access Rhino Help. In addition to finding information about each command, Rhino help has
conceptual information as well as many examples and graphics to help you complete your model. When you are
confused or unsure about what to do, the first place you should look is the help file. You can also access help for a
specific command by starting the command and press F1.
In addition, the CommandHelp command displays the help topics in theHelp panel and displays help for the current
command.
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Most of the commands include short video clips that show how the command and the options work.
If Auto-Update is checked, the help for the current command displays. If Auto-Update is unchecked, you can type the
name of the command that you want displayed and press Enter to display the information.
TheHelp panel gives location of command on the Menus and Toolbars. For example, you can type a command, and
theHelp panel will detail where the commands are found.

Help panel.

Command Finder

Note:
In this training guide, the commands are located for you primarily in the menu.
As you gain experience and prefer to use the toolbars, theHelp panel will locate the commands for you.
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Command-line history
The Command Historywindow lists the last 500 command lines from the current Rhino session.
Press F2 to view the command history.

Mouse actions

Pick
In a Rhino viewport, the left mouse button selects objects and picks locations.
In this training guide, Pick and click are used interchangeably in this guide to communicate a left mouse button pick.

Three button mouse
The right mouse button has several functions including panning and zooming, popping up a context-sensitive
menu, and acting the same as pressing the Enter key.

l Use the left mouse button to select objects in the model, commands or options on the menus, and buttons in
the toolbars.

l Use the right mouse button to:
- Complete a command
- To move between stages of commands
- To repeat the previous command.
- To initiate commands from some toolbar buttons.

l Drag with the right mouse button to pan a parallel view.
l Drag with the right mouse button , hold down Shift key to pan a perspective viewport.
l Drag with the right mouse button to rotate a perspective viewport.
l Use the mouse wheel to zoom and change the magnification of the view
l With a the track pad or 2-button mouse, hold down the Ctrl key and drag with the right mouse button to
zoom a viewport.
You must press and hold the right mouse button down to activate this feature.

Note: If you have selected your primary mouse button to be the right mouse button in your operating system's mouse
configuration, then use the right as a the Pick.
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Exercise 4-2 Getting started
1. On the Filemenu, click Open.
2. In the Open dialog box, navigate to the Level 1 folder and Open the model Start.3dm.

This model contains five objects: a cube, a cone, a cylinder, a sphere, and a rectangular plane.
It opens in a three viewport configuration: it opens in two parallel viewports and one perspective viewport.

3. On the View menu, click Viewport Layout, and then click 4 Viewports.
The result is three parallel viewports and one perspective viewport.
Note: To return to the three viewports, on the View menu, click Viewport Layout, and then click 3 Viewports.

4. On the Status Bar, click Grid Snap to turn on the Grid Snap.
Grid Snap may already be on in your system. Be careful that you do not turn it off instead of on. If Grid Snap is
on, it will be bold and black on the Status Bar. If it is off, the word it will be gray.

Note: This is an important step. Grid Snap only lets your cursor move in certain intervals. In this model, the
setting for Grid Snap is one-half of a grid line. Grid Snap helps you line up your objects as if you were building
with LEGO® blocks.

Activate a viewport

1. Click in the Perspective viewport to make it active.
The viewport title highlights when it is active. The active viewport is the viewport where all your commands and
actions take place.

2. Click the arrow icon on the Perspective viewport title or right-mouse click the viewport title to display the
viewport menu, and then click Shaded.
The objects appear shaded. A shaded viewport lets you preview the shapes. The viewport will remain shaded until
you change it back to a wireframe view.
You can change any viewport to the Shaded display mode.
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Render the viewport

1. On the Render menu, click Render.
Rendering the model opens a separate render window.

The model displays in render colors previously assigned to the objects. You can also set lights and a background
color. You will learn about doing this later.
You cannot manipulate the view in the render display window but you can save image to a file.

2. Close the render window.

Tumble the viewport

1. In the Perspective viewport, click and drag with your right mouse button held down to rotate the view.
The plane helps you stay oriented.

2. On the Perspective viewport title menu, click X-Ray.
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3. On the Perspective viewport title menu, click Ghosted.

4. On the Perspective viewport title menu, click Rendered.

5. On the Perspective viewport title menu, try Technical, Artistic, and Pen display modes.
6. To rotate your view, drag from the bottom of the view toward the top.

You are now under the objects looking up.

The plane obscures the objects. In the Shaded display mode, the plane helps you see when your viewpoint is
below the objects.
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The Technical display mode displays lines
as though the drawing were a 2-D, flat
drawing on paper.
This mode uses real-time silhouettes and
intersections, creases, borders, blended
shaded and rendered display. Objects
behind other objects appear occluded.

The Artistic display mode is similar to
Technicalmode. Artistic mode displays
lines as though the drawing were a 2-D,
flat, pencil drawing on textured paper.

Pen display mode is similar to Technical
mode. Penmode displays lines as though
the drawing were a 2-D, flat, pen drawing
on paper.

7. Change toWireframemode.

Navigating the model
You have used the right mouse button to rotate in the Perspective viewport. You can hold Shift and drag with the
right mouse button to pan. Dragging the right mouse button to move around does not interrupt any commands
in progress.

Pan in a viewport

1. In the Perspective viewport, hold the Shift and drag with the right mouse button to pan the view.
2. Pan the view in the parallel viewports by dragging with the right mouse button.

The Top, Front, and Right viewports use a parallel projection.
In the parallel viewports, it is not necessary to press the Shift key.

3. Pan the viewport using the Shift key and the right mouse button.
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4. Pan the viewport in a parallel view with the right mouse button.

Zoom in and out
Sometimes you want to get closer to your objects or move back so you can see more. This is zooming. As with many
things in Rhino, there are several ways to do this. The easiest way is to roll the mouse wheel to zoom in and out. If you
do not have a wheel mouse, hold down the Ctrl key and drag up and down in a viewport with the right mouse button.

Zoom in and out

1. In the Perspective viewport, roll the wheel on your mouse forward to zoom in, roll it backward to zoom out.
The camera zooms at cursor position.

2. In the Perspective viewport, hold the Ctrl key, click, hold the right mouse button, and drag the mouse up and
down.

3. Drag up to zoom in.
4. Drag down to zoom out.
5. Zoom the viewport using the Ctrl key and the right mouse button.

Zoom extents
The Zoom command, Extents option displays a viewport so the objects fill up the viewport as much as possible. You
can use this command to make everything visible.

Zoom extents in a viewport

On the View menu, click Zoom, and then click Zoom Extents.
If you get lost, it is often handy to zoom extents in all your viewports at once, so there is a command to do just
that.

Zoom extents in all viewports

On the View menu, click Zoom, and then click Zoom Extents All.
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Move objects
Dragging follows the construction plane of the current viewport.

Move objects

1. If Gumball is on bold in the Status Bar, gumball is on.
2. Click to turn gumball off.
3. Click the cone and drag it.
4. Drag the objects around. You can drag in any viewport.

In this model, the Grid Snap setting is one-half of a grid line. Using this snap, you should be able to line objects
up with each other.
The selected cone changes to the selection color.

5. Drag the cone in the Perspective viewport until it lines up with the cylinder.
It will be inside the cylinder.

The cone moves on the base represented by the grid. This base is a construction plane. Each viewport has its own
construction plane. When you start Rhino, the Perspective viewport has the same construction plane as the Top
viewport. You will learn more about using construction planes later.

6. From Edit menu, click Undo.
7. Drag the cone in the Perspective viewport until it lines up with the cylinder. Next tap the Alt key.

You will see a plus + on the screen. Pick a location and the cone is copied to base surface.

8. From Edit menu, click Undo.
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9. In the Front viewport, drag a cone to the top of the cylinder.
Watch what happens in the Perspective viewport.
Watch the other viewports to place your objects.

10. Click in the Perspective viewport.
11. Change the viewport to a Rendered display.

Copy objects
To create more objects, copy the shapes.

Open themodel

1. On the Filemenu, click Open.
2. Do not save the changes.
3. In the Open dialog box, select Start.3dm.

Copy objects

1. Click the box to select it.
2. On the Transformmenu, click Copy.
3. Click somewhere in the Top viewport.

It usually helps to click a spot that relates to the object like the middle or near a corner.

4. Click where you want the first copy.
Zoom in closer if you like.
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5. Click other places to make more copies of the box.
6. When you have enough copies, press Enter.
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Editing with gumball
Gumball displays a widget on a selected object, which is used to facilitate the direct editing. The gumball provides
move, scale, and rotate transformations around the gumball origin.

Click the Gumball pane on the Status Bar.

Gumball actions

l Drag gumball arrows to Move the object.
l Drag scale handles (squares) to Scale the object in one direction.
l Drag arcs to rotate the object.
l Tap the Alt key after starting to drag to toggle copy mode.
l Click a control handle to enter a numeric value.
l Hold the Shift key during Scale to force 3-D scale.

Gumball Controls

 Axis plane indicator

 Free move origin

 Menu location

Move arrows

 Move X

 Move Y

 Move Z

Rotation arcs

 Rotate X

 Rotate Y

 Rotate Z

Scale handles

 Scale X

 Scale Y

 Scale Z

 Extrude Z
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Move geometry with the gumball

1. In the Top viewport, select the cone.
2. Drag the red arrow to move the object in the positive x or negative x-direction.

3. Drag the green arrow to move the object in the positive y or negative y-direction.

4. In the Front viewport, select the cone.
5. Drag the blue arrow to move the object in the positive z or negative z-direction.

6. Undo enough times to get back to the original model.
7. In the Top viewport, select the cone.
8. Click x Move Arrow (red) to enter numeric value of 1.
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The cone moves a distance of 1 units to the right.

9. Repeat for yMove Arrow and z Move Arrow.

Copy objects with gumball
In this exercise you will drag objects with the gumball and tap the Alt key after starting to drag to toggle copy mode.
1. In the Top viewport, select the cone.
2. Drag the red arrow to move the object in the positive x or negative x direction.

3. While still dragging, tap the Alt key.
A plus + appears to the right of the red arrow.
When you release the mouse button, a copy of the object is created.

4. In the Top viewport, select the two cones.
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5. Drag the green arrow to move the objects in the positive y direction.

6. While still dragging, tap the Alt key.
A plus appear to the right of the green arrow.
When you release the mouse button, a copy of the object is created.

7. Undo enough times to get back to the original model.

Rotate objects with gumball
Drag arcs to rotate the object.
1. In the Top viewport, select the cone.
2. Click and drag along blue arc to rotate cone.

3. In the Right viewport, click and drag along green arc to rotate cone.
4. Undo enough times to get back to the original model.

Scaling with Gumball
Drag scale handles (squares) to Scale the object in one direction.
Click a scale control handles (squares) to enter numeric value.
Hold the Shift key during Scale to force 3-D scale.
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Scale objects with gumball

1. In the Front viewport, select the cone.
2. Drag the red scale handle (square) to scale the object.

Release the mouse button to complete the scale.

3. In the Front viewport, select the cone.
4. Drag the blue scale handle (square) down to scale the object larger in height.

Release the mouse button to complete the scale.

5. Try clicking a scale control handle (square) and enter numeric value or scale factor like .75.

6. In the Front viewport, select the cone.
7. While holding down the Shift key, drag the red scale handle (square) to scale the object uniformly in the x, y, and

z direction. Let go to complete the scale.

8. Undo enough times to get back to the original model.
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Try on your own

Make copies of more objects and move them around.
See if you can build something.

Change the view of your model
When you add detail to your models, you will need to see different parts of your model with different magnifications.
You can use the view commands, the mouse, and the keyboard to change the view in a viewport.
Each view corresponds to the view through a camera lens. The invisible target of the camera is located in the middle of
the viewport.

Viewports
With Rhino, you can open an unlimited number of viewports. Each viewport has its own projection, view, construction
plane, and grid. If a command is active, a viewport becomes active when you move the mouse over it. If a command is
not active, you must click in the viewport to activate it.
Most viewport controls can be accessed through the viewport pop-up menu.
To open the pop-up menu, right-click the viewport title.
Or click the small triangle on the viewport title.

Parallel vs. perspective projection
Unlike other modelers, Rhino lets you work in both parallel and perspective views.

Toggle between parallel and perspective views

1. Right-click on the viewport title, and on the menu, click Viewport Properties.
2. In the Viewport Properties dialog box, for Projection click Parallel or Perspective, and then click OK.

Pan and zoom
The simplest way to change the view is to hold down the Shift key and drag the mouse with right mouse button held
down. This pans the view. To zoom in and out, hold down the Ctrl key and drag up and down or use the mouse wheel.
You can also use the keyboard to navigate:

Perspective Projection Parallel Projection
Key Action Action + Ctrl Action
Left arrow Rotate left Pan left Pan left
Right arrow Rotate right Pan right Pan right
Up arrow Rotate up Pan up Pan up
Down arrow Rotate down Pan down Pan down
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Perspective Projection Parallel Projection
Key Action Action + Ctrl Action
Page Up Zoom in Zoom in
Page Down Zoom out Zoom out
Home Undo view change Undo view change
End Redo view change Redo view change

You can change your view in the middle of a command to see precisely where you want to select an object or select a
point.
There are additional zoom controls that will be discussed in other exercises.

Reset the view
If you get lost, four view techniques can help you get back to a starting place.

Undo and redo view changes
Click in a viewport, press your Home or End key on your keyboard to undo and redo view changes.

Set the view looking straight down on the construction plane
On the View menu, click Set View, and then click Plan.

Bring all your objects into view
On the View menu, click Zoom, and then click Zoom Extents.

Bring all your objects into view in all viewports
On the View menu, click Zoom, and then click Zoom Extents All.
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Display options

Exercise 4-3 Practice with Display Options
You will use the camera model to practice changing views. You will create views from six directions and an oblique
perspective view.
1. Open the model Camera.3dm.

2. Click in the Top viewport to make it active.
3. On the View menu, click Viewport Layout, and then click Split Horizontal.
4. Make the Front viewport active.
5. On the View menu, click Viewport Layout, and then click Split Vertical.
6. Repeat this step for the Right viewport.
7. Right-click the Top viewport title, click Set View, and then click Bottom.

Three viewports are split down the middle either horizontally or vertically.

Change the shape of viewports

1. Move your cursor to the edge of a viewport until you see the resizing or cursor, hold the left mouse button down,
and drag the bar.

2. Move your cursor to the corner of a viewport until you see the resizing cursor, hold the left mouse, and drag the
intersection in any direction. If several viewports touch at that corner, all re-size.

Synchronize the viewports

1. On the View menu, click Zoom, and then click Zoom Extents.
2. On the Front viewport title, click Set Camera, and then click Synchronize Views.

All the parallel views are sized to the same scale as the active viewport and aligned with each other.
3. Change the viewport displays to one of the shaded viewport settings.
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4. On the Front viewport title on the left viewport, click Set View, then click Left.
5. On the Right viewport title on the right viewport, click Set View, then click Back.

Zoom to a window

1. On the View menu, click Zoom, and then click ZoomWindow.
2. Click and drag a window around a portion of the model.

Zoom to a selected object

1. Select the shutter release.
2. On the View menu, click Zoom, and then click Zoom Selected.

The view zooms to the selected object.

Rotate the view

1. In a perspective viewport, drag with right mouse button.
2. In a parallel viewport, on the View menu, click Rotate or use Ctrl+Shift and drag with the right mouse button.
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Maximize and restore a viewport

1. Double-click the viewport title to maximize the viewport.
2. Double-click the title of the maximized viewport to restore the viewport to its smaller size and reveal the other

viewports.

Start drawing
The Line, Lines, and Polyline commands draw straight lines. The Line command draws a single line segment. The Lines
command draws multiple end-to-end line segments. The Polyline command draws a series of straight or arc joined
segments (a single linear curve with multiple segments). To Rhino, all these lines are curve geometry.

Exercise 4-4 Draw lines
This existing file will help you organize your geometry as you learn about Rhino curves. Create your curves inside the
labled tiles if it helps you match the command to the curve.
Open the model Practice with Lines.3dm.

Draw a single line segment

1. Zoom and pan to the Command: Line tile.
2. On the Curvemenu, click Line, and then click Single Line.
3. Pick a Start point.
4. Pick an End point.

The command ends after one segment is drawn.

Draw line segments

1. Zoom and pan to the Command: Lines tile.
2. On the Curvemenu, click Line, and then click Line Segments.
3. Pick a point in the Top viewport.
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4. Pick another point in a viewport.
A line segment appears between the two points.

5. Continue to pick points.
Additional segments appear.

6. Press Enter to end the command.
The segments meet at a common point, but are not joined.

Close option
The Close option closes the shape by drawing a segment from the last point picked to the first point picked. It applies
to many curve drawing commands.

Use the Close option

1. Repeat the Lines command.
(Choose from the menu again or right-click in the viewport.)

2. Pick a Start point and 4 or 5 more points.
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3. In the command-line, click Close.
The last line segment will end at the original start.

Draw a polyline

1. Zoom and pan to the Command: Polyline tile.
2. On the Edit menu, click Undo.

Or press Ctrl + Z.
3. Make the layer Lines 02 current.
4. On the Curvemenu, click Polyline, and then click Polyline.
5. Pick a Start point and 3 or 4 more points.
6. Press Enter when done.

This makes an open polyline. A polyline a single object made of line segments that are joined together.

Use the Undo option
The Undo option deletes the last point picked.

Use the Undo option

1. Repeat the Polyline command.
2. Pick a Start point and 3 or 4 more points.
3. In the command-line, click Undo.

Notice that your cursor moves back to the previous point and one segment of the polyline is removed.
4. Continue to pick points.
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5. Click Close to end the command.
This makes a closed polyline (2).

Use the Line Bothsides option

1. Zoom and pan to the Command: Line Bothsides tile.
2. On the Curvemenu, click Line, and then click Single Line.
3. Click Bothsides in the command-line.
4. Pick a point that will locate the middle of the line.
5. Pick an End point of the line.

A segment is drawn with equal length on both sides of the middle point.

Use the Line FourPoint Option

1. Zoom and pan to the Command: Line FourPoint tile.
2. On the Curvemenu, click Line, and then click Single Line.
3. Click FourPoint option in the command-line.
4. At the Start of base line, pick a point (1).
5. At the End of base line, pick a point (2).

This determines the angle of the line that you are creating.
Hint: use the Point osnap.

6. At the Start of line, pick a point (3).
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7. At the End of line, pick a point (4).
A segment is drawn with input from four points.

Free-form curves
Draw curves from control points

1. Zoom and pan to the Command: Curve tile.
2. On the Curvemenu, click Free-form, and then click Control Points.
3. Pick a Start point.
4. Continue picking points.

The points that you pick are control points and may not lie on the curve.
5. Press Enter to end the command.

This makes an open curve.

The InterpCrv and Curve commands draw free-form curves. The InterpCrv command draws a curve through the
points you pick. The Curve command uses control points to create a curve.

Draw interpolated curves

1. Zoom and pan to the Command: InterpCrv tile.
2. On the Curvemenu, click Free-form, and then click Interpolate Points.
3. Pick a Start point.
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4. Continue picking points.
Notice that with this command the curve goes through each point that you pick.

5. Press Enter to end the command.
This makes an open curve.

On your own
Using the Rhino Help, investigate these additional commands. Try them out in the appropriate tile in the existing file.
1. Explode a polyline

2. Join lines into a polyline.
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Save your work
Save your work periodically during a session to keep it from being accidentally deleted.

Save your model

On the Filemenu, click Save.
Or
Click one of the other options.
You will have an opportunity to save your work.
It is good practice to save your model in stages under different names, using the Save As command. This lets you
go back to an earlier version of your model for modifications if necessary.
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Chapter 5 - Modeling helpers
Helpers include modeling aids, layers, object selection, hide and show, lock and unlock.
In the last chapter, you created a model with lines. If it is not already open, you will need to open it.

Open the model Practice with Lines.3dm from your work in the previous chapter.

Modeling aids now
Modeling aids are modes that you can toggle on or off by pressing shortcut keys, a function key, typing a single letter
command, or clicking a button.

Click the Grid Snap, Ortho, Planar, Osnap, SmartTrack, Gumball, Record History and Filter panes on the Status Bar
to toggle these modeling aids on and off.

Grid Snap
Grid snap constrains the marker to snap to grid intersections.
Press F9 or type S and press Enter to toggle Grid Snap on and off.
Press F7 to hide or show a reference grid in the current viewport at the construction plane.

Ortho
This modeling aid constrains the marker movement to the points at a specified angle from the last point created. The
default angle is 90 degrees.
Press F8 or press and hold the Shift key down to toggle Ortho on and off.

Gumball
Displays a widget on a selected object or set of selected objects. This widget facilitates move, scale, and rotate
transformations around the gumball origin.
Covered in previous chapter.

Modeling aids later
These modeling aids will be covered in a later chapter. Disable them until they are covered. However, here are the basic
descriptions to build on later.
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Planar
This is a modeling aid similar to Ortho. This helps you model planar objects by constraining the input to be on a plane
parallel to the construction plane that passes through the last point that you picked.
Type P and press Enter to toggle Planar mode on and off.

Osnap
Object snaps constrain the marker to an exact location on an object such as the end of a line or the center of a circle.

SmartTrack
This modeling aid uses temporary reference lines and points that are drawn in the Rhino viewport using implicit
relationships among various 3-D points, other geometry in space, and the coordinate axes' directions.
More on this later.

Record History
Records history and updates history-aware objects. With the Record History and Update Children option turned on,
geometry created with history can be updated by editing the input curves.

In general, it is best to leave the Always Record option unchecked or off and use the Record History on in Status Bar
pane to selectively record history when using commands that support history. For a list of commands that support
history, see History in the Rhino Help.

History can make editing unpredictable when geometry updates automatically and you were not expecting it.
Rhino experts may set history to Always Record. However, this is not recommended until you are more experience
with Rhino.

Filter
This modeling aid restricts any selection mode to specified object types. Objects types that can be restricted are:
Annotations, Blocks, Control points, Curves, Lights, Meshes, Point clouds, Points, Polysurfaces, Surfaces, Hatches, and
others.

Exercise 5-1 Modeling aids in use

Draw lines and curves using mode functions
1. Zoom and pan to the GRID tile.
2. Turn on the Dimension layer.

Note: Locking a layer will prevent any accidental edits to objects on this layer.
3. In the Status bar, toggle Grid Snap on. Function key F7 will toggle the Grid visibility.

Type the Grid and Enter.
The marker snaps to each grid intersection. In the current file, SnapSize and the Grid-MinorLineSpacing are both
set to 1.

4. Zoom and pan to the GRID SNAP tile.
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5. Toggle Grid Snap on and draw some lines.

6. Zoom and pan to the ORTHO tile.
7. Toggle Grid Snap off, toggle Ortho on and draw some lines and curves.

You can only input points that are at 90 degree intervals from the last point.
8. To change the ortho angle, type OrthoAngle and Enter.
9. At the Ortho Angle prompt type 45 and Enter.

Now, you can only input points that are at 45 degree intervals from the last point.

By using Grid Snap and Ortho toggles, you can draw with precision.
We will discuss other ways to get precision in a later session.

10. Zoom out. The tiles now look complete.

Summary of Function Keys
Now let's summarize the function keys F1-F12 and the default commands that are assigned to them.
To review your own settings,, from the Toolsmenu, click Options and the Keyboard page. Key F4 and F5 are
unassigned.
Hint:Watch for commands in the training that would be helpful to access using these unassigned keys.
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Function Key Assigned Command
F1 Help
F2 CommandHistory
F3 Properties panel
F4 unassigned
F5 unassigned
F6 Camera Toggle
F7 Grid Toggle
F8 Ortho Toggle
F9 Grid Snap Toggle
F10 PointsOn command
F11 PointsOff command (Esc also works here.)
F12 DigClick command

Deleting objects
The Delete command and the Delete key remove selected objects from the model.

Selection options
Geometry in Rhino can be selected by picking on an object with the primary mouse button in any of the Rhino
viewports.
You can be in a command selecting objects or selecting objects with no command active.
Press the Shift key and pick to add to the selection set.
Or press the Control key and pick a selected object to remove the highlighting.

You can also select groups of objects using selection windows. They are activated by picking in an area with no
geometry and dragging in either the right or left direction for the second pick. The direction of right or left will
determine how objects are selected.

A crossing window will select objects that are crossed by the windows or enclosed by the window.
To use a crossing window, pick in an open area on the screen, and then drag the window from right to left.

Crossing selection window
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An enclosedwindow will only select objects that are completely surrounded by or enclosed by the window.
To use an enclosed window, pick in an open area on the screen, and then drag the window from left to right.

Enclosed selection window

Exercise 5-2 Practice using selection options
1. Open the model Delete.3dm.

2. Select the square and the circle.
3. On the Edit menu, click Delete or press the Delete key.

The objects disappear.
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Select objects for deletion

1. In the Top viewport, select one of the lines on the hexagon.
Because there are several curves superimposed on each other, the pop-up Selection Menu appears, allowing you
to select only one of the curves.

2. Select the top curve from the list.

3. On the Edit menu, click Delete.
In the Perspective viewport, observe one disappear.

4. In the Top viewport, use a crossing window to select the surface and the polyline in the top right part of the
drawing.
To use a crossing window, pick in an open area on the screen, and then drag the window from right to left.
Both objects are selected.

5. On the Edit menu, click Delete.
6. Window select the polyline and the cylinder in the lower right part of the drawing.

Only those objects that are completely inside the window are selected.
7. Hold down the Ctrl key, and click the cylinder to remove it from the selection set.

8. On the Edit menu, click Delete.
9. Continue deleting objects in the drawing.
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Practice using different selection methods to select and deselect objects.
Use crossing and window selection.
Hold the Shift key while selecting to add objects to your selection set.
Hold the Ctrl key while selecting to remove objects from your selection set.

Undo and redo deletions

1. On the Edit menu, click Undo.
Each time you click, Undo takes you back one command.

2. On the Edit menu, click Redo.
Each time you click, the previous Undo is reinstated.

3. Undo all the deletions you made in the previous exercise.

Dedicated selection commands
In addition to the selection options we just practiced, there are several other useful tools for selecting objects. In the
next exercise we will use some of these tools.

Select objects using select tools

1. On the Edit menu, click Select Objects, and then click Curves.
All the curves are selected.

2. On the Edit menu, click Select Objects, and then click Invert.
Everything but the previously selected curves is selected.

3. On the Edit menu, click Select Objects, and then click None.
Everything is unselected.

4. On the Edit menu, click Select Objects, and then click Polylines.
All of the polylines are selected.

5. On the Edit menu, click Select Objects, and then click Surfaces.
The single surface is added to the selection set.

6. On the Edit menu, click Select Objects, and then click Polysurfaces.
The polysurfaces are added to the selection set.

7. On the Edit menu, click Select Objects, and then click None.
8. Draw a few lines and curves.
9. On the Edit menu, click Select Objects, and then click Last Created Objects.

The last object you created is selected.

Filter selection
A filter restricts any selection mode to specified object types. Objects types that can be restricted are: Annotations,
Blocks, Control points, Curves, Lights, Meshes, Point clouds, Points, Polysurfaces, Surfaces, Hatches, and Others.
Note: Filters are only in affect when the Filter dialog is open. Closing the dialog, disables the active filter.

Use the Filter control

1. On the Status Bar, click Filter.
The selection Selection Filter control will appear.
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2. Right-click Curves.
All other selection options are unchecked.

3. Use a crossing selection or Ctrl + A keys to select the entire the drawing.
Only the curves are selected.

4. Press Esc to deselect.

5. Right-click Surfaces.
All other selection options are unchecked.

6. Use a crossing window or Ctrl + A to select the entire the drawing.
Only the surfaces are selected.

7. Press Esc to deselect.

8. Right-click Polysurfaces.
All other selection options are unchecked.

9. Use a crossing window or Ctrl + A to select the entire the drawing.
Only the polysurface objects are selected.
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10. Press Esc to deselect.

11. Right-click Disable to reset all filters to on.

Object visibility and locking
A few commands are useful here before we go on.

Select a single object
Move your pointer arrow over the object and click.
The object turns yellow, which is the default selection color.

Select more than one object
1. Move your pointer arrow over the first object and click.
2. While holding the Shift key down, move your pointer over another object and click.

Hide an object
1. Select an object.
2. On the Edit menu, click Visibility, and then click Hide.

The object becomes invisible.

Show hidden objects
On the Edit menu, click Visibility, and then click Show.
The Show command re-displays all hidden objects.

Lock an object
1. Select an object.
2. On the Edit menu, click Visibility, and then click Lock.

The object becomes shaded gray. You can see the locked object, you can snap to it, but you cannot select it.

Unlock locked objects
On the Edit menu, click Visibility, and then click Unlock.
The Unlock command unlocks all locked objects.
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Layers
Rhino layers work like other CAD layering systems you may be familiar with. By creating objects on different layers, you
can edit and view related portions of a model separately or as a composite. You can create as many layers as you like.
You can display all layers simultaneously or turn any of them off. You can lock layers so they are displayed but cannot
be selected. Each layer has a color. You can assign a name to each layer (for example, Base, Body, Top) to organize the
model or you can use preset layer names (Default, Layer 01, Layer 02, Layer 03).
The Layers panel manages layers. Use it to set up layers for your model. The Layers panel can be floating or docked
with the other tabbed panels like Properties, Command Help, Lights, Notes, and more.

Exercise 5-3 Working with layers

Create a new layer
1. On the Edit menu, click Layers, and then click Edit Layers.
2. In the Layers panel, click theNew icon.

The Default layer is created automatically when you start a new model with no template. If you use a standard
Rhino template, a few additional layers are also created.

3. The new layer, Layer 06, appears in the list. Type Lines and press Tab.
Use the Tab key to quickly add layers.

4. The new layer, Layer 06, appears again. Type Curves and press Tab.
5. The new layer, Layer 06, appears. Type Solids and press Enter.
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Assign a color to a layer
1. Click the square Color patch on the Lines row in the list.
2. In the Select Color dialog box, click Red from the list.

The right half of the sample rectangle turns red.
Hue, Sat, Val are the hue, saturation and value components of the color.
R, G, and B are the red, green and blue components of the color.

3. Click Ok.
4. In the Layers panel, the new color appears in the color patch on the Lines row of the layer list.
5. Repeat steps 1–3 to make the Curves layer Blue.
6. Click Ok to close the Select Color dialog box.

Make a layer current
1. On the Status Bar, click the Layer pane.

The Layer pane on the Status Bar displays the current layer (Default).

2. In the Layer pop-up, click Lines.
The current layer is displayed in the Layer pane.

3. Draw some lines.
The lines are on the Lines layer and they are colored red.

4. To make a different layer current, click the Layer pane again.
5. Click Curves.
6. Draw some curves.

They are on the Curves layer and are colored blue.

49



Rhinoceros Level 1 Training Guide

7. Draw more lines and curves on each layer.
Clicking the name or the check box sets the current layer.
Note: If objects are selected, and a layer is selected from the Status Bar, the highlighted objects will be changed
to the selected layer and the current layer does not change.

Lock a layer
1. On the Status Bar, click the Layer pane, click Solids to make the Solids layer current.
2. On the Layer pop-up menu, click the Lock icon on the row for the Lines layer.

Locking a layer turns it into a reference only layer. You can see and snap to objects on locked layers. You cannot
select any objects on locked layers. You cannot make a locked layer current without unlocking it.

Turn a layer off
1. On the Status Bar, click the Layer pane.
2. On the Layer pop-up menu, click the On/Off icon (light bulb) in the row for the Curves layer.

Turning a layer off makes all objects on it invisible.

Change an object from one layer to another
1. Select an object.
2. On the Edit menu, click Layers, and then click Change Object Layer.
3. In the Layer for object dialog box, select the new layer for the object, and click Ok.

4. From the Edit menu, click Undo.
5. Select an object.
6. In the Properties panel, in the Object section in the Layer row, click arrow and from the menu select the new

layer for the object.
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7. From the list, pick the new layer.

8. Click on the Rhino viewport to un-select the object and see the change.
Hint: The object will display the layer color, if the object's Display Color is set to By Layer in the Properties panel.

Exercise 5-4 Practice with Layers
You will look at an existing model that uses hierarchical layers.
1. Open the model Camera.3dm.

2. Go to the Layer panel. Lens is the current layer.

3. Turn off the Bumper layer. The bumper goes off, but the parent layer is still visible.
4. Turn on the Bumper layer
5. Turn off the Body layer. All children layers to the Body layer, also are turned off.
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6. Under the Lens layer, highlight the Trim and Details layer and use arrow buttons across the top to move the
layer out of the hierarchy.

7. Highlight the Trim and Details layer and drag and drop back under the Lens layer. It will now be returned to the
former hierarchy.

8. Close the Cameramodel and do not save.
Extra Credit:

l Discuss with your class how hierarchical layers can be used to organize models frommany different industries.
l Brainstorm how hierarchical layers could be used in an architectural model.
l Develop standard set of layers for your templates that uses the hierarchical layer organization.
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Chapter 6 - Precision modeling
So far you have been drawing imprecise lines. Now you will try drawing lines at specific places. To do this you will use
coordinates. Whenever you draw a curve, or create a solid primitive, Rhino asks you for a series of points.
You can tell that Rhino is asking for point input two ways: the command prompt has a prompt like Start of line, Start
of polyline, Start of curve, orNext point
and the arrow-shaped cursor turns into a cross-shaped cursor.

You can enter a point two ways:

Pick a point in a viewport with the left mouse button .
Type coordinates at the command-line. (Enter is necessary after you type in a coordinate at a point prompt.)

Note: Give these terms special attention in the following section on Coordinate input. It will be critical that you Pick or
Enter as indicated in the specific steps.
If you have selected your primary mouse button to be the right mouse button in your operating system's mouse
configuration, then use the right as a the Pick.

You will select the units and tolerance of the model before you begin. You can do this in the Options dialog under the
Units page or by picking a template that has units and Tolerance already set.
You can change the tolerance after you start, but objects that are edited before the change still have the old tolerance
value.

Coordinate entry
Rhino uses a fixed Cartesian coordinate system called the world coordinate system (WCS), based on three axes (the x-,
y-, and z-axes) that define locations in three-dimensional space.
Each viewport has a construction plane that defines coordinates for that viewport. We will work in the Top and
Perspective viewports where the two coordinate systems are the same.

Exercise 6-1 Set up a model
1. On the Filemenu, click New.
2. Click Small Object - Millimeters.3dm, and then click Open.
3. On the Filemenu, click Save As.
4. Name the model BOXES.

Use the BOXES.3dmmodel to learn how to draw with absolute coordinates.

Absolute coordinates
The first forms of coordinates you will use are called absolute coordinates. Absolute coordinates are exact locations
relative to the x-, y-, and z-axes.

Enter absolute coordinates

1. In the Top viewport, double-click the viewport title to maximize the viewport.
2. On the Curvemenu, click Polyline, and then click Polyline.
3. To Start type 0 and press Enter.

If you are going to start at the origin of the sheet (0,0,0) you can simply type 0 as a shortcut.
4. For theNext point type 5,0 and press Enter.
5. For theNext point type 5,5 and press Enter.
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6. For theNext point type 0,5 and press Enter.
7. Click Close to close the polyline.

Relative coordinates
Relative coordinates are often easier than absolute coordinates to use.
Every time you select a point, Rhino saves that point as the last point.
Relative coordinates are based on the last point entered, instead of on the origin (0,0,0) of the construction plane.
Precede the x,y,z coordinates with the letter R (upper or lower case) or the@ symbol to enter relative coordinates.

(1) Last point, (2) Next point, (3) Change in y, (4) Change in x.

Enter relative coordinates

1. On the Curvemenu, click Polyline, and then click Polyline.
2. For the Start point, type 8,0 and press Enter.

These are absolute coordinates.
3. For theNext point, type r5,5 and press Enter.

These are relative coordinates.
4. For theNext point, type r-5,0 and press Enter.
5. Click Close to close the polyline.

Polar coordinates
Polar coordinates specify a point that is a distance and direction away from 0,0 in the current construction plane.
Vector directions in Rhino start with zero degrees at 3 o'clock on a standard clock. They change in an anti (counter)-
clockwise direction as illustrated below.
For example, if you want a point four units away from the construction plane origin, at a 45° angle counterclockwise
from the construction plane x-axis, type 4<45, and press Enter.
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Relative polar coordinates are preceded by R or@; absolute polar coordinates are not.
Instead of using x, y, and z coordinates, enter relative polar coordinates like this: Rdistance<angle.

(1) Last point, (2) Next point, (3) Distance, (4) Angle.

Enter polar coordinates

1. On the Curvemenu, click Polyline, and then click Polyline.
2. For the Start point, type 0,8, and press Enter.
3. For theNext point type R5<0, and press Enter.
4. For theNext point type R5<90, and press Enter.
5. For theNext point type R5<180, and press Enter.
6. Click Close to close the polyline.

55



Rhinoceros Level 1 Training Guide

Distance and angle constraint entry
Using distance constraint entry, type a distance and press Enter to specify a point. Then as you move your cursor in any
direction, the distance from the last point will be constrained. This is a good way to quickly specify a line length. Using
angle constraint entry, type < followed by a value and press Enter specify an angle. The next point is constrained to
lines at multiples of the angle relative to the x-axis you specified.

Use the Shift key to toggle Ortho

When Ortho is off, hold the Shift key down to toggle it on while you pick points.
This method is an efficient way to draw perpendicular lines. In the following example, draw a line five units long
using distance constraints.

Distance constraint entry

1. On the Curvemenu, click Polyline, and then click Polyline.
2. For the Start point, type 8,8, and press Enter.
3. For theNext point, type 5, and press Enter.
4. Hold the Shift key down, and pick a point to the right.

Shift toggles Orthomode to constrain the marker to 0 degrees.
5. For theNext point, type 5, and press Enter.

6. Hold the Shift key down, and pick a point above the last point.
The Shift key toggles Orthomode to constrain the cursor to 90 degrees.

7. For theNext point, type 5, and press Enter.
8. Hold the Shift key down and pick a point to the left of the last point.

Shift toggles Orthomode to constrain the cursor to 180 degrees.
9. Click Close to close the polyline.

Distance and angle constraint entry

1. On the Curvemenu, click Polyline, and then click Polyline.
2. To Start type 16,5 and press Enter.
3. For theNext point type 5 and press Enter, then type <45 and press Enter.

As you drag your cursor around, the marker snaps to a distance of 5 and an angle of 45 degrees.

(1) Distance constrain
(2) Angle constraint.
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4. Pick a point down and to the right of the previous point.
The angle constraint sets the angle.

5. For theNext point type 5 and press Enter, then type <45 and press Enter.
6. Pick a point up and to the right.

The angle constraint sets the angle.
7. For theNext point type 5 and press Enter, then type <45 and press Enter.
8. Pick a point up and to the left.

The angle constraint sets the angle.
9. Click Close to close the polyline.
10. Save your model. You will use this model for another exercise.

Exercise 6-2 The Arrow
In this exercise, you will practice using distance and angle constraint entry
1. Start a new model, use the Small Objects - Millimeters.3dm template. Save as Arrow.

Since the object is symmetrical, you will only draw the lower half of the model.
2. Draw the arrow with a polyline, using a combination of absolute coordinates (x,y), relative coordinates (Rx,y),

polar coordinates (Rdistance<angle), and distance constraint.

Examples of the Command-line input
Absolute x,y

1. On the Curvemenu, click Polyline, and then click Polyline.
2. For the Start of Polyline type -11,0.

Relative x,y

For theNext point, type r-2,-2.

Distance constraint

For theNext point, type 8 and press Enter, turn Ortho on, and then pick to the right.

Relative x,y

For theNext point, type r1,1.

Relative polar

For theNext point, type r11<0.

Distance constraint

1. For theNext point, type 1 and press Enter, turn Ortho on, and then pick down.
2. For theNext point, type r6,2.
3. For theNext point, press Enter to end the command.
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4. Save your model.

Make a copy of the polyline

1. Select the polyline.
2. On the Transformmenu, click Copy.
3. For the Point to copy from, pick a point near the polyline.
4. For the Point to copy to, type 6 and press Enter, turn Ortho on, and pick above the selected polyline.
5. Press Enter to end the command.

Make amirror image of the polyline

1. Select the original polyline.
2. On the Transformmenu, clickMirror.
3. For the Start of mirror plane, type 0 and press Enter.
4. For the End of mirror plane, turn Ortho on, and then pick to the right.

Make it 3-D

1. Right-click the Perspective title, and set the display mode to Shaded.
2. Select the original polyline and the mirror copy.
3. On the Solidmenu, click Extrude Planar Curve, and then click Straight.
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4. For the Extrusion distance, type 1, and press Enter.

Make it 3-D (alternate)

1. Select the copy of the polyline.
2. On the Status Bar, click Osnap.
3. On the Osnap toolbar check End.
4. On the Surfacemenu, click Revolve.
5. For the Start of revolve axis, select the end of the polyline.
6. For the End of revolve axis, select the other end of the polyline along the center line.
7. Press Enter to use the default Start angle.
8. Press Enter to use the default Revolution angle.

Deform the shape with bend

1. Select the 3-D arrow.
2. On the Transformmenu, click Bend.

3. For the Start of spine, click the end point on the left end of the arrow.
4. For the End of Spine, click the end point on the right end of arrow.
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5. For the Point to bend through, drag the cursor down, and pick a point.

Deform the shape with twist

1. Pick the extruded arrow.
2. Turn Ortho on.
3. On the Transformmenu, click Twist.
4. In the Top viewport, pick the Start of Twist with the End point osnap at the left center end of the arrow.
5. Pick the End of Twist with the End point osnap at the right center end of the arrow
6. At the Angle or first reference prompt, pick a point to the right or angle 0 direction in the Right viewport.
7. Then watch the Perspective viewport, move the cursor clock wise or counter clockwise. Pick to the right to fill an

angle of 360.
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The twist transform is applied to the arrow solid.

Revolve to 3-D

1. Open Arrow Options.3dm.
2. Revolve to create the three arrow options shown on the Picture in the file..
3. Discuss with your instructor how to create the more complex arrows.

Hint: Try the Loft, Cap and Array Polar commands or come back to this exercise after the class.
4. Right click on the Perspective viewport, and select your favorite display mode.
5. Right click on the Perspective viewport and pick Capture and pick To File.

Exercise 6-3 The V-block
1. Start a new model using the Small Objects – Millimeters.3dm template.
2. Save as V-Block.
3. In the Front viewport, double-click the viewport title to maximize it.
4. Create the following model in the front construction plane.
5. Draw the object below using a combination of absolute coordinates (x,y), relative coordinates (rx,y), and relative

polar coordinates (rdistance<angle).
6. Start your model at 0 in the Front viewport.
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Try to create the model using a single polyline in a clockwise direction.
7. In the Front viewport, double-click the viewport title to restore your views.

Make it 3-D

1. Select the polyline.
2. On the Solidmenu, click Extrude Planar Curve, and then click Straight. 
3. For the Extrusion Distance type 150, and press Enter.

You can view the model as a three-dimensional object in the Perspective viewport.
4. Save your model.
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Object Snaps
Object Snaps (osnaps) are tools for specifying points on existing objects. Use object snaps for precision modeling and
to get accurate data. Object snaps are often referred to as object snaps. In Rhino, reliable modeling and easy editing
depends on objects actually meeting at specified points. Objects snaps give you precision you cannot get using the
“eyeball” method

Open the Osnap toolbar

Click the Osnap pane on the Status Bar.
The display of the Osnap control is controlled with the Osnap pane on the Status Bar.

Click it to toggle the display on and off.
The Osnap control turns persistent object snaps on and off.

Use persistent objects snaps to maintain an object snap through choosing several points without having to
reactivate the object snap.
When an object snap is active, moving the cursor near an eligible point on an object causes the marker to jump
to that point and a tooltip to appear.
Click a check box to turn on the object snap.
Right-click a check box to turn on the object snap and clear all other object snaps.
You can place the control anywhere on your desktop.

Practice using object snaps
In this model we will practice using most of the object snaps listed on the toolbar.

Exercise 6-4 Use osnaps
1. Open the model Osnap.3dm.
2. Toggle Grid Snap and Ortho off.

End andMidpoint object snaps

1. Click the Osnap pane on the Status Bar.
You can leave the Osnap control displayed.

2. Check End andMid.
Check and clear individual object snaps as needed.

3. On the Curvemenu, click Polyline, and then click Polyline.
4. For the Start of Polyline, move your cursor close to the end of the line at the lower left corner of the first square

and pick when the marker snaps to the end of the line.
The line starts exactly at that corner.
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5. For theNext point, move your cursor close to the midpoint of the vertical line at the right side of the square on
the right, pick when the marker snaps to the midpoint.
The marker snaps to the midpoint of the line that the cursor touches, making the new line cross to the exact
midpoint of that side.

6. For theNext point, move your cursor close to the end of the line at the upper left corner of the first square, pick
when the marker snaps to the end of the line.
The marker snaps to the end of the line.

7. Press Enter to end the command.

Near and Perpendicular to object snaps

1. On the Osnap control, check Near and Perp, clear End andMid.
2. On the Curvemenu, click Line, and then click Single Line.
3. For the Start of line, pick the lower edge of the circle at the top right.

The marker snaps to the point on the circle nearest to where the cursor is positioned.
4. For the End of line, pick the top horizontal edge of the second square when the Perp tooltip appears.

The marker snaps to a point making a perpendicular to the previous point.

64



Rhinoceros Level 1 Training Guide

Intersection and Tangent to object snaps

1. In the Osnap control, check Int and Tan; clearNear and Perp.
2. On the Curvemenu, click Line, and then click Single Line.
3. For the Start of line, pick the intersection where the diagonal line crosses the vertical line on the first square.

The marker snaps to the intersection between the two lines.

4. For the End of line, pick the top, left edge of the circle on the right.
The marker snaps to a point tangent to the circle.

Center of object snap

1. In the Osnap control, check Cen, clear Int and Tan.
2. On the Curvemenu, click Line, and then click Single Line.
3. For the Start of line, pick the edge of a circle.

The marker snaps to the center of the circle.
4. For the End of line, pick the edge of the other circle.

The marker snaps to the center of the circle.

Quadrant of object snap

1. In the Osnap control, check Quad, clear Cen.
2. On the Curvemenu, click Polyline, and then click Polyline.
3. For the Start of Polyline, pick a point on the top edge of the first circle.

The marker snaps to the quadrant point of the circle.
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4. For theNext point, pick the left edge of the circle.
The marker snaps to the quadrant point of the circle.

5. For theNext point, pick the bottom edge of the circle.
6. For theNext point, pick the right edge of the circle.
7. Click Close to finish.
8. Use the SaveAs command to save the model.
9. Name it Analyze.

We will use it for a later exercise.

Analysis commands
Rhino provides analysis tools for finding lengths, angles, areas, distances, and the volume and centroid of solids.
Additional commands let you analyze curve curvature, determine continuity between curves, and find unjoined edges.

Exercise 6-5 Analyze the model

Distance
Measures the distance between two picked points.

Find the distance between two points

1. Open the model Analyze.3dm that you saved from an earlier exercise.
If you didn’t get a chance to save the model, open the model Analyze-01.3dm instead.

2. On the Analyzemenu, click Distance.
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3. For the First point, pick the intersection where a diagonal line intersects a vertical line.
Use the Int object snap.

4. For the Second point, pick the intersection where the other diagonal line intersects the same vertical line.

5. Press F2 to display the information.
CPlane angles and deltas: xy = 90 elevation = 0 dx = 0 dy = 3.077 dz = 0
World angles and deltas: xy = 90 elevation = 0 dx = 0 dy = 3.077 dz = 0
Distance = 3.077 millimeters

Length
Displays the length of a selected line.

Find the length of a line

1. On the Analyzemenu, click Length.
2. Select the line between the centers of the circles.

Length = 8.000 millimeters
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Measure the angle between two lines

1. On the Analyzemenu, click Angle.
2. Select a point that defines the vertex of an angle line.

3. Select a point that defines the end of an angle line.
Use object snaps as appropriate.

4. Select a point that defines the vertex of the second angle line.
5. Select a point that defines the end of the second angle line.

The angle displays in the command-line in the following format: Angle = 21.7711

Radius
Displays the radius of a circle, arc, or curve segment.

Measure the radius of a circle

1. On the Analyzemenu, click Radius.
2. Select one of the circles.

This also measures the radius of curvature of a curve at a point.
The radius displays in the command-line in the following format:
Radius = 2.5

Point evaluation
Displays the coordinates of a picked location.
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Display the coordinates of a point

1. On the Analyzemenu, click Point.
2. Snap to the end point of the tangent line.

The x,y,z point is displayed for the world coordinate plane and the current construction plane.
Point in world coordinates = 8.203,11.488,0.000

CPlane coordinates = 8.203,11.488,0.000

Additional modeling aids
As well as allowing the user to work in a completely unconstrained free-formmanner Rhino has a number of
modeling aids and constraints that help with precision modeling. This section outlines these aids and constraints.

SmartTrack
SmartTrack creates a set of temporary reference lines and points that work in conjunction with Rhino’s object
snaps. Using SmartTrack obviates the need to create dummy reference lines and points. SmartTrack works on
both 2-D and 3-D objects. It can be used in conjunction with the Project and Planar constraints described later in
this section.

Exercise 6-6 Use SmartTrack
1. Open the model Constraints.3dm.
2. Maximize the Top viewport.
3. Make sure that the following object snaps are turned on: End, Near, Point,Mid, Cen, and Int.
4. Turn on SmartTrack on the Status Bar.
5. On the Curvemenu, click Point Object, then click Single Point.
6. Hover the cursor over the lower left corner of the green rectangle, the End snap will be displayed and a

white marker point becomes visible.
7. Repeat this process on the bottom left hand corner of the gold rectangle.

8. Move the cursor towards the apparent intersection point of these two corners.
Two temporary construction lines are displayed.
The point is positioned on the intersection of these two construction lines.
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9. Click to place the point object.
SmartTrack will work with any of the available object snaps. Experiment with some alternatives.

Tab Constraint
The Tab constraint lets you fix a direction to a reference point and thereby constrain cursor movement. The
following example shows a simple use of the Tab constraint.

Use the Tab constraint

1. In the Constraints.3dm file, maximize the Top viewport.
2. Turn off SmartTrack.
3. On the Curvemenu, click Line, then click Single Line.
4. For the Start of Line, snap to the end of the bottom left hand corner of the gold rectangle.

5. For the End of Line, hover the mouse over the bottom left hand corner of the green rectangle, when the
End snap appears, press the Tab key.

Note: The line now becomes white and the direction is constrained.
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6. For the End of Line, drag your mouse to the desired location and click.

The Tab constraint will work in conjunction with all object snaps and all tools that require a directional
input, for exampleMove, Copy, and Rotate.

Project constraint
By default 2-D geometry is created on the active construction plane. Object snaps override this behavior and
snapping to objects that are not on the construction plane will cause the geometry to be non-planar. The Project
constraint ignores objects snaps and pushes all the geometry onto the active construction plane.
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Use the Project constraint

1. Use the Constraints.3dm file, as previous section.
2. Make sure that the Ortho constraint is On.
3. Turn Layer 01 off and turn Layer 02 on.

The surfaces on Layer 02 are located at different elevations.

4. On the View menu, click Zoom, then click Zoom Extents.
5. Double-click the Top viewport title to restore the four view layout.
6. In the Top viewport, draw a polyline around the perimeter of the three rectangles.

In the Perspective viewport, notice how the planar nature of the polyline is overridden by the object snaps.
7. Delete the polyline.
8. Turn on the Project constraint on the Osnap toolbar.
9. In the Top viewport, draw a polyline around the perimeter of the three rectangles.

Look in the Perspective viewport as you draw the polyline and note how the object snaps for the endpoints
of the green and blue rectangles are projected to the construction plane.
The Project constraint forces all the segments of the polyline onto the construction plane. The resulting
polyline is planar.

10. Delete the polyline.
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Planar constraint
The Planar constraint limits successive picked locations to the same construction plane elevation as the previous
location. For example, a command such as Polyline can be started off the construction plane and the Planar
constraint will override Rhino’s default behavior of snapping back to the construction plane.
We will first look at what happens with the Planar constraint Off. Then, we will turn the Planar constraint On to
see what changes.

Use the Planar constraint

1. In the Constraints.3dm file, turn off the Ortho and Planar constraints, and Project object snap.
2. In the Top viewport, start a Polyline at the lower left corner of the green rectangle.
3. Add some more segments without snapping to any of the objects.

Look at the Perspective viewport, and notice how the polyline pulls back onto the construction plane after
the initial point.

4. Delete the polyline.
5. To create a planar curve turn on the Planar constraint.
6. Draw the polyline again.

It now stays on the same plane as the first point.

7. Delete the polyline.

Create a planar curve above the active construction plane

First we will draw a polyline without the Project constraint activated. Then we will use the planar constraint in
conjunction with the Project constraint to see what changes.
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1. Turn the Planar constraint On.
2. In the Top viewport, draw a new Polyline starting again at one of the corners of the green rectangle.
3. Create some additional points this time snapping to some of the blue and gold rectangle corner points.

Look at the Perspective viewport and note how the object snaps override the Planar constraint.

4. Delete the polyline.
5. In the Perspective viewport, draw a new polyline starting again at one of the corners of the green

rectangle.
6. After making the first point, turn the Project constraint On.
7. Create some additional points, snapping to some of the blue and gold rectangle corner points.

Notice that the points stay planar to the first point, even though you are snapping to points that are at
different elevations.

Introduction to construction planes
In the following exercise, you will practice using object snaps while learning more about viewports and
construction planes.
You will transform the surfaces in this model, set a construction plane to each surface and then name the
construction plane in theNamed CPlanes panel.
The CPlanes are saved with each file and can be restored by name later, even in a future editing session.
In this introduction to CPlanes, we will be using the 3Point option in the CPlane command. The 3 points are the
origin, a point on the x axis and a point on the y axis
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1. Use the Constraints.3dm file, as in the previous section.
2. Turn off Layer 01 and Layer 02. Turn on Layer 03.
3. Zoom in on the green surface.

4. On the View menu, pick Set CPlane and 3 points..
5. For the CPlane origin, pick in the lower left corner of the surface.

6. For the X axis direction, pick in the adjacent corner.

7. For the Y axis direction, pick in the edge of the surface.

8. Now the CPlane is set to the green surface.
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9. Type the Plan command . This will Set the viewport to the parallel and plan view of the green surface.

10. From the Curvemenu, pick Circle and Center radius.
11. Draw a circle on the green surface.

12. Open theNamed CPlanes panel. Pick the Save button. Type in the name Green.

13. On the View menu, pick Set Viewand Perspective.
14. On theNamed CPlanes panel, Double-click onWorld Top.

15. Repeat steps above and save both Blue and Gold custom construction planes in theNames CPlanes panel.
16. Save model.
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Exercise 6-7 Using construction planes
Open the model CPlanes.3dm.

Construction planes
The construction plane is the guide used for modeling Rhino objects. Points you pick are always on the
construction plane, unless you use coordinate input, elevator mode, or object snaps.

l Each viewport has its own construction plane.
l Each construction plane has its own axes, a grid, and an orientation relative to the world coordinate system.
l The grid is a plane of perpendicular lines lying on the construction plane. On default grids, every fifth line is
slightly thicker.

l The red line represents the construction plane x-axis. The green line represents the construction plane y-
axis. The red and green lines meet at the construction plane origin.

l The icon in the left hand corner always shows world coordinates, which are different from the construction
plane axes.

l Default construction planes are provided with the default viewports.

l The Top construction plane x- and y-axes align with the world x- and y-axes.
l The Right construction plane (x- and y-axes) align with the world y- and z-axes.
l The Front construction plane (x- and y-axes) align with the world x- and z-axes.
l The Perspective viewport uses the Top construction plane.

To set construction planes:
l Type CPlane.
l Select from the View menu.
l Right-click on the viewport title.
l Click the arrow on the viewport title.

There are many options to the CPlane command. In this exercise, you will work with:

77



Rhinoceros Level 1 Training Guide

l Origin
l 3 Point
l To Object
l Named CPlanes

Change a construction plane

1. On the View menu, click Set CPlane, and then click 3 Points.
2. For the CPlane origin, snap to the lower left corner of the surface labeled 1.

3. For the X axis direction, snap to the lower right corner of the surface labeled 1.

4. For the CPlane orientation, snap to the upper left corner of the surface labeled 1.
Now the construction plane is set.

5. On the Solidmenu, click Cylinder.
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6. For the Base of cylinder and Radius, pick points anywhere on the new construction plane.
7. Drag and click to place the End of cylinder.

Save the new construction plane

1. On the View menu, click Set CPlane, and then click Named CPlanes.
2. TheNamed CPlanes panel opens.
3. Click the Save as button in the toolbar area.
4. Type a name or use the default name CPlane 01, click OK.

You have a named construction plane that can be restored at any time.

5. Repeat setting and saving named construction planes for surfaces labeled 2 and 3.

Set a construction plane to an object

1. On the View menu, click Set CPlane, and then click To Object.
2. Select the surface labeled as 4.

The construction plane is set to the surface. The origin of the new construction plane is the center of the
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underlying untrimmed surface.
3. Using Named CPlanes, name this construction plane CPlane 04.

Change the construction plane origin

1. On the View menu, click Set CPlane, and then click Origin.
2. For the CPlane origin, snap to the upper left corner of the surface labeled 4.

3. Set a CPlane by Object for the surface labeled 5.
4. Set a new CPlane Origin for the surface labeled 5.
5. Using Named CPlanes, name this construction plane, CPlane 05.

Exercise 6-8 The Chair

Viewports and construction planes
1. Open the model Chair.3dm.
2. Each layer contains an image for a chair. Later in this exercise we will create our own chair.
3. Turn the following layers on:

l CP-Top
l CP-Front
l CP-Right
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Each of the layers contains an image of a view of a tubular chair.
Notice that all the chair images intersect at the origin of the model (0,0,0).
When you draw on any viewport the geometry will be located on the construction plane, unless you use
constraints.

Modeling in 3-D space

Chair: Technical Method (Recommended)
Rhino makes it easy to draw in 3-D space. You can draw on a different construction plane by simply moving your
cursor into a different viewport.

l Reference the technical drawing below, to input the precise curves for the chair with coordinate input.
l If precision is not required, you may trace the picture of the chair to generate the curves for the chair frame.
l When you have completed the curves, go to section “Finishing the chair.”
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Set up themodel

1. Toggle Planar on and Grid Snap on.
Toggle Ortho on as needed.

2. Turn on the Point object snap.

Draw a polyline

1. On the Curvemenu, click Polyline, and then click Polyline.
2. Move your cursor into the Front viewport.
3. For the Start of line, type absolute coordinate 4,2,Enter and Pick.
4. With Ortho on, drag the cursor to the right and lock the 0 angle, type 44,Enter and Pick.
5. Drag the cursor vertical and lock the 90 angle, type 43, Enter and Pick.
6. Drag the cursor to the left and lock the 180 angle, type 39,Enter and Pick
7. Using angle constraint, type <100 and Enter. Next type 42 , Enter.
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8. Lock your cursor on the angle of 100 degrees and distance of 42.

9. Confirm your inputs with a Pick and Enter to end the command.
10. From the Curve menu, pick Line and Single Line command. Move your cursor to the Right viewport. With

the End pt osnap, pick the Start of line at the end point of the last polyline.
11. Drag the cursor to the right, lock the 0 angle, and type 45, Enter, Pick.

12. Select the polyline profile curve, however do not include the last line curve.
13. On Transform, select Copy.
14. For the Point to copy from, pick with the End point osnap.

83



Rhinoceros Level 1 Training Guide

15. For the Point to copy to, pick at the other end of the line.

16. Draw a line to connect both profile. Use the End point osnap.

17. Select the frame curves.
18. Use the Join command to join the curves into one polyline.

Finish the chair
After creating the chair curve, you now need to construct the chair surfaces. It will help to first create a custom
construction plane aligned to the back of the chair.

Make a custom construction plane

1. On the Osnap Bar, verify End is checked.
2. Change to the Perspective viewport ,and press F7 to turn on the Grid.
3. On the View menu, click Set CPlane, and then click 3 Points.
4. For the CPlane origin, pick end (1).
5. For X axis direction, pick end (2).
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6. For the CPlane orientation, pick end (3).
The construction plane is aligned with the back of the chair.

Create a named construction plane

1. On the View menu, click Set CPlane, and click Named CPlanes.
2. In theNamed CPlanes panel, click Save.
3. In the Save CPlane dialog, type ChairBack, then click OK.

Note: You have a custom construction plane that can be restored as needed. This custom construction
plane is saved in the file.

Create a named view

1. On the View menu, click Set View, click Plan.
The view changes. You are looking straight down on the new construction plane.

2. On the View menu, click Set View, click Named Views.
3. In theNamed Views panel, click SaveAs.
4. In the Save Viewport As Named View dialog, type ChairBack, then click OK.

This creates a custom view that can be restored as needed.
5. Make the Perspective viewport current.
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6. On the View menu, click Set View, then click Perspective.
7. Draw some lines on the new construction plane.

Make it solid

1. Make the Frame layer current.
2. Select the chair frame.
3. On the Solidmenu, click Pipe.
4. For the Start and End Radius, type 3, and press Enter.

The chair has a solid frame.
5. Save the model.
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Fillet the corners

1. Undo the pipe.

2. Select the chair frame.
3. On the Curvemenu, click Fillet corners.

4. Click Radius and type 10 and press Enter.
The fillet will be applied to all the chair corners.

Make the back and seat surfaces

1. Select the curves you just filleted.
2. Make the Seat layer current.
3. On the Edit menu, click Explode.
4. To create a back surface, on the Surfacemenu, click Edge Curves.
5. Select the two side edges of the back of the chair, then press Enter.
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6. Repeat this procedure for the additional back and seat surfaces.

Join the seat surfaces and trim

1. Select all the seat surfaces.
2. On the Edit menu, click Join.

The seat will be joined into one polysurface.
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Trim the opening in the back.

1. Select the rectangular curve you created earlier.
2. On the Edit menu, click Trim.
3. Click the part the surface that is inside the rectangle to trim the chair back.

Create the frame pipe

1. Make the Frame layer current.
2. Turn off the Seat layer.
3. Select the curves for the frame.

4. On the Edit menu, click Join.
5. Use the Pipe command to make the new curves into a tubular frame.
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6. Turn Seat layer back on.

7. Render your model.

On your own

Try modeling a variation to the chair design.

Chair Designs by Vanessa Steeg

Chair Designs by Doaa Alsharif

Draw circles with precision
You can create circles using a center point and radius, center point and a diameter, two points on the diameter, three
points on the circumference, and tangent points to two coplanar curves and a radius.
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Exercise 6-9 Practice with Circles

Draw a center, radius circle
1. Open the model Circles.3dm.

2. On the Curvemenu, click Circle, and then click Center, Radius.
3. For the Center of circle snap to the intersection of the centerlines.
4. For the Radius type 4 and press Enter.

A circle is created around the center line intersection.

Divide a curve by the number of segments
For the next part of this exercise, we need to find some specific points to locate two of the circles. We will use the
Divide command to create the points.
1. On the Curvemenu, click Point Object, then click Divide Curve by, and then click Number of segments.
2. Select the bottom line as the curve to divide, press Enter.

3. For theNumber of segments type 4 and press Enter.
The line is marked off into four segments with a point at the end of each segment.
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Draw a diameter circle

1. Turn on the Point object snap.
2. On the Curvemenu, click Circle, and then click 2 Points.
3. For the Start of diameter pick snap to the second point from the left end of the line you divided.

4. For the End of diameter type 4 and press Enter, then turn Ortho on and pick in the straight up direction.
A circle is created with the two points you picked as the diameter, and the diameter was constrained to a value of
4.

5. Repeat these steps for the second diameter circle.

Draw a tangent, tangent, radius circle

1. On the Curvemenu, click Circle, and then click Tangent, Tangent, Radius.
2. For the First tangent curve, select the top line.
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3. For the Second tangent curve, select the left line.

4. For the Radius, type 2 and press Enter.
A circle is created that is tangent to the two lines you selected with a radius of 2.

5. Repeat these steps for the second circle.

Use extrusions to make it 3-D

1. Select the lines that form the rectangle.
2. On the Solidmenu, click Extrude Planar Curve, and then click Straight.
3. For the Extrusion Distance, type 2 and press Enter.

The rectangle generates a box.

4. Select the four smaller circles.
5. On the Solidmenu, click Extrude Planar Curve, and then click Straight.
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6. For the Extrusion Distance type, -6 and press Enter.
The circles generate cylinders.

7. Select the large circle in the center.
8. On the Solidmenu, click Extrude Planar Curve, and then click Straight.
9. For the Extrusion Distance, type 4 and press Enter.

The circle generates a cylinder.
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Exercise 6-10 Use circle commands with object snaps
1. Open the model Link.3dm.
2. Complete the model as shown.

3. Draw the three large circles first.
Snap to the center line intersections to place the circles.
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4. Draw the small holes next.
Use object snaps to snap to the centers of the large circles

5.
Optional Approach: Create the concentric circles in steps 3 & 4 by picking a reasonable size. Do not enter the precise
sizes. However, after the circles have been created, set the exact size with theModifyRadius command.

Draw the tangent lines

1. On the Curvemenu, click Line, and then click Tangent to 2 Curves.
2. For the First tangent point pick the edge of one of the circles near where you want the tangent line to attach.

3. For the Second tangent point pick the edge of another circle. Rhino will find the tangent points for you.
4. Continue to use this command to complete the model.

Arcs
You can create arcs using various points on the arc and construction geometry.
You can continue an existing curve with an arc to an existing curve, to a point or by an angle.
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Exercise 6-11 Drawing Arcs: CSA, SED, SER
1. Open the model Arc1.3dm.

2. On the Curvemenu, click Arc, and then click Center, Start, Angle.
3. For the Center of arc, snap to the center of the circle at the lower left.
4. For the Start of arc, snap to the end of the line.
5. For the End point or angle, snap to the end of the other line.

Draw a start, end, direction arc

1. On the Curvemenu, click Arc, and then click Start, End, Direction.
2. For the Start of arc, snap to the upper end of the vertical line.
3. For an End of arc, snap to the adjacent end of the horizontal line at the top.
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4. For the Direction at start, toggle Ortho on and drag in the straight up direction and pick.

5. Make another Direction Arc at the upper right.
6. For the Start of arc, snap to the right end of the horizontal line.
7. For an End of arc, type R2,-2 and press Enter.
8. For the Direction at start, toggle Ortho on and drag in the straight down direction and pick..

Addmore arc segments using extension option

1. On the Curvemenu, click Arc, and then click Center, Start, Angle.
2. In the command-line, click Extension.
3. For the Select near curve end, pick near the end of the arc you just made.
4. For the End of arc, type 4 and press Enter.
5. With Ortho on pick a point below the first point.

The arc will be tangent to the curve you chose.

Addmore arc segments using the extension option

1. On the Curvemenu, click Arc, and then click Center, Start, Angle.
2. In the command-line, click Extension.
3. For the Select near curve end, pick near the end of the arc you just made.
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4. For the End of arc, snap to the end of the horizontal line.

Draw a tangent, tangent, radius arc

1. On the Curvemenu, click Arc, and then click Tangent, Tangent, Radius.
2. For the First tangent curve pick the lower right side of the top circle.
3. For the Radius type 3 and press Enter.
4. For the Second tangent curve pick the upper right side of the lower circle.
5. Move your cursor and pick when the correct arc is displayed.

6. On the Curvemenu, click Arc, and then click Tangent, Tangent, Radius.
7. For the First tangent curve pick the upper left side of the top circle.
8. For the Radius type 6 and press Enter.
9. For the Second tangent curve pick the lower left side of the lower circle.
10. Move your cursor and pick when the correct arc is displayed.

Make it solid
First you will have to trim the two small circles, then you can extrude the remaining curves.
1. Select the two arcs you just completed.
2. On the Edit menu, click Trim.
3. For the Objects to trim, pick the inner edge of each small circle.

You will be left with a slot.
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4. Use the Circle command to draw the circle concentric to the arc on the right.

5. Select all the curves.
6. On the Solidmenu, click Extrude Planar Curve, and then click Straight.
7. For the Extrusion distance, type 1 and press Enter.

The curves have been extruded and capped.

Practice drawing arcs
It might be helpful to start this model by drawing centerlines first and then lock them or put them on a locked layer.
Use the Line command to construct the centerlines. When you have the centerlines drawn, you can use their
intersection points to draw your arcs and circles.

Exercise 6-12 The Mechanical Arm
1. Start a new model, use the Small Objects - Inches.3dm template.
2. Save as Arc2.
3. Rename layers that are already in the template as follows:

Layer Name New Name

Layer 01 Center

Layer 02 Object Lines

Layer 03 Dimensions

Layer 04 Text
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Create this model using object snaps and the Line, Circle, and Arc commands.

Modeling Skills to Consider
l Start by making the horizontal and vertical construction lines with the use of the Offset command.
l Draw lines and arcs with the Intersection osnap referencing the construction lines.
l Recommended arcs: Center Start Angle, Center Start End, Start End Radius
l DrawOrder commands like BringToFront and SendToBack will keep the object geometry in front of the
construction lines.

Make it solid

1. Type SelClosedCrv. All the curves should be selected.
If not, then figure out where the curve is open with CrvEnd and close the curve with the CloseCrvcommands.

2. On the Solidmenu, click Extrude Planar Curve, and then click Straight.
3. For the Extrusion distance, type 1 and press Enter.
4. The curves have been extruded and capped.
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Ellipses and polygons
You can draw ellipses from the center or by the ends. You can draw polygons from a center point or an edge. You can
draw a rectangle from diagonal corners or by choosing three points.

Exercise 6-13 The Toy Table
1. Start a new model, use the Small Objects - Millimeters.3dm template.
2. Save as Toy.

3. On the Curvemenu, click Rectangle, and then click Corner to Corner.
4. For the First Corner, type -10,-5 and press Enter.
5. For the Length, type 20 and press Enter.
6. For theWidth, type 10 and press Enter.

Draw rectangles from a center point with rounded corners

1. On the Curvemenu, click Rectangle, and then click Center, Corner.
2. Type R, and press Enter to give the rectangle rounded corners.
3. For the Center of rectangle, type 0 and press Enter.
4. For the Length, type 19, and press Enter.
5. For theWidth, type 9, and press Enter.
6. For the Radius, type 1, and press Enter.

If you are creating a rounded rectangle, you can choose to select a point in the corner to set its curvature instead
of typing a radius value.
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To change the type of corner, click Corner in the command-line to toggle from circular rounded corners to conic
rounded corners.

7. Repeat these steps for a second rounded rectangle with a length of 18 and a width of 8 with 0.5 radius corners.

Draw an ellipse from its center and axis ends

1. On the Curvemenu, click Ellipse, and then click From Center.
2. For the Ellipse center, type 0, and press Enter.
3. For the End of first axis, type 4, and press Enter.
4. Hold the Shift key to toggle the Ortho on and pick to the right.
5. For the End of second axis, type 2.5, and press Enter.
6. Pick a point vertical.

Draw a rectangle to locate the polygon centers

1. On the Curvemenu, click Rectangle, and then click Center, Corner.
2. For the Center of rectangle, type 0 and press Enter.
3. For the Length, type 14, and press Enter.
4. For theWidth, type 4, and press Enter.

If you are creating a rounded rectangle, you can choose to select a point in the corner to set its curvature instead
of typing a radius value.
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Draw the 5-sided polygon from its center and radius

1. On the Curvemenu, click Polygon, and then click Center, Radius.
2. Click NumSides in the command-line, type 5, and press Enter to change the number of sides for the polygon.
3. For the Center, pick in the upper left of the 14x4 rectangle to locate the center point for the polygon.
4. For the Corner, type 1.5, and press Enter.
5. Pick a point to orient the polygon.

Draw the 3-sided polygon from its center and radius

1. On the Curvemenu, click Polygon, and then click Center, Radius.
2. Click NumSides in the command-line, type 3, and press Enter to change the number of sides for the polygon.
3. For the Center, pick in the lower left of the 14x4 rectangle to locate the center point for the polygon.
4. For the Corner, type 1.5, and press Enter.
5. Pick a point to orient the polygon.

Draw the 6-sided polygon from its center and radius

1. On the Curvemenu, click Polygon, and then click Center, Radius.
2. Click NumSides in the command-line, type 6, and press Enter to change the number of sides for the polygon.
3. For the Center, pick in the upper right of the 14x4 rectangle to locate the center point for the polygon.
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4. For the Corner, type 1.5, and press Enter.
5. Pick a point to orient the polygon.

Draw the 8-sided polygon from its center and radius

1. On the Curvemenu, click Polygon, and then click Center, Radius.
2. Click NumSides in the command-line, type 8, and press Enter to change the number of sides for the polygon.
3. For the Center, pick in the lower right of the 14x4 rectangle to locate the center point for the polygon.
4. For the Corner, type 1.5, and press Enter.

5. To set the angle, type <22.5 and move the mouse to Pick the proper orientation. This will orient the top and
bottom edges of the octagon to horizontal.

Make the rounded rectangles solid

1. Select the larger and the smaller rounded rectangle.
2. On the Solidmenu, click Extrude Planar Curve, and then click Straight.
3. Drag both down to set the thickness and click or type a value for the thickness.

Use a negative number to extrude down.
The two rounded rectangles are coplanar or in the same plane. Because of this the smaller rounded rectangle is
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removed from the larger one, and the difference is extruded.

Make the rectangle solid

1. Select the rectangle.
2. On the Solidmenu, click Extrude Planar Curve, and then click Straight.
3. Set the Bothsides option to No.
4. Drag it up to set the thickness and click.

Make the ellipse solid

1. Select the ellipse.
2. On the Solidmenu, click Extrude Planar Curve, and then click Straight.
3. Set the Bothsides option to Yes.
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4. Pick to set the thickness.
Make sure the thickness is enough to protrude through both sides of the rectangular solid.

Cut the ellipse solid from the rectangle

1. Select the solid rectangle.
2. On the Solidmenu, click Difference.
3. Select the solid ellipse, and press Enter.

4. Select the solid rectangle and solid extrusion base.
5. On the Solidmenu, click Union.
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Extrude the polygons

1. Select the polygons.
2. On the Solidmenu, click Extrude Planar Curve, and then click Straight.
3. Pick to set the thickness.

Make sure the thickness is enough to protrude through both sides of the rectangular solid.

Cut holes with the solid polygons

1. Select the rectangular solid.
2. On the Solidmenu, click Difference.
3. In the command-line, set DeleteInput=No.
4. For the second set of surfaces or polysurfaces, select the solid polygons, and press Enter.

Holes will be cut, but the objects will remain.

Free-form curves
The use of free-form curves allows more flexibility to create complex shapes.

Exercise 6-14 Practice drawing curves
1. Open the model Curve.3dm.

In this exercise, you will learn how to make a curve by control points, an interpolated curve, and a conic curve to
compare the differences between the three methods.
A common method for creating free-form curves is to draw lines that are accurately measured. Use these lines as
guidelines. Another method for creating free-form curves is to use a background image made from a sketch or a
photograph. In this exercise the guidelines have been created for one of the exercises and an image has been
included for the other exercise.

2. In the Osnap toolbar, check End and Near, clear all others.
Hint: If you click Endwith your right mouse, it will clear all the others.

3. Toggle Ortho and Grid Snap off.

Draw a curve by control points
Control points define the curvature of the curve, but the points are usually not on the curve.
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1. On the Curvemenu, click Free-form, and then click Control Points.
2. For the Start of Curve, snap to the end point of the polyline guideline.
3. For theNext point, snap on the polyline guideline using theNear object snap.
4. Continue to snap to the guideline until you get to the end.
5. Press Enter.

A free-form curve is drawn. The control points, while on the guideline, were not on the curve itself except at the
two ends.

Draw a curve interpolate through points

1. Change to the Interpolated Curve layer.
2. On the Curvemenu, click Free-form, and then click Interpolate Points.
3. For the Start of Curve, snap to the intersection of the center line and the image using theNear object snap.
4. For theNext point, continue to pick points along the edge of the image until you get to the other end, then use

theNear object snap to snap to the intersection of the center line and the image.
5. Press Enter.

A free-form curve is created from specified interpolate points. These points lie on the curve and determine its
curvature.

Draw a conic curve

1. Change to the Conic layer.
2. On the Curvemenu, click Conic.
3. For the Start of conic, snap to the point (1) at the lower left.
4. For the End of conic, snap to the point (2) above and to the right from the previous point.
5. For the Apex, snap to the point (3) in between the previous points.
6. For the Curvature point or rho, pick a point for the desired curvature.

Make the curve into a surface

1. Select the control point curve.
2. On the Surfacemenu, click Revolve.
3. For the Start of revolve axis, snap either end of the curve.
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4. For the End of revolve axis, snap to the other end of the curve.

5. For the Start angle, click FullCircle.

6. Repeat steps 2-5 for the interpolated curve.

Helix and Spiral
Now you make some special curves with theHelix and Spiral commands. These curves can become surfaces or solids
with the Pipe command. Also Helix option AroundCurve can be use to create a Helix around a curve, similar to a
coiled cord.

Exercise 6-15 Helix and spiral curves
Open themodel

1. Open the model Helix-Spiral.3dm.
2. In the Osnap toolbar, check End and Point, clear all others.

Click Endwith your right mouse, to clear all the others.
3. Toggle Ortho and Grid Snap off.

Draw a helix

1. Change to theHelix layer.
2. On the Curvemenu, click Helix.
3. For the Start of axis, in the Perspective viewport, snap to the end of the vertical line (1).
4. For the End of axis, in the Perspective viewport, snap to the end of the vertical line (2).
5. ClickMode in the command-line until it is set toMode=Turns.
6. Click Turns in the command-line.
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7. For theNumber of turns, type 10, and press Enter.

8. Pick the point (3) to the right of the axis line.
A helix with 10 turns and a radius of 20 is created.

Draw a spiral

1. Make the Spiral layer current.
2. On the Curvemenu, click Spiral.
3. For the Start of axis, in the Perspective viewport, snap to the end of the other vertical line (1).
4. For the End of axis, snap to the other end of the same line (2).
5. ClickMode in the command-line until it is set toMode=Pitch.
6. in the command-line, click Pitch.
7. For the Pitch, type 15 and press Enter.
8. In the command-line, click ReverseTwist to set it to Reverse Twist=Yes.

9. For the First radius and start point, snap the point (3).
10. For the Second radius, snap to the other point (4).

A spiral is created with a reverse twist and the distance between each turn is 15.

Draw a helix around a curve

1. Make theHelixAlongCurve layer current.
2. On the Curvemenu, click Helix.
3. In the command-line, click AroundCurve.
4. Select the free-form curve.
5. ClickMode=Turns.
6. Click Turns.
7. Type 25. and press Enter.
8. Click ReverseTwist=No.
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9. For the Radius, type 5, and press Enter.

10. For the Start point, pick a point .
A helix is created around the curve.

11. Undo this helix.

Draw a helix around a curve with History

1. On the Status Bar, click Record History to turn history on for this command.
2. On the Curvemenu, click Helix.
3. In the command-line, click AroundCurve.
4. Select the free-form curve.
5. ClickMode=Turns.
6. Click Turns.
7. Type 25, and press Enter.
8. Click ReverseTwist=No.

9. For the Radius, type 5, and press Enter.
10. For the Start point, pick a point.

A helix is created around the curve.
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Edit the input curve

1. Select the free-form curve.
2. Type PointsOn F10.
3. Pick a few control points and pull the curve into a new shape.

4. Helix will update automatically to the new shape for the free-from curve.

Note: Helix with the AroundCurve and Pipe commands support History.

Draw free-form curves
The use of free-form curves allows more flexibility to create complex shapes. In the following exercise we will draw the
guidelines and free-form curves for a toy screwdriver.

Exercise 6-16 The Toy Screwdriver
1. Start a new model, use the Small Objects - Millimeters.3dm template.
2. Save as Screwdriver.
3. Create Construction and Curve layers.

Make them different colors.
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Create the construction lines

1. Make the Construction layer current.
2. In the Top viewport, draw a Polyline using these dimensions for the guideline.

A good starting point for the Polyline would be -70,0.

Create the curve by control points

1. Make the Curve layer current.
2. Use the Curve command to draw the shape for the toy screwdriver.

Notes about the drawing
(1) Curve from control points.
(2) Two points in a row (ortho) will give you a tangent at the endpoint.
(3) Three or more points in a row (ortho) will allow you to make a portion of the control point curve straight.

3. Save your model.

Make it solid

1. Toggle Grid Snap and Ortho on.
2. Select the curve.
3. On the Surfacemenu, click Revolve.
4. For the Start of revolve axis, snap to the end of the curve.
5. For the End of revolve axis, snap to the other end of the curve.
6. For the Start angle, in the command-line, click FullCircle.
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Add details on your own
Since we haven’t discussed many of the commands that you need to complete this model, use the Command Help
panel for assistance. Following is a list of procedures for one method to finish the model.
1. In the Top viewport, on the Curvemenu, click Line, and then click Single Line.
2. Draw a line that will be used to slice the flat part from the screwdriver blade.

3. Select the line.

4. On the Solidmenu, click Solid Editing Tools, and then clickWirecut.
5. For the Select objects to cut, choose the screwdriver, and press Enter.

6. For the First cut depth point, press Enter.
7. For the Part to cut away, choose the part you want to remove, and press Enter.
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Mirror the construction line

1. In the Top viewport, on the Transformmenu, clickMirror.
Use osnaps to precisely mirror the line to the other side of the screwdriver.

2. Repeat steps 3-6 to complete the other side of the blade.

3. In the Front viewport, draw a Curve along the top of the handle to be used for cutting grooves.
Drawing the curve in the Front viewport, eliminates problems that might arise from having one of the slots along
the seam of the surface.

4. Use the Pipe command (Solid menu > Pipe) to make a pipe surface on the curve.

5. Use the ArrayPolar command (Transform menu > Array > Polar) to make copies of the pipe around the handle.

116



Rhinoceros Level 1 Training Guide

6. Use the BooleanDifference command (Solid menu > Difference) to remove the pipes from the handle.

7. Try using the Render command (Render menu > Render) to make a rendering of the finished screwdriver.
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Chapter 7 - Editing geometry
Once you create objects, you can move and edit them to produce complex and detailed variations.

Fillet
Fillet connects two lines, arcs, circles, or curves extending or trimming them to touch or to join with a circular arc.
Rules to follow when filleting curves:

The curves must be coplanar.
The created fillet is determined by picking on the curve portion to keep.
The radius cannot be so large that it runs past the end of the curve.

Exercise 7-1 Filleting curves
Connect lines that intersect

1. Open the model Fillet.3dm.

2. On the Curvemenu, click Connect Curves.

3. For the first curve, select an outer vertical line.
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4. For the second curve, select an adjacent horizontal line.
The ends of the lines are trimmed to a corner.

5. Press Enter to repeat the command.
6. Connect the other corners, as shown.

Remember to select the part of the line that you want to keep.

Join the connected objects

1. Select the lines you just connected.
2. On the Edit menu, click Join.

The objects are joined together. Curves join only if they touch.

Fillet lines using an arc

1. On the Curvemenu, click Fillet Curves.
2. To change the radius, type 2, and press Enter .
3. In the Command line, set the Join option to Yes.

This option joins the curves as they are filleted.
4. Select an outer vertical line.
5. Select an adjacent horizontal line.

The ends of the lines are trimmed to a radius.
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6. Press Enter to repeat the command.
7. Fillet the other corners as shown.

Fillet the inner lines

1. Press Enter to repeat the command.
2. Set the radius to 1, and press Enter.

This radius will be used for the smaller object.
3. Select an inner vertical line.
4. Select an adjacent horizontal line.
5. Fillet the other corners as shown.

Fillet circles

1. On the Curvemenu, click Fillet Curves.
2. To set the radius, type 3, and press Enter.
3. Select the right edge of a circle.
4. Select the right edge of the other circle.
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5. Repeat the command for the left side of the circles.

6. Select the two fillets you just created.

7. On the Edit menu, click Trim.
8. For the Objects to trim, select the inner edge of each circle.

122



Rhinoceros Level 1 Training Guide

Fillet and join arcs and lines

1. On the Curvemenu, click Fillet Curves.
Set Join=Yes and Trim=Yes.

2. Select the line in the lower left part of the viewport.
Make sure you select the left half of the line.

3. Select the adjacent arc right above the selected line.
4. Repeat this procedure for the two arcs below the line and the arc you just filleted.

Fillet the corners of a closed polyline

1. Select the closed polyline.

2. On the Curvemenu, click Fillet Corners.
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3. For the Fillet radius, type 2, and press Enter.
All corners are filleted at once.

Curve blends
Blending is another method to connect lines, arcs, or curves. There are two blend commands that work on curves:
BlendCrv and ArcBlend.

BlendCrv
The BlendCrv command allows you to adjust the continuity with the input curves and has adjustable endpoints. It also
has options to Join and Trim the result.

Blend two curves with adjustable curve blend

1. On the Curvemenu, Blend Curves, then click Adjustable Curve Blend.
2. Select the upper right curve near the left end, and then select the lower left curve near the right end to blend the

curves.

You will see a preview of the default blend with control points displayed and a dialog.
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3. In the Adjust Curve Blend dialog, check the Join and Trim options.

4. For the Select control point to adjust, select point (1) and drag it further up the curve and click.

5. For the Select control point to adjust, select the point to the right of (2), drag it closer to (2), and click.
6. After making your adjustments, pick the OK button to make the blend.

7. On the Edit menu, click Undo.
8. Repeat Adjust Curve Blendwith Continuity set to G3 and G4. Compare the results. Keep the blend curve you like

the best.

ArcBlend
ArcBlend consists of two arcs with adjustable endpoints and bulge.
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Blend two curves with ArcBlend

1. On the Curvemenu, Blend Curves, then click Arc Blend.
2. Select the curves to blend near the ends that you want to connect.

The two input curves are connected with two arcs.

3. Preview the blend.

4. In the command-line, click the Trim=yes and Join=yes options.
5. Enter to create the blend.

Loft
The Loft command fits a surface through selected profile curves that define the surface shape.
Select the curves in the order in which the surface should pass through them.
Select open curves near the same ends. For closed curves, use the preview to adjust the curve seams.

126



Rhinoceros Level 1 Training Guide

Exercise 7-2 Lofting curves
Make a lofted surface with closed curves
The curves in this model are at two different elevations. You are going to connect the curves at different elevations
with a surface.
1. Change to the Surfaces layer.
2. In the Top viewport select the two squares in the upper left.
3. Make the Perspective viewport current.
4. On the Surfacemenu, click Loft.

The two squares show a seam direction arrow. They should point the same direction.
If the seams don’t line up at corresponding points on the two curves, drag the seam point until it does.

5. Press Enter.
6. In the Loft Options dialog box, click OK.

A surface is generated between the two closed polylines.

7. Repeat the procedure for the rounded squares.
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8. In the Loft Options dialog box, click OK.

Make a lofted surface with open curves

1. Repeat the Loft command for the three open curves.
2. In the Loft Options dialog box, change the Style to Loose, and click Preview.

3. Change the Style to Straight sections, and click Preview.
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4. Change the Style to Normal, and click Preview.
5. For the Cross-section curve options, click Rebuild with, set the number of control points to 12, and click

Preview.

6. Click Refit within, click Preview.
7. Click to Do not simplify, and click OK.

Chamfer
Chamfer connects two curves by extending or trimming them to intersect or to join with a beveled line. Chamfer works
on convergent or intersecting curves.

Exercise 7-3 Chamfer lines
1. Open the model Chamfer.3dm.
2. On the Curvemenu, click Chamfer Curves. 
3. For the Select first curve to chamfer, to set the distances, type 1,1 and press Enter.
4. Set Join=Yes.
5. Select one of the inner vertical lines.
6. Select an adjacent horizontal line.

7. Continue creating chamfers on all of the corners.
8. Press Enter to repeat the command.
9. For the Select first curve to chamfer, type 3,2, and press Enter.
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10. Select one of the outer horizontal lines.
11. Select an adjacent vertical line.

The first value is the distance from the intersection of the two curves on first curve selected, the second value is
the distance from the intersection of the two curves on the second line selected.

Turn the curves into surfaces

1. Make the Surfaces layer current.
2. On the Edit menu, click Select Objects, and then click Curves.
3. On the Surfacemenu, click Loft.

4. Adjust the seam line if necessary, press Enter.
5. In the Loft Options dialog box, click OK.

A surface is generated between the two chamfered rectangles.
6. Save your model.
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Exercise 7-4 Practice with Fillet and Chamfer
1. Open the model Filletex.3dm.

2. Use Fillet and Chamfer to edit the drawing as shown.
All fillets and rounds use a radius of 0.5 units.

Make it solid

1. On the Edit menu, click Select Objects, and then click Curves.
2. On the Solidmenu, click Extrude Planar Curve and then click Straight.
3. For the Extrusion distance, type 1 and press Enter.
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Fillet the top edge of the solid

1. On the Solidmenu, click Fillet Edge, and then click Fillet Edge.
2. Change the Current radius to 0.25.
3. Select the edges around the top of the solid, and press Enter.

Transform Commands: Move
Use theMove command to move objects without changing orientation or size

Exercise 7-5 Transform Commands
1. Open the modelMove.3dm.
2. Turn off both Ortho and Grid Snap so you can move objects freely.
3. Turn Cen object snap on.

Move using object snaps for placement

1. In the Top viewport, select the small circle at the bottom left side.
2. On the Transformmenu, clickMove.
3. For the Point to move from, snap to the center of the small circle.
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4. For the Point to move to, snap to the center of the arc at the lower left of the object.

Move using absolute coordinates

1. On the Edit menu, click Select Objects, and then click Curves.
2. On the Transformmenu, clickMove.
3. For the Point to move from, snap to the end of the line at the lower part of the object.
4. For the Point to move to, type 0,0, and press Enter.

The end of the line is exactly at point 0,0 in the Top viewport.

Move using relative coordinates

1. Select the large slotted circle in the middle of the object.
You will move the slotted circle relative to the part.

2. On the Transformmenu, clickMove.
3. In the Top viewport, pick any point.

It is usually better if you pick near the object you are going to move.
4. For the Point to move to, type r0,-.25 and press Enter.

The circle moved down .25 units.
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Copy
The Copy command duplicates selected objects and places them in a new location. The command can repeat to create
more than one copy in the same command sequence.

Copy using object snaps for placement

1. Select the small circle at the lower left of the object.
2. On the Transformmenu, click Copy.
3. For the Point to copy from, snap to the center of the small circle.

4. For the Point to copy to, snap to the center of the arc at the upper left of the object.
5. Pick to place the object, and press Enter.

Makemultiple copies

1. Select the small circle at the lower left of the object.
2. On the Transformmenu, click Copy.
3. For the Point to copy from, snap to the center of the small circle.
4. For the Point to copy to, begin picking points on the screen.

Each time you pick, a circle will be copied to that location.

5. Press Enter to end the command.
6. Undo the multiple copies.

Undo and Redo
If you make a mistake or do not like the results of a command, use Undo. If you decide you want those undone results
back after all, use Redo command. Redo restores the last thing undone.
If a command has an Undo option, type U to enter it, or click Undo on the command prompt.
You cannot use the Undo command after you exit the modeling session or open a different model.

Rotate
Use Rotate to move objects in a circular motion around a base point. For precise rotation, enter a number of degrees to
rotate. Positive numbers rotate counterclockwise; negative numbers rotate clockwise.
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Rotate objects

1. Select the large slotted circle in the middle of the object.
2. On the Transformmenu, click Rotate.
3. For the Center of rotation, snap to the center of the slotted circle.

4. For the Angle, type -28 and press Enter.

Group
Grouping objects allows all members of the group to be selected as one. You can then apply commands to the entire
group.

Group selected objects

1. Select the two circles that you placed.
2. On the Edit menu, click Groups, and then click Group.
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Add objects to a group

1. Select the polyline on the left, the original circle, and the slotted circle in the center.
2. On the Edit menu, click Groups, and then click Add To Group. 
3. For the Select Group, select one of the circles in the previous group.

The objects are part of the group.

Remove an object from a group

1. On the Edit menu, click Groups, and then click Remove From Group. 
2. For the Select objects to remove from group, select the slotted circle, press Enter.

The slotted circle is removed from the group.

Mirror
Mirror creates a copy of the objects flipped over a specified axis on the construction plane.

Mirror objects

1. Select the group.
2. On the Transformmenu, clickMirror. 
3. For the Start of mirror plane type 0,0, or snap to the end of the line at the lower right of the part.
4. Toggle Ortho on, and pick directly above the previous point.

Since you mirrored a group, in addition to having a mirror image copy, you also have two groups.

Join
Join unites curves that meet at a common end, making a single curve. Join can unite curves that do not touch, if you
select them after the command has started. As you select non-touching curves, a dialog box asks if you want to fill the
gap.
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Join objects

1. Select the two polylines.
2. On the Edit menu, click Join.

Scale
Scale changes the size of existing objects without changing their shape. This command scales three-dimensional
objects equally along all three axes. There are also two-dimensional, one-dimensional, and non-uniform scale
commands.

Scale objects

1. On the Edit menu, click Select Objects, and then click Curves.
2. On the Transformmenu, click Scale, and then click Scale 2-D.
3. For the Origin point, type 0, and press Enter.
4. For the Scale factor, type .75, and press Enter.

The whole part scaled to 75 percent of its original size.

Scale2D using the reference point option

1. Select the slotted circle.
2. On the Transformmenu, click Scale, and then click Scale 2-D.
3. For the Origin point, snap to the center of the slotted circle.
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4. For the First reference point, snap to the quadrant of the slotted circle.
The radius of the slotted circle is the reference for the scale factor.

5. For the Second reference point, type 1.375 and press Enter.
The slotted circle now has a larger radius of 1.375.

Make it solid

1. On the Edit menu, click Select Objects, and then click Curves.
2. On the Solidmenu, click Extrude Planar Curve, and then click Straight.
3. For the Extrusion distance, type 1, and press Enter.

Scale in 3-D

1. On the Edit menu, click Select Objects, and then click Polysurfaces.
2. On the Transformmenu, click Scale, and then click Scale 3-D.
3. For the Origin point type 0, and press Enter.
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4. For the Scale factor type 1.5, and press Enter.
The solid is larger in every dimension.

Scale in one dimension

1. On the Edit menu, click Select Objects, and then click Polysurfaces.
2. On the Transformmenu, click Scale, and then click Scale 1-D. 
3. For the Base point, type 0, and press Enter.
4. For the First reference point, snap to the End point at the top of the part.

5. For the Second reference point, type .5, and press Enter.
The object is half as thick.

More on gumball
Gumball displays a widget on a selected object, which is used to facilitate the direct editing. The gumball provides
move, scale, and rotate transformations around the gumball origin.

Click the Gumball pane on the Status Bar.

Exercise 7-6 Gumball menu
In this exercise, we will drag gumball arrows to move an object. Three direction arrows: x (red), y (green), and z (blue)
control the direction.
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1. Open the model Gumball.3dm.

2. In the Front viewport, select the cone.

3. Right-click and hold on any part of the Gumball widget.

When the page icon appears, release the right mouse button. The Gumball pop-up menu will appear.
4. Click Relocate Gumball.
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5. With the End point object snap, pick the top of the cone, and press Enter to complete the relocation of the
Gumball.

The gumball origin is now located at top of cone. All editing is in reference to the new origin.

6. Click the Blue arc.
A text edit box will appear. You can type a rotation angle into this box to rotate an object an exact angle.

7. Type 90 and press Enter.
The cone is rotated exactly 90 degrees in a counter clockwise direction.

Exercise 7-7 The 3D Puzzle
Use the Gumball to orient the puzzle pieces in 3D.
For additional practice, also use Rotate3D and Orient3Pt to orient some of the puzzle pieces. Use the Help for details
about these commands. Discuss how these commands are different than using the Gumball.
1. In the Layer panel, do the following:

Make Default the current layer.
Turn off the Cone layer.
Turn on the parent Puzzle layer.
Note: The Puzzle layer contains sub-layers. Turning on or off the parent Puzzle layer, affects the sub-layers
visibility, too.

141



Rhinoceros Level 1 Training Guide

(1) Parent layer; (2) Sublayers.

2. On the View menu, select Zoom and Zoom Extents All (Alt+Ctrl+E) to see the puzzle pieces.
3. On the Status Bar, turn Ortho and Grid Snap on. Next right-click Grid Snap and click Settings.
4. For the Snap Spacing, type a value of 0 . 05.
5. Click OK.
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Reposition the puzzle pieces

1. In the Perspective viewport, select the red puzzle Piece 1.

2. Right-click and hold on any part of the Gumball widget.

3. When the page icon appears, release the right mouse button. The Gumball pop-up menu will appear.
4. Click Relocate Gumball.

5. With the End point object snap, pick lower left corner of the piece and press Enter to complete the relocation of
the Gumball.
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6. In the Front viewport, click and drag along blue arc to rotate pieces to 90 degrees.
Note: Hold the Shift key down to temporarily toggle the Ortho setting.

Orient 3Point
The Orient3Pt command moves or copies and rotates objects using three reference and three target points.
1. Undo the previous transformation with Gumball.
2. Again, in the Perspective viewport, select the red puzzle Piece 1.

3. On Transformmenu, select Orient , then 3Points.
4. Pick Reference points 1, 2 and 3 as shown image below.

5. Pick Targets points 1, 2 and 3 as shown image below.
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6. Now the Piece 1 is transformed to the new location and orientaion.

Transforming the other puzzle pieces
You choose how to transform puzzle Pieces 3, 5, 6. You may use Gumball or Orient3Pt.
1. Movewith Gumball.
2. Relocate Gumball origin.
3. Rotatewith Gumball.

Use the appropriate viewport for rotation.
Hint: In the Front viewport, rotate Piece 3. In the Right viewport, rotate Piece 5 and Piece 6.

Puzzle Piece 3
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Puzzle Piece 5

Puzzle Piece 6

4. Now use gumball to move the final Piece 4 into position on the top of the box using the Axis plane indicator.
Drag by the plane icon to constrain movement to that plane.
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Trim
Trim cuts and deletes portions of an object to make it end precisely at its intersection with another object.
In this exercise, we will pre-select the cutting objects.

Exercise 7-8 Trim curves
1. Open the model Trim-Split.3dm.
2. Toggle Gumball off.
3. In the Top viewport, ZoomWindow around the grid in the lower left corner.
4. For the cutting objects, select the two outside vertical lines in the grid.

5. On the Edit menu, click Trim.
6. Select each of the horizontal lines at their left and right ends.

The lines are trimmed to the cutting edges.
7. Press Enter.
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Trim surfaces

1. In the Perspective viewport, ZoomWindow around a sphere and surface.
2. In the Perspective viewport, select the surface that intersects the sphere as the cutting object.

3. On the Edit menu, click Trim.
4. For the Object to trim, pick the right side of the sphere.

The sphere is trimmed at the surface.
5. Press Enter.

Split
The Split command divides objects into parts using other objects as cutters. The Split command breaks the object
where it intersects the cutting object but does not delete anything.
In this exercise, we will pre-select the object or objects we are going to split.
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Split a curve

1. In the Top viewport, ZoomWindow around the closed curve in the lower right corner.
2. Select the closed curve.

3. On the Edit menu, click Split.
4. Select the lines, and press Enter.

The curve is separated into four curves precisely where the lines intersect it.

Split a surface

1. On the View menu, click Zoom, and then click Zoom Extents All.
2. Select the sphere (green).

3. On the Edit menu, click Split.
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4. Select the extrusion surface (gold), and press Enter.

The sphere is separated into two pieces where the surface intersects it

Extend
The Extend command lengthens an object to make it end precisely at its intersection with another object or you can
lengthen an object when there is no intersection.

Exercise 7-9 Extend curves
1. Open the model Extend .3dm.
2. On the Curvemenu, click Extend Curve, and then click Extend Curve.
3. For the Select boundary objects, select the line at the left and the curve at the right.

4. To close the selection of boundary curves, press Enter.
5. For the Select curve to extend, in the Command line, click set Type=Line.

150



Rhinoceros Level 1 Training Guide

6. Select both ends of the top line and the left end of two curves.
The curve and line extend to touch the boundary. The extension is a straight segment.

7. For the Select curve to extend, in the Command line, set Type=Arc.
8. Select the right end of the middle curve.

The curve extends with a tangent arc to touch the boundary.

9. For the Select curve to extend, in the Command line, set Type=Smooth.
10. Select the right side of the bottom curve.

The curve extends with a curvature (G2) continuous extension to touch the boundary.
11. Press Enter to end the command.

Extend with a set extension length

1. On the Curvemenu, click Extend Curve, and then click Extend Curve.
2. At the Select boundary objects or enter extension length... prompt, type 4, and press Enter.
3. In the Command line, set Type=Smooth.
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4. Select the upper end of the curve on the right.
The curve extends exactly four units.

5. Press Enter to end the command.

Extend a curve dynamically

1. On the Curvemenu, click Extend Curve, and then click Extend Curve.
2. At the Select boundary objects... prompt, press Enter for a dynamic extension.
3. In the Command line, set Type=Smooth.
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4. Select the lower end of the curve on the right.

The curve continues with the cursor.

5. On the Command line, click ToPoint.
6. Click to end the extension at a point.

7. Press Enter to end the command.
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Extend to a surface

1. On the Curvemenu, click Extend Curve, and then click Extend Curve.
2. For the boundary objects, select the cylinder on the left and the surface on the right.
3. Press Enter.

4. Change the type to Type=Arc.
5. Select both ends of the line and the curve.

The curves extend to the surface of the cylinder and to the surface.

Offset
The Offset command creates an object parallel or concentric to another object. Use Offset to create specialized copies,
such as parallel lines, concentric circles, and concentric arcs, through specified points or at pre-set distances.

Exercise 7-10 Offset curves
1. Open the model Offset.3dm.
2. Maximize the Top viewport.
3. Select the line.
4. On the Curvemenu, click Offset, then click Offset Curve.
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5. For the Side to offset, pick the upper right side of the line.

A parallel line is created.

Offset with the through point option

1. Turn on the End object snap.
2. Select the circle.
3. On the Curvemenu, click Offset, and then click Offset Curve.
4. For the Side to offset, in the Command line, click Throughpoint.
5. For the Throughpoint, snap to the lower right end of the line you offset.

A concentric circle is created that goes through the endpoint of the line.

Offset a polyline with sharp corners

1. Select the polyline.
2. On the Curvemenu, click Offset, then click Offset Curve.
3. To change the offset distance, type 1, and press Enter .
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4. For the Side to offset, pick inside the polyline.
The polyline is offset with sharp corners.

Offset a polyline with round corners

1. Select the polyline.
2. On the Curvemenu, click Offset, then click Offset Curve.
3. In the Command line, set Corner=Round.
4. Pick outside the polyline.

The polyline is offset, but the corners are rounded with arcs.
Other corner options include Smooth and Chamfer. Smooth makes a tangent curve that is smoother than an arc
at each vertex, while Chamfer makes a bevel at each vertex.

Offset a curve on bothsides

1. Select the free-form curve.
2. On the Curvemenu, click Offset, then click Offset Curve.
3. In the Command line, click Bothsides.
4. For Side to offset, pick either side of the curve.

Free-form curves are created on both sides of the selected curve.
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5. Repeat this process on the arc.
Concentric arcs are created on both sides of the selected arc.

6. From the Edit menu, click Undo.

Offset a curve on bothsides with caps

1. Select the arc.
2. On the Curvemenu, click Offset, then click Offset Curve.
3. In the Command line, click Cap, and then click Round.
4. Click Bothsides in the Command line.
5. For Side to offset, pick either side of the curve.

Concentric arcs are created on both sides of the selected arc with a rounded end piece connecting the offset
curves.
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Offset a surface

1. Select one of the open surfaces.
2. On the Surfacemenu, click Offset Surface.
3. Place your cursor over the surface and click to change the offset direction.

4. Press Enter.
The surface is offset in the direction of the arrows.

Offset a surface to a solid

1. Select the other open surface.
2. On the Surfacemenu, click Offset Surface.
3. If necessary, click the surface to change the normal direction.
4. In the Command line, click the Solid option.
5. Press Enter to create the offset surface and the surfaces needed to make the solid.

Offset a polysurface
Offsetting polysurfaces may not give the desired results. In this example we will demonstrate some of the problems.
1. Select the cylinder.
2. On the Surfacemenu, click Offset Surface.

The normals on a closed polysurface will always point to the outside.
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3. In the Command line, click Distance, and type 1.
4. Set Corners=Round, and press Enter.

Each surface of the polysurface is offset as a separate surface, then extended or filleted, and joined together as a
solid.

5. Undo. Repeat the command and set Corners=Sharp.
What you have in both cases is a solid inside of a solid.
Hint: Select the object, and on the Properties panel, click the Details button, to confirm that offset polysurface is
a closed solid.
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Shell a polysurface

1. Undo.
2. Select the Cylinder.
3. In the Command line, type Shell.
4. For Select faces to remove pick the top of the cylinder and press Enter.

The surface is removed and the remainder is offset inward, using the outer parts of the removed surface to join
the inner and outer parts.

Array
Use the Array commands to make multiple copies of selected objects.
Array Rectangular copies objects in rows (x direction), columns (y direction) and levels (z direction).
Array Polar copies objects in a circle around a center point.

Exercise 7-11 Array
Create a polar array

1. Open the model Array.3dm.
2. In the Top viewport, select the small circle.
3. On the Transformmenu, click Array, and then click Polar.
4. For the Center of polar array, snap to the center of the large circle.

5. For theNumber of items, type 10 and press Enter.
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6. For the Angle to fill, check to see if it is set to 360, press Enter.
The small circle is arrayed around the larger one.

7. Save your model.
Note: You must include the original and the copies as the number in the array.

Make the shape for the column

1. Window select the circles.
2. On the Curvemenu, click Curve Edit Tools, then click Curve Boolean.
3. For the Regions to keep, click inside the large curve.

The inside of the circle, excluding the smaller circles is shaded.

4. In the Command line, click DeleteInput, click All, and press Enter.
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Make the column

1. Select the new polycurve.
2. On the Solidmenu, click Extrude Planar Curve, then click Straight.
3. For the Extrusion distance, type 14, press Enter.

Make a partial polar array

1. Turn on the Base layer.
2. Select the column base, the column, and the column cap.
3. On the Edit menu, click Groups, then click Group.

The three parts are grouped into one.
4. Select the group.
5. On the Transformmenu, click Array, and then click Polar.
6. For the Center of polar array, type 0, press Enter.
7. For theNumber of items, type 6 and press Enter.

8. For the Angle to fill, type -180, press Enter.
Six columns are arrayed to fill 180 degrees in the negative direction.

Rectangular array
Array Rectangular makes rows and columns of objects.

Create a rectangular array

1. Select the same column group as the last exercise.
2. On the Transformmenu, click Array, then click Rectangular.
3. For theNumber in X direction, type 4, press Enter.
4. For theNumber in Y direction, type 4, press Enter.
5. For theNumber in Z direction, type 1, press Enter.
6. For the X spacing, type 12 and press Enter.

162



Rhinoceros Level 1 Training Guide

7. For the Y spacing, type 12 and press Enter.
The columns are visible.

8. At this stage you can change the number in each direction or the spacing.
If you need to make a change, click the option in the Command line and then make the adjustment.

9. Press Enter to accept.
10. Turn on all the layers to see the result.

On your own: Experiment with additional array commands like Array Linear and Along Curve.

Exercise 7-12 Practice - The Gasket
In all these practice models, you should separate the geometry into respective layers like:
Construction Lines, Object Lines, Dimensions, and Text.
Hint: The Curve Boolean command can help clean up this geometry with just a few picks.
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1. Start a new model, use the Small Objects - Inches.3dm template. Save as Gasket1.

2. Use Circle, Arc, Trim, Fillet, and Join to create the part shown.

3. On the Solidmenu, click Extrude Planar Curve, and then click Straight to create the 3-D part.
4. Set the extrusion thickness to 0.125.

Exercise 7-13 Practice - The Cam
1. Start a new model, use the Small Objects - Inches.3dm template.
2. Save as Cam.
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3. Use Circle, Arc, Line, Trim, Join, and Polar Array to draw the part shown.

4. On the Solidmenu, click Extrude Planar Curve, and then click Straight to create the 3-D part.
5. Set the extrusion thickness to 0.5.

Exercise 7-14 Practice - The Link
1. Start a new model, use the Small Objects - Inches.3dm template. Save as Link.

2. Use Line, Arc, Trim, Offset, Join, Fillet and Circle to draw the part shown.

3. On the Solidmenu, click Extrude Planar Curve, and then click Straight to create the 3-D part.
4. Set the extrusion thickness to 0.5.
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Chapter 8 - Point editing
You can display the control points or the edit points of an object so that you can adjust the shape of an object, rather
than manipulating the whole object at once. That is called control point editing.
You can use point editing on meshes, curves, and surfaces, but not on polysurfaces or solids.
Rhino’s curves are represented internally with non-uniform rational B-splines (NURBS). Three things determine the
shape of a NURBS curve:

l A list of points called control points
l Degree
l A list of numbers called knots

If you change any of these things, it changes the shape of the curve.

About control points, edit points, and knots
l Control points do not have to be on the curve.
l Edit points are always on the curve.
l Rhino lets you edit curves and surfaces by moving control points and edit points.
l Knots are parameters (that is, numbers, not points).
l Adding knots to a curve or surface lets you control the movement of the object during control-point editing.

Control point editing
In this exercise we are going to experiment with moving control points. Understanding how curves and lines react
when control points are moved is very important to understanding NURBS modeling.

Exercise 8-1 Edit control points
1. Open the model Control Point.3dm.

There are pairs of curves with different degrees in the model.
2. Turn Ortho and Grid Snap on.
3. On the Edit menu, click Select Objects, and then click Curves.
4. On the Edit menu, click Control Points, and then click Control Points On F10.

5. In the Front viewport, select the middle row of points.
6. Drag the points vertically 8 units.

Notice that the degree-1 curves (polylines) come to a point at each moved control point and the control points
are exactly on the curve.
The degree-3 and degree-5 curves are smooth. The degree-3 curves have more curvature than the degree-5
curves
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Individual points have more influence on a small area of the curve with degree-3 curves, while points have
greater influence over a wider span of the curve with degree-5 curves.

Check the differences

1. Turn off the control points F11 or the Esc key.
2. Turn the Plane layer on.
3. Select the curves and the plane.
4. On the Curvemenu, click Curve from objects, then click Intersection.

Lines are shown on the surface showing the intersections.

5. Note the difference between the degree 3 and 5 curves.
The higher the degree, the greater the influence over the span of a curve, when you edit control points.
As you can see by the illustration, editing one point out of 11, on the degree-5 curve, influenced most of the
curve. The degree-3 curve has a sharper curvature, because the influence of one point takes place over a shorter
span.

6. Undo twice until you get back to seeing just the curves.
The intersections will disappear, and the Plane layer is off.
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Continue editing control points

1. In the Front viewport, select the two rows of points that are three points on either side of the center.
2. Drag the points vertically 5 units.
3. Turn off the control points F11 or Esc.

When a curve or polyline bends sharply at a point, it is called a kink.
If you create a surface from a curve that has a kink, it will have a seam at the kink.

Make a lofted surface

1. Select the curves.
2. On the Surfacemenu, click Loft.
3. In the Loft options dialog box, click OK.

Because the degree-1 curves were included in the loft, a polysurface is created with a seam at each kink.
4. Select the surface.
5. Turn on the control points F10.

The points do not turn on and the following message is displayed in the Command line: "Cannot turn on points
for polysurfaces."

6. Undo the loft.
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Change the polylines into curves without kinks

1. Select both polylines.
2. On the Edit menu, click Rebuild.
3. In the Rebuild dialog box set the Point count to 11 and the Degree to 3, and click OK.

A degree-3 curve cannot have kinks. The curve smooths and changes shape.

Loft a surface over the curves

1. Select all of the curves.
2. On the Surfacemenu, click Loft.
3. In the Loft Options dialog box, click OK.

A single surface appears over the curves. The surface can be edited with control points.
4. Select the surface.
5. Turn on the control points F10.

Note that there are more control points than what you started with. Rhino adds control points to make the
surface conform the original curves.

Rebuild a surface

1. Turn off the control points F11 or Esc.
2. Select the surface.
3. On the Edit menu, click Rebuild.
4. In the Rebuild Surface dialog, change the point count to 8 in U direction and 13 in the V direction.
5. Change the Degree to 3 for both U and V.
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6. Check Delete input.
The surface is smoother with fewer control points.

Nudge Controls
Another method to move control points and other geometry in a more subtle way is to use the Nudge keys. The nudge
keys are the arrow keys on the keyboard activated with the Alt, Alt+Ctrl, and Alt+Shift keys.

Exercise 8-2 Change the nudge settings
1. On the Toolsmenu, click Options.
2. In the Options dialog box, on theModeling Aids page, note theNudge settings.

Any of these values can be changed.

Use Nudge keys to move control points

1. In the Front viewport, select one or two control points.
2. Hold the Alt key down, and press an Arrow key.

The control points move (nudge) a small amount.
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3. Hold the Alt and the Ctrl key down and press another Arrow key.
The movement is much smaller.

4. Hold the Alt and the Shift key down and press another Arrow key.
The movement is magnified.

5. Hold the Alt and press the Page Up or Page Down key to nudge in the construction plane z-direction.

Use Set X, Y, Z coordinates to adjust points

1. Select all the points in one row along the top of the surface.
2. On the Transformmenu, click Set X, Y, Z coordinates.
3. In the Set Points dialog box, check Set Z, and clear the Set X and Set Y check boxes.

4. In the Right viewport, move the points and click.
The control points are aligned in the world z-direction.

5. Repeat this on some of the other rows of points.

Use Gumball to move control points
You can use the gumball to move, rotate and scale control points, in a very similar way as you were able to transform
objects. Let’s look at moving the control points with the gumball.
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1. Select the surface.
2. On the Edit menu, select Control Points, and then Control Points On F10.

3. Turn on gumball, and select the points in one row along the top of the surface.

4. In the Front viewport, window select points as shown.

The points along the top row are selected.

5. In the Front viewport, select the green gumball arrow, drag up and pick.
The points move up.
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6. In the Front viewport, select the red gumball arrow, drag to the right and pick.
The points move to the right.

7. In the Front viewport, pick the green gumball arrow, drag down and pick.
The points move in the top rows move down.

8. Press Esc to unselect points.
9. Use the gumball for control point editing whenever possible in the next few exercises.

Exercise 8-3 Practice with curves and control point editing
The Glass model contains a picture frame of a glass profile. Use the Curve command to trace the profile and revolve
into a surface. If the curve and the axis of rotation form a closed area, then the result of the revolution will be closed. If
the curve that you revolve is smooth with no kinks, then the result of the revolution will be a closed surface, not a
closed polysurface. This is important if you want to control point edit the surface into a fluted shape.

1. Open model Glass.3dm.
Glass model is in Inch units. If you prefer MM, then change the Model units in Options off the Units page. When
prompted to scale the model by the conversion factor of 25.4, pick yes. Now you may continue with this exercise
in your preferred unit. (Discuss options with your instructor or reference the Help.)

2. Make the Profile_curve layer current.
3. Use the Curve command to create a half cross-section of the glass. (The red center line marks the center of the

glass.)
4. Use control point editing to adjust the curve until you get the desired shape.
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Make it 3-D

1. Select the curve you created.
2. On the Surfacemenu, click Revolve.
3. For the Start of revolve axis, pick one end of the curve.

4. For the End of revolve axis, pick the other end of the curve.
5. For the Start Angle, click Deformable=Yes.

This changes the structure of the revolved surface to make it easier to deform without creating kinks.
6. For the Start Angle, click FullCircle.

7. Save your model.
8. Experiment with adjusting the control points to see what happens.
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9. From the Edit menu, Undo to return the glass to the symedtrical shape.

Fluted The Glass

1. To flute the glass you just made, turn on the control points for the surface.
2. In the Top viewport, with the Lasso command, select every other radial grouping of control points. Enter at the

end of each grouping, and Enter to repeat the Lasso command. This will keep the commands repeating efficiently.

3. Pick Scale 2D from the Transformmenu.
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4. At the Base Point prompt, in the Top viewport, pick at the center of the glass with the End point osnap.

5. At the Scale factor or first reference point prompt, pick off to the right or left.
Hint: If Ortho is off, hold down the Shift key while picking.

Isocurves will appear in a star shape while picking.
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6. View the model in Shaded and Ghosted display modes.

Shaded and Ghosted display modes.
7. Save your model.
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Chapter 9 - Creating Deformable Shapes
When building models in Rhino, you should first determine which methods should be used for each part of the project.
There are two basic ways to model in Rhino—free-form and accurate. Some models require more attention to exact
dimensions because they might have to be manufactured or parts may have to fit together. Sometimes it is the shape
of the object, not the accuracy that is important. These techniques can be merged together to create accurate, free-
form shapes. This tutorial focuses only on the free-form, squishy aspect. The exact size and placement of the objects is
not critical. The overall form is the main objective.

Exercise 9-1 The Rubber Duck
This exercise shows:

l Simple surface creation
l Surface rebuilding
l Control point editing
l Curve creation ( drawing, projecting )
l Splitting surfaces with curves and surfaces
l Blending between two surfaces
l Lighting and rendering

When you model the rubber ducky, you will use similar modeling techniques for the head and the body.
You will create spheres that will be deformed to make the shapes.
If you need to know more about control points and surfaces, search the Rhino Help index for “control points.”

Start themodel

1. Start a new model using the Small Objects - Millimeters.3dm template.
2. Save as Duck.
3. You can use layers to separate your parts, but for this model, it is not necessary.

Create the body and head shapes
The body and head of the ducky are created by modifying two spheres. The size and placement of the spheres does not
need to be exact.

Create the basic shapes

1. On the Solidmenu, click Sphere, and then click Center, Radius.
2. In the Front viewport, pick a point to specify the center of the sphere.

Or you can type 0 and Enter to locate the center of the sphere at the origin of the Front construction plane.
3. Next, in the Front viewport, to specify the sphere radius, pick a second point to the left of the center point.

This will locate the seam of the surface to the left side of the sphere. Later in the exercise when trimming the neck
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and beak, you will see the advantages.
Note Toggle Ortho on with the Shift key.

4. Repeat this procedure for the second sphere, also pick to the left of the center point.
Note: The seam will appear thicker than the isocurves. Verify the seam location to the left side of the sphere.

Make the spheres deformable

1. Select both spheres.

2. On the Edit menu, click Rebuild.
3. In the Rebuild Surface dialog box, change the Point Count to 8 for both U and V.
4. Change the Degree to 3 for both U and V.
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5. Check Delete Input, clear Current Layer, and click OK.

The spheres are now deformable. Having more control points allows more control over smaller parts of the
surface. A degree-three surface will have a smoother shape when deformed.

Modify the body shape

1. Select the large sphere.
2. On the Edit menu, click Control Points, and then click Control Points On.
3. In the Front viewport select the control points near the bottom of the sphere.

To window select, drag a rectangle left to right around the control points.
4. On the Transformmenu, click Set X, Y, Z coordinates.
5. In the Set Points dialog box check Set Z, and Align toWorld as illustrated above.

181



Rhinoceros Level 1 Training Guide

6. Drag the selected control points up, snap to one of the upper most selected points.
This aligns all of the selected control points to the same world z-value (vertical in Front viewport), flattening the
surface.

Scale the sphere shape

1. Turn off control points and select the body shape.
2. On the Transformmenu, click Scale, and then click Scale 1-D.
3. For the Base point, pick a point near the center of the body sphere.
4. For the First reference point, with Ortho on, in the Front viewport, pick a point to the right.
5. For the Second reference point, in the Front viewport, pick a point farther to the right.

The body is shaped like an ellipsoid.
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Reshape the chest and tail

1. Turn the control points on F10.
2. Window select the control points at the top right of the body, and drag them to the right to bulge out the chest.

3. Window select the control points at the upper left edge of the body, and drag them up to form the tail.
Notice in the Top viewport that two control points are selected, though in the Front viewport, it looks like only
one is selected. This is because the second control point is directly behind the one you can see in the Front
viewport.

Add control for further shaping the tail
Before we start to edit the tail further, we will add an additional set of points to the tail portion of the body.
1. On the Edit menu, click Control Points, and then click Insert Knot.
2. For the Surface for knot insertion, pick the body surface.

A surface isocurve will be displayed. It will either be in the U or the V direction.
3. Flip the direction if necessary.
4. For the Point on surface to add knot, pick a point midway between the tail and the center of the body.

5. Press Enter to end the command.
A new set of isocurves and a new row of points have been added to the body.
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6. Window select the control points at the upper part of the new isocurve, and drag them down to further form the
tail and the body.

7. Adjust the control points further until you get the shape you want.

8. Save your model.

Create the head

1. In the Front viewport, select the small sphere.
2. Turn Control Points On F10.
3. Select the control points on the right side and drag them to begin forming the bill.
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4. Window select the control points further back on the same isocurve and drag them forward to widen the bill.
There may be multiple control points in the same location in this view.

5. Window select control points at the top of the bill and drag them down as shown.
6. Press F11 or Esc to turn control points off.
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Separate the bill from the head
For the final rendering, the bill must be a different color from the body. To do this, they must be separate surfaces. You
can split a single surface into multiple surfaces many ways. The following technique is just one.

Split a surface with a curve

1. In the Front viewport create a curve that looks like the illustration.

2. Select the head.
3. On the Edit menu, click Split.
4. For the Cutting object, pick the curve you just created, and press Enter.

The bill and head are now separate surfaces. This will allow you to render the surfaces with different colors.

Create the duck’s neck
The ducky needs a neck. You will first make an edge on the surface of the head and a corresponding edge on the
surface of the body so you can create a blended surface between the two edges.
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Trim the head and the body

1. Draw a Line across the bottom of the head.
2. Copy the line and adjust it so that it intersects the top of the body as illustrated on the right.

It is important that the lines intersect the bottom of the head and the body completely.

3. Select the lines.
4. On the Edit menu, click Trim.
5. For the Object to trim, pick the bottom of the head and the top of the body.

The bottom of the head and the top of the body is trimmed.

6. Save your model.
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Create the blend surface between the head and body

1. On the Surfacemenu, click Blend Surface.
2. For the Segment for first edge, pick the edge curve at the bottom of the head.
3. For the Segment for second edge, pick the edge curve at the top of the hole in the body.

4. Make any adjustments you desire by moving the slider bars in the dialog box, click OK when finished.
If you click the lock icon at the left of the sliders the surface adjustments are symmetrical.

5. Save your model. 
Note: In Rhino 6, the BlendSrf command supports History.
Undo the last BlendSrf, and redo with Record History in the Status bar enabled. A blend that is created with
Record History enabled will react when the input surfaces are moved or rotated. This can be helpful in choosing
the best distance for the head of the duck to be located from the body
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Join the parts

1. Select the body the blend surface and the back of the head.
2. On the Edit menu, click Join.

The three surfaces are joined into one. The bill is left separate for rendering purposes.

Make an eye
For this part of the exercise we will make a curve and revolve it to get the surfaces for the eye.
1. ToggleGrid Snap on to assist with the point placement.
2. On the Curvemenu, click Conic.
3. In the Front or Right viewport make a conic curve as illustrated.

Start of Conic (1), End of Conic (2), Apex (3), Curvature point.

4. Use SmartTrack, with Point, End and Int object snaps on, to help place the two points as illustrated.
These points will be used for placement of the eye on the head.

5. On the Curvemenu, click Point Object, then clickMultiple Points.
6. For the Location of point object, hover over the end of the conic until the point activates, drag you cursor down

and click to place the point.
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The point should be placed above the lower end of the conic.
This will be the insertion point for eye.

7. For the Location of point object, hover over the point you just made until the point activates, drag you cursor
left and click when you reach the intersection point.
This point is for scaling and rotating the eye.

Split the curve

1. Draw a line that intersects the conic curve.
2. Select the conic curve.
3. On the Edit menu, click Split.
4. For the Cutting object, select the line.

Splitting the curve allows you to assign a different color and material properties for the eye and the pupil.
This step can be done at this stage or after you make the surface.

Make the surface

1. Select both parts of the conic curve.
2. On the Surfacemenu, click Revolve.
3. For the Start of revolve axis, snap to the point.
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4. For the End of revolve axis, snap to the end of the conic.
5. For the Start Angle, click FullCircle.

Assign display color andmaterial color

1. Select the top of the eye.
2. On the Edit menu, click Object Properties.
3. For the Display color, choose a contrasting color, like red.
4. With surface still selected, in the Properties pane, select theMaterial page button

5. InMaterials select the"+" next to Use a new naterial and select Plastic as the new material template.

6. Select the Color frame and the Select Color dialog appears.
7. Select Black and click OK.
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8. Set the Reflectivity to 80%.

9. Repeat these steps create a white material for the eye.
10. On the Render menu, click Render Preview to see the material color.

Place the eye on the head

1. In the Top viewport, select both parts of the eye.
2. On the Edit menu, click Groups and then click Group.

The eye parts are grouped as one object.
3. Select the group.
4. On the Transformmenu, click Orient, then click On Surface.
5. For Base point, snap to the point at the center of the eye.
6. For Reference point for scaling and rotation, snap to the point at the edge of the eye.
7. For Surface to Orient on, pick the head.
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8. In the Orient on Surface dialog, for Scale check Prompt and Rigid, click OK.

9. For the Point of surface to orient to, pick a point on the head.
10. For the Scale factor, drag your mouse and pick to scale the eye.

11. Mirror the eye to the other side of the head.

Render a picture of the ducky
Rendering creates a realistic picture of your model with colors you assign. These render colors are different from the
layer colors you might be using, which control the display in wireframe and shaded mode.

Render the ducky

1. Select the beak.
2. On the Edit menu, click Object Properties.
3. In the Properties panel, on theMaterial page, click and arrow next to Use Layer Material, then click the + next

to Use new material.
4. From the menu, click Plastic as the new material template. This will create a new material with presets for plastic.
5. in the Properties panel, on theMaterialspage, under the Plastic settings, click on the color swatch.
6. In the Select Color dialog box, select a color for the beak, like orange. Click OK to close the dialog.
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7. Select the body.
8. On the Edit menu, click Object Properties.
9. In the Properties panel, on theMaterial page, click and arrow next to Use Layer Material, then click the + next to

Use new material.
10. From the menu, click Plastic as the new material template. This will create a new material with presets for plastic.
11. Under Plastic settings in the Properties panel, click on the color swatch.
12. In the Select Color dialog box, select a color for the duck body, like yellow. Click OK to close the dialog.
13. On the Render menu, click Render.

Place lights

1. On the Render menu, click Create Spotlight.
2. Select a point in the middle of the model.

3. Drag the radius until it is approximately three times as large as the model.
4. In the Top viewport, pick a point while holding the Ctrl key down to activate elevator mode.
5. In the Front viewport, pick a point slightly above the object.
6. On the Render menu, click Render.
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On your own

Try modeling and rendering a variation of the duck.
In this image, the duck shape is used for the exterior design of the "Duck Cafe".

Duck Cafe by Doaa Alsharif
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Chapter 10 - Modeling with solids
Next, you will work with several commands that create and edit solid objects.

l In Rhinoceros, solids are closed surfaces or polysurfaces that enclose a volume.
l Some of the solid primitives are closed single-surfaces carefully edge-matched, others are polysurfaces.
l Rhino’s polysurface objects are deformable by using the deformation commands under the Transformmenu.
l You can also extract surfaces and deform the surfaces with control point editing like the last exercise.

In this part of the training, you will focus on making some solids, separating the parts, making changes and then
joining the parts back together to make a solid.

Exercise 10-1 Model a bar with text
In the following exercise we will make a solid primitive, extract some surfaces, rebuild a surface and deform it, join the
new surfaces into a solid, fillet the edges, add text to a surface, and do a Boolean operation on the solid.

Set up themodel

1. Start a new model using the Small Objects - Millimeters template.
2. Save as Bar.
3. On the Solidmenu, click Box, and then click Corner to Corner, Height.
4. For the First corner type 0,0, and press Enter.
5. For the Length type 15, and press Enter.
6. For theWidth type 6, and press Enter.
7. For theHeight type 1, and press Enter.

Edit a surface

1. On the Solidmenu, click Extract Surface.
2. For the Surface to extract, select the top and both end surfaces, press Enter.
3. Select the two ends and delete them.

4. Select the top surface.
5. On the Edit menu, click Rebuild.
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6. In the Rebuild Surface dialog box, set the Point count to 4 and the Degree to 3 for both U and V, click OK.

7. Turn control points on.
8. In the Right viewport, window select the middle points.
9. Drag the points up approximately one unit.
10. Turn control points off.

Make the bar solid

1. Select all of the surfaces.
2. On the Edit menu, click Join.

The surfaces are joined making an open polysurface.
3. Select the polysurface.
4. On the Solidmenu, click Cap Planar Holes.

Two end caps are created.

Fillet the edges

1. On the Solidmenu, click Fillet Edge, and then click Fillet Edge.
2. Set theNext Radius=1.0.
3. For Select edges to fillet, pick the four vertical edges, press Enter.
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4. For Select fillet handle to edit, press Enter.

5. Repeat the Fillet Edge command.
6. Set theNext Radius=0.2.
7. For Select edges to fillet, window select the entire bar to get the horizontal edges, press Enter.
8. For Select fillet handle to edit, press Enter.

Make a copy of the bar on a different layer
We need to make a copy of the finished bar for the next part of this exercise. On one of the copies we will engrave text,
on the other we will emboss text.
1. Select the finished bar.
2. On the Edit menu, click Layers, then Copy objects to layer.
3. In the Select layer to copy objects dialog, pick Layer 01, and click OK.
4. In the Layers panel, turn Layer 01 off.

Make solid text

1. Make Layer 02 current.
2. On the Solidmenu, click Text.
3. In the Text Object dialog box, set theHeight to 3.00,
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4. In the Font list, pick a font like Arial.
5. Click the B button to set the text format to bold.
6. In the Output section, click Solids and set the Thickness to 1.00.
7. Check the Group output, and click OK.
8. For the Insertion point in the Top viewport, position the text in the center of the bar and click.

9. In the Front or Right viewport, drag the text until it protrudes through the top surface.
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Engrave the text in the bar

1. Select the bar.
2. On the Solidmenu, click Difference.
3. For Select second set, set DeleteInput=Yes, select the text, press Enter.

The text is engraved into the bar. However, it does not follow the curvature of the bar. Let’s look at how to make
this text better follow a curved surface.

Offset solid text
Occasionally you will want to create text that exactly follows the curvature of a base surface. One method is to split the
top surface of the bar with the text curves and offset the surface into solid text objects. The solid text can be used to
engrave (difference) or emboss (union) into the original surface or polysurface:

Make a label

1. Turn Layer 01 on and turn the Default layer off.
2. On the Solidmenu, click Extract Surface.
3. Set Copy=Yes.
4. Select the top surface, press Enter.

5. Hide the lower part of the bar.
The top surface will only remain visible.

6. In the Top viewport, on the Solidmenu, click Text.
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7. In the Text Object dialog box, under Output, click Curves, check Group output and set theHeight to 3, if it not
already. Click OK.

8. For the Insertion point, position the text in the center of the bar in the Top viewport and click.
Hint: Use Gumball to scale the text curves for acceptable size and placement.

Trim the top surface of the bar with the text

1. In the Top viewport, select the text curves.
Since the Group objects box was checked when you created the text, you can pick all of the text by clicking on
one element.

2. On the Edit menu, click Trim.
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3. Select the surface in three places: near outer edge, in center of O, and in center of R.
Remember to trim out the center of letters like R and O.

The curves have split the surface. The outside surface has been deleted and each part of the text is a separate
surface.

4. Delete the original text curves.
Hint: The SelCrv command will select just the curves.

5. Select the text surfaces.
Hint: The SelSrf command will select just the surfaces.

6. On the Edit menu, click Group, and then click Group.
The text surfaces are now grouped for easier selection.

Create solid text

1. On the Edit menu, click Select Objects, and then click Previous Selection.
This selects the text surfaces again. Or since they are grouped, you can pick on any one of the surfaces, and they
will all select.

2. On the Surfacemenu, click Offset Surface.
3. For the Offset distance, click Bothsides=Yes, Solid =Yes, and DeleteInput=Yes in the Command line.

Bothsides will create the offset located on both sides of the original.
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4. For the Distance, type .1, and press Enter.

Hint: Keep the letters separate to render a different material than the bar.
5. Show the bottom part of the bar. (You used theHide command on it in an earlier step.)
6. Use the gumball to Copy the bar and solid text to create a second additional set.

Modeling embossed text
Next you will union the solid text with the bottom solid bar.
1. Select the first set of bar and solid text.
2. On the Solidmenu, click Union.
3. The text and the bar are unioned into one closed polysurface with the text embossed on the top bar surface.

Modeling engraved text
Next you will difference the solid text from the bottom solid bar.
1. Select the bottom polysurface of the second set.
2. On the Solidmenu, click Difference.
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3. For the Select surfaces or polysurfaces to subtract with DeleteInput=Yes, select the second solid text, and
press Enter.
The second set of the solid text and the bar are joined into one closed polysurface with the text engraved into the
bar surface.

4. On the Render menu, click Render.

Embossed polysurface. Engraved polysurface.
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Chapter 11 - Creating surfaces
A Rhino surface is similar to a piece of stretchy fabric. It can take on many different shapes.
Surfaces are bounded by curves called edges. To visualize the surface shape Rhino displays a grid of isoparametric
curves (isocurves) on the surface.
Surfaces have an area, their shape can be changed by moving control points, and they can be meshed.

Simple Planar Surfaces
Planar or flat surfaces are created by picking points or by picking an existing, closed planar curve. In the next exercise,
you will create planar surfaces using these commands.

Exercise 11-1 Closed polysurface box
In this exercise, you will model some simple surfaces.
1. Start a new model, use the Small Objects - Millimeters.3dm template.
2. Save as Surfaces.
3. Turn on Grid Snap and Planar.

Create a plane from two corner points

1. On the Surfacemenu, click Plane, and then click Corner to Corner.
2. For the First corner of plane, pick a point.
3. For the Other corner, pick another point to make a rectangular plane.

Create a vertical plane

1. On the Surfacemenu, click Plane, and then click Vertical.
2. For the Start of edge, snap to the endpoint at the right side of the surface.
3. For the End of edge, snap to the other endpoint at the right side of the surface.
4. Drag your cursor up and pick.

Create a plane from three points

1. On the Surfacemenu, click Plane, and then click 3 Points.
2. For the Start of edge, snap to the endpoint at the left of the first surface.
3. For the End of edge, snap to the other endpoint at the left side of the first surface.

207



Rhinoceros Level 1 Training Guide

4. For theHeight, use SmartTrack to track a point from the top of the vertical plane.

Drag the tracking point until the surface is tilted slightly and click.

Create a plane from corner points

1. On the Surfacemenu, click Corner Points.
When you pick the points in the next four steps, pick them in a clockwise direction.

2. For the First corner, snap to an endpoint at the edge of the first surface.
3. For the Second corner, snap to the endpoint at the edge of the second surface.
4. For the Third corner, snap to an endpoint at the edge of the third surface.
5. For the Fourth corner, snap to the other endpoint at the edge of the third surface.

A surface will be created with corners at the points you selected.
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Create a surface from planar curves

1. Turn Planar mode on.
2. Draw a curve that starts and ends at the top of the two vertical surfaces as shown below.

Planar mode keeps this curve on the same plane as the surface corners.

1. On the Surfacemenu, click Planar Curves.
2. Select the curve you just created.
3. Select the top edge of the three surfaces and press Enter.

A surface is created.

Create a surface from edge curves

1. On the Surfacemenu, click Edge Curves.
2. Select the four surface edges.

A surface is created.
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3. Select all the surfaces, and on the Edit menu, click Join.

Result should be valid, closed polysurface.
Hint : Use theWhat command to confirm that offset polysurface is valid, closed solid.

Surfaces from Extruded curves
The extrude curve commands create surfaces by tracing the path of a curve in a straight line or to follow a specific
curve. You can also extrude to a point or tapered.

Exercise 11-2 - Retro handset
In this exercise, you create a 1990's style cordless phone using extrusions. This technique can be used to create other
hand-held controls. To aid in organizing the model, surface and curve layers have been created. Make sure you change
layers as you are making the surfaces.

Extrude curves to surface the phone

1. Open the model Extrude.3dm.
2. Make the Top Surface layer current.
3. Select the curve as shown.

4. On the Surfacemenu, click Extrude Curve, and then click Straight.
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5. Drag the cursor in the -x direction or towards the second vertical rectangle.
This will tell Rhino the direction of the extrusion.

6. At the Extrusion distance prompt, type 3.5 and press Enter.
Note: If the object being extruded is a planar curve, the curve is extruded perpendicular to the plane of the curve.

Extrude a curve along another curve

1. Select the curve (1) on the left of the first extruded surface.

2. On the Surfacemenu, click Extrude Curve, and then click Along Curve.
3. Select the path curve (2) near its right end.

The curve is extruded along the path of the secondary curve.
If you don’t get the answer you expected, undo and try picking near the other end of the path curve.
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Extrude a curve with a taper (draft angle)

1. Select the curve on the right.

2. On the Surfacemenu, click Extrude Curve, and then click Tapered.
3. For the Extrusion distance, click DraftAngle in the Command line.
4. For the Draft angle, type -3 and press Enter.
5. For the Extrusion distance, type .375 and press Enter.

The curve is extruded with a three-degree draft angle in the positive direction on the y-axis.

Create a surface from planar curves

1. On the Surfacemenu, click Planar Curves.
2. Select the edge curves that bound the opening of the tapered extrusion at the top.

3. Press Enter.
A surface is created at the end.
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4. Select the four surfaces.

5. On the Edit menu, click Join.

Make the extruded surfaces for the other half of the phone
Next, we will repeat the previous steps for the other half of the phone.
1. Make the Bottom Surface layer current.
2. Select the curve as shown.

3. On the Surfacemenu, click Extrude Curve, and then click Straight.
Drag the cursor in the -x direction or towards the second vertical rectangle.
This will tell Rhino the direction of the extrusion.

4. For the Extrusion distance, type -3.5 and press Enter.
If the object being extruded is a planar curve, the curve is extruded perpendicular to the plane of the curve.

5. Select the curve (1) on the left of the first extruded surface.

6. On the Surfacemenu, click Extrude Curve, and then click Along Curve.
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7. Select the path curve (2) near its right end.
The curve is extruded along the path of the secondary curve.

8. Select the curve on the right.

9. On the Surfacemenu, click Extrude Curve, and then click Tapered.
10. For the Extrusion distance, type -1.375 and press Enter.

The curve is extruded with a three-degree draft angle in the negative direction on the y-axis.

11. On the Surfacemenu, click Planar Curves.
12. Select the edge curves that bound the openings of the tapered extrusion at the top.
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13. Press Enter.
A surface is created at the end.

Join the surfaces

1. Select the four surfaces.
2. On the Edit menu, click Join.

Create an extruded surface on both sides of a curve

1. Turn on the Extrude Straight-bothsides layer.
2. Select the free-form curve as shown.

3. On the Surfacemenu, click Extrude Curve, and then click Straight.
4. For the Extrusion distance, click Bothsides in the Command line.

5. For the Extrusion distance, drag the extrusion and pick.
Make sure the surface extends past the other surfaces in both directions. The surface is extruded symmetrically
from the curve.
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Basic techniques joining surfaces together
Trim the surfaces

1. Select the joined top and bottom polysurfaces, and the surface you just extruded.

2. On the Edit menu, click Trim.
3. For the Object to trim, pick the outer edge of each surface.

Split the trimmed surface

1. Select the trimmed extruded surface.
2. On the Edit menu, click Split.
3. For Select cutting objects, in the Command line, click Isocurve.

Drag you cursor along the surface to determine which isocurve direction is selected.

4. Click Toggle in the Command line if it is not the correct direction.
5. For the Split point, snap to the intersection where all three surfaces intersect.
6. Press Enter. The surface is split into two surfaces along that isocurve.

Join
Next you will join the split surface and the polysurface for the top and the bottom of the handset. The left (smaller)
part of the split surface goes with the top of the phone handset, the larger part goes with the bottom part of the phone
handset.
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Join the surfaces

1. Select the left (smaller) part of the split surface and the top polysurface.

2. On the Edit menu, click Join.
3. Select the larger part of the split surface and the bottom polysurface
4. On the Edit menu, click Join.

Round the edges of the polysurfaces

1. On the Solidmenu, Fillet Edge, then Fillet Edge.
Use a radius of .2 to round the edges.

2. For the Select edges to fillet, select the edges around the top of the top polysurface and the two horizontal
edges at the front, press Enter.

3. For the Select fillet handle to edit, click the command-line option to set Preview=Yes.
4. Check the model to make sure the fillet is doing what you expect, press Enter.
5. Repeat these steps for the Bottom polysurface.

Create an extruded surface from a curve to a point

1. Turn on the Extrude to a Point layer.
2. Turn off the Extrude Straight and Extrude Along Curve layers.
3. Select the U-shaped curve on the Extrude to a Point layer.
4. On the Surfacemenu, click Extrude Curve, and then click To Point.
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5. For the Point to extrude to, snap to the point object near the top surface.
The curve is extruded to the point.

6. On the Solidmenu, click Difference command to remove the surface from the top of the phone.
If the result is not correct, flip the normals of the top polysurface or the extruded surface with the Dir command.
The normals of the top polysurface and the extruded surface should point toward each other.

7. Select the circle.
8. On the Surfacemenu, click Extrude Curve, and then click To Point.
9. For the Point to extrude to, snap to the point object inside the bottom surface.

The curve is extruded to the point.

10. To remove the surface from the top of the phone, on the Solidmenu, click Difference.

The normals of the bottom polysurface and the extruded surface should point toward each other.
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11. Save your model as Phone.

Create the buttons

1. Turn on the Curves for Buttons layer.
2. In the Front viewport, window select the first column of buttons.

Three curves are selected.
3. On the Solidmenu, click Extrude Planar Curve, and then click Straight.
4. On the Command line, click, Solid=Yes and Bothside=Yes.
5. For the Extrusion Distance, type .2 and press Enter.

6. Repeat these steps for the other columns of buttons.

Round the button edges

1. On the Solidmenu, click the Fillet Edge, and then click Fillet Edgewith a radius of .05 to round the edges.
The button edges are rounded.

2. Save your model.

Lofted surfaces
The Loft command fits a surface through selected profile curves that define the surface shape.
Select the curves in the order in which the surface should pass through them. Select open curves near the same ends.
You can not mix open and closed curves in the same Loft command.

Exercise 11-3 Loft surfaces— The Canoe
Create the side surfaces of the canoe with the Loft command. Offset the surface, Trim and Join. The seats are created
to fit to inside the canoe and the bumper on the outer edge of the canoe. Contour and Section the sides of the canoe.
Apply materials and render.
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Loft the Side

1. Open the model Loft.3dm.
2. Window select all of the curves.

3. On the Surfacemenu, click Loft.
A surface is fitted over the curves.

4. In the Loft Options dialog box, set the Style to Straight sections.
A surface is fitted through the curves, but the sections are straight between the curves.

5. In the Loft Options dialog box, set the Style to Loose.
A surface is created that uses the same control points as the curves. The surface follows the curves more loosely.
Use this option when you want the surface to conform to the control points of the input curves.
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6. In the Loft Options dialog box, switch Style to Normal, and then click OK.

7. Highlight the surface.
8. On the Surfacemenu, click Offset Surface and set Distance=.1,FlipAll and Solid=no.

The offset inside surface is created.

9. Highlight the outside polysurface.
10. From Edit menu, click Visibility andHide

You will make the surface visible again with Show off the same menu, after the seats have been created.

Trim inside surface to line curve
Trim to a line curve then erase the curve.
1. On the Curvemenu, pick Line and Single line.
2. In the Command line, pick the BothSides options.
3. Locate the middle of the line at the origin by typing 0 and Enter.
4. For the second point, with Ortho on, pick a second point to the right or left.

Hint: Shift to toggle the Ortho state.

5. Select the curve. Now you will Trim using the line.
6. On the Edit menu, click Trim. The highlight curve will be used as the cutting object.
7. In the Top view, pick the surfaces to trim as instructed in the section above.
8. Erase the line curve used as the cutting object.
9. Mirror and join as instructed in the section above.

Alternative: Trim inside surface with IP
Undo the previous trim, if you would like to try the trim to an invisible infinite plane. With this option, there will be no
trimming object to erase.
1. Select the inside surface. Now you will Trim using the option IP or Infinite Plane
2. On the Edit menu, click Trim and type IP for Infinite Plane and Enter.
3. Next in Top viewport, pick Vertical option and type 0
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4. At the End of Vertical Planeprompt, with Ortho on, pick anywhere along the X Axis. Press Enter.
Hint: Shift to toggle the Ortho state.

5. In the Top view, pick the surfaces to trim.
There are two surface that extend beyond the Infinite Plane in the Top view on each end of the canoe. Trim on
the right, then pan to trim the surfaces on the left of the canoe.
When done, Enter again to exit the Trim command.

Left Side of Canoe Right Side of Canoe

The surface will be trimmed back to the infinite plane.
6. Mirror the surface to create the other half. 

Hint: you may also use the origin 0 and any pick along the x axis.

7. Join the two halves. 

8. Select the hull polysurface.
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9. In the Properties panel, verify that you have one polysurface.

Make a seat

1. Turn theHull Curves layer off and turn the Seat Curves, and Seats layers on.
2. Make the Seat Curves layer current.
3. In the Front viewport, select the rounded rectangles.

4. On the Curvemenu, click Curve From Objects, and then click Project. 

Project uses the current construction plane to determine the direction of projection. Make sure you select the
curves and surface to project onto in the Front viewport.

5. For the Surface to project onto, select the hull.
The curves will be projected to both sides of the hull surface.

6. Select one pair of curves on the surface.
7. Make the Seats layer current.
8. From the Surfacemenu, click Loft.
9. In the Loft Options dialog, click OK.
10. Repeat this for the other seat.

A surface is fitted over the curves that fit exactly with the shape of the hull.

11. On the Layers panel, turn the Seat Curves and Seat layers off

Create section curves from the surfaces

1. Select the hull.
2. Make the Sections layer current.
3. From the Curvemenu, click Curve From Objects, and then click Section.
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4. For the Start of section, in the Top viewport, pick a point to the left at the center of the hull.

5. For the End of section, with Ortho on, drag a line to the right and pick.
A curve is generated on the surface. Repeat this at various locations.

6. Press Esc to deselect the section curves.

Create contour curves across the hull surfaces

1. Select the hull.
2. Make the Contours layer current.
3. From the Curvemenu, click Curve From Objects, and then click Contour. 
4. For the Contour base point, snap to the left end of the canoe.

5. For the Direction perpendicular to contour planes, snap to the other end of the canoe.
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6. For the Distance between contours, type 12, and press Enter.
A curve is generated every foot along the hull.

7. Press Esc to deselect the contour curves.

8. In the Layers panel, turn off the Contours layer.

Mirror the outside hull surface

1. From Edit menu, pick Visibility and Show
You will see the outside hull surfaces again.

2. Highlight the inside hull surface.
3. From Edit menu, pick Visibility and Hide

You will hide the inside hull surfaces while you mirror the outside hull.
4. Highlight a outside hull surface.
5. Mirror the surface to create the other half. 

Hint: you may also use the origin 0 and any pick along the x axis.

6. Join the two halves. 

7. Select the hull outside polysurface.
8. Verify that you have one polysurfaces with Properties.
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Make a solid canoe

1. From Edit menu, pick Visibility and Show
You will see the inside hull surfaces again.

2. From the Surfacemenu, click Loft.
3. Pick the curves from one side of the canoe . Pick OK forNormal. The top surface is created.

4. Repeat the Loft command, and pick the curves on the other side of the canoe. Pick OK forNormal style. The
other top surface is created.

5. Select the two new surfaces and the two hull surfaces,.
6. From the Edit menu, pick Join

The hull is joined into one closed polysurface.
Hint: If the join is successful, Rhino will echo to the Command line "4 surfaces or polysurfaces joined into one
closed polysurface."

7. Type the CheckorWhat commands to verify that polysurface is valid and closed.
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Create an edge curve from the surfaces

1. Make the Top Rail layer current.
2. From the Curvemenu, click Curve From Objects, and then click Duplicate Edge. 
3. Select the both top edges of the hull.

4. Press Enter.
Two curves are generated at the edges of the hull

5. With the curves still selected, on the Edit menu, click Join.
6. The curve should be closed. Use Properties panel to check the curve condition

Hint: if the curve is not closed use the CloseCrv command.

Pipe the rim

1. Select the curve you just joined.

2. From the Solidmenu, click Pipe.
3. Set the radius of closed pipe to 1", press Enter.
4. At prompt for the next radius, press Enter.

The pipe solid is created.
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Render the canoe

You will now Assign materials to the hull and rim layers.
1. In the Perspective viewport, set the display mode to Render.

2. In the Layers panel, pick on theMaterial icon in theHull layer row.

3. In the Layers Materials dialog, click and arrow next to Default Material, then click the + next to Use new material
label. From the menu, click Plastic as the new material template. This will create a new material with presets for
plastic.

4. In the Layer Material dialog, in theName field, type Yellow_plastic.
5. Pick the color swatch, and in the Select Color dialog, select a yellow color with the wheel or list. Then click OK.

The Hull will render preview the yellow plastic material.
6. In the Layers panel, pick on theMaterials icon in the Top Rail layer row.
7. In the Layers Materials dialog, click and arrow next to Default Material, then click the + next to Use new material

label. From the menu, click Plastic as the new material template. This will create a new material with presets for
plastic.

8. In the Layer Material dialog, in theName field, type Green_plastic. Then click OK.
9. Pick the color swatch, and in the Select Color dialog, select a green color with the wheel or list. Click OK. Then

click OK again to close the Layer Material dialog.
The Top Rail will now preview the green plastic material.
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10. Render the canoe.

11. Save the render image file to your computer.

Render with a ground plane

1. From the Panelsmenu, click Ground Plane.
This will open the Ground Plane panel

2. From the Ground Plane panel, click On and Height above setting should be set to Automatic.
3. From the Effect section, pick Use amaterial.
4. Click the arrow next to Default material, and pick the "+" next to Use new material.
5. From the material template menu, select Custom.
6. In theName field, typeWater.
7. In the Texture section, under the Color section, click the link "click to assign texture".
8. In the Open dialog, navigate to your class files folder and select theWater.jpg.
9. In the Custom settings, area, set the following:

Gloss 20%
Reflectivity 10%
Transparency 10%

10. In Texturemapping section (at the bottom of the Ground Plane panel), set the X size to 100, and the Y size to
100.
Pick anywhere on the Rhino viewport. The Render preview should update.

11. If you see an edge of the water texture in your Render preview, move the model to better part of the ground
plane.

12. Render and save image file.

Revolved surfaces
The Revolve command creates a surface by revolving a profile curve that defines the surface shape around an axis.
Revolve also supports History.

229



Rhinoceros Level 1 Training Guide

Exercise 11-4 Revolve -The Vase
1. Open the model Revolve.3dm.
2. Select the free-form curve.

3. On the Surfacemenu, click Revolve.
4. For the Start of revolve axis, select one end of the curve.

5. For the End of revolve axis, select the other end of the curve.
6. To use the default Start Angle, press Enter.
7. To use the default Revolution Angle, press Enter.

A surface is revolved around the axis line.

8. From the Edit menu, click Undo.

Revolve with History
When History is on, and the Revolve command is used, History stores the connection between a command's input and
the resulting geomatry.
If the input geometry changes, the resulting surface updates accordingly.
However, editing the resulting surface will break the history and the input will no longer drive the output.

230



Rhinoceros Level 1 Training Guide

For example, with History recording and Update turned on, a revolved surface can be changed by editing the input
curves.
Let's redo the revolve with History on.

1. Select the free-form curve.

2. Turn Record History on the Status Bar
3. On the Surfacemenu, click Revolve.
4. For the Start of revolve axis, select one end of the curve.

5. For the End of revolve axis, select the other end of the curve.
6. To use the default Start Angle, press Enter.
7. To use the default Revolution Angle, press Enter.

A surface is revolved around the axis line.

8. Select the free-form curve. (Double check, do not select the surface.)
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9. Turn on the Control Points.
From the Edit menu, click Control Points and Control Points On.

10. With Gumball on, highlight a control point and pull to a new position.

11. The surface will update, as well.

Refer to theHelp for a list of commands that support History.

Rail Revolve
The RailRevolve command creates a surface by revolving a profile curve of the surface shape around a rail curve that
defines the surface edge.

Exercise 11-5 Rail Revolve—Heart and Star

Create a rail revolve
1. Open the model Rail Revolve.3dm.
2. On the Surfacemenu, click Rail Revolve.
3. For the Profile Curve, select the conic shaped curve (1).
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4. For the Rail curve, select the heart shaped curve (2).

5. For the Start of revolve axis, select one end of the vertical line.
6. For the End of revolve axis, select the other end of the vertical line.

A surface is revolved around the axis while it follows along the curve. The profile curve is scaled in one direction
between the axis and the rail.

7. Turn the Bowl layer on and other layers off.
8. Repeat the previous steps to make a bowl.

One-rail sweeps
The Sweep1 command fits a surface through a series of profile curves that define the surface cross-sections and one
curve that defines a surface edge.
The Freeform and Roadlike options determine how the frames along the rail are made.
With the Freeform option, the cross-section curve rotates to maintain its angle to the rail throughout the sweep.
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With the Roadlike option, you can specify an axis for calculating the 3-D rotation of the cross-section.
The default Roadlike axis will be different depending on the rail curve.

l For a planar rail curve, the default axis is perpendicular to the curve plane.
l For a non-planar rail curve, world-Z axis will be used.
l Click the Set axis button to specify a different axis.

Exercise 11-6 One-rail sweeps
In the following exercise, you will create a variety of one rail sweeps with single and multiple cross-section curve
inputs. You can also experiment with history and how changing the inputs to drives an updated sweep.

One cross-section

1. Open the model 1 Rail Sweep.3dm.
2. Select the two curves on the left.

3. On the Surfacemenu, click Sweep 1 Rail.
4. In the Sweep 1 Rail Options dialog, click OK.
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Two cross-sections

1. Select the three curves in middle.

2. On the Surfacemenu, click Sweep 1 Rail.
3. In the Sweep 1 Rail Options dialog, check Global shape blending.
4. In the Sweep 1 Rail Options dialog, click OK.

Multiple cross-sections

1. Select the four curves on the right.

2. On the Surfacemenu, click Sweep 1 Rail.
3. In the Sweep 1 Rail Options dialog, clear the Global shape blending check box.
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4. In the Sweep 1 Rail Options dialog, click OK.

Refer to the Help for a definition of the Global shape blending option.

Create a one-rail sweep to a point

1. Make Surface 02 layer group current, and turn off Surface 01 layer group.
2. On the Surfacemenu, click Sweep 1 Rail.
3. For the Rail, select the open free-form curve.

4. For the Select cross section curves, select the three closed curves, and in the Command line, click Point.

5. For the Pick end point, snap to the End of the free-form curve. Press Enter.
6. In the Sweep 1 Rail Options dialog, click OK.

Create a road-like one-rail sweep

1. Make Surface 03 layer group current and turn off Surface 02 layer group.
2. Select the helix.

3. On the Surfacemenu, click Sweep 1 Rail.
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4. For the Select cross section curves, select the closed curve and press Enter.
5. For the Drag seam point to adjust, press Enter.

6. Change the style to Roadlike. Check the preview of the sweep in the Rhino's Perspective viewport.
7. The preview should look correct. Click OK.

The rail is a non-planar curve, therefore the world-Z is used as the axis for calculating the 3-D rotation of the cross-
section.

Two-rail sweeps
The Sweep2 command fits a surface through a series of profile curves that define the surface shape and two curves that
define the surface edges.

Exercise 11-7 Two-rail sweeps—Rear-view mirror
In the first part of this exercise, we will explore one of the Sweep2 options. To illustrate the option we will use one
cross-section. In the second part we will use the same rail curves with two cross-sections. Lastly, we will use two rails
that converge to a single point.

Use two-rail sweeps to create the mirror
Open the model 2 Rail Sweep.3dm.

Create the base— Part 1
TheHousing Surface layer is current.
1. On the Surfacemenu, click Sweep 2 Rails.
2. Select the two rail curves (1).
3. Select the cross-section curve (2).
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4. Press Enter twice.
Since we only picked one cross-section, the surface doesn’t conform to the circle at the top of the sweep.

5. In the Sweep 2 Rail Options dialog, checkMaintain height.
Notice that the cross-section maintains the same height throughout the sweep.

6. In the Sweep 2 Rail Options dialog, click Cancel.

Create the base— Part 2

1. Select the two rail curves (1).
2. On the Surfacemenu, click Sweep 2 Rails.
3. Select both cross-section curves (2).
4. Press Enter twice.
5. In the Sweep 2 Rail Options dialog, click OK.

A surface is created whose edges match the rail curves and the cross-section curves.
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Create the housing

1. On the Surfacemenu, click Sweep 2 Rails.
2. Select the two rail curves (1).

3. For the cross-section, select the outer edge of the cylinder, press Enter twice.
4. In the Sweep 2 Rail Options dialog, click OK.

A surface is created.

Join the two parts

1. Select the base(1) and the housing(2) surfaces.

2. On the Solidmenu, click Union.
The surfaces are unioned into one polysurface.
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Note: If Union does not produce the correct results, try the Boolean2Objects command.
3. Use FilletEdgewith a radius of .25 to round the intersecting edge.

Network Surface
TheNetworkSrf command creates a surface from a network of crossing curves. All curves in one direction must cross
all curves in the other direction and cannot cross each other. On the Surface menu this command is called Curve
Network.

Exercise 11-8 Curve Network - The Side Panel
1. Open the model Networksurf.3dm.
2. On the Surfacemenu, click Curve Network.
3. For Select curves in network, pick the two edge curves and the cross-section curves, and press Enter.

4. In the Surface From Curve Network dialog box, change the edge matching to Curvature, click OK.
A surface is created that has curvature continuity with the other two surfaces.
Next let’s analyze the surface continuity of the joined surface.

5. On the Analyzemenu, click Surface, then click Zebra.
View the stripes where they cross the seams. Notice that they seem to be seamless and smooth.
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6. On the Analyzemenu, click Surface, then click Environment map.
Try changing the image by clicking the dropdown menu in the EMap Options dialog.

Exercise 11-9 The Table
In this exercise, you use one rail sweeps to make an end table with free-form tapered legs.

Create the legs

1. Open the model Table.3dm.
2. In the Layer panel, make the Leg layer current.
3. On the Surfacemenu, click Sweep 1 Rail.
4. Select the path curve for the leg.

5. Select the shape curve for both ends of the leg, and press Enter.
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6. In the Sweep 1 Rail Options dialog box, click OK.
The table leg is created.
Note the nice transition from one cross-section curve to the other.

Create the brace

1. Make the Braces layer current.
2. Repeat the previous process to create the brace.

Create the top and finish the table

1. Make the Top layer current.
2. On the Surfacemenu, click Sweep 1 Rail.
3. For the Rail, select the ellipse.
4. For the Cross-section, select shape curve.

5. Press Enter.
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6. In the Sweep 1 Rail Options dialog box, click OK.
The surface for the rim of top is created.

7. Select all of the surfaces you created.
8. On the Solidmenu, click Cap Planar Holes.

Six caps were created.
9. UseMirror to copy the brace and the leg to finish the model.

Mirror them around 0,0 in the Top viewport.
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Modeling techniques—Toy hammer
In this exercise you will use many of the commands and techniques that you’ve learned in the previous sessions.
Commands like Circle, Arc, Revolve, Sweep1, Sweep2, BooleanDifference, Trimand more will be need to complete
this model. You can also consider rendering it or preparing it for 3-D printing.
Some models require more attention to detail. This is an example of a model that requires precise modeling techniques.
This exercise also requires a number of different surface creation techniques. The technical drawing is included to help
you create a very precise model.

Exercise 11-10 The Hammer
1. Open the model Hammer.3dm.

The following layers have been created: Construction Lines, Curves, Handle, Tang, Head, Hole, Cutout, and Claw.
Use the appropriate layer when constructing the model.

2. In the Top viewport, draw outlines for the hammer.
Drawing outlines helps while drawing the curves. You can either draw lines, polylines, or rectangles to create the
outlines. Use the dimensions on the technical drawing to get accurate outlines.

Note: The Hammer model contains an existing layer with the construction lines for the this model already created
called Construction Lines. There is a sublayer with centerlines that should also be helpful. Turn these layers on to
speed up the exercise. Or create your own construction geometry for additional practice and a more realistic
approach.
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3. All Filets are 2mm, typical, unless otherwise noted.

Add the Picture
In the Front view use the Picture commands to attach theHammer_mm.png. It will make it easy to reference the
dimensions while modeling.
1. Make the Front viewport current.
2. On the Surfacemenu, under Planar click Picture.
3. In the Open Bitmap dialog, navigate to your class files folder and select theHammer_mm.png.
4. Pick the First corner of picture and then the Other corner to get the length of the image.
5. Highlight the picture and using the Gumball, move the surface back behind the curves.

6. Highlight the picture and in the Properties panel, pick theMaterials page.
7. Under the Picture section, drag the Object transparency slider to 50%.

This will fade the picture, and make it easier to see the object lines that you will add next.

Create the claw
When modeling the shape of the claw, you will use circles, arcs, and curves. You can trim the circles and arcs and then
join them together to create a closed curve. You can rebuild the curve and adjust the control points to get a more
sculptural shape.
1. Change to the Curves layer.
2. In the Top viewport, draw a curve defining the shape of the claw.

You can use a free-form curve or use a combination of arcs and circles that are trimmed and joined to create the
curve. Following is a systematic approach to creating the curve for the claw part of the hammer using arcs and
circles.
Start by drawing two circles.

3. Use the Circle command (Curve menu > Circle > Tangent to 3 curves) to create a circle at the lower end of the
claw.
Draw the circles tangent to the construction geometry
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4. Use the Circle command (Curve menu > Circle > Tangent, Tangent, Radius) to create a circle at the upper end of
the claw that is tangent to the upper right corner with a 4 mm radius.
Draw the circles tangent to the construction geometry.

5. Use the Arc command (Curve menu > Arc > Tangent, Tangent, Radius) to create arcs that are tangent to the two
circles.

6. Use the Trim command (Edit menu > Trim) to trim the inside part of the circles.
7. Use the Join command (Edit menu > Join) to join the arc segments.

8. Make the Claw layer current.
9. Select the joined segments.
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10. Use the ExtrudeCrv command (Solid menu > Extrude Planar Curve > Straight) to extrude the curve on both sides
of the construction plane.

Create the head

1. Make the Curves layer current.
2. Use the Curve command (Curve menu > Free-form > Control Points) to create the curve for the cross-section of

the head.
Make sure the curve intersects the claw part. This makes joining the two pieces easier.

3. Make theHead layer current.
4. Use the Revolve command (Surface menu > Revolve) to revolve the curve.

Use the midpoint of the construction line for the revolve axis.

5. Save your model.

Add the head to the claw part

1. Use the BooleanUnion command (Solid menu > Union) to join the head with the claw.
If the result is not correct, flip the normal of the head surface with the Dir command. The normal of the head
surface should be pointing outwards.
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2. Use the FilletEdge command (Solid menu > Fillet Edge > Fillet Edge) fillet the intersection between the head and
the claw.

3. Save your model.

Create slot for the claw part of the hammer

1. Use the Curve command (Curve menu > Free-form > Control Points) to draw a curve for the slotted part of the
claw.
Make sure the curve is symmetrical.

2. Use the Line command (Curve menu > Line > Single Line) to draw a line between the endpoints.
3. Use the Join command (Edit menu > Join) to join the curve and the line.

4. Drag the closed curve closer to the claw.
5. Use the Rotate command (Transform menu > Rotate) or gumball to rotate the curve to align more closely with

the curve of the claw.

6. Make the Claw layer current.
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7. Use the ExtrudeCrv command (Solid menu > Extrude Planar Curve> Straight) to extrude the curve through the
claw.

8. Save your model.
9. Use the BooleanDifference command (Solid menu > Difference) to subtract the slot from the claw.

10. Use the FilletEdge command (Solid menu > Fillet Edge) to make the fillets around the top and bottom of the claw,
and the slot.

Create the shape curve for the tang and the handle
Create the shape curve for the tang in the Right viewport. This curve will also be used for the handle.
1. Make the Curves layer current, and turn on Ortho.
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2. Use the Curve command (Curve menu > Free-form > Control Points) to draw a curve for the upper cross-section
of the tang.
Make sure the curve is symmetrical.

3. Use theMirror command (Transform menu > Mirror) to create the other curve.

4. Use the Join command (Edit > Join) to join the curves.
5. Save your model.

Create the tang

1. Use the InterpCrv command (Curve menu > Free-form > Interpolate Points) to draw one of the curves for the
tang of the hammer.
Make sure that it intersects the claw.
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2. Use theMirror command (Transform menu > Mirror) to create the other curve.

3. Make the Tang layer current.
4. Use the Sweep2 command (Surface menu > Sweep 2 Rails) to make the surface.
5. Use the Cap command (Solid menu > Cap Planar Holes) to make the tang a closed polysurface.

6. Save your model.

Finish the hammer head

1. Select the tang and the claw.

2. Use the BooleanUnion command (Solid menu >Union) to join the tang with the claw and the head.
3. Use the FilletEdge command (Solid menu> Fillet Edge) to make the fillets at the intersection between the tang

and the claw.
The edge has a round on it.

4. Save your model.
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Create the handle

1. Make the Curves layer current.
2. Use the Curve command (Curve menu > Free-form > Control Points) to draw a curve for the top edge of the

handle.
Make it start at the endpoint of the tang profile curve and end on the center line.

3. Use theMirror command (Transform menu > Mirror) to make the other half.

4. Make theHandle layer current.
5. Use the Sweep2 command (Surface menu > Sweep 2 Rails) to make the surface using the tang curve as the

profile curve.

A surface is created.
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6. Use the Cap command (Solid menu > Cap Planar Holes) to cap the open end.

7. Save your model.

Create the hole for the handle

1. Use the Circle command (Curve menu > Circle > Center, Radius) to make a circle 25mm from the end of the
handle.
You may have to draw a construction line to help you position the circle.

2. Use the ExtrudeCrv command (Solid menu > Extrude Planar Curve > Straight) to extrude the curve on both sides
of the construction plane.
Make sure the extrusion intersects both sides of the handle.

3. Use the BooleanDifference command (Solid menu > Difference) to subtract the hole from the handle.
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4. Use the FilletEdge command (Solid menu> Fillet Edge) to make the fillets at the edges of the hole.
The edges have rounds on them.

5. Save your model.
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Precision modeling
Some models require more attention to detail. This is an example of a model that requires precise modeling techniques.
This exercise also requires a number of different surface creation techniques.
The technical drawing is included to help you create a very precise model.

Exercise 11-11 — The Squeeze bottle

Creating a squeeze bottle

1. Openmodel Squeeze Bottle.3dm.
2. Use the pre-drawn rectangle to create a circle, an ellipse, and a profile curve.

These curves will be used to generate the surfaces of the bottle.
Note: A set of these curves is already included in the model as Bottle_curves and Path_curves. These layers are
sublayers of a layer named Curves.
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3. Make another (smaller) ellipse that will be used for the concave part at the bottom of the bottle.

4. Move this ellipse vertically .25 units.

Create the surfaces for the bottle

1. Change to the Bottle_surface layer and turn off the Reference layer.
2. Select the small ellipse.
3. Use the PlanarSrf command (Surface > Planar Curves) to make a flat surface.

Bottle_surface is a sublayer of Surfaces

4. Select the large ellipse and the circle.
5. Start the Sweep2 command (Surface > Sweep 2 Rails).

The pre-selected ellipse and circle will be the rails for the sweep.
6. For the Select cross section curves, choose the profile curve, and then press Enter.
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7. In the Sweep 2 Rail Options dialog box, click Do not change cross sections. This option will creates the sweep
without altering the cross-section curves.
Also check Closed sweep, and then click OK.

Create a blend surface for the bottom of the bottle

1. Hide the rail and profile curves.
2. Start the BlendSrf command (Surface > Blend Surface).
3. For the Segment for first edge, select the edge of the ellipse surface, and then press Enter.
4. For the Segment for second edge, select the edge of the bottle surface, and then press Enter.

5. For the Drag seam point to adjust, move the seam points so that the align with each other, and press Enter.
6. In the Adjust Surface Blend dialog, preview the sweep.

Make any adjustments that are necessary and then click OK.
7. Join the three surfaces.

Hint In the Display panel, you can enable Object settings and Color Backfaces in your current display mode.
Pick a Backface color like cyan that will easily identify the normal direction of the surface and any openings in
your polysurface.

Shaded displaymode image with a backface color set to cyan
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Cap the top
If you close the bottle, thereby creating a solid, Rhino can calculate the bottle’s volume. If you were creating this
bottle in real life, knowing the volume would be important. Normally, a bottle would have to be designed to hold
a specified volume.
If the edges of the remaining open surfaces are planar curves, you can use the Cap command to close them. The
open edges on the bottle are the top circular shape and the bottom elliptical shape, and they are planar.

Cap the top and bottom

3. Select the surface.
4. Use the Cap command (Solid menu > Cap Planar Holes) to close the holes.

Making the Surface for the Label
In this part of the exercise, you will create custom surfaces to trim an area on each side of the bottle for a label. The
new surface will have curvature in only one direction.
Note: A set of these curves is already included in the model on layer Label_Surface_Curves, a sublayer of the Curves
layer.

Create the trimming surface

1. Make the Label_Surface_Curves layer current.
2. In the Front viewport, draw two lines.

One line in the middle and one on the side.
Make sure the lines extend a little below and above the height of the bottle.
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3. In the Right viewport,Move the lines so that they will intersect the bottle, like the illustration on the right.

4. Mirror the line on the side to the other side of the bottle.
These lines will be used to create a cutting surface for the flat side of the bottle.

5. Make the Label_Surface layer current.
6. Select the three curves you just created.

7. Use the Loft command (Surface menu > Loft) to make the cutting surface.
8. In the Loft Options dialog, clear the Closed loft check box, and click OK.

A lofted surface intersects the bottle.
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9. Mirror the surface to the other side of the bottle.

10. Save your model.

Remove the surface from the bottle

1. Change to the Bottle Srf layer.
2. Use the Dir command (Analyze menu > Direction) to check the surface normal direction.

Flip the normals if necessary.
The normals should be pointing toward the center of the bottle.

3. Select the bottle.

4. Use the BooleanDifference command (Solid menu > Difference) to subtract the two lofted surfaces from the
bottle.

5. To create a hollowed out shell from a solid polysurface, like this bottle, use Shell.
At the command prompt, type Shell.
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6. Pick the top surface as the surface to remove.

7. Use a shell thickness of .05mm. You may experiment with other shell thicknesses.
8. Enter to Shell the bottle.

9. Use theWhat command to check the geometry. After the Shell, it should still be "valid and closed polysurface."
If not, Undo and use a thinner shell. Use the ShowEdges with the Naked option to determine where the opening
have occurred.
Shell only operates on simple, solid, manifold polysurfaces. For more information on this command view the
Shell Help topic.

10. Turn on the Bottle Srf layer

Create the bottle’s top
To create the bottle top, you are going to revolve a profile curve to create the surface.

Create the thread curve

1. Turn on the Top_Detail_curves layer and make theNeck_Curves sublayer current.

2. On the Curvemenu, pick Helix.
3. Pick the AroundCurve option in the Command line.
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4. Pick the magenta curve as the axis for the helix.

5. In the Command line, set Helix options:Set Mode=Turns,Turns=2 and ReverseTwist=No.
6. In the Front viewport, snap the radius to the green profile curve.

Extend and scale the thread curve
To allow the thread to ramp smoothly at each end instead of starting and stopping abruptly, here you will extend the
helix and scale it inward towards the middle of the bottle’s neck.
1. On the Curvemenu, pick Extend Curve and Extend Curve.
2. Enter to dynamic extend.
3. Pick on one end of the helix.
4. Set the extension Type=Smooth or Type=Natural.
5. Type .5, and Enter to extend the curve smoothly .5 units.

6. Click on the other end of the curve and repeat the .5 unit extension. The command keeps running after the first
extension so you do not need to start it again. Enter or Esc after the second extension to end the command.

7. Select the red and green curves. From the Edit menu, pick Visibility and Hide.
(They will be turned back on with the Show command later in this exercise.)

8. Turn on control points for the helix with the PointsOn command.
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9. Select the control points at both ends.

10. From the Transformmenu, pick Scale and Scale2D command.
11. In the Top viewport, set the base of the scale to the CPlane origin by typing in 0 and Enter.
12. For the scale factor, type .85 .

The location of the end points will scale towards the origin, and the ends of helix will be reset.

Orient the curve
Now you will place the thread profile on our newly extended helix.
1. On the Transformmenu, pick Orient and the OrientOnCrv command.
2. In the Top viewport, select the small triangle at the origin as the object to orient.

3. In the Top viewport, set the base point at the origin by typing 0 and Enter.
This will be the point, in the middle of the triangle, that is mapped to the orientation curve.

4. Select the helix as the Orientation curve very close to one of the ends.
You will only need one curve oriented at one of the ends of the helix.
An End point osnap will be used here to snap exactly at the end of the helix.

5. You will see the preview of the triangle floating with the cursor along the helix. Set the options Copy=Yes , click
the Perpendicular .
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6. Next click XFlip=Yes only if the point of the triange is not oriented to the outside of the helix.
NoteWith XFlip=Yes the curve to orient flips itself perpendicular to the curve on the axis you specify.
Toggle the Xflip setting and choose the one that previews the point of the triangle oiented to the outside of the
helix.

XFlip required. Desired orinetation.

7. Click at the end of the helix curve to place the triangle.
8. Preview the result in the Rhino viewport and Enter .

Now everything is in place to create the thread surfaces.

Sweep the curve
Now you will sweep the thread profile curve located on the end of the extended helix to create the thread surface.
1. Make theNeck_surface layer current.
2. From the Surfacemenu, pick the Sweep1 command.
3. Select the helix as the path curve, the triangle at one end as the shape curve.
4. With the Perspective view active, set the sweep style to Roadlike to ensure that the profile maintains its

orientation correctly for a vertical thread as it sweeps around.

5. Make any adjustments that are necessary and then click OK.
6. Highlight the swept surface and from the Solidmenu pick Cap Planar Holes. Cap makes the resulting sweep

closed at the open ends and solid.

Union the neck
To make the neck itself, you will revolve the two vertical curves to create solids and combine them into a closed solid
with two Boolean operations.
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1. From the Edit menu, pick Visibility and Show.
2. From the Surfacemenu, pick Revolve .
3. Select the green vertical curve as the curve to revolve.

4. Set the axis to the origin 0 of the Top CPlane and press Enter to use the CPlane z-axis direction. Or pick the end
points of the magenta line, indicating the revolve axis.

5. Pick Full circle option in the Command line.

6. From the Solidmenu, pick BooleanUnion. Select the thread solid and the revolved solid.

7. Hide the threaded neck which resulted from the BooleanUnion.
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Difference the opening

1. Make the Plug layer current.
2. Select the red vertical curve.

3. From the Surfacemenu, pick Revolve.
4. At the Start of revolve axis type 0 and Enter.
5. In the Top CPlane and press Enter to use the default option of the CPlane z-axis direction.

Option: Pick the end points of the magenta line, indicating the revolve axis.

6. Pick Full circle option in the Command line.

7. Show the threaded neck.
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8. From the Solidmenu, pick BooleanDifference. Select the thread solid and Enter. Next pick the last revolve and
Enter
The revolved surface is not subtracted from the solid thread, resulting in a new solid neck for the bottle.

The whole bottle
Now you will put both pieces together.
1. Turn on the Bottle Srf layer and make it current.
2. From the Solidmenu, pick BooleanUnion. Select the bottle solid and the neck solid. Press Enter to union them

into one closed solid.

Fillet the bottle
Soften the transition between the label surface and the bottle.
1. From the Solidmenu, pick Fillet Edge and Fillet Edge.
2. Type .25 as the fillet radius and Enter.
3. Select the curve that defines the transition between the label surface and the bottle.
4. Enter twice to exit the command.

5. Repeat for the other side of the bottle.

Rendering the bottle
Render the bottle with plastic materials. Place lights.
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Adding a decal
Use Decals to attach a label to the front of the bottle.
1. In the Properties panel, on the Decal page, click the "+".

2. Navigate to and select image file, tHbestLogo.png.
3. On the Decal Mapping Style dialog, accept the defaultMapping style of Planar and Direction of Forward by

picking OK.

4. In the Front viewport, pick two diagonal points to locate and size the decal. This is easier with osnaps disabled.
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5. Right-click on the tHbestLogo.png decal in the Decal panel, and pick Show the Decal Widget.

6. On the Status Bar, turn on the Gumball control. With the Gumball on, you can move, re-size, and rotate the
decal with the gumball control.

Refer to the Rhino Help for additional details on the Decalfeature.

269



Rhinoceros Level 1 Training Guide

On your own

l Use the SnapShot command to save and restore configurations for the bottle and caps. Refer to the Rhino Help
for details on the SnapShot command.
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Chapter 12 - Annotating your model
Rhino can also produce 2-D drawings of your models. Rhino has these annotation objects:

l Dimensions
l Annotation Text
l Leaders
l Dots
l Hatching

Dimensions
You can create dimensions on all viewports. They will be created parallel to the current viewport’s construction plane.
Dimension commands are combined with object snaps to give precise values. There are many different types of
dimensions that are used to annotate a model. We will look at linear, radial, diameter, and angular.
The annotation style controls the way a dimension and the text displays. For example the dimension text location can
be above the dimension line or in the dimension line. The end of a dimension line can display an arrow, a tick, or a dot.
The dimension text can show decimal, fractional, or feet and inches numbers. A new model will open with Default as
the annotation style.
You can make additional annotation styles, assign existing dimensions to a different style, or update a style to make all
the dimensions assigned to that style update. You can also import a annotation style from another model. Or add the
annotation style to a template so new models always have it.
Let’s look at the dimension types:

Dimension types

Annotating the model
Annotation styles control the appearance of both annotation text and dimension objects. These are saved with your
model.
Changes to the properties of an annotation style will update all the text and dimensions that are assigned to that style.
It is possible to override the properties of the annotation style on a per object basis. These objects with overrides will
not update with changes to their assigned style.
You may also have your favorite styles already created in a template file. These styles will be ready to go in your new
files.
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To start this exercise you will create a new annotation style. Then, you will create text and dimensions that will use your
new annotation style.

Exercise 12-1 Dimension the part
Make a new annotation style

1. Open the model Dimension.3dm.
2. On the Toolsmenu, click Options.
3. In the Rhino Options dialog, under Document Properties, pick Annotation Styles.
4. Next to Annotation Styles, click the chevron > to expand the list of existing styles.
5. On the right margin of the Annotation Styles page, click New button.
6. In theNew Annotation Style dialog, select (built-in) Millimeter Small as the new annotation style template. Pick

OK.

7. Highlight the radio button next the new style TemplateMillimeters Small to make it the current annotation
style.
As the current style, any new text and dimensions objects will be assigned to the TemplateMillimeters Small
annotation style.

Edit the new annotation style

1. Select TemplateMillimeters Small as the current annotation style, then click the Edit button on the right of the
Annotation Style dialog.

2. At the top of the Edit page , change the Style name toMillimeter Small.
3. Next changeModel space scale to 1.0
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4. Under the Arrows section, reset the Arrowhead 1 and Arrowhead 2 fromOpen Arrow to Arrow.
Note: Browse the dialog and familiarize yourself with the many annotation style settings. As you change a
setting, the preview images at the top of the Annotation style page will update.

5. Click OK to save your edits.
New dimensions and text will be assigned to theMillimeter Small dimension style.
Or an existing dimension can be changed to this style on the Dimension page of the Properties panel.

Linear Dimensions
Linear dimension creates a horizontal or a vertical dimension.

Make linear dimensions

1. On the Dimensionmenu, click Linear Dimension.
2. In Top viewport, snap to the lower left end of the part.
3. In the Top viewport, snap to the lower right end of the part.
4. In the Top viewport, pick a point below the part.

5. On the Dimensionmenu, click Linear Dimension.
6. In Front viewport, snap to the lower left end of the part.
7. In Front viewport, snap to the upper left end of the part.
8. In Front viewport, pick a point to the left of the part.
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9. In the Front viewport, create two additional linear dimensions on the top and right sides of the part.
Note: Use object snaps to locate the extension line origins. To move extension line or text locations for
dimensions, turn on control points for the dimension and move the control points.

Leaders
Leaders include an arrowhead and text.

Draw an arrow leader and text

1. On the Dimensionmenu, click Leader.
2. In the Front viewport, click the top of the part.

This will be where the arrow will be created
3. Turn Grid Snap on and click a point to the right and at an angle from the first point.

Or use the Shift to temporarily enable the ortho during the pick.
4. Click to the right of the second point, and press Enter.

5. In the Leader Text dialog box, type Smooth Finish, and click OK.

6. To edit the text, double-click and make changes in text box.
7. Click in graphics area when editing is complete.
8. For long notes try the word-wrap feature on the leader object.

Use the PointsOn command to turn on the control on the Leader text.
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9. Select the Control point on the right.

10. Using the gumball, drag the point to the left, and re-size the width and, wrapping the text.

11. Esc to turn off the control points on the leader text.

Radial and Diameter Dimensions
Radial and diameter dimensions note arcs and circles.

Make a radius or diameter dimension

1. On the Dimensionmenu, click Radial Dimension.
2. In the Top viewport, select the lower right quadrant of the arc .
3. Click to place the dimension text.

4. On the Dimensionmenu, click Diameter Dimension.

5. In the Top viewport, select the upper right quadrant of the hole.
6. Click to place the dimension text.

Continuous Linear Dimensions
The Dim command has a Continue option, that when activated adds chained dimensions along the same dimension
line. This option needs to be activated for each Dim command that you begin.
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Make continuous (chained) dimensions

1. On the Dimensionmenu, click Linear Dimension.
2. In the Command line, set Continue=Yes.
3. In Top viewport, snap to the left end of the part (1).
4. In the Top viewport, snap to the end of the vertical part (2).
5. In the Top viewport, pick the Dimension line location (3).
6. Continue to snap to the center of the hole (4), and the right end of the object (5).
7. Press Enter to end continuous linear dimension.

8. In the Top and Right viewports, create additional continuous linear dimensions on the side and on the bottom of
the part.

9. Now dimension the rest of the drawing using leaders, text blocks, horizontal, vertical, radius, and diameter
dimensions.

10. Save your model.

Baseline Linear Dimensions
The Dim command has a baseline option to create a string of dimensions that all measure back to the initial start of the
first dimension in the string. Because you have just made a set of chain dimension, the dimension will try to continue
from that previous dimension. You will need to make one dimension first, and then continue with baseline. Here are
the steps.

Make baseline dimensions

1. On the Dimensionmenu, click Linear Dimension.
2. The dimension is continuing from the last dimension. In Command line, set Continue=No.
3. In Top viewport, snap to the left end of the part (1).
4. In the Top viewport, snap to the end of the vertical part (2).
5. In the Top viewport, pick the Dimension line location (3).
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6. Enter to repeat the Dim command.
7. In Command line, set Continue=No and Baseline =Yes.
8. Continue to snap to the center of the hole (4), and the right end of the object (5).
9. Press Enter to end baseline linear dimension.

Continuing a dimension
1. On the Dimensionmenu, click Linear Dimension.
2. In Command line, set Continue=Yes. A dimension may be continuing from the last dimension.
3. In Command line, click SelectDimensionToContinue.
4. At the Select dimension to continue pick the existing dimension that you would like to continue (1).
5. Continue to pick end points for new dimension (2).
6. Press Enter to end linear dimension.

Making a 2-D drawing from a 3-D model
Rhino has the ability to generate a two-dimensional drawing from a three-dimensional model, by projecting the
geometry to the world coordinate plane, and aligning the views. Options for first angle projection or third angle
projection are available. In addition to the three orthographic views, a two-dimensional perspective drawing is also
generated. Hidden lines are removed and placed on a separate layer.
Options for creating four views (three parallel projection viewports and one perspective projection viewport), or single
views of individual viewports are supported.

Exercise 12-2 Practice making a 2-D drawing
1. Open the modelMake2D.3dm.
2. Select the 3-Dmodel.
3. On the Dimensionmenu, clickMake 2-D Drawing.
4. In the 2-D Drawing Options dialog box under Projection click Third Angle Projection. Under Options check

Tangent edges and check Hidden Lines then click OK.
The 2-D drawings are created on the Top construction plane near the origin on the world xy plane. View them in
the Top viewport.
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5. Dimension the 2-D drawing.
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Chapter 13 - Importing and exporting
Rhino supports many different import and export formats, making it possible to model in Rhino and then export your
model to downstream processes, or import models from other software applications into Rhino. For a complete list of
import and export file types refer to the Rhino Help > Contents > File I/O > File Formats.

Importing other file formats into Rhino
We will not be importing any models in this class. Importing files from other applications is covered in our Level 2
Training course. If you have any specific questions about importing models into Rhino, consult your instructor.

Exporting Rhino File Information
When you export to a format like 3DS, STL or DWG, Rhino has to convert from smooth NURBS surfaces to a polygon
mesh representation made of triangles. To do a good approximation of the curved surfaces, Rhino can sometimes use
many polygons. The density of triangles can be adjusted when exporting. You can create a mesh object and export it,
or Rhino can create the mesh during the export process.
There are two methods to export models to other formats. You can use the Save As command to choose a specific
export format to export an entire model. Or, you can select some objects and use the Export Selected command to
choose a specific export format to export a portion of the model. In the following exercise you will use the Save As
method to export three of the most common file formats.

Exercise 13-1 Export a model to a mesh format
1. Open the model Export.3dm.
2. On the Filemenu, click Save As.
3. In the Save dialog box, change the Save as type to Stereo lithography (*.stl).
4. In the file name box type Export and click Save.

5. In the STL Mesh Export Options dialog box, set the Tolerance to 0.01, and click Preview.

6. Set the Tolerance to 0.1, click Preview, and then click OK.
7. Visually inspect the preview. If the mesh faces do not follow your geometry, increase the tolerance to .001 and

preview again.
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Poor Preview Acceptable Preview

8. In the STL Export Options dialog box, select Binary, uncheck Export open objects, and click OK.
Note: In most cases, when outputing an STL for 3D printing, the "Export open objects" is NOT checked.
You can also isolate your open polysufaces in Rhino with the SelOpenPolysrf and SelClosedPolysrf commands.

Export a model to IGES

1. On the Filemenu, click Save As.
2. In the Save dialog box, change the Save as type to IGES (*.igs).
3. In the IGES Export Options dialog box, select Pro EWindows solids as the IGES type, click Detailed Controls.

Detailed controls allow the user more input.
4. Click Cancel to terminate, or OK to create the IGES file.

Export a model to STEP

1. On the Filemenu, click Save As.
2. In the Save dialog box, change the Save as type to STEP (*.stp, *.step).
3. In the STEP Options dialog box, use the default setting.
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Chapter 14 - Rendering
Rhino has a built-in rendering engine called Rhino render. The rendering shows your model as if it were in a
photograph or sketch. Rendering your model to look like a photo is called photorealistic rendering. Flamingo nXt is an
example of a photorealistic render plug-in for Rhino. If you render your model to look hand-sketched, this is called
non-photorealistic. Penguin is an example of this type of render. 3rd party renders with more advanced features are
available as plug-ins for Rhino.
The built-in Rhino render may all you need for much of your work. In this section, you will work with the features of
the built-in Rhino render. Later, you can explore other rendering programs such as Flamingo nXt, V-Ray, Maxwell or
others plug-ins for higher quality results. Most 3rd party plug-ins for Rhino are found on the Food4Rhino web site.

Materials and other features
Rhino’s built-in renderer creates materials with color, reflectivity, transparency, clarity and bump map settings. The
render material also allows the attachment of textures for color, transparency, bump and environment.
The renderer has built-in, ready-to-use material presets like Metal, Plastic or Glass. This is very helpful to quickly create
new materials with specific preassigned properties.
The renderer offers custom lighting, displays shadows, automatic ground plane, sun and environment. It also has
configurable levels of anti-aliasing and post processing options. In this exercise we will focus on the rendering
features.

Exercise 14-1 Practice rendering the toy screw driver
1. Open the model Render.3dm.
2. On the Render menu, click Current Renderer, and then click Rhino Render. 
3. On the Status Bar, turn off Gumball.
4. Right-click on the Perspective title bar, and then click Rendered display.

The viewport mimics but does not exactly duplicate what you will get in a Render.

Setting the Rendering Defaults
It may be necessary to return a model to the rendering defaults or reset a model from an earlier Rhino version to the
Rhino 6 defaults.. An fast and convenient way to perform this task is to use the Reset to Defaults button on the
Rendering panel.
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1. Right click on the tab of any open panel, and pick the Rendering panel.

2. At the bottom of the Rendering panel, pick on the Reset to Defaults button.

3. The Rhino render settings and environment will be set to the Rhino 6 rendering defaults and ground plane.
This is helpful when opening a model created by an earlier version of Rhino. In these older model, the rendering
will look very gray compared to the Rhino 6 templates. Picking the Reset to Defaults is an easy way set the
model to the Rhino 6 rendering defaults.

Assign amaterial to the handle by object
To render the handle in color, we will first assign a red glossy material to the handle object. This material assigned to
the object will override any material that might be assigned to the layer of the object.
1. Select the handle.

2. In the Properties panel, click theMaterial button.

3. On theMaterial page, pick drop down arrow on Use Layer Materialsmenu, choose Use a new
material.

4. On theMaterial template list, pick Plastic.
5. In the name field, type Red_glossy.
6. Click the Color swatch.
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7. In the Select Color dialog box, select Red, and click OK.

When the Perspective viewport is in Render display mode, you can preview the material color in the viewport.

8. On the Render menu, click Render.
A display window appears with the current viewport rendered in colors, but it will probably lack detail. You can
close the Display Window without disturbing your model. Placing lights will add depth and detail to the rendered
image.

The image size is determined by the Resolution and Quality Setting on the Options >Document Properties,
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Render page. By setting the Dimension option to Viewport, Rhino will render to the current viewport resolution.
Vary the render size by maximizing and re-sizing the viewport being rendered.

Assign amaterial to the blade by layer
To render the blade in color, we will assign a glossy, yellow plastic material to the blade layer. All the objects on the
blade layer that are set to Use Layer Material, will be rendered in the layer's assigned material. Changing the layer's
material will update all the objects on the layer that are set to set to Use Layer Material. This is the advantage of
rendering with material set to Use Layer Material.
1. Select the blade.

2. If the Properties panel is not open, right-click on the tab of any open panel, and click Properties.
3. In the Properties panel, on theMaterial page, verify that the material is set to Use Layer Material.
4. In the Layers panel, click theMaterial icon for the Blade layer.

5. In the Layer Material dialog in theName box, type the name Yellow_glossy.
6. Under Type, select Custom.
7. Under Custom Settings, click the Color swatch.
8. In the Select Color dialog box, select a color, for example, Yellow, and click OK.
9. Set the Gloss finish between 80 and 90%
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10. Set the Reflectivity slider to 5%

11. On the Render menu, click Render.
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Add a new preset material to a layer

1. In the Layers panel, click theMaterial icon for the Blade layer.
2. In the Layer Material dialog box, click the drop down arrow next to the Yellow_Glossymaterial.

3. When the list of materials appears, click Use a new material and click the type Plastic .

4. In theName box typeWhite_Plastic. Pick the color swatch and set the color to white
5. Render the model.
6. The next time you click the down arrow for a material listed in the Layer Material dialog, you will see a list

including Default Material and the three materials you just created.
You can switch between any of the materials in the model or make a new one at any time. This works whether
you are assigning the material by layer or object.
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Add lights
Start with a standard lighting scheme. You can experiment to develop your own lighting schemes later.

Place a light

1. Zoom out in the Top and the Front viewport.
2. Make the Lights layer current.
3. On the Render menu, click Create Spotlight.
4. For the Base of cone, type 0 and press Enter.
5. For the Radius, in the Top viewport, pick a point so that the circle is larger than the entire screwdriver.

6. For the End of cone, hold down the Ctrl key, and in the Top viewport, pick a point below and to the right.
This starts elevator mode.

7. For the End of cone, in the Front viewport, pick a point above the object.
This will be your main light.

8. Make the Perspective viewport active.
9. On the Render menu, click Render.

The image now has some highlights and shadows. The automatic ground plane is also visible.
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Place a second light

1. Zoom out in the Top and the Front viewport.
2. On the Render menu, click Create Spotlight.
3. For the Base of cone, type -70,0 and press Enter.
4. For the Radius, in the Top viewport, pick a point so that the circle is larger than the handle of the screwdriver.

5. For the End of cone, hold down the Ctrl key, and in the Top viewport, pick a point below and to the left.
This starts elevator mode.

6. For the End of cone, in the Front viewport, pick a point above the object.
This will be your secondary (fill) light.
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7. Make the Perspective viewport active. and set its display mode to Rendered.

8. On the Render menu, click Render.

Assign properties to the lights

1. Select the new light.
2. In the Properties panel, click the Light icon.
3. On the Light page, turn the second light Off.
4. Select the first light
5. In the Properties panel, click the Light icon.
6. On the Light page, change the Intensity to 90 the Shadow intensity to 50 and the Spotlight hardness to 50.

Experiment with these settings to get the desired effect.
7. FromOptions and Render settings, scroll to Lighting section.

Lower the Skylight Intensity option to .5.
8. Make the Perspective viewport active.
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9. On the Render menu, click Render.

10. Finally, in the Layer panel, make the Default layer current and turn the Lights layer Off.
The Skylight and the default environment will provide the lighting.

11. On the Render menu, click Render.

Add textures
Add a bumpy surface to the handle

1. Select the handle.

2. In the Properties panel , click theMaterial button.
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3. On theMaterial page, under Bump texture setting, click the drop down arrow next to None to assign.

4. From the list of built-in Bump textures, select Leather and set the Scale toMedium or Small.
5. The Rendered display will update to display the bump.

The surface of the handle has a bumpy appearance, however the color of the material and gloss setting is still
used.

The bumps come from the pattern of light and dark in the bitmap image. You can use a bitmap file for a bump.

Add a custom material to the handle

1. Select the handle .
2. In the Properties panel , click theMaterial page button.

3. Choose the arrow to expand menu and pick next to Use a new material.
4. In the pop-up dialog, scroll to select Custommaterial.
5. On theMaterial page, in the name field, enter RedMarble.
6. In the Custom Settings section under Color, click the color frame.
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7. From the Select Color dialog, click on a red color or enter RGB: R=255, G=0, B=0.

8. Under Bump, select click to assign material.

9. In the Open dialog, pick the button Choose from more texture types.

10. Under Type, click onMarble Texture and click OK.

11. In the Edit Marble Texture dialog, under theMapping section, checkWCS  to enableWorld Coordinate System
texture mapping control. Also underMapping, set the size of the tecture to X Size to 20.0, the Y Size to 20.0,
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and the Z Size to 20.0 click OK.
Note: The lock bar to the left of these setting, will lock the x, y, and z values to the same setting.

12. The Rendered display will update to display the bump.
The surface of the handle has a bumpy appearance, however the bump texture in the Marble material will not be
used by preview. You will need to execute the Render command.

13. To see the marble material, on the Render menu, click Render.

14. On the Filemenu in the Render dialog, click Save As.

15. Under Save as type, click PNG. Type your file name and location.
16. Click Save button.
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Add a custom texture to the handle

1. Select the handle.

2. In the Properties panel, click theMaterial page button.

3. On theMaterial page, pick drop down arrow to the right of RedMarble.

4. The arrow will expand menu. Pick next to Use a new material.
5. Under Type select Custom.

Note: The Custom template is important because the Picture tempate does not allow for UV repeat.
6. In theName field, typeWood.
7. In the Texture section, under Color, pick "click to assign texture" label.

296



Rhinoceros Level 1 Training Guide

8. In the Open Bitmap dialog box, selectWood.jpg, and then click Open.
Wood color texture is mapped to handle.
Note: This texture file Wood.jpg is included in the Level 1 file set.

9. Render. It looks like wood but the texture is being stretched over the entire surface.

Repeat the texture

1. Select the handle.
2. In the Properties panel, click theMaterial page button.

3. In the Textures section, click onWood.jpg to open the EditingWood dialog.
4. In the EditingWood dialog, under Type pick Bitmap Texture.

(Simple Texture does not allow for UV repeat.)
5. InMapping section, set the U Repeat to 4 and the V Repeat to 6.

Click the lock icon to allow the 4 & 6 input. Select the icon to unlock the uniform repeat.

Locked Unlocked
6. Click OK to close the EditingWood dialog.
7. In the Custom Settings section of theMaterial page, change the Gloss slider to 30% and the Reflectivity slider

to 2%.
8. On the Render menu, click Render or use a Rendered viewport.

The surface of the handle has a wood texture appearance tiled at 4 times in the U and 6 times in the V.
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Make the wood handle transparent

1. On the Panelsmenu, click and check theMaterials panel to turn it on.
2. Click on theWoodmaterial that is already assigned to the handle.
3. In the Custom Settings section of theMaterials panel, drag the Transparency slider to 20%.
4. Click back into the graphics area.
5. On the Render menu, click Render.

The handle will look transparent with the Wood texture.

Make the red handle transparent

1. Select the handle.
2. In the Properties panel, click theMaterial page button.
3. Select Red_glossy from theMaterial list.

The handle will no longer render in the material assigned to the layer.
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4. In the Object Properties panel, on theMaterial page and under the Custom Settings section, change the
Transparency slider to 30 and clear the Bump texture box to disable the cell2 texture setting.

5. Click back into the graphics area.
6. On the Render menu, click Render.

The handle will look transparent with the red glossy material.

7. Finally, on theMaterial page, under the Custom Settings section, return the Transparency slider to 0 .

Use the ground plane
The Rhino Render has a ground plane option. The ground plane provides an infinite horizontal platform for the image
that stretches to the horizon in all directions positioned at a defined elevation. A ground plane renders much faster
than using a surface as a background. Any material can be assigned to the ground plane.

Turn on the ground plane
The ground plane may already be on, but if not you can turn it on in the Ground Plane panel.
1. Right-click Properties panel tab.
2. On the menu, click Ground Plane panel.
3. In Ground Plane panel check the On box.

The viewport will display a ground plane.
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4. Click option Use amaterial.
The Default material is assigned.

5. In theMaterial list pick the existing Yellow_glossy, a material created earlier in this exercise.
Viewport will now show a yellow glossy ground plane.

6. On the Render menu, click Render.

Change the ground plane texture

1. In Ground Plane panel, click the down arrow next to the Yellow_Glossymaterial.
2. When the list of materials appears, click the "+" button next to Use a new materialmaterial, and select Picture.

3. In the Open dialog, navigate to folder where you have the Level 1 training support files, and selectWood.jpg. A
new custommaterial will be added.

4. Double-click the new Wood material to continue editing it.
5. On theMaterial page, in theName field, type the nameWood_table.
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6. In the Texturemapping section, click on the scale icon to allow for non-uniform scale of the texture.

Scale Texture Uniform Scale Texture Non-Uniform

7. In the Texturemapping section, type X size 100 and Y size 75.

8. The viewport in Render mode will now show and render a wood ground plane.

9. On the Render menu, click Render.
10. On the Filemenu in the Render dialog, click Save As.
11. In the Save As dialog, in the Save as type control, click PNG.
12. Type your file name and pick the folder location.
13. Click Save button.

Setting the Rendering Resolution
The Rendering panel manages the Rhino Render settings for the current model. You can select your current Render
and set Resolution and quality here.
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1. Right-click Properties panel tab.
2. On the menu, click Rendering panel.
3. In the Current Renderer area should be set to Rhino Render
4. Under Resolution and Quality area, pick the Dimensions list box, and select 800 by 600.
5. On the Render menu, click Render. After viewing, close the Rhino Render dialog.
6. Next, on the Rendering panel under Resolution and Quality, pick the Dimensions list, and select Viewport

resolution.
7. On the Render menu, click Render. Compare this option to the fixed size.

Rendering Metals
Now you will assign a metal material to the blade.
1. Select the handle.
2. In the Properties panel, click theMaterial button.
3. Select Use Layer Material
4. In the Layers panel, click theMaterial icon for the Blade layer.
5. In the Layer Material dialog pick Use New Material
6. In the new material Type area, selectMetal.
7. In theName field, typeMetal_silver.
8. In theMetal section, click on the color frame to select from additional metal color options.
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Metal color options

9. Click OK.
10. From Render menu, click Render

You will see the blade rendering in the silver metal.

Raytraced Mode
The Raytraced display mode sets the viewport to a render mode with Cycles, a real-time raytracer. The image will
continue to progressively improve indefinitely. The raytrace engine uses the Cuda cores on the Nvidia graphics
cards and therefore may not be suitable for all computers.
Completed passes are displayed in a status bar at the bottom of the viewport. It indicates how many passes on
your image have been completed. 50 passes minimum is typically recommended. You may always leave the
viewport and return to complete more passes and improve the raytraced image.
When you decide that the raytraced image is ready to be saved to a file, use the ScreenCaptureToFile command.
This command will write your rendering to a file in one of the standard image file formats.
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4.  On the Perspective viewport menu, click Raytraced

5. The viewport updates with materials and lighting in the real-time, persistent raytraced image of the model.

6.

Rendering with Sun

Rhino also offers a Sun as a lighting option. The sun is a strong directional light whose location and direction is
determined by the Sun Position, Date and Time, and Location settings.

Exercise 14-2 Rendering the Gazebo
Next you will render using the architectural model. You will use the features of Sun, environment, and directional light
to get a realistic looking exterior rendering.
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Turn on the ground plane and sun
1. Open the model Gazebo.3dm.

2. On the Panelsmenu, click and check the Rendering panel to turn it on.
3. In the Rendering panel, pick the Reset to Defaults button. In the dialog that appears, pick the OK button to

confirm the reset of rendering settings to defaults, including turning on the ground plane.

4. Next, right-click Properties panel tab and click the Sun panel on.
This is another way to control the Panel display.

5. In the Sun panel check the On box.
Now the shadows appear.

Configuring the Ground Plane
1. On the Ground Plane panel, under the Effect area, pick the button next to Use amaterial.
2. In the Use amaterial pick the arrow (1), the plus + (2) and from the menu pick on the Import from Material

Library (3).

3. Navigate to the folder Render Content\Organic\Grass and select the Grass bright material.
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4. In the Ground Plane panel, under the Texturemapping section, in the X size field, type 10. Since the x & y
dimensions are locked, the Y size fieldwill change proportionally.

5. Pick outside the panel and on the viewport to update the material.
The grass material is assigned to the ground plane. A viewport set to Render display mode will show this grass
material on the ground plane

However, with out the sun configured the grass looks dark. Next you will configure the sun to add brightness to
your model.

Setting the Sun position
1. In the Sun panel, in the Date and Time area, pick the month June and the time of 3 PM.

2. In the Location area, pick SeattleWA USA.

3. From the Render menu, click Render.

Next you will assign materials to the layers in the model.

Assigning Materials
Materials, environments, and textures are stored in the model, but render content can also be saved to files that can be
shared between models. Content can be dragged between Rhino sessions and into a folder. The Materials are assigned
to objects or to layers. Here you will assign the material to the layer.
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1. In the Layers panel, turn on the Planting and Fence_post layers.
2. In the Layers panel, pick on theMaterial icon in each layer row to the layers to configure the materials.

3. Here are some material suggestions.
Note: You will find these materials created for you in the file.

Layer Material Details

Walls Rose_Paint Use Paint template and set color to RGB: 255, 191, 191

Lights Metal Use Metal template and select Yellow Gold.

Fence White_paint Use Paint template and set color to White.

Roof Roofing Import from Library: Render
ContentArchtiectural\Roof\Shingle\Cedar brownred

Concrete Plaster Use Plaster template and set color to gray: RGB: 190, 190,
190.

Sizing the Texture Materials
The roof shingle is too small for the gazebo roof. You will edit the size of the bitmap to help the material look more
realistic.
1. On the Panelsmenu, click and check theMaterials panel to turn it on.
2. On theMaterials panel, click on the Roofingmaterial.
3. Scroll to the Texture section. Under Color, select Roofing.jpg.
4. In the Editing Cedar brownred_1000_DB dialog, underMapping, in the X size field, type 4. Since the x & y

dimensions are locked, the Y size fieldwill change proportionally.
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5. Pick outside the panel and one the viewport to update the material.

6. Rotate the Perspective view for the angle you wish to render.
7. From the Render menu, click Render.

Hint: Explore the materials that are located in your Render Content folder. This will give you a better idea which
materials you will need to create and which materials are ready for you to use in the library.

Setting the Environment
The environment is a background color and optional texture you can configure for your model. Next you will assign a
Rhino Environment called RhinoSky.
1. Right-click Properties panel tab or any open panel tab.
2. On the menu, click Environment panel.
3. In Environment panel, click the plus + and from the menu select Import From Environment Library.
4. In the Open file dialog, from the \Render Content\Environments location, selectMtMonadnock NH.renv and

click Open.
5. In Environment panel, double-clickMtMonadnock NH.renv or right-click and click "Set as Global

Environment.
The MtMonadnock NH will now be set to the global environment.

6. In Environment panel, under Rotation section, drag the rotation angle dial or type 320 degrees.
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Hint: Watch the Perspective viewport as you are dragging the dial. It will update with a preview of the image at
the current location.

Rendering to an image file
The Save command button in the render window saves the image in the render window to a file.

The render resolution is set in Options or on the Rendering panel.
1. In the Toolsmenu, click Options
2. In the Options dialog, click Render.
3. On the Render page, in the Resolution and Quality area, pick the resolution 800 x 600, and click

OK.
You can also set the render resolution from the Rendering panel, under Resolution and Quality.

4. From the Render menu, click Render

5. In the Render dialog, pick the Save button or from the Filemenu, click Save-As
6. In the Save-As dialog, under "Save as type", click JPEG and in the File name field, type Gazebo01.JPG. Click the

Save button.
Your file can now be edited by any image editor.

Rendering with Directional Lighting and the Skylight
Adding a directional light will add illumination when it is most necessary. The Skylight option will add an overall
illumination to your model.
1. In the Layers panel, turn on the Render_lighting layer.

A directional light will appear. It is located in the NE quadrant of the model. It is oriented to point SW.
Create your own directional lights with the DirectionalLight command.
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2. Right-click Properties panel tab or any open panel tab.
3. On the menu, click Rendering panel.
4. On the Rendering panel, in the Lighting section, uncheck Skylight (360 env.)

The Perspective viewport is set to Render display mode and should update with the new lighting.
5. From the Render menu, click Render

6. In the Save-as dialog, under "Save as type", click JPEG and in the File name field, typeGazebo02.JPG. Click
Save.

Explore:
l There are additional Rhino environments in the Render Content\Environments folder. Pick the "+" button on the
Environments panel to browse the Library for these environments.
There are even more Rhino environments available for download at the web site Food4Rhino.

l Trees in this exercise were created with plugin Lands Design for Rhino developed by Asuni Group
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Chapter 15 - Printing and Layouts
Printing
The Print command will let you print one viewport at a time or Print a collection of viewports on the layout.

Exercise 15-1 Printing the model
1. Open the model Print.3dm.
2. Make the Top viewport active.
3. On the Filemenu, click Print.
4. In the Print Setup panel, under Destination, select a printer as the built-in Rhino PDF, Letter paper, Landscape

orientation, Raster Output, and Display Color.

5. Under View and Output Scale, viewport should say Top, and select Extents button.
6. Also under View and Output Scale, select Scale of 2:1, On Paper 1.0 Millimeter, and In Model 0.5 Millimeter.

Rhino will print .5 mm of the model in every 1 mm on the printed sheet.

7. Pick the Print button.
8. In the Save PDF File dialog, specify name and location to save the PDF.

Exercise 15-2 Layouts
Rhino has a Layout feature that will print multiple details of the model on one sheet. The details can have different
scales, sizes, layer color, layer visibility, and object visibility. In addition, you can add multiple layouts to a model.
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Add a layout

1. In the Layers panel, make the Details layer current.
2. On the View menu, click Layout and New Layout.

Or click the on the Viewport Tabs bar, located below the Rhino graphics area.

The layout name is Page 2, by default. The sheet size is offered in the units of the model.
However, selecting a different unit system will let you specify the sheet in more familiar units, without changing
the layout units. Rhino will apply the conversion to create the correct size sheet in your layout units.

3. In theNew Layout dialog, setWidth to 11, select Inches, and set Height to 8.5.
4. Set the Initial Detail Count to 4. Click OK.

5. Double-click to activate the Perspective detail.
6. On the View menu, click the Shaded display mode.
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Configure the perspective detail
To suppress the display of geometry in any detail, hide the object in the detail or turn off the layer in the details.
Objects are hidden in the details with theHideInDetail command and made visible with the ShowInDetail command
In addition, the Layers panel allows a layer to be turned off only in the detail, but remain visible in other details or
viewports.
1. Double-click to activate Perspective detail.
2. In the Layers panel, scroll to the right or undock the panel and stretch it horizontally.
3. Select the Dimensions layer, and click the light bulb icon in the Detail On column.

All the objects on the layers that were turned off in the Detail On column are not visible in the Perspective
viewport but remain visible in all other details.

Note: In the Layers panel, visibility of model and detail layer settings is control by the View button. In the images
above, View all layer settings is checked.

4. Double-click the Perspective detail to de-activate.
5. Select the boundary edge of the detail.
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6. In Object Properties, confirm the Print Width of the detail is set to No Print.
The edge of the detail will not print unless you assign a width.

Assign a scale to details
Details that are parallel can get a scale assigned to them. The scale will tell Rhino how many model units are in each
paper unit. By assigning the scale to the detail, the layout can be plotted 1=1. Also by assigning the scale to the detail,
details can have different scales.
1. Select the Top detail.

Do not double-click to activate.
2. In the Properties panel, click the Detail icon.
3. In the Scale area, set 1.0mm on layout equal to 1mm in model.

The scale is now set to 1=1.
If you set 1mm in the layout equal to 2mm in the model detail, it is half size or 1=2.
If you set 1mm in the layout equal to 10mm in the model detail, the scale is 1=10.

4. Make detail active by Double-clicking it and pan geometry to center in viewport.
5. Deactivate detail by Double-clicking.
6. Select detail and in the Properties panel, click the Detail page, and then click the Locked check box.

Details that are locked prevent zooming or panning.
7. Repeat this procedure for the Front and Right details.

Label details

1. Make a new layer called Notes.
2. Make theNotes layer Red and current.
3. Turn Ortho off, and deactivate any details.

You should be on the layout and not in an active detail.
4. On the Dimensionmenu, click Text Block.
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5. In the Text dialog set theHeight to 7mm and type Top View.

6. Pick the OK button.
7. Pick a point on the layout to locate the text below the Top detail.

8. Repeat to add the labels Front View and Right View.

Add a border

1. On the Curvemenu, click Rectangle, Corner to Corner.
2. Snap to the lower left corner of the Front detail boundary and the upper right corner of the Perspective viewport

boundary.
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3. Select the border.
4. In the Properties panel, on the Object page, click Print Width, and then click 0.70mm.

5. Right-click on the Layout Title (Page 2), and then click Print Preview.
The layout has a thick border around the detailed viewports.
You can also add a title block at this stage if you choose.

Print the layout

1. On the Filemenu, click Print.
2. Select a physical printer or a virtual printer like Rhino PDF.
3. Select sheet size as letter or 11x81/2 landscape.
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4. In the View and Output Scale area, set the scale to 1=1.

5. Toggle Output color between Black &White and Display Color.
6. Click Print to print; Cancel if no printer is available.
7. Save the file.

Scaling and locking details on a layout

Exercise 15-3 Layout the Frigate
1. Open the model SimpleLayout_Print.3dm.

2. Click in the Top viewport.
3. On the View menu, click Layout, click New Layout.
4. Click the Printer list, and select Rhino PDF.
5. Click the Size list, and select in inchesTabloid (11" x 17") or in millameters 432 x 279.5.
6. In theNew Layout dialog, click Landscape.
7. Set the Initial Detail Count to 4.
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8. Adjust any other options appropriate for your printer or plotter, click OK.

A layout page opens and a new viewport tab labeled Page 1 appears at the lower edge of the Rhino window. The
new layout has four detail views, showing the object from the same direction as the four default Rhino viewports.
Details are windows into the 3-Dmodel. They can be activated as modeling viewports by double-clicking in the
viewport.

Set scale and lock details

1. Double-click in the Right detail.

2. If the Properties panel is not open, from the Panelsmenu, click Properties
Note:With no objects are selected in the model, the Properties panel shows the viewport properties.
With no detail active, the properties shown are for the layout as a whole.

3. Click the Edit button to edit the title, and size and printer properties.
4. In the Command line, for the Distance on layout (mm), set it to 1 and press Enter.
5. In the Command line, for the 1.000 millimeter on layout = Distance in model (m), set it to 1 and press Enter.
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6. Change the title to Right Profile, and Lock the detail.
7. Repeat this in the Top and Front details to set all of these details to the same scale.

8. Activate the Perspective detail.
9. On the View menu, click Shaded.

Draw borders and title blocks in the layout space

1. Double-click in the Perspective detail to deactivate it and make the layout space active.
2. In the Layers panel, make a new layer named Title Block and make it current.
3. Draw a Rectangle (Curve>Rectangle>Corner to corner) around the viewports on the Layout.

First corner: 10,10
Other corner or length; 422,269

4. Next, resize the details borders to match the image.
Hint: Use control points, Gumball scale and move, Osnap, Smart Track, etc.

5. On the Filemenu, click Insert.
6. On the Insert dialog, check Prompt under Insertion point, uncheck Prompt under Scale and Rotation. Also

under Scale, keep the check in Uniform.

319



Rhinoceros Level 1 Training Guide

7. On the Insert dialog, click the File icon .

8. In the Select File to Insert dialog, navigate to and pick the fileTitleBlock_Meters .3dm. Click Open.
9. In the Insert File Options dialog, under the Block definition type area, click Embedded. Click OK
10. In the Insert dialog, under Insert as area, click As Group.

Next under Scalewith Uniform check, type 1000. Click OK
11. For the Insertion Point, use the End pt osnap and pick the lower right corner of the rectangle.

A title block is inserted on the layout.

12. Click to select the title block. It is a group and will select as one.
13. Change the title block to the Title Block layer. In the Properties panel, under the Layer list, click the layer Title

Block. All the geometry in the group will be assigned to the selected layer.
14. You can add information to the title block with the Text command.

To edit the text in the group, Shift + Control (sub object selection) and pick on the text.
On the Text Properties page in the Properties panel, you can change the text string, the formatting, font,
justification and more settings.

Add dimensions to the layout space
On the layout use Linear dimensions to measure some features. The dimensions are located on the layout. They will not
display in the model views.
1. On the Toolsmenu, click Options. Click Annotation Style, select Default style and click the Edit button.
2. In the right pane, under the Font section, change theHeight to 2. Click OK.
3. In the Layers panel, make a new layer named Dimensions and make it current.
4. On the Dimensionmenu, click Linear Dimension.
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Use the Continue=Yes option and Baseline=Yes options to create both chain and baseline dimensions.
5. Add more dimensions as needed to the other layout viewports.

Set linetypes and line weights for curves
These are used in printing and can be displayed in the Rhino views using the PrintDisplay and LinetypeDisplay
commands.
1. In the Layers panel, hold down the Ctrl key and select the Border and the Title Block layer.
2. In the Print Width column, change the width to thicker weight of .7mm.
3. Next select only the Dimensions layer. In the Print Width column, change the width to thicker weight of .5mm.
4. Right-click the viewport title Page 1 and from the menu, click Preview.

Notice the difference in thickness of the curves.
Linetypes can be adjusted in a similar way.

Print to Rhino PDF

1. On the Filemenu, click Print.
2. On the Print Setup dialog, make the following changes:

Under Destination, set the printer to Rhino PDF, set the Size to Tabloid (11" x 17") and Landscape, Output
Type as Vector, Output Color as Display Color.
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3. In the View and Output Scale section, under Scale, click 1:1.

4. In the Linetypes and LineWeights section, under Default line click .35mm. This will affect all the objects and
layers whose Print Width is set to Default .

5. Pick the Print button and in the Save PDF File dialog, pick a location. The file name will default to the name the
current file.

6. View and print the PDF with Adobe, Microsoft Edge or your favorite PDF viewer.
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Chapter 16 - Intro to Grasshopper
Grasshopper is a visual scripting platform that is included in Rhino 6.

l With Grasshopper, you will write scripts to automate tasks by dragging controls on to a canvas which is its main
interface.

l Parameters like theNumber Slider, Graph Mapper, Random and Jitter are used to drive infinite design options.
l The Grasshopper design is immediately previewed in the Rhino’s application without generating geometry.
l When final design is selected the geometry is created by “baking” into the Rhino object.

Note: BikeWheels.GH is included in the models folder. You can also print BikeWheels.JPG and follow along with the
exercise.

The Grasshopper UI
Before you start using Grasshopper. you will need to know the parts of the Grasshopper screen. Using the graphic
below, study the names so you will be prepared to do your first Grasshopper definition.

Grasshopper Canvas

1. Window title bar
2. Main menu bar
3. Collection of components
4. Canvas toolbar
5. Grasshopper canvas
6. Recently used GH definitions
7. Current version display
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Category tab and Sub-category panel

1. Category tab
2. Sub-category panel
3. Click Black Bar to open Drop-down menu.
4. Drop-down menu with additional commands
5. Compass
6. Markov widget

Opening the Grasshopper Canvas
1. Begin a new model with template Small Objects Inches.

2. Open the Grasshopper canvas by picking Grasshopper button in the Standard toolbar or typing:
Grasshopper in the Command line.
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3. Double-click on the title bar at the top of the Grasshopper window to expand and compress it. However, leave it
in the open state. (Windows only feature)

The Grasshopper Settings
There are a couple settings that you will use to control the way the Grasshopper interface will look.
1. From the Grasshopper Filemenu, click Preferences.
2. The Grasshopper Settings dialog will appear.
3. In the left pane, highlight Interface.
4. If you are teaching Rhino to younger students, in the right pane, slide the Content Filter to Strict. This will

display the Grasshopper icons in a way that is acceptable to younger users.
5. Check the option Show obscure components.

6. Pick the "X' in the upper right corner of the dialog to save and close Grasshopper Settings.

7. On the Grasshopper menu, pick Display.
8. From the Displaymenu, turn on:

Draw Icons
Draw FancyWires

Canvas Search Feature
In addition to inserting a component from the Grasshopper menu, tabs and panels, you can find a component by name
by double clicking in an open space on Grasshopper canvas.
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A search box will pop-up and you can type in the name of the component to be inserted. A key word search will
display all the components that satisfy the request.

Pick on the command name in the list to insert it on to the Grasshopper canvas.

The Finder
When you open a completed Grasshopper defintion file, you can trace any component or parameter back to its
location on the Category tab. Grasshopper will display a finder arrow that will mark where the component is located on
the Grasshopper menu. Reverse engineering a Grasshopper definition that you find on the Forum or are given by an
expert user is an excellent way to learn more advanced concepts in Grasshopper.
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1. From the Grasshopper Filemenu, click Open Document.
2. Navigate to the files that you downloaded for this training, and open BikeWheels.GH.
3. While hovering over any Grasshopper parameter or component on the canvas, hold down the Control + Alt keys,

while pressing and holding the Left mouse button . The red finder arrows will appear.

4. You will see the arrows while you have the keys and the mouse button pressed. When you let go, the finder arrow
will disappear.
Hint: Use Command + Alt with Rhino for Mac.
This is a helpful way to "reverse engineer" a Grasshopper Definition.

Let's get started with our first simple Grasshopper definition.

Exercise 16-1 The Bike Wheel

Create the Circles
1. On the Grasshopper Filemenu, pick New Document.
2. On the Grasshopper Curve tab, and the Primitive panel, drag and drop two Circle components on to the

Grasshopper canvas.

Grasshopper Canvas Rhino's Top Viewport

3. Double-click on the Grasshopper canvas to open a dialog box with the prompt Enter a search keyword.
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4. TypeNumber and pick Number slider from the menu.

5. A Number slider parameter will be added to the canvas.
6. Drag the output connector from theNumber slider to the input R of the Circle.

7. Now drag the slider and see the radius of the circle in the top view update.

8. To create the second Number slider, double-click on the canvas and type: 24<32<36. With this syntax, the
Number slider will be set to 32, range from 24, to 36, and output integer values. In other words, the domaine of
theNumber slider is between 24 and 36.

9. Connect in theNumber slider output to the input R on the second circle component.

10. Double-click on the Radius label on the first number slider. The Slider dialog will appear.
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11. Edit theMin andMax values. Set theMin to 1, theMax to 10, and the Rounding to N or Natural number
(Integer).

12. Pick the OK button to close the dialog.
13. Drag the first slider to 6.

Divide the Circle
1. On the Curve tab, under Division panel, click Divide Curve and drop two on to the canvas to the right of the

circles.
Hint: To copy a component, tap Alt key while dragging and pick to place the copy.

2. Connect the output circle curve to the Curve input on the Divide Curve component. Repeat for the second
circle.

Connect the Points
By default, the Divide component generates 10 divisions or 10 points on each circle. Now you will make a slider to
control that number of points and connect the points to a line component.
1. Double-click on the Grasshopper canvas and create a slider by typing 5<10<20. This will create a Number slider

that is set to 10, and whose domain is between 5 & 20.
2. Connect the output of theNumber slider to theN of both Divide components.

The number slider will control the number of divisions for both Divide componets
3. Now drag the slider and watch the points increase and decrease.
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4. On the Grasshopper Curve tab, from the Primitive panel, pick Line and place it on the canvas, to the right of the
Divide component.

5. Connect the output Points from the first divide component to the Line input A.
6. Connect the output Points from the second divide component to the Line input B.

The lines are now connecting the points which are dividing both the circle curves.

7. Right click on the Divide components and pick on Preview to disable the preview of points.

Pipe the Curves
The curves will be used to generate surfaces for the wheel and spokes of the wheel.
1. On the Grasshopper Surface tab, under Freeform panel, click Pipe and place it on to the Grasshopper canvas, to

the right of the Line component.
2. Add a second Pipe componet and place it on to the Grasshopper canvas, below the first Pipe .
3. Connect the output from Lines to the Curve input of the first Pipe component.

4. Double-click on the Grasshopper canvas and create a slider by typing .25<1<2. This creates a Number slider that
is set to 1, and whose domain is between .25 & 2.00.

5. Connect the output from theNumber slider to the Radius input of the first Pipe component.
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6. Connect the output from second Circle curve to the input Curve on the second Pipe component.
Hint: To allow multiple inputs, press the Shift key while connecting the outputs to the input.

7. Double-click on the Grasshopper canvas and create a slider by typing .50<1<3. This creates a Number slider that
is set to 1, and whose domain is between .50 & 3.00.

8. Connect the output of the last Number slider to the input of the radius of the second Pipe component.
9. Drag the slider bar and watch the radius of the pipe change.

Orienting the Wheel
The wheel needs to be oriented parallel to the Front view or to the World XZ plane. To do this, you will provide a plane
to orient the circle.
1. On the Grasshopper Vector tab, under Plane panel, click the XZ Plane component and place two XZ Plane on to

the Grasshopper canvas, to the left of each circle component.
2. Connect each Plane output from XZ plane to the Plane input of each Circle component. The entire wheel design

is now oriented in the Front view or the World XZ plane.

Preview the Wheel in Custom Color
The geometry is being previewed in the default Grasshopper colors. In this section, you will assign a colored material to
the wheel and the spokes in Grasshopper.
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1. On the Grasshopper Display tab, under the Preview panel, drag and drop two Custom Preview componets and
place them to the right of each Pipe componet.

2. Connect the output from P from Pipe components to the input Geometry of the Custom Preview components
like shown in the image below.

3. On the Grasshopper Params tab, under Input panel, drag and drop a Color Swatch component to the
Grasshopper canvas to the left of the Custom Preview components like shown in the image below.

4. Drag the output from the Color Swatch components to the input Material override on the Custom Preview
components as shown in the image below.

5. Double-click on the Color Swatch components to select a custom color from the color picker dialog.

The dialog has sliders to set the Hue, Saturation, Value, and Alpha transparency of the custom color. Pick Accept
when the color preview is as you like.
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6. Pick Save Document from the Grasshopper Filemenu, or pick the Save icon from the Grasshopper canvas
toolbar.

7. Save definition asMy BikeWheel.gh.

Bake The Wheel
The wheel geometry is still only being previewed in Rhino. To send the geometry to Rhino for editing, rendering,
printing and more, you will need to Bake from certain components. During the bake, there are options to assign the
geometry to a target layer and group the geometry.
1. On the Grasshopper Params tab, under Primitive panel, click Data component.

The Data component will make a copy of the input to be used collectively in another operation, like Bake.
2. Connect the output from the both Pipe components to the Input of Data.

Hint: To allow multiple inputs, press the Shift key while connecting the outputs to the input.
3. Right click over Data and click Bake from the menu.
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4. Select Layer 03 and Yes, Please to Group the output.

5. In the upper right corner of the Grasshopper canvas, turn off the preview of the Grasshopper geometry.

6. Minimize the Grasshopper window by picking the the "-" button in the upper right corner of the Grasshopper
Window title bar.

7. You will now see the model in Rhino.
8. Render the wheel.
9. Restore the Grasshopper Window by picking the Restore Up button from the minumized Grasshopper toolbar

located in the lower left of the Rhino application window.

Render the model.

Custom bike by Julie Pedalino and Pedalino
Bicycles, Lenexa, Kansas.
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Note: design the bike frame and other features of your
bike using Rhino.
See Prof. Steve Jarvis' ART Final Project
https://vimeo.com/172640973

Additional Grasshopper Resources
l Modelabs Grasshopper Primer, 3rd Ed.
The Grasshopper Primer 3rd edition, has been translated in four languages, including Spanish, German, Russian.

l Grasshopper Web Site
l Grasshopper on the Rhino Support Forum
l Grasshopper: New in Rhino 6
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Chapter 17 - Transforming solids
It is much easier to model things on a flat plane than it is on an organic surface or any other 3-D shape. Rhino has
several tools that allow you to model something in a simple way and then transform it onto a surface or a curve in 3-D
space. In this chapter, you will use two commands that do this: Flow and FlowAlongSrf.

Flow along surface
The FlowAlongSrf command morphs objects from a source surface to a target surface.
Modeling on a curved surface is difficult and hard to achieve accurate results. The FlowAlongSrf command simplifies
the process by allowing you to model on the flat construction plan first. Then FlowAlongSrf to morphs objects from a
source surface to follow target surface.

Exercise 17-1 Flow solid text
1. Open the model FlowAlongSrf.3dm
2. On the Transformmenu, click Flow Along Surface.
3. For the Select objects to flow along a surface, select the solid text and press Enter.

The text is a group and will select as one.

4. For the Base surface, select the lower left corner of cyan surface.
5. For the Target surface, select the lower left corner of the magenta target surface.

The text is flowed to the target surface.

6. Undo FlowAlongSrf.
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Surface direction
The success of the FlowAlongSrf depends on the direction of the base and target surface. Each surface has a normal
direction, a U direction, and a V direction. Ideally, the normal, U and V directions on the base surface should
correspond to the normal, U and V directions on the target surface.
The direction arrow colors are:

l U=Red
l V=Green
l Normal=White

Check the surface direction

1. Select both the cyan and magenta colored surfaces.
2. On the Analyzemenu, click Direction.
3. At the Select object to flip direction, you can click either surface to change the normal direction, press Enter

when done.
You can use theNextMode option to toggle through all of the possible changes to U, V, and Normal directions.

4. If you only need to change one surface, select it and start the Dir command again.
5. Make any necessary changes to the direction of the surface so that the U, V, Normal directions match between

the two surfaces.

History and Gumball
Now let’s combine FlowAlongSrf with RecordHistory. RecordHistory keeps the objects to be flowed and the objects
that have been flowed linked. If the original objects are moved, scaled, or rotated, the flowed objects will update.

Flow with history and gumball

1. On the Status Bar turn on Gumball and RecordHistory.

2. On the Transformmenu, click Flow Along Surface.
3. For the Select objects to flow along a surface, select the solid text and press Enter.

4. For the Base surface, select the lower left corner of cyan surface.
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5. For the Target surface, select the lower left corner of the magenta target surface.
The text is flowed to the target surface.

Note: The Record History pane is toggled off as soon as the Flow Along Surface command is complete. By
default the Always Record History option is not checked. If you want to record history on another command,
you will need to select it before you run the next command that supports history.
See theHelp for a complete listing of History Enabled Commands.

6. Select the original text on the base surface.

7. Use the Gumball arrow to move the text to the right.
Notice that after you release the text on the base surface, the flowed text is updated on the target surface.

Note: If the flowed text does not update, return to step 1 and make sure Record History is on before starting
FlowAlongSrf.

8. Select the original text on the base surface.
9. Use the Gumball arc to rotate the text to the left.
10. Release your mouse button and watch the flowed text update.

11. Select the original text on the base surface.
12. Using the Gumball red scale handle, and the Shift key held down, pull to the handle to the left.
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13. Release your mouse and watch the flowed text update.

Flow a logo onto a free-form surface

Exercise 17-2 Flow logo to penguin
Create the base surface

1. Open the model PenguinBrand.3dm.

2. On the Layers panel, make the curves layer current.
3. Select the magenta surface (front panel) on the penguin.
4. On the Curvemenu, click Curve from Objects, then Create UV Curves and press Enter. 

The UV curves are created at the origin of the World XY plane.
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5. On the Layers panel, make the surface layer current.
6. Select the closed curve, and on the Surfacemenu, click Planar Curves.

To flow the Logo

1. Turn on RecordHistory on the Status Bar.
2. In the Layers panel turn on the logo layer.

The logo appears.

3. Select the logo.

4. On the Transformmenu, click Flow Along Surface.
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5. For the Base surface, select the lower left corner of green surface.

6. For the Target surface, select the lower left corner of the magenta surface.

7. Turn on Gumball on the Status Bar.
8. Use Gumball tomove, scale and rotate the original logo on the base surface.

The flowed logo updates.

9. On the Render menu, Render to render the model.
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Flow
The Flow command re-aligns an object or group of objects from a base curve to a target curve.

Steps

1. Select objects.
2. Select the base curve near one end.
3. Select the target curve near the matching end.

Similar to Flow Along Surface, the Flow command lets you flow solids along a curve. This makes designing in 3-D
easier on the construction plane and lets Rhino do all the morphing work.

Exercise 17-3 Making a Ring with Flow
Flow the parts of a ring along the shank curve

1. Open the model Flow_ring.3dm.
2. Select the green polysurface as the object to flow.
3. On the Transformmenu, click Flow along Curve.

4. For the Base curve, select the red linear curve towards the left end.

Base curve.
5. Stop at this stage and confirm the following option settings in the Command line (Copy=Yes Rigid=No

Stretch=No).
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6. As the Target curve, select the circle curve slightly below the point location.

The polysurface is morphed or flowed to the shape of the target curve.
Notice that the polysurface doesn’t flow completely around the circle.

7. Undo.

You will flow this polysurface a few more times and use different options.
First, you will change the direction of the Flow.

Flow the parts of a ring along the shank curve in a different direction

1. Repeat Flow along curvewith identical steps, except select the Base Curve near the opposite end.
Note: In the Perspective viewport, change the display mode to Ghosted to view and select the base curve more
easily.

Base curve.
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2. As the Target curve, select the circle curve slightly below the point location.

Notice that the inside and outside of the original polysurface has flipped.
3. Undo again.

Bottom of original polysurface is on the outside.

Top of original polysurface is on the inside.
Second, you will stretch the original polysurface so that it fits completely around the circle.

Flow the parts of a ring along the shank curve, stretching it to fit the whole curve

1. Repeat Flow along curve the same way you did it the first time, selecting the Base Curve near the left end.
Note: In the Perspective viewport, change the display mode to Ghosted to view and select the base curve more
easily.
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2. Stop at this stage and confirm the following option settings in the Command line (Copy=Yes Rigid=No
Stretch=Yes).

3. Select the circle curve slightly below the point location as the Target curve.

The polysurface is morphed or flowed completely around the circular shape of the target curve.
4. Use theWhat command to confirm that it is a closed solid polysurface.
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Flow the gems and bezels

1. Hide both the original polysurface and the flowed polysurface.
2. On the Transformmenu, click Flow along Curve.
3. For the Objects to flow, you will select the gems and bezels by layer.

4. In the Layers panel, Right click on the Bezel layer. Pick Select objects from the cursor menu.
5. In the Layers panel, right click on the Gem_ruby layer. Pick Select objects from the cursor menu.
6. Enter to close the object selection.
7. Next, select the Base Curve near the left end.
8. Stop at this stage and confirm the following option settings in the Command line:

(Copy=Yes Rigid=No Stretch=Yes).
9. As the Target curve, select the circle curve slightly below the point location.

The bezels and gems are morphed to fit around the circle.

10. Examine the results.
The sides of the bezels are not perpendicular, the top surface is not flat, and gem is stretched.

11. Undo.
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To flow the gems and bezels with Rigid=Yes

1. On the Transformmenu, click Flow along Curve.
2. For the Objects to flow, select the gems and bezels in the Layers panel.

In the Layers panel, right-click on the Bezel layer. Pick Select objects from the cursor menu.
In the Layers panel, right-click on the Gem_ruby layer. Pick Select objects from the cursor menu.

3. Enter to close the object selection.

4. Select the Base Curve towards the left end.
5. Stop at this stage and confirm the following option settings in the Command line:

(Copy=Yes Rigid=Yes Stretch=Yes).
6. As the Target curve, select the circle curve slightly below the point location.

The bezels and gems are stretched to fit around the circle, but the objects are not deformed.

7. Examine the results.
The sides of the bezels are perpendicular, the top surface is flat, and gem is not stretched.
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8. Show the green polysurface again.

View the ring in a rendered viewport

1. On the View menu, click Rendered.
A Rubymaterial is assigned to the Gem_ruby layer.
A Goldmaterial is assigned to the Bezel and Ring layers.
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2. Render the ring.
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