彩現後處理效果

彩現視窗有一些彩現後的功能,例如:通道顯示、色調對應、後處理效果、縮放...等。

工具列

複製彩現視窗

建立目前彩現視窗的複本,便於比較不同的後處理效果設定的差別。

另存新檔

將彩現影像儲存為一般的圖片檔案,使用支援高動態範圍的彩現器時可以儲存特殊的 HDRi 與 OpenEXR 格式。

支援的檔案類型
複製

複製整個按鈕圖示至 Windows 剪貼簿。

顯示 RGB 通道

以所有的顏色通道顯示彩現影像。

請參考:Wikipedia: Channel (digital image)

顯示紅色通道

只顯示彩現影像的紅色通道。

顯示綠色通道

只顯示彩現影像的綠色通道。

顯示藍色通道

只顯示彩現影像的藍色通道。

顯示 Alpha 通道

只顯示彩現影像的 Alpha (透明) 通道。

請參考:Webopedia: Alpha channel

顯示距離通道

以灰階色顯示彩現影像裡每一個像素距攝影機的遠近。

請參考:Wikipedia: Z-Buffering

開啟效果面板

效果面板可以設定彩現影像的曝光度及加入各種後處理效果。

停止彩現

終止彩現運算。

Pause

Pauses and resumes the rendering process.

檔案功能表

複製彩現視窗

建立目前彩現視窗的複本,便於比較不同的後處理效果設定的差別。

開啟舊檔

開啟 Rhino 的彩現影像檔案 (.rimage),這個檔案格式可以儲存所有的通道,檔案重新開啟後可以再加入後處理效果。

另存新檔

將彩現影像儲存為一般的圖片檔案,使用支援高動態範圍的彩現器時可以儲存特殊的 HDRi 與 OpenEXR 格式。

支援的檔案類型

列印

以印表機列印彩現影像。

The printing controls are basic and do not support the kind of color management a high-quality image printing system would. The recommended way to print rendered images is to save the image and transfer to a dedicated image-processing application.

最近的彩現影像

開啟最近彩現的影像,這些是彩現時自動儲存的 Rhino 彩現影像檔案格式 (.rimage)。

結束

關閉彩現視窗。

編輯功能表

複製

複製整個按鈕圖示至 Windows 剪貼簿。

檢視功能表

工具列

顯示/隱藏工具列。

效果面板

效果面板可以設定彩現影像的曝光度及加入各種後處理效果。

顯示彩現影像

顯示/隱藏彩現影像。

縮放

在彩現視窗裡放大、縮小彩現影像,實際的像素不會改變。

通道
預設值 RGB

以所有的顏色通道顯示彩現影像。

請參考:Wikipedia: Channel (digital image)

紅色

只顯示彩現影像的紅色通道。

綠色

只顯示彩現影像的綠色通道。

藍色

只顯示彩現影像的藍色通道。

Alpha

只顯示彩現影像的 Alpha (透明) 通道。

請參考:Webopedia: Alpha channel

Z-Buffer

以灰階色顯示彩現影像裡每一個像素距攝影機的遠近。

請參考:Wikipedia: Z-Buffering

法線 X

Displays normals in the x direction as grayscale.

法線 Y

Displays normals in the y direction as grayscale.

法線 Z

Displays normals in the z direction as grayscale.

遞色

一種像素混色運算,可以避免彩現影像出現明顯的色階。

請參考:Wikipedia: Dither

無

不使用遞色。

Floyd-Steinberg

繪圖軟體將全彩的相片轉換為有 256 色限制的 GIF 圖片時常用的遞色計算方法。

簡易雜訊

加入隨機運算的雜訊。

說明功能表

開啟目前的彩現器的說明主題。

效果面板

含有各種彩現後處理效果設定的面板。

曝光面板

曝光面板上有中間色修正與色調對應的設定。

中間色修正

因為螢幕從暗到亮的變化並非線型的,中間色的顯示會偏暗,所以一般圖片為了要在螢幕上看起來顏色正確會預先做與螢幕相反的中間色修正,把中間色加亮。彩現後的影像如果有中間色偏暗或偏亮的問題可以利用這個數值做修正。

請參考:Wikipedia: Gamma correction

使用線性流程

一般的圖片都有經過中間色修正,彩現器利用這種經過修正的非真實影像來進行彩現運算得到的結果當然也不會是正確的,可能會有亮部過亮、暗部過暗的問題。使用線性流程的意思是圖片在進入彩現運算之前先把預設的中間色修正還原,使圖片具有線性的明暗變化,這樣可以得到更真實的彩現結果。


中間色小於 1 (左)、預設值 1 (中)、大於 1 (右)。

請參考:What is linear work flow and how can it help your renders look better

色調對應

色調對應是將高動態範圍的亮度資訊轉換為螢幕可顯示的低動態範圍影像的演算方法,這裡提供了幾種不同的色調對應演算法。

請參考:Wikipedia: High dynamic range imaging

黑/白點

在指定為黑色與白色的點之間以線性變化,通常一般圖片黑點的值為 0.0,白點的值為 1.0。

黑色點

設定黑色點的數值。

白色點

設定白色點的數值。

對數

請參考:Adaptive Logarithmic Mapping For Displaying High Contrast Scenes, by F. Drago, K. Myszkowski, T. Annen and N. Chiba

色階分布

統計數位影像裡每一個像素的亮度值,以圖形顯示亮度的分布情形,一眼就可以看出彩現影像是偏亮或偏暗,可以做為色調修正的參考。

請參考:Wikipedia: Image histogram

儲存為檔案預設值
預設為顯示這個面板

後處理效果面板

後處理效果面板含有所有可用的後處理效果項目。

這裡可以啟用/停用不同的後處理效果,以上移與下移按鈕調整效果的順序,排序在前的效果會先計算。

後處理效果是彩現後的圖形運算處理,可以在彩現影像加入特殊的效果。

工具列

啟用

開啟/關閉選取的效果。

上移

將選取的效果在清單中往上移動,優先運算該效果。

下移

將選取的效果在清單中往下移動,讓在它前面的效果優先運算。

內容

開啟選取的效果的內容對話框。

儲存為預設值

儲存目前的後處理效果清單與設定,可以套用到後續的彩現影像。

霧氣

霧氣效果是以像素離攝影機的距離遠近不等量加上設定的顏色,這個效果可以加入濃厚的霧氣,也可以加入淡薄的霧氣用以增加彩現影像遠處的距離感。

霧氣內容

視覺效果內容

強度

設定霧氣的最大濃度,0 等同於關閉霧氣效果,數值越大霧氣越濃。數值大於 1 時要使用雜訊才有意義。

雜訊

在霧氣加入隨機變化的強度。

霧氣顏色

調整霧氣的顏色。

指定

從彩現影像指定顏色。

以滴管在彩現影像選取顏色。

作用區域

起點距離

從攝影機位置算起的距離,從這個距離開始產生霧氣效果。

指定

從彩現影像指定距離。

終點距離

從攝影機位置算起的距離,從這個距離霧氣達到最大濃度。

指定

從彩現影像指定距離。

範圍

上 / 下 / 左 / 右

設定彩現影像受霧氣影響的區域,可以用來產生距離地面較近的低高度霧氣效果。

指定區域

在彩現影像上框選範圍。

霧氣背景

設定彩現背景是否做霧氣處理,開啟這個選項時,背景以最大強度進行霧氣處理。

羽化

設定模糊範圍邊緣漸變區的大小 (像素)。

預覽

變更對話框裡的設定後可以預覽結果。

用上下微調的按鈕改變
間率的數字
鍵 間率

Shift

0.05

Alt

0.01

Ctrl

0.002

光暈

在指定的顏色的週圍產生發光效果,可以用在 LED 燈或霓虹燈的彩現。

光暈內容

視覺效果內容

啟用

開啟顏色的光暈效果。

顏色

彩現影像裡最多可以設定十種會產生光暈效果的顏色。

按顏色方塊,以取色滴管選取彩現影像中的顏色。

以滴管在彩現影像選取顏色。

臨界值

設定相近的顏色是否產生光暈效果的範圍。

光暈大小

高亮度像素產生光暈效果的半徑。

增益值

光暈效果的倍數值,預設值 1.0 可以產生一般的光暈效果,數值越高光暈的效果越強烈。

預覽

變更對話框裡的設定後可以預覽結果。

用上下微調的按鈕改變
間率的數字
鍵 間率

Shift

0.05

Alt

0.01

Ctrl

0.002

光芒

光芒是以亮度高低決定是否產生光芒效果,光芒的效果通常用於夜間場景,可以使燈光看起來更具真實感。

光芒內容

白點界線

設定開始產生光芒效果的臨界點,這個數值可以直接在色階圖上指定,色階圖在白點界線右邊的像素都會產生光芒效果。

光芒大小

高亮度像素產生光芒效果的半徑。

增益值

光芒效果的倍數值,預設值 1.0 可以產生一般的光芒效果,數值越高光芒的效果越強烈。

使用光度資訊

以光度資訊計算光芒的效果,當彩現影像裡沒有光度資訊時這個選項無法使用,一般以光線追蹤計算的彩現影像即未包含光度資訊。

預覽

變更對話框裡的設定後可以預覽結果。

用上下微調的按鈕改變
間率的數字
鍵 間率

Shift

0.05

Alt

0.01

Ctrl

0.002

景深

彩現影像以像素離攝影機的距離遠近加上不等量的模糊效果。

景深內容

視覺效果內容

模糊強度

設定模糊量的大小,不同的彩現影像可能需要不同的模糊強度才能產生適當的效果。

最大模糊度

設定高斯模糊計算的最大半徑,避免模糊量非常大的區域拖累模糊計算的速度。

作用區域

焦距

攝影機鏡頭至焦點的距離,也是彩現影像經過模糊處理後最清晰的點。

指定

從彩現影像指定距離。

模糊背景

設定彩現背景是否做模糊處理,開啟這個選項時,背景以最大模糊度進行模糊處理。

預覽

變更對話框裡的設定後可以預覽結果。

用上下微調的按鈕改變
間率的數字
鍵 間率

Shift

0.05

Alt

0.01

Ctrl

0.002

點物件、曲線、結構線、註解

這四個選項決定是否在彩現影像裡顯示點物件、曲線、結構線與註解。

Line and point sizes are determined by the Rendered viewport display settings.


點物件開啟 (左)、曲線開啟 (右)。

結構線開啟 (左)、註解開啟 (右)。

色調

彩現後調整材質的顏色。

可以用來改變彩現影像裡某個部分的顏色,不必重新彩現整個場景。

這個功能純粹只是改變彩現影像裡顏色相同的像素的顏色,不會重新計算這個顏色經過物件的反射與折射後得到的顏色。

色調內容

材質 1 / 2 / 3

可以指定三種要改變的顏色。

取色滴管

按取色滴管,在彩現影像裡指定一個顏色。色調後處理效果對飽和度為 0 的顏色 (例如:白色、灰色或黑色) 沒有作用。

顏色預覽方塊

顯示目前的顏色。

色調變更值

所有相同顏色的像素都會因為這個數值的變更而改變。

預覽

變更對話框裡的設定後可以預覽結果。

用上下微調的按鈕改變
間率的數字
鍵 間率

Shift

0.05

Alt

0.01

Ctrl

0.002

重設

將所有設定回復為預設值。

飽和度

飽和度內容

飽和度

設定飽和度的量,數值越小彩現影像越偏灰階色,數值越大越鮮豔。

染色

設定當飽和度設為 0 時用以取代中灰色的顏色,如果您想將彩現影像整體染上某個顏色,可以設定該顏色,並將飽和度設為 1 以下的數值。

預覽

變更對話框裡的設定後可以預覽結果。

用上下微調的按鈕改變
間率的數字
鍵 間率

Shift

0.05

Alt

0.01

Ctrl

0.002

重設

將所有設定回復為預設值。

焦距模糊

Focal blur is a quick version of the Focal Blur Properties. The parameters are compatible with 35mm single-lens-reflex camera and depend on the camera lens length in the viewport to render.

快速焦距模糊是依據每一個像素的深度將像素放大,放大後的像素相互重疊產生模糊效果。焦距平面的像素不放大,最小、最清晰。距離焦距平面越遠的像素越放大、越模糊。

快速焦距模糊只是彩現後針對像素所做的非精確的後處理效果,物件因為位置前後不同在視角上重疊的邊緣會有模糊計算的瑕疵,慢速焦距模糊可以避免這個問題。

焦距模糊內容

焦距

從攝影機的位置算起至與視圖方向垂直的聚焦平面的距離,與真實世界的單眼相機的焦距環的功能相同。

光圈

光圈數值越大聚焦區域的深度越廣,數值越小聚焦區域的深度越窄。

Update slow focal blur settings in document properties

將這裡的焦距模糊設定套用至文件內容 > Rhino 彩現 > 焦距模糊頁面,在後續的彩現加入精確的慢速焦距模糊計算。

預覽

變更對話框裡的設定後可以預覽結果。

用上下微調的按鈕改變
間率的數字
鍵 間率

Shift

0.05

Alt

0.01

Ctrl

0.002

重設

將所有設定回復為預設值。

高斯模瑚

在彩現影像加入一般平面繪圖軟體常見的高斯模糊效果。

高斯模糊內容

水平

只做水平方向的高斯模糊處理。

垂直

只做垂直方向的高斯模糊處理。

雙向

平水與垂直方向皆做高斯模糊處理。

預覽

變更對話框裡的設定後可以預覽結果。

用上下微調的按鈕改變
間率的數字
鍵 間率

Shift

0.05

Alt

0.01

Ctrl

0.002

重設

將所有設定回復為預設值。

雜訊

在彩像影像加入雜訊。

雜訊內容

雜訊

雜訊後處理效果預設是將 RGB 通道分開處理,所以純灰階的彩現影像加入的雜訊會是隨機的顏色。

單色

只對像素的明暗度做隨機變化。

預覽

變更對話框裡的設定後可以預覽結果。

用上下微調的按鈕改變
間率的數字
鍵 間率

Shift

0.05

Alt

0.01

Ctrl

0.002

重設

將所有設定回復為預設值。

Rhino 彩現影像檔案格式 (.rimage)

Rhino 預設的彩現器的彩現影像可以儲存為 .rimage 檔案,這種檔案格式可以儲存許多彩現資訊,包括:顏色、Alpha、距離、法線,每一個通道都可以儲存 32 位元的資料。

這些資訊是彩現視窗的各種後處理效果計算的來源資料,其它彩現外掛程式的開發人員也可以在彩現視窗裡加入自訂的後處理效果。

.rimage 是 Rhino 彩現視窗特有的檔案格式,其它軟體無法開啟。它可以儲存高動態範圍資訊,這些資訊可以無損轉移至 .HDR 與 .EXR 格式。因為它是未壓縮的格式,所以檔案可能非常巨大。

開啟 .rimage 檔案

每次彩現完成都會自動在暫存檔資料夾儲存一個 .rimage 檔案,以後重新開啟這些檔案仍然可以編輯所有的後處理效果,就像剛才完成的彩現一樣。

開啟最近的 .rimage 檔案

彩現影像後處理效果的進一步資訊請參考:彩現影像後處理效果

請參考

彩現模型場景

建立彩現的照明燈光

使用材質與貼圖

 

 

 

Rhinoceros 6 © 2010-2017 Robert McNeel & Associates. 10-一月-2018