# Table of Contents

## 1 - Introduction

- The Rhino interface ................................................. 1
- Rhino commands .................................................. 2
- Using templates .................................................. 3
- Start from the menu ............................................. 3
- Start from a toolbar icon ....................................... 5
- Start from the command line ................................... 7
- Undo a mistake ................................................... 9
- Command history ............................................... 9
- Command options ............................................. 9
- Repeat the last command .................................... 11
- Cancel a command ........................................... 11
- Get help any time ............................................. 12

## 2 - Rhino Objects

- Why NURBS modeling .......................................... 13
- Points .................................................................. 13
- Curves .................................................................. 14
- Surfaces ............................................................. 14
  - Closed and open surfaces ................................... 15
  - Trimmed and untrimmed surfaces ....................... 15
  - Surface isoparametric and edge curves ............... 17
  - Curve and surface degree .................................. 17
- Control points .................................................... 19
  - Control point visibility ...................................... 19
  - Change control point locations ......................... 19
  - Add, delete, or redistribute control points .......... 19
- Polysurfaces ........................................................ 20
- Solids .................................................................. 20
- Light-weight extrusion objects ............................. 21
- Polygon mesh objects .......................................... 22

## 3 - Selecting Objects

- Select and deselect objects .................................... 23
- Choose Objects menu .......................................... 25
- Select objects with windows ................................. 25
- Other ways of selecting objects ............................. 28
4 - Navigating Viewports ................................................................. 31
   Viewport title ........................................................................... 31
   Viewport projection .................................................................. 32
      Parallel .................................................................................. 32
      Perspective ............................................................................. 32
      Two Point Perspective .............................................................. 33
   Viewport navigation .................................................................... 33
      Mouse navigation ..................................................................... 33
      Key and mouse combinations ................................................ 34
   Viewport display modes .............................................................. 35
      Wireframe .............................................................................. 35
      Shaded .................................................................................. 36
      Rendered ................................................................................ 37
      Raytraced .............................................................................. 37
      Other shaded modes ............................................................... 37

5 - Accurate Modeling .................................................................... 39
   The Rhino cursor ........................................................................ 39
   Grid snap ................................................................................... 40
   Ortho mode ............................................................................... 40
   Object snaps ............................................................................. 42
      Persistent object snaps .............................................................. 42
      One-time object snaps .............................................................. 42
      Object snaps using references ................................................ 44
   Constrain cursor movement ....................................................... 44
      Ortho ...................................................................................... 44
      Distance constraint .................................................................. 44
      Angle constraint ...................................................................... 45
      Distance and angle together ................................................... 45
   SmartTrack™ ............................................................................ 46
   Coordinate systems .................................................................... 47
      Right-hand rule ........................................................................ 47
      Construction plane coordinates ................................................. 47
      Relative coordinates ................................................................ 48
      World coordinates ................................................................... 49
   Elevator mode ............................................................................ 49

6 - Create Surfaces from Curves .................................................... 53
   Surface from edge curves .......................................................... 53
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extrude curves</td>
<td>54</td>
</tr>
<tr>
<td>Loft curves</td>
<td>55</td>
</tr>
<tr>
<td>Revolve curves</td>
<td>56</td>
</tr>
<tr>
<td>Revolve curves with a rail</td>
<td>58</td>
</tr>
<tr>
<td>Sweep along one rail curve</td>
<td>60</td>
</tr>
<tr>
<td>Sweep along two rail curves</td>
<td>61</td>
</tr>
<tr>
<td><strong>7 - Edit Curves and Surfaces</strong></td>
<td><strong>63</strong></td>
</tr>
<tr>
<td>Join</td>
<td>63</td>
</tr>
<tr>
<td>Explode</td>
<td>67</td>
</tr>
<tr>
<td>Trimming and Splitting</td>
<td>69</td>
</tr>
<tr>
<td>Trim</td>
<td>69</td>
</tr>
<tr>
<td>Split</td>
<td>71</td>
</tr>
<tr>
<td>Untrim</td>
<td>73</td>
</tr>
<tr>
<td><strong>8 - Transforms - Move, Copy, Rotate, and Scale</strong></td>
<td><strong>75</strong></td>
</tr>
<tr>
<td>Move</td>
<td>75</td>
</tr>
<tr>
<td>Move objects by dragging</td>
<td>77</td>
</tr>
<tr>
<td>Move objects using elevator mode</td>
<td>77</td>
</tr>
<tr>
<td>Copy objects</td>
<td>80</td>
</tr>
<tr>
<td>Rotate</td>
<td>82</td>
</tr>
<tr>
<td>Scale</td>
<td>84</td>
</tr>
<tr>
<td>Mirror</td>
<td>86</td>
</tr>
<tr>
<td><strong>9 - Organization - Layers, Groups, and Blocks</strong></td>
<td><strong>89</strong></td>
</tr>
<tr>
<td>Layers</td>
<td>89</td>
</tr>
<tr>
<td>Popup layer list</td>
<td>89</td>
</tr>
<tr>
<td>Layers panel</td>
<td>90</td>
</tr>
<tr>
<td>Groups</td>
<td>91</td>
</tr>
<tr>
<td>Blocks</td>
<td>92</td>
</tr>
<tr>
<td><strong>10 - Annotation: Dimensions and Text</strong></td>
<td><strong>93</strong></td>
</tr>
<tr>
<td>Dimensions</td>
<td>93</td>
</tr>
<tr>
<td>Annotation Text</td>
<td>94</td>
</tr>
<tr>
<td>Leaders</td>
<td>94</td>
</tr>
<tr>
<td>Dots</td>
<td>95</td>
</tr>
<tr>
<td>Hatching</td>
<td>95</td>
</tr>
<tr>
<td>Hidden line removal</td>
<td>96</td>
</tr>
<tr>
<td>Notes</td>
<td>96</td>
</tr>
<tr>
<td><strong>11 - Curve and Surface Analysis</strong></td>
<td><strong>97</strong></td>
</tr>
<tr>
<td>Measure distance, angle, and radius</td>
<td>97</td>
</tr>
<tr>
<td>Direction</td>
<td>97</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Visual surface analysis</td>
<td>98</td>
</tr>
<tr>
<td>Curvature analysis</td>
<td>98</td>
</tr>
<tr>
<td>Environment map</td>
<td>99</td>
</tr>
<tr>
<td>Zebra</td>
<td>99</td>
</tr>
<tr>
<td>Draft angle analysis</td>
<td>99</td>
</tr>
<tr>
<td>Edge evaluation</td>
<td>100</td>
</tr>
<tr>
<td>Diagnostics</td>
<td>100</td>
</tr>
<tr>
<td>12 - Render</td>
<td>101</td>
</tr>
<tr>
<td>Lights</td>
<td>101</td>
</tr>
<tr>
<td>Materials</td>
<td>102</td>
</tr>
<tr>
<td>Environment</td>
<td>102</td>
</tr>
<tr>
<td>Ground Plane</td>
<td>103</td>
</tr>
<tr>
<td>Render Preview</td>
<td>103</td>
</tr>
<tr>
<td>13 - Solids and Transforms - Pull Toy</td>
<td>105</td>
</tr>
<tr>
<td>Enter coordinates</td>
<td>105</td>
</tr>
<tr>
<td>Draw the pull toy body</td>
<td>106</td>
</tr>
<tr>
<td>Draw the axles and wheel hubs</td>
<td>108</td>
</tr>
<tr>
<td>Draw the lug nuts</td>
<td>110</td>
</tr>
<tr>
<td>Array the lug nuts</td>
<td>112</td>
</tr>
<tr>
<td>Draw the tires</td>
<td>113</td>
</tr>
<tr>
<td>Mirror the wheels</td>
<td>115</td>
</tr>
<tr>
<td>Draw the eyes</td>
<td>116</td>
</tr>
<tr>
<td>Make the pull cord</td>
<td>118</td>
</tr>
<tr>
<td>14 - Tutorial: Revolve Curves - Flashlight</td>
<td>123</td>
</tr>
<tr>
<td>Set up the guides</td>
<td>124</td>
</tr>
<tr>
<td>Draw the body profile curve</td>
<td>125</td>
</tr>
<tr>
<td>Draw the lens profile curve</td>
<td>126</td>
</tr>
<tr>
<td>Build body and lens surfaces</td>
<td>129</td>
</tr>
<tr>
<td>Use History</td>
<td>131</td>
</tr>
<tr>
<td>15 - Tutorial: Sweep, Loft, and Extrude - Headphones</td>
<td>133</td>
</tr>
<tr>
<td>Create the speaker shell</td>
<td>134</td>
</tr>
<tr>
<td>Sub-object selection</td>
<td>135</td>
</tr>
<tr>
<td>Create the padding and cover</td>
<td>138</td>
</tr>
<tr>
<td>Create the mounting bracket</td>
<td>140</td>
</tr>
<tr>
<td>Create the headband</td>
<td>143</td>
</tr>
<tr>
<td>Round the headband ends</td>
<td>148</td>
</tr>
<tr>
<td>Create the speaker wire</td>
<td>152</td>
</tr>
<tr>
<td>Mirror the headphone parts</td>
<td>156</td>
</tr>
<tr>
<td>Tutorial: Loft and Sweep - Boat</td>
<td>159</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-----</td>
</tr>
<tr>
<td>Lay out the hull curves</td>
<td>160</td>
</tr>
<tr>
<td>Check the curves for fairness</td>
<td>161</td>
</tr>
<tr>
<td>Fix the curvature</td>
<td>163</td>
</tr>
<tr>
<td>Improve the curve further</td>
<td>164</td>
</tr>
<tr>
<td>Create the 3-D curves</td>
<td>166</td>
</tr>
<tr>
<td>Revise the curves</td>
<td>168</td>
</tr>
<tr>
<td>Loft the hull surfaces</td>
<td>170</td>
</tr>
<tr>
<td>Create the other side of the hull</td>
<td>171</td>
</tr>
<tr>
<td>Build the transom</td>
<td>173</td>
</tr>
<tr>
<td>Add the deck</td>
<td>176</td>
</tr>
<tr>
<td>Compromise between concept and reality</td>
<td>176</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tutorial: Point Editing and Blending - Penguin</th>
<th>181</th>
</tr>
</thead>
<tbody>
<tr>
<td>The body</td>
<td>182</td>
</tr>
<tr>
<td>The eyes</td>
<td>188</td>
</tr>
<tr>
<td>The beak</td>
<td>191</td>
</tr>
<tr>
<td>The feet</td>
<td>194</td>
</tr>
<tr>
<td>The tail</td>
<td>200</td>
</tr>
<tr>
<td>The wings</td>
<td>202</td>
</tr>
<tr>
<td>Finishing touches</td>
<td>205</td>
</tr>
<tr>
<td>Add a light and materials</td>
<td>206</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tutorial: Trace Images - Dragonfly</th>
<th>209</th>
</tr>
</thead>
<tbody>
<tr>
<td>Place the reference images</td>
<td>211</td>
</tr>
<tr>
<td>Trace the chest and body</td>
<td>215</td>
</tr>
<tr>
<td>Create the body segments</td>
<td>220</td>
</tr>
<tr>
<td>Create the tail</td>
<td>222</td>
</tr>
<tr>
<td>Create the chest</td>
<td>229</td>
</tr>
<tr>
<td>Create the head</td>
<td>232</td>
</tr>
<tr>
<td>Add the neck</td>
<td>235</td>
</tr>
<tr>
<td>Create the eyes</td>
<td>237</td>
</tr>
<tr>
<td>Trace the wings</td>
<td>240</td>
</tr>
<tr>
<td>Create the legs</td>
<td>242</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tutorial: Flow Along a Surface - Wrap Text</th>
<th>245</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create the planar reference plane</td>
<td>246</td>
</tr>
<tr>
<td>Create text objects to wrap</td>
<td>247</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tutorial: Blocks - Mechanical Part</th>
<th>251</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create solid shapes</td>
<td>251</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Drill the holes</td>
<td>255</td>
</tr>
<tr>
<td>Copy the holes</td>
<td>256</td>
</tr>
<tr>
<td>Make a 2-D drawing</td>
<td>258</td>
</tr>
<tr>
<td>Dimension the 2-D drawing</td>
<td>259</td>
</tr>
<tr>
<td><strong>21 - Tutorial: Layouts - Title Block</strong></td>
<td>263</td>
</tr>
<tr>
<td>Layout viewports</td>
<td>264</td>
</tr>
<tr>
<td>Insert a title block</td>
<td>265</td>
</tr>
</tbody>
</table>
1 - Introduction

Modeling in 3-D is the process of creating a mathematical representation of an object's surfaces. The resulting model is displayed on your screen as a two-dimensional image. Rhino provides tools for creating, displaying, and manipulating these surfaces.

The Rhino interface
The image below illustrates some of the major features of the Rhino window.

Menu (1)
The menus group Rhino commands by function.

History window (2)
The command history window displays the previous commands and prompts.

Command box (3)
The command box displays a typed command. Once the command is accepted, the prompts, options and a Value box appear in this space.
Toolbars (4)
Toolbars contain graphical icons for initiating commands. Many toolbar icons have a second command that you can access by right-clicking the icon. The tooltip that appears when you hover over the icon tells you what the left and right mouse button do.

- **To access the command on the first line**
  - Click the icon with the **left mouse button**.

- **To access the command on the second line**
  - Click the icon with the **right mouse button**.

**Note**: If you are using a one-button mouse or a track pad, to access the second command, hold the **Option** key and click the icon.

Viewports (5)
Viewports display the Rhino working environment.

Sidebar (6)
The right sidebar contains layers, properties, and other settings. The left sidebar contains the toolbar and the object snap list.

Status bar (7)
The status bar is located at the bottom of the Rhino window. It displays the current coordinate system, the cursor location and system unit.

Top panel (8)
The top panel has quick access to layers, object properties and toggles of modeling aids.

Rhino commands
Rhino is a **command-driven** program. In other words, all actions are activated by named commands such as **Line**, **Box**, or **CurvatureAnalysis**.

**Tip**: To learn more about a command, use the **Command Help** panel.

Commands are accessed through the **menus**, or the **toolbars**, or by **typing** the command name. In the next sections, you will explore using these methods. You may find one method easier than another. The choice is yours, and there is no preference for one method over another.

In the exercises, you will use Rhino’s commands, navigation tools, shaded modes, render, and use some basic object manipulation.

**Tip**: To cancel a command any time, press the **Esc** key.
In this session you will:

- Start a command by choosing from the menu.
- Start a command by choosing from a toolbar icon.
- Start a command by typing.

To start your first Rhino model

1. Start Rhino.
2. On the File menu, click New Using Template.

Using templates

A template is a file that serves as a starting point for a new Rhino model. When starting a new model, Rhino provides default templates that set units appropriate for the model size, provide a few layers, and display a standard fourviewport layout.

Custom templates can include any kind of document information such as units, viewport layouts, layers, and even geometry. If you find yourself creating similar models over and over, set up and save a model as a template (see the SaveAsTemplate command in the Help). That way you will not have to spend time formatting your models each time you make a new one. You can start a new model from your own template, and start from there.

Start from the menu

Most Rhino commands are located in the menus.

Start the Cone command

- On the Solid menu, click Cone.
  Use the CommandHelp command to display the Command Help panel before starting the Cone command.

Draw the cone

1. At the Base of cone... prompt, in the Top viewport, click the left mouse button to pick the center point for the base of the cone.
2. At the **Radius**... prompt, in the ***Top*** viewport, drag the mouse, and click to draw the cone’s base.

3. At the **End of cone** prompt, in the ***Front*** viewport, drag the mouse up and down. Watch what happens in the ***Perspective*** viewport.
4. Click to place the end of the cone.

Start from a toolbar icon
Toolbars provide a graphic interface to the commands.

To display a button tooltip, hover your mouse over the icon
- The command names that are activated with the left and right mouse click or with the Option key + mouse click appear.

Start the Curve command
- On the toolbar docked on the left side of the Rhino window, click the icon for **Control point curve**.
  
  Find help for the Curve command in the **Command Help** panel.

Draw the curve
1. At the **Start of curve...** prompt, in the **Top** viewport, click the mouse to start the curve.
2. At the **Next point...** prompts, in the **Top** viewport, click a few more points.

3. At the **Next point...** prompts, move the mouse into the **Front** viewport and click a few more points.

4. At the **Next point...** prompts, move the mouse into the **Right** viewport and click a few more points.

5. Right-click, press **Enter**, or press the **Spacebar** to complete the curve.
6. Look at the curve in the **Perspective** viewport.

![Perspective](image)

**Admire your work**
- In the **Perspective** view, drag with the right mouse button to rotate the view.

---

**Start from the command line**

You can start a command by typing the command name.

**Start the Sphere command by typing**

1. With the command prompt clear (if there is text at the command prompt, press the **Esc** key), just start typing **Sphere**. When you type the first letter of a command, a list of possible commands appears.
2. When the command name **Sphere** appears, press **Enter**, or choose **Sphere** from the list.

Find help for the Curve command in the **Command Help** panel.

**Draw the sphere**

The default option for the **Sphere** command is **Center, Radius**, so you can simply start drawing the center of the sphere.
2. At the **Center of sphere**... prompt, in the **Perspective** viewport, click the mouse anywhere in the viewport to pick the center point for the sphere.

3. At the **Radius**... prompt, in the **Perspective** viewport, move the mouse away from the center point, and click to draw the sphere.

4. In the **Perspective** viewport, right-click the **viewport title**, and on the menu, click **Shaded**.
   You can also use the **View** menu to set the viewport to **Shaded** mode.
   Shaded mode lets you see surfaces as opaque objects rather than wires.
**For more information on display modes**

1. On the **Rhinoceros** menu, click **Preferences**.
2. In the **Rhino Preferences** dialog box, click **Display Modes**.
3. In the **Display Modes** dialog box, click the ? button at the upper-right corner.

**Undo a mistake**

If you did something you did not want to do, you can undo your actions.

- **Undo a command**
  - On the **Edit** menu, click **Undo**.
  - Or press the **Command ⌘** and **Z** keys.
  - You can undo a series of commands, or **Redo** the **Undo** if you go too far.

- **Redo commands**
  - On the **Edit** menu, click **Redo**.
  - Or press the **Shift**, **Command ⌘**, and **Z** keys.

**Command history**

You can display command history in the **Command History** panel in the right sidebar, or click the command history icon in the lower left corner of the screen to display temporarily.

**Command options**

Command options change how a command acts. For example, when you draw a circle, the circle is normally drawn on the active construction plane. The **Circle** command has several options including **Vertical** and **AroundCurve**.
To choose a command option

1. Start typing **Circle**.
   As soon as you have typed enough letters to identify the command, the **Circle** command automatically completes at the prompt.

2. Press **Enter**.
   The options for the **Circle** command appear:

   **Center of circle**
   - Deformable
   - **Vertical**
   - 2 Point
   - 3 Point
   - Tangent
   - Around Curve
   - Fit Points

3. Click **Vertical**, or type **V** to draw a circle vertical to the active construction plane.
Repeat the last command
Many tasks in Rhino are repetitive. You might want to move or copy several objects, for example. Methods for repeating commands are provided.

To repeat the last command
These all perform the same function:
- Press the Enter key when no command is active.
- Press the Spacebar.
- Click the right mouse button in a viewport and select a command to repeat.

Note: Some commands, such as Undo and Delete do not repeat. Instead, the command prior to these commands is repeated. This prevents you from accidentally undoing too many commands or deleting objects accidentally.
Also, you often want to repeat the command you were using before undoing a mistake.
To suit your own way of working, you can define the list of commands that do not repeat in Rhinoceros > Preferences > General > Never repeat these commands.

Cancel a command
Whenever you run the wrong command or do something wrong in the command procedure, you can cancel the command several ways.

To cancel the current command
When a command is running:
- Press the Esc key.
  The command line is cleared and returns to the Command prompt.
- Click a toolbar button or click a command on a menu.
  The current command is canceled immediately and the chosen command runs.
Get help any time

The *Rhino Help* file is the major resource for detailed information on specific commands.

**To get help on a specific command**

- On the *Help* menu, click *Command Help*.
  Or, click the ? icon in the right sidebar.

  The *Command Help* panel displays the Help topic for the current command.

- Find the answers to frequently asked questions at: *Rhino Support*. 
2 - Rhino Objects

The fundamental geometric objects in Rhino are points, curves, surfaces, polysurfaces, solids, light-weight extrusion objects, and polygon mesh objects.

This chapter goes into some detail to explain the mathematical basis for Rhino modeling. It is not necessary to understand everything in this chapter to start using Rhino.

Why NURBS modeling

NURBS (non-uniform rational B-splines) are mathematical representations that can accurately model any shape from a simple 2-D line, circle, arc, or box to the most complex 3-D free-form organic surface or solid. Because of their flexibility and accuracy, NURBS models can be used in any process from illustration and animation to manufacturing.

NURBS geometry is an industry standard for designers who work in 3-D where forms are free and flowing; where both form and function is important. Rhino is used in marine, aerospace, and automobile interior and exterior design. Makers of household and office appliances, furniture, medical and sports equipment, footwear, and jewelry use Rhino to create free-form shapes.

NURBS modeling is also widely used by professional animators and graphic artists. The advantage of using NURBS over using polygon modelers is that NURBS surfaces have no facets. The models can be rendered at any resolution. A mesh can be created from the model at any resolution.

See also

For more information about the mathematics of NURBS, see What are NURBS? at http://www.rhino3d.com/nurbs/

For perhaps more than you want to know, see the Wikipedia article, Non-uniform Rational B-Spline at https://en.wikipedia.org/wiki/Non-uniform_rational_B-spline.

Points

Point objects mark a single point in 3-D space. They are the simplest objects in Rhino. Points can be placed anywhere in space. Points are most often used as placeholders.
Curves
A Rhino curve is similar to a piece of wire. It can be straight or wiggled, and can be open or closed. A *polycurve* has several curve segments joined together end to end. Rhino provides many tools for drawing curves. You can draw straight lines, polylines that consist of connected line segments, arcs, circles, polygons, ellipses, helices, and spirals. You can also draw curves using curve *control points* and draw curves that pass through selected points.

Curves in Rhino include lines, arcs, circles, free-form curves, and combinations of these. Curves can be open or closed, planar, or non-planar.

Surfaces
A surface is like a rectangular stretchy rubber sheet. The NURBS form can represent simple shapes, such as planes and cylinders, as well as free-form, sculptured surfaces. All surface creation commands in Rhino result in the same object: a NURBS surface. Rhino has many tools for constructing surfaces directly or from existing curves.

All NURBS surfaces have an inherently rectangular organization. Even a closed surface such as a cylinder is like a rectangular piece of paper that has been rolled up so two opposite edges are touching. The place where the edges come together is called the *seam*. 
**Closed and open surfaces**
A surface can be open or closed. An open cylinder is closed in one direction. A torus (donut shape) is closed in two directions.

**Trimmed and untrimmed surfaces**
Surfaces can be trimmed or untrimmed. A trimmed surface has two parts: a surface that underlies everything and defines the geometric shape, and trimming curves that mark sections of the underlying surface that are trimmed away. Trimmed surfaces are created with commands that trim or split surfaces with curves and other surfaces. Some commands create trimmed surfaces directly.

The shape of a surface is still defined by a set of control points arranged in a rectangular pattern.

Since it can be important for you to know if a surface is trimmed, the **Properties** command lists the trimmed or untrimmed state of the surface. Some Rhino commands work only with untrimmed surfaces and some software does not import trimmed NURBS surfaces.
Trimming curves lie on the underlying surface. This surface may be larger than the trimming curves, but you will not see the underlying surface because Rhino does not draw the part of the surface that is outside the trimming curves. Every trimmed surface retains information about its underlying surface geometry. You can remove the trimming curve boundaries to make the surface untrimmed with the **Untrim** command.

If you have a trimming curve that runs across a surface, the trimming curve itself does not have any real relationship to the control point structure of the surface. You can see this if you select such a trimmed surface and turn its control points on. You will see the control points for the whole underlying surface.

If you create a surface from a planar curve, it can be a trimmed surface. The illustrated surface was created from a circle. The control points display shows the rectangular structure of the surface.
The **Untrim** command removes the trimming curve from the surface to get back to the underlying untrimmed rectangular surface.

**Surface isoparametric and edge curves**
In wireframe view, surfaces look like a set of crossing curves. These curves are called *isoparametric curves* or *isocurves*. These curves help you visualize the shape of the surface. Isoparametric curves do not define the surface; they are merely a visual aid that allows you to see the surface on the screen. When a surface is selected, all of its isoparametric curves highlight.

Edge curves bound the surface. Surface edge curves can be used as input to other commands.

*Isocurves (1), Edge curves (2).*

**Curve and surface degree**
A NURBS curve is defined by four things: degree, control points, knots, and an evaluation rule.

NURBS functions are rational polynomials and the degree of the NURBS is the degree of the polynomial.

A polynomial is a function like \( y = 3x^3 - 2x + 1 \). The "degree" of the polynomial is the largest power of the variable. For example, the degree of \( 3x^3 - 2x + 1 \) is 3; the degree of \(-x^5 + x^2\) is 5, and so on.
From a NURBS modeling point of view, the (degree – 1) is the maximum number of "bends" you can get in each span. This determines how much you can affect the shape of the curve.

**For example:**

- A degree-1 curve must have at least two control points.  
  A line has degree 1. It has zero bends.

- A degree-2 curve must have at least three control points.  
  A parabola, hyperbola, arc, and circle (conic section curves) have degree 2. They have one bend.

- A degree-3 curve must have at least four control points.  
  A cubic Bézier has degree 3. If you arrange its control points in a zig-zag shape, you can get two bends.

For more information about curve geometry, see the Wikipedia article, Gallery of Curves at https://en.wikipedia.org/wiki/Gallery_of_curves.
Control points
Control points influence the shape of a curve or surface. The control point holds such information as location, direction, and weight. You can make subtle changes in the shape of a curve or surface by moving the location of its control points. Rhino offers many tools for editing control points. Some of the later tutorials show control point manipulation.

Control point visibility
To edit curves and surfaces by manipulating control points, use the PointsOn (F10) command to turn the control points on.
When you are finished with control-point editing, use the PointsOff (F11) command or press Esc to turn them off.
Control points of polysurfaces cannot be turned on for editing with PointsOn. Editing the control points of polysurfaces could separate the edges of the joined surfaces creating “leaks” in the polysurface. A special SolidPtOn command turns on grip points for polysurfaces, which act like control points.

Change control point locations
When you move control points, the curve or surface changes, and Rhino smoothly redraws it. Rhino’s transform commands, such as Move, Copy, Rotate, and Scale, can manipulate individual or multiple points.

Add, delete, or redistribute control points
Adding control points to a curve gives you more control over the shape of the curve. Commands such as InsertControlPoint, InsertEditPoint, and InsertKink add control points to curves.
Manipulating control points also lets you remove kinks, make curves uniform, and add or subtract detail.
Some commands such as Rebuild, Fair, ChangeDegree, and Smooth offer some automated solutions for redistributing control points over a curve or surface.
Other commands, such as control point dragging and nudging, MoveUVN, and HBar let you manually control the location of individual or groups of control points.
The **Delete** key removes selected curve control points. This changes the shape of the curve.

**Polysurfaces**

A *polysurface* consists of two or more surfaces that are joined together. A polysurface that encloses a volume of space defines a solid.

![Polysurface examples](image)

**Solids**

A solid is a surface or polysurface that encloses a volume. Solids are created anytime a surface or polysurface is completely closed. Rhino creates single-surface solids, polysurface solids, extrusion solids and mesh solids.

A single surface can wrap around and join itself. Example commands include **Sphere**, **Torus**, and **Ellipsoid**. Control points can be displayed on single-surface solids and moved to change the surface.

![Solid examples](image)

Some Rhino commands create polysurface solids. **Pyramid**, **Cone**, and **TruncatedCone** are examples of commands that create polysurface solids.
The **SolidPtOn** command turns on grip points for polysurfaces, which act like control points.

**Light-weight extrusion objects**

Light-weight extrusion objects use only a profile curve and a length as input instead of the network of isocurves normally needed for NURBS objects. The **Box, Cylinder, Tube**, and **ExtrudeCrv** commands create extrusion objects. Extrusion objects can be closed with a planar cap or open. These objects will be converted to polysurfaces by some commands if necessary to add more information for editing.
**Polygon mesh objects**

Because there are many modelers that use polygon meshes to represent geometry for rendering, animation, stereolithography, visualization, and finite element analysis, the **Mesh** command translates NURBS geometry into polygon meshes for export. Also, the Mesh creation commands **MeshSphere**, **MeshBox**, **MeshCylinder**, etc., draw mesh objects.

![Image of a mesh object](Image)

**Note:** There is no easy way to convert a mesh model into a NURBS model. The information that defines the objects is completely different. However, Rhino has a few commands for drawing curves on meshes and extracting vertex points and other information from mesh objects to assist in using mesh information to create NURBS models.
3 - Selecting Objects

Most operations you will do in Rhino require you to select one or more objects. Objects can be selected by clicking anywhere on the object. Click away from the object to deselect it. This method lets you select one object at a time.

Objects can be selected before you start a command. This is called prepick. Prepicking is handy for selecting input objects for many commands. The prepicked objects act as input for the first prompt to select objects.

Objects can also be selected during a command sequence anytime the command prompts you to select objects.

By default, objects change color to yellow when they are selected so you can see which objects are selected. This color can be customized to suit you in Rhino Preferences > Colors > Object display > Selected objects.

Select and deselect objects

Practice selecting objects

1. Open the tutorial model Select Objects.3dm.
   (Help menu > Learn Rhinoceros > Tutorials and Samples > User’s Guide > Select Objects)

2. In the Perspective viewport, click the sphere to select it.
   Notice that the Perspective viewport shows the objects in Shaded mode. The other viewports use Wireframe mode.
   In Shaded mode, you can click anywhere on the object to select it. You don’t have to aim for one of the wires.
3. Hold the **Shift** key and select the cylinder.
   The cylinder is added to the selection.

4. Hold the **Command** ⌘ key and click the sphere again.
   The sphere is removed from the selection.

5. Click away from the objects, or press the **Esc** key.
   The selection is canceled.
To select additional objects
- Hold the Shift key while clicking the objects.

To remove objects from the selection
- Hold the Command ⌘ key and click the objects again.

To cancel the selection
- Click away from the objects, or press the Esc key.

Choose Objects menu
If you click a location that is very close to the place where several objects are close to each other, it is possible that Rhino will not be able to determine which object you want to select. When this happens, a selection menu will appear with a list of the possible objects.

As you move the mouse over the object name in the list, each object highlights. You can also scroll through the potential objects using the arrow keys on your keyboard. When the object you want to select highlights, click or press the Enter key to select it. Choose None to cancel the selection.

Choose Object menu.

Select objects with windows
Another method is to make a window selection or a crossing selection to select multiple objects in one operation.

You can click in an open area of the screen and drag to create a selection window. A window selection selects all objects completely enclosed by the window. A crossing selection selects all objects that are enclosed by the window or any object the window crosses.
To make a window selection
- Click in an open area of the screen and drag to the right.

To make a crossing selection
- Click in an open area of the screen and drag to the left.

To add objects
- Hold the Shift key while making a window or crossing selection.

To remove objects
- Hold the Command ⌘ key while making a window or crossing selection.

Practice window and crossing select
1. In the Perspective viewport, click and drag a window around the sphere as shown in the illustration below.
3. Selecting Objects

The sphere is selected.

2. In the **Perspective** viewport, hold the **Shift** key then click and drag a window section from left to right around the box and the cylinder as shown in the illustration below.

![Illustration of selecting objects](image1.png)

*The cylinder and box are added to the selection.*

3. In the **Perspective** viewport, hold the **Command** ⌘ key then click and drag a crossing selection from right to left over the box and cylinder as shown in the illustration below.

![Illustration of selecting objects](image2.png)

*The cylinder and box are removed from the selection.*
Other ways of selecting objects
Rhino has many commands and methods for selecting objects. You can select an object by name, layer, color, type; by capturing with boundaries or crossing fences; by volume shapes, by group name and many others. Search the Help for the topic Selection commands.

Practice selection by object type
1. In the **Value** box, type **SelAll**.
   The SelAll command selects all visible, unlocked objects in the model.

2. Type **SelNone**.
   The SelNone command removes all of the currently selected objects from the selection.
3. Type **SelSrf**.
   The SelSrf command selects all visible, unlocked **surfaces**. In this case, only the sphere is a surface, the other objects are **polysurfaces**.

4. Type **SelPolysrf**.
   The SelPolysrf command adds all **polysurfaces** to the selection. In this case, the cylinder and box are polysurfaces.

5. Press the **Esc** key.
   The Esc key clears the selection the same as the SelNone command.

**Sub-object selection**
You can select sub-parts of objects to use in commands, for example, select a surface edge to use as input for a Loft or ExtrudeCrv operation. The available parts include polysurface faces; surface and polysurface edge curves; control points; mesh vertices, faces, boundaries, and edges; and objects within a group. Search the Help for the topic **Sub-object selection**.

**To select parts of objects for use with other commands**
- Press and hold both the **Command** and **Shift** keys at the same time and click an object part.
Practice sub-object selection

1. In the **Perspective** viewport, press the **Command** ⌘ and **Shift** keys and click a face of the box as shown in the illustration below.

   ![Illustration of selecting a face](image1)

   *The face you select highlights.*

2. Press the **Delete** key.

   The face of the box is separated from the box solid and deleted.

   ![Illustration of deleted face](image2)
4 - Navigating Viewports

Viewports are windows in the graphics area that display views of your model. You can customize the viewports to suit your preferences. The size of viewports is adjustable; they can be any rectangular size and shape. Each viewport has its own construction plane and grid that the cursor normally moves on and a projection mode. To toggle between a small viewport and one that fills the graphics area, double-click the viewport title.

Viewport title

The viewport title has some special functions for manipulating the viewport. To re-size a viewport, drag the viewport border. You can rename viewports, and use predefined viewport configurations from the viewport title menu.

- Click the title to make the viewport active without disturbing the view or the set of selected objects.
- Double-click the viewport title to maximize the viewport.
  Double-click again to restore the viewport layout.

To use the viewport title menu

- Right-click the viewport title to display the viewport title menu.

The viewport title menu contains most of viewport and display related commands. The same commands can be found in the View menu on the main menu bar.
**Viewport projection**

Graphical projection is used in technical drawing to project an image of a three-dimensional object onto an imaginary fixed plane.

The viewport projection can be parallel, three-point perspective, or two-point perspective. The viewport projection is set in Viewport Properties. When no object is selected, the Properties panel shows viewport properties.

In the default four-viewport layout, there are three parallel viewports (Top, Front and Right) and one perspective viewport.

For more information about graphical projections, see https://en.wikipedia.org/wiki/Graphical_projection.

**Parallel**

In a parallel view, all the grid lines are parallel to each other, and identical objects look the same size, regardless of where they are in space. Parallel views are also called orthogonal views in some systems.

**Perspective**

A perspective view, uses three-point perspective. Grid lines converge to a vanishing point. This provides the illusion of depth. Perspective projection makes objects farther away look smaller.
Two Point Perspective
In a two-point perspective view, objects look smaller as their horizontal distance increases, but look the same as their vertical distance increases.

Perspective (left) vs. Two Point Perspective (right).

Viewport navigation
Working in 3-D on a computer requires visualizing 3-D objects drawn on a 2-D medium - the computer screen. Rhino provides tools to help do this. Rhino’s easy view navigation helps you visualize your model. You can look at you model from any direction, look at the whole model, or look into the details. You can change your view in the middle of a command to see precisely where you want to select an object or pick a point.

Mouse navigation
Dragging with the right mouse button easily manipulates the views so you can look at the model from various angles. Mouse navigation works differently in parallel and perspective viewports. In parallel viewports, right mouse drag pans the view. In a perspective viewport, right mouse drag rotates the view, and you must use the Shift key modifier to pan the view.

To pan the view
- In a viewport with a parallel projection, such as the Top viewport, drag the mouse with the right mouse button held down.
- In the Perspective viewport, hold the Shift key, and drag with the right mouse button held down.

Undo or redo view changes
If you get lost, there are several ways to get yourself reoriented:
- Press the Home key to step back through your view changes.
- Press the End key to step forward through your view changes.
- To bring all your objects into view, use the Zoom command, Extents option.
To rotate a perspective view

- In the Perspective viewport, drag the mouse with the right mouse button held down to rotate the view and see the objects from a different angle.

To zoom in and out

- Hold down the Command ⌘ key and drag up and down with the right mouse button held down.
- If you have a mouse with a wheel, you can also scroll the wheel to zoom in and out.

Key and mouse combinations

Pan

In parallel viewports (for example: Top, Front, and Right), drag with the right mouse button.

In perspective viewports, hold the Shift key, and drag with the right mouse button.

RotateView

In perspective viewports, drag with the right mouse button.

Note: Rotating a parallel view is not common. It is a special operation that should be used rarely and with caution.

In parallel viewports (for example: Top, Front, and Right), hold the Command ⌘ and Shift keys, and drag with the right mouse button.

Zoom

Hold the Command ⌘ key, and drag up and down with the right mouse button, or rotate the mouse wheel.
Viewport display modes
You can view your model in a variety of wireframe, shaded and rendered methods that depend on your needs. Wireframe mode usually offers the fastest display speed. Shaded modes offer the ability to view surfaces and solids with shading to help you visualize the shapes.

Wireframe
In **Wireframe** mode, surfaces look like a set of curves that cross each other. These curves are called *isoparametric curves* or *isocurves*. Isocurves do not actually define the surface. They are merely a visual aid.

To set wireframe mode

1. Open the sample model, **Start.3dm**.
   * (Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Start)
2. Click the left mouse button in the **Perspective** viewport to make it active.
   An active viewport is the viewport where all your commands and actions take place.
3. Right-click on the viewport title menu, and click **Wireframe**.
Shaded
The Shaded modes, (for example, Shaded, Rendered, Artistic, and Pen) display surfaces and solids with render meshes to show surfaces.

To set shaded mode

1. On the viewport title menu, click Shaded.

2. Rotate your view by holding down the right mouse button and dragging from the bottom of the view upwards. You are now under the objects looking up. The construction plane grid helps you stay oriented.

3. Press the Home key to undo your view changes.
### Rendered

The Rendered mode shows objects with lighting and render materials applied.

![Rendered Mode](image)

### Raytraced

The Raytraced mode displays objects with materials and raytraces the scene and lighting in real-time.

![Raytraced Mode](image)

### Other shaded modes

Other display modes and custom settings are described in the Rhino Help.

![Artistic and Pen Modes](image)

*Artistic (left) and Pen (right) display modes.*
5 - Accurate Modeling

The cursor can always move freely, but sometimes you may need to put some restrictions on the cursor. You can restrict the cursor’s movement to the construction plane grid, a distance or an angle from a point, snap to specific locations on existing objects, or enter Cartesian coordinates to locate points in 2-D or 3-D space.

The Rhino cursor

The Rhino cursor consists of a marker and a cross. The marker usually stays at the center of the cross. The cross always follows the mouse movement.

Rhino cursor (1), Marker (2) and Cross (3)

The marker may leave the cross when a constraint is in effect. For example, when Elevator mode is active, a tracking line connected to the marker displays. The location of the marker is picked when you click the left mouse button..
Grid snap
Grid snap constrains the marker to the crossing points of an imaginary grid that extends infinitely in the x- and y-directions.
Click Grid Snap in the top panel to turn grid snap on and off. Use the Grid command to set the snap spacing and other options.

Ortho mode
Ortho mode constrains the marker movement or object dragging to a specific set of angles. By default, this is parallel to the grid lines, but you can change this.
Click Ortho in the top panel to turn ortho on and off.
Press and hold the Shift key to temporarily toggle the ortho mode.
Ortho is active after the first point for a command. For example, after picking the first point for a line, the second point is constrained to the ortho angle.

If you need a different angle for only a single operation, angle constraint is faster to use. Enter a specific angle for one operation instead of changing the ortho angle and then changing it back.
**Object snaps**

When Rhino asks you to pick a point, you can use object snaps to pick a precise location on an existing object. When you move the cursor near a location on an object that corresponds to an object snap, the marker jumps to that location.

**The Osnap control**

Object snaps are set in the Osnap control. The Osnap control is located at the bottom of the left sidebar.

![Osnap control](image)

**Persistent object snaps**

A persistent object snap stays on until you turn it off. You can turn on as many persistent object snaps as you need.

**Turn on persistent object snaps**

- In the Osnap panel, select **Persistent** and then click object snap check boxes.

![Osnap settings](image)

**One-time object snaps**

Multiple persistent object snaps may interfere with one another, so you can also turn on an object snap for a single pick. One-time object snaps override persistent object snaps. This lets you keep your persistent object snaps set, but to override them as needed with a one-time object snap.
**Turn on one-time object snaps**

- In the Osnap panel, select **One shot** and then click an object snap check box.

- Or-

  - Click the Osnap button in the top panel. In the pop-up, select **One shot** and then click an object snap check box.

- Or-

  - During a command, type an object snap name such as, **cen** (center), **int** (intersection), **tan** (tangent), and press **Enter**.

Object snaps normally take precedence over grid snap or other constraints. In some situations object snaps work in conjunction with other constraints. You will see examples of this later in this chapter. For more information, including video demonstrations, see the Rhino help topic **Object snaps**.

**To temporarily suspend all persistent object snaps**

- In the **Osnap** panel, click the **Disable all** button.
  All persistent object snaps will be suspended, but remain their checking status.

**To turn on one object snap and turn all others off with one click**

- In the **Osnap** panel, hold **Alt** and click the object snap you want to turn on.
  All other object snaps will turn off.
Object snaps using references
Some special object snaps let you select multiple reference points or add other advanced controls.

To turn on complex object snaps
- During a command, when you are at a prompt to pick a point, type one of these commands:
  From, PerpendicularFrom, TangentFrom, AlongLine, AlongParallel, OnCrv, OnSrf,
  OnPolysurface, OnMesh, PersistentOnCurve, PersistentOnSurface,
  PersistentOnPolySurface and PersistentOnMesh.
- See the Rhino help topic Object snaps for more information about these object snaps.

Constrain cursor movement
When entering points, you can restrict the cursor to a distance or angle from the previous point.

Ortho
Ortho restricts the cursor movement to a 90-degree angle from the last point created.
Note: The default angle is 90 degrees, but any angle can be used. You can change Ortho angle in Rhino Preferences > Modeling Aids > Snaps.

Example: Draw a line using Ortho
1. Type Line.
2. At the Start of line prompt, place the first point.
3. At the End of line prompt, drag the cursor away from the start point.
4. Click Ortho in the top panel to toggle Ortho on and off while dragging the cursor.
   You will see the cursor jump to 90 degrees when Ortho is on and drag freely when Ortho is off.

Note: A shortcut for toggling Ortho on and off temporarily is to hold down the Shift key.

Distance constraint
The distance constraint restricts the distance the cursor can travel from the previous point.
Set the distance constraint during a command by typing a number at the command prompt.
Example: Draw a line using a distance constraint

1. Type **Line**.
2. At the **Start of line** prompt, place the first point.
3. At the **End of line** prompt, type a number, and press **Enter**.
   Once you have set the distance, drag the line around. You will see that the marker cannot move away from the first point more than the set distance.
   You can also use other snaps such as Grid snap or an object snap to point the line in a direction.
4. Drag the line around the first point until it heads the direction you want it to go, and pick a point for the end of the line.

Angle constraint
Angles constraint is similar to Ortho, but you can set any angle. The angle constraint setting is only in effect for the next pick.

Example: Draw a line using an angle constraint

1. Type **Line**.
2. At the **Start of line** prompt, place the first point.
3. At the **End of line** prompt, type `<` followed by an angle value, such as **35**.
   The angle symbol `<` is used because it is similar to the symbol used in geometry to indicate an angle.
4. Once you have set the angle, drag the line around the first point.
   You will see that the marker jumps around the first point in 35-degree increments.
5. Drag the line to the distance you want and pick a point for the end of the line.

Distance and angle together
Distance and angle constraints can be used at the same time. The order you enter the distance and angle does not matter.
### Example: Draw a line using a distance and angle together

1. Type **Line**.
2. At the **Start of line** prompt, place the first point.
3. At the **End of line** prompt, type a distance, and press **Enter**.
4. At the next **End of line** prompt, type the `<` character and an angle value, and press **Enter**.
5. Drag the line.
   You will see that the marker is restricted to the distance from the first point and at increments of the angle you set.

---

### SmartTrack™

SmartTrack is a system of temporary reference lines and points drawn in the Rhino viewport using implicit relationships among 3-D points, other geometry, and the coordinate axes directions.

Temporary infinite lines (tracking lines) and points (smart points) can be used by object snaps just like real lines and points.

You can snap to intersections of the tracking lines, perpendiculars, and directly to smart points as well as intersections of tracking lines and real curves. The tracking lines and smart points are displayed only for the duration of a command.
Coordinate systems
Rhino uses two coordinate systems: construction plane coordinates and world coordinates. Construction plane coordinates are defined for each viewport. World coordinates are fixed in 3-D space.
For more information about coordinate systems, see www.mathopenref.com/coordinates.

Right-hand rule
Coordinate systems follow what is called the right-hand rule. The right-hand rule can help you determine the direction of the z-axis in a coordinate system. Form a right angle with the thumb and forefinger of your right hand. When your thumb points in the positive x-direction, your forefinger points in the positive y-direction, and the palm of your hand faces in the positive z-direction.

Construction plane coordinates
Each viewport has its own construction plane. A construction plane is like a tabletop that the cursor moves on unless you use coordinate input, elevator mode, object snaps, or a few other instances where input is constrained. By default, each viewport’s construction plane is independent of those in other viewports.

Rhino’s standard viewports come with construction planes that correspond to the viewport. An exception is the default Perspective viewport, which uses the World Top construction plane, the same as the default Top viewport.
The grid helps you visualize the construction plane. The dark red line represents the construction plane positive x-axis for that viewport. The dark green line represents the construction plane positive y-axis for that viewport. The red and green lines meet at the construction plane origin (0,0) for that viewport.
Note: By default there is no line showing the construction plane z-axis in order to cut down on clutter on the screen.
Example: Draw a line using 2-D construction plane coordinates

1. Type **Line**.
2. At the **Start of line** prompt, type **1,1**.
   These are the construction plane coordinates for the start point of the line in the format \(x,y\) where \(x\) is the x-coordinate and \(y\) is the y-coordinate of the point. There are no spaces between the coordinate values.
3. At the **End of line** prompt, type **4,2**.
   A line is drawn starting at 1 unit from the construction plane origin in the positive x-direction and 1 unit from the construction plane origin in the positive y-direction and ending at 4 units from the origin in the positive x-direction and 2 units from the origin in the positive y-direction.

3-D construction plane coordinates

You can also use 3-D coordinates to place points that do not lie on the construction plane. To use 3-D coordinates, during a command, at a prompt requesting a point, type the coordinates in the format \(x,y,z\) where \(x\) is the x-coordinate, \(y\) is the y-coordinate, and \(z\) is the z-coordinate of the point.

**Example: Draw a point in 3-D using construction plane coordinates**

1. Type **Point**.
2. At the **Location of point object** prompt, type **3,4,10**.
   This places a point object 3 units from the construction plane origin in the x-direction, 4 units from the origin in the y-direction, and 10 units from the origin in the z-direction.

Relative coordinates

Use relative coordinates to locate points according to their relationship to the previous active point. Rhino remembers the last point used, so you can enter the next point relative to it. Relative coordinates are useful for entering a list of points where the relative locations instead of absolute locations of the points are known.

To enter relative coordinates, at a command prompt, type the coordinates in the format \(rx,y\) where \(r\) signifies that the coordinate is relative to the previous point.
Example: Draw a line using relative coordinates

1. Type **Line**.
2. At the **Start of line...** prompt, click to place the first end of the line.
3. At the **End of line...** prompt, type **r2,3**, and press **Enter**.

The line is drawn to a point 2 units in the x-direction and 3 units in the y-direction from the last point.

World coordinates

Rhino contains one world coordinate system. The world coordinate system cannot be changed. When Rhino prompts you for a point, you can type coordinates in the world coordinate system in the format **wx,y,z**.

The arrow icon in the lower left corner of each viewport displays the direction of the world x-, y-, and z-axes. The arrows move to show the orientation of the world axes when you rotate a view.

Elevator mode

Elevator mode lets you pick points that are off the construction plane in the positive or negative z-direction. Elevator mode requires two point picks to define the point. The first point sets the base point. The second specifies how far the final point is above or below the base point.

To move the marker in the construction plane z-direction, hold the **Command** key and click a point on the construction plane, and then drag vertically from the construction plane and click to pick a point.

Using elevator mode to move your pick point vertically from the construction plane lets you work in the Perspective viewport more easily.
Example: Draw a 3-D curve using elevator mode

1. Type Curve.
2. At the Start of Curve prompt, in the Perspective viewport, place the first point.
3. At the Next point of curve... prompt, pick a second point in the Perspective viewport.
4. At the Next point... prompt, hold the Command key and pick a point in the Perspective viewport.
   This is the base point for the elevator mode action. After the base point is specified, the marker is constrained to a tracking line perpendicular to the construction plane that passes through the base point.
5. Drag the mouse in the Perspective viewport.
   A tracking line displays indicating that the marker is constrained to move perpendicular to the construction plane.
6. Pick a second point to specify the z-coordinate of the desired point.
   -Or-
   Type a number to specify the height above the construction plane. Positive numbers are above the construction plane; negative numbers are below.
   You can use other constraints such as coordinates, object snaps, or grid snap for the first point, and you can use object snaps for the height.

For a short video demonstration of using elevator mode, search the Rhino Help for "Elevator mode."

See also
For more information about the mathematical principles involved in 3-D modeling, see: www.mathopenref.com.
6 - Create Surfaces from Curves

One way of working in 3-D is to draw curves that represent edges, profiles, cross-sections, or other surface features and then to use surfacing commands to create surfaces from those curves. Curves can be free-standing curves or the edges of existing surfaces.

Surface from edge curves
You can create a surface from three or four curves that define the edges of the surface.

Create a surface from edge curves

1. Open the tutorial model EdgeSrf.3dm.
   (Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > EdgeSrf)

2. On the Surface menu, click Edge Curves.
   Optional: Review the Help topic for the EdgeSrf command in Rhino Help.

3. At the Select 2, 3, or 4 open curves prompt, select the four curves as shown in the illustration below.

To select the curves, you can click each individual curve using the Shift key, or you can use a window or crossing selection to select all of the curves at once. To review selecting objects, see Chapter 3, Selecting Objects. A surface is created from the curves, which define its edges.
Extrude curves
Surfaces can be created by extruding curves in a straight line perpendicular to the construction plane.

Create an extruded surface

1. Open the tutorial model ExtrudeCrv.3dm. 
   (Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Extrude)

2. On the Surface menu, click Extrude Curve, and then click Straight. 
   Optional: Review the Help topic for the ExtrudeCrv command in Rhino Help.

3. At the Select curves to extrude prompt, select the curve (1) as shown in the illustration below.

4. At the Extrusion distance prompt, drag a distance with your mouse and click.
Loft curves
Lofting creates a smooth surface that blends between selected curves. The curves define "ribs" for the surface you are creating.

Create a lofted surface
1. Open the tutorial model **Loft.3dm**.
   (Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Loft)
2. On the **Surface** menu, click **Loft**.
   *Optional:* Review the Help topic for the **Loft** command in Rhino Help.
3. At the **Select curves to loft** prompt, select the three curves (1), (2), and (3) as shown in the illustration below, and press **Enter**.

   ![Illustration of lofted surface with curves 1, 2, and 3]

   **Tip:** Select the curves by picking near the same end where the numbers are. This avoids twisting the loft surface. In this model, you can use any selection method. The Loft command will sort out the order of the curves. In other more complex cases, picking the curves near the same end may be important, and you may have to make adjustments for the loft to work properly.
4. In the **Loft** dialog box, click the drop-down menu under **Style** to try some of the options.
   The default style is **Normal**. As you change the style, the preview will update in real time to show you what the results will be.
5. In the **Loft Options** dialog box, click **Loft**.

---

**Revolve curves**

Revolving creates a surface by revolving curves about a *revolve axis*. The curve defines the silhouette of the revolved surface. This action is sometimes called *lathing* in other programs.

---

### Create a revolved surface

1. Open the tutorial model **Revolve.3dm**.

   *(Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Revolve)*

2. In the **Osnap** panel, click **End**.

3. On the **Surface** menu, click **Revolve**.

   *Optional:* Review the Help topic for the **Revolve** command in Rhino Help.

4. At the **Select curves to revolve** prompt, select the curve (1) and press **Enter**.
5. At the **Start of revolve axis** prompt, snap to one end of the line (2) that defines the revolve axis.

**Note:** A reference line is not strictly necessary; you can pick any two points to define the axis.

6. At the **End of revolve axis** prompt, snap to the other end of the line (3) that defines the revolve axis.

7. At the **Start angle...** prompt, click the **Full Circle** option.

The Full Circle option creates a complete 360-degree surface.
Revolve curves with a rail

Rail revolve creates a surface by revolving a profile curve around a reference axis while at the same time following a rail curve as closely as possible. The profile curve defines the silhouette of the surface, and the rail curve defines a path the profile curve will try to follow.

Create a revolved surface with a rail curve

1. Open the tutorial model RailRevolve.3dm.
   
   (Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > RailRevolve)

2. On the Surface menu, click Rail Revolve.
   
   Optional: Review the Help topic for the RailRevolve command in Rhino Help.

3. At the Select profile curve prompt, select the profile curve (1).

4. At the Select rail curve... prompt, select the rail curve the revolve will follow (2).
5. At the **Start of RailRevolve axis** prompt, snap to an endpoint of the axis line (3).

6. At the **End of RailRevolve axis** prompt, snap to the other end of the axis line (4).
Sweep along one rail curve
Sweeping with one rail creates a smooth surface with from multiple cross-section curves and a single rail curve. The cross-section curves define the surface shape, and the rail curve defines a path the surface will follow.

1. Open the tutorial model **Sweep1.3dm**.
   
   *(Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Sweep1)*

2. On the **Surface** menu, click **Sweep 1 Rail**.
   
   *Optional:* Review the Help topic for the **Sweep1** command in Rhino Help.

3. At the **Select rail** prompt, select the rail curve (1).

4. At the **Select cross section curves...** prompt, select the cross-section curve (2), and press **Enter**.
   
   Only one cross-section curve is used in this example.

5. At the **Drag seam point to adjust...** prompt, press **Enter**.
   
   No adjustment is necessary in this case.
6. In the **Sweep 1 Rail Options** dialog box, click **Sweep**.
   
The default Freeform option will be used.

### Sweep along two rail curves

Sweeping with two rails creates a smooth surface with from multiple *cross-section curves* and two *rail curves*. The *cross-section curves* define the surface shape, and the *rail curves* define the path the two edges of the surface will follow as closely as possible. Use the Sweep2 command when you want to control the location of the edges of the surface; for example, when the using the edges of other surfaces as the rail curves.

#### Create a sweep surface with two rail curves

1. Open the tutorial model **Sweep2.3dm**.
   
   *(Help menu > Learn Rhinoceros > Tutorials and Samples > User’s Guide > Sweep2)*

2. On the **Surface** menu, click **Sweep 2 Rails**.
   
   *Optional:* Review the Help topic for the **Sweep2** command in Rhino Help.

3. At the **Select first rail...** prompt, select the first rail curve (1).

4. At the **Select second rail...** prompt, select the second rail curve (2).
5. At the **Select cross section curves** prompt, select the two cross-section curves (3) and (4), and press **Enter**.

6. In the **Sweep 2 Rails Options** dialog box, click **Sweep**.
   
   No further adjustments are needed in this case.
7 - Edit Curves and Surfaces

The editing operations in this section break objects apart, cut holes in them, and put them back together. Some of these commands join curves to curves, or surfaces to surfaces or polysurfaces, and break a composite curve or polysurface into its components. The commands: Join, Explode, Trim, and Split apply to curves, surfaces, and polysurfaces.

Join

The Join command connects curves or surfaces together into one object. Join turns lines that touch end to end into polylines, curves that touch end to end into polycurves, and surfaces and polysurfaces that touch on an edge into polysurfaces or solids.

When a curve is selected first, surface edges or mesh edges can be joined with the curve to create a polyline or polycurve.

Join curves into a polycurve

1. Open the tutorial model Join Curves.3dm

(Get menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Join Curves)

2. Select all of the curves using a window or crossing.

The command history displays 5 curves added to selection.

The Object Type in the Properties panel shows 5 open curves.
3. On the **Edit** menu, click **Join**.

*Optional: Review the Help topic for the Join command in Rhino Help.*

The command history displays **5 curves joined into one closed curve**.

The **Object Type** in the **Properties** panel shows **closed curve**.

---

**Join surfaces into a polysurface**

1. Open the tutorial model **Join Surfaces.3dm**.

   *(Help menu > Learn Rhinoceros > Tutorials and Samples > User’s Guide > Join Surfaces)*

2. **Select** both of the surfaces using a window or crossing.

   The command history displays **2 surfaces added to selection**.

   The **Object Type** in the **Properties** panel shows **2 surfaces**.
3. On the **Edit** menu, click **Join**.

   The command history displays **2 surfaces or polysurfaces joined into one open polysurface**.

   The **Object Type** in the **Properties** panel shows **open polysurface**.

---

**Join surfaces into a solid polysurface**

1. Open the tutorial model **Join Solid.3dm**.

   *(Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Join Solid)*

2. **Select** all of the surfaces using a window or crossing.

   The command history displays **6 surfaces added to selection**

   The **Object Type** in the **Properties** panel shows **6 surfaces**.
3. On the **Edit** menu, click **Join**.
   The command history displays **6 surfaces or polysurfaces joined into one closed polysurface**.
   The **Object Type** in the **Properties** panel shows **closed solid polysurface**.
Explode

The **Explode** command removes the connection between joined curves and polysurfaces. Explode works on any object that can be reduced to its component parts.

**Explode a polycurve into individual curves**

1. Open the tutorial model **Explode Curves.3dm**.
   
   *(Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Explode Curves)*

2. **Select** the curve.
   
   The command history displays **1 curve added to selection**.
   
   The **Object Type** in the **Properties** panel shows **closed curve**.

3. On the **Edit** menu, click **Explode**.
   
   Optional: Review the Help topic for the **Explode** command in Rhino Help.
   
   The command history displays **Exploded a curve into 5 segments**.
   
   The **Object Type** in the **Properties** panel shows **5 open curves**.

   **Note:** For the illustration, the **ScalePositions** command was used to separate the individual curves. The **Explode** command does not move the curves.
Explode a polysurface into individual surfaces

1. Open the tutorial model **Explode Polysurface.3dm**.
   
   *(Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Explode Polysurface)*

2. **Select** the polysurface.
   
   The command history displays **1 polysurface added to selection**.
   The **Object Type** in the **Properties** panel shows **open polysurface**.

3. On the **Edit** menu, click **Explode**.
   
   The command history displays **Exploded a polysurface into 3 surfaces**.
   The **Object Type** in the **Properties** panel shows **varies**.
   
   Three surfaces were created, two surfaces and a trimmed surface. Select each surface individually to check the object type.

**Note:** For the illustration, the **ScalePositions** command was used to separate the individual surfaces. The **Explode** command does not move the exploded surfaces.
Trimming and Splitting

The **Trim** and **Split** commands are similar. They both cut objects with other objects. When you trim an object, you select the parts to remove and they are deleted. When you split an object, no parts are deleted.

### Trim

The Trim command cuts and deletes selected portions of an object at the intersection with another object used as a cutter.

#### Trim curves

1. Open the tutorial model **Trim Curves.3dm**.
   
   *(Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Trim Curves)*

2. On the **Edit** menu, click **Trim**.
   
   Optional: Review the Help topic for the **Trim** command in Rhino Help.

3. At the **Select cutting objects** prompt, select the blue curve (1) as illustrated below, and press **Enter**.

4. At the **Select object to trim** prompt, select the right side of the red circle (2) and the black rectangle (3), and press **Enter**.

The circle and the rectangle are trimmed by the blue curve.
Trim surfaces

1. Open the tutorial model Trim Surfaces.3dm.
   (Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Trim Surfaces)
2. On the Edit menu, click Trim.
3. At the Select cutting objects prompt, select the red surface as illustrated below, and press Enter.
4. At the Select object to trim prompt, select the right side of the red circle and the black rectangle, and press Enter.
Split

The Split command divides objects into parts using other objects at the intersection with another object used as a cutter.

Split curves

1. Open the tutorial model Split Curves.3dm.
   
   (Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Split Curves)

2. On the Edit menu, click Split.
   
   Optional: Review the Help topic for the Split command in Rhino Help.

3. At the Select object to split... prompt, select the red circle (1) and the black rectangle (2), and press Enter.

4. At the Select cutting objects prompt, select the blue curve (3) as illustrated below, and press Enter.

The red circle and the black rectangle are split by the blue curve.

Note: For the illustration, the individual curves were moved. The Split command does not move the split objects.
Split surfaces

1. Open the tutorial model Split Surfaces.3dm.
   *(Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Split Surfaces)*

2. **Select** the green sphere.

   ![Image of green sphere](image)

   **Note:** This is an example of pre-picking input for a command. You can select the input for the first prompt of most commands.

3. On the **Edit** menu, click **Split**.
4. At the **Select cutting objects** prompt, select the red surface, and press **Enter**.

   ![Image of sphere split by red surface](image)

   The sphere is split by the red surface.

   **Note:** For the illustration, the split surface was moved. The **Split** command does not move the split objects.
**Untrim**

The Untrim command removes trim curves from a surface restoring the underlying untrimmed object.

**Untrim surfaces**

1. Open the tutorial model **Untrim Surfaces.3dm**.
   
   *(Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Untrim Surfaces)*

2. Press **F10** to turn on the control points for the green surface.
   
   The control point array shows that this surface is actually a trimmed sphere. When the trim curves are removed, the surface fills in to reform the original sphere.

3. On the **Edit** menu, click **Untrim**.

   *Optional:* Review the Help topic for the **Untrim** command in Rhino Help.

4. At the **Select edge to untrim...** prompt, select the edge of the hole (1) as illustrated below.

   ![Select edge to untrim](image)

   The hole edge is deleted causing the hole to be removed.
5. At the next **Select edge to untrim...** prompt, select the edge of the surface (2) as illustrated below.

The edge is deleted causing the sphere to return to its full untrimmed state.
8 - Transforms - Move, Copy, Rotate, and Scale

Transforms change the location, rotation, number and shape of whole objects by moving, mirroring, arraying, rotating, scaling, shearing, twisting, bending, and tapering. The transform commands do not break the objects into pieces or cut holes in them.

**Note:** For all of the following exercises, the images were captured using **Shaded** mode display.

### Move

Use the **Move** command when you want to move an object a certain distance or if you want to use object snaps to place an object accurately.

You can pick these locations on the screen or type coordinates in the **Value** box.

**Practice moving objects**

The object of this exercise is to move a sphere from the center of the sphere to the coordinate system origin at 0,0,0.

The **Move** command requires a **from** and **to** location.

1. Start a new model.
2. Draw a **Sphere** anywhere on the screen.
3. **Select** the sphere.
4. On the **Transform** menu, click **Move**.

*Optional:* Review the Help topic for the **Move** command in Rhino Help.
5. At the **Point to move from** prompt, with the **Center** object snap on, move the mouse around the edge of the sphere until the **Center** tooltip displays and click.

6. At the **Point to move to** prompt, type **0,0,0**.

   The center of the sphere moves to the 0,0,0 coordinate point.

   **Tip:** Simply typing 0 is a shortcut for the coordinates **0,0,0**.
Move objects by dragging
The quickest way to move objects is to click the object and drag it. Rhino provides tools for accurately dragging objects. You can drag objects in any viewport. Object snaps help align objects to each other.

Practice dragging objects
1. Open the tutorial model Drag Objects.3dm.
2. In the Osnap panel, turn on the Center object snap.
3. In the Perspective viewport, hold down the mouse button and move the mouse on the cone's bottom edge until the Center object snap tooltip displays.
4. Drag the cone until the center of the cone's base lines up with the top surface of the cylinder, and the Center object snap for the cylinder's top face displays.
5. Release the mouse button to place the cone.
   Note: Dragging with accuracy like this can be tricky. Keep your eye on the object snap tooltips.

Move objects using elevator mode
You can press the Command key to move objects in the z-direction. This is called elevator mode. See Chapter 5, Accurate Modeling, Elevator mode.
Elevator mode is similar to Ortho, except the movement is vertical to the active construction plane.
To practice using elevator mode to move vertically, you are going to move the box to a location five units above the center of the sphere.
Using elevator mode to move objects vertically lets you work in the Perspective viewport more often.
Move the box with reference to another object

Note: For the following images, the Display Mode Shade-highlight selected surfaces and polysurfaces option has been turned on.

(Rhinoceros > Preferences > Display Modes > Shaded > Objects > Selection)

1. Turn Ortho off.
2. On the Transform menu, click Move.
3. In the Perspective viewport, rotate the view so the sphere is toward the front.
4. Select the box.

5. At the Point to move from... prompt, turn on the End object snap and click the lower right corner of the box.
6. At the **Point to move to** prompt, turn on the **Center** object snap.
   Drag the box around the equator of the sphere until the **Center** tooltip displays.

7. Hold down the **Command** ⌘ key, and click at the center of the sphere.
8. Release the mouse button and the **Command** ⌘ key, and start to drag the box.
   The box can now move only up and down in the z-direction.

9. In the **Value** box, type **5**, and press **Enter**.
   The box will be placed so that the selected end of the box is 5 units in the z-direction from the center of the sphere.
Copy objects
The Copy command makes copies of objects. Like the Move command, the Copy command requires a from and to location.

Practice copying objects
1. On the Transform menu, click Copy.
   Optional: Review the Help topic for the Copy command in Rhino Help.
2. In the Perspective viewport, select the cone and the cylinder.
3. At the Point to copy from... prompt, click anywhere in the Top viewport.
4. At the Point to copy to... prompts, click where you want the copies.
5. When you have enough copies, press **Enter** or right-click the mouse to end the command.
Rotate
The Rotate command rotates an object around a center point.

Rotate an object
1. Open the tutorial model Rotate-Scale.3dm.
   (Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Rotate-Scale)

2. Select the green half-cylinder as shown in the illustration below.

3. On the Transform menu, click Rotate.
   Optional: Review the Help topic for the Rotate command in Rhino Help.
4. in the Top viewport at the **Center of rotation**... prompt, with the **End** object snap on, click the lower left corner of the half-cylinder as shown in the illustration below.

5. In the status bar turn **Ortho** on.

6. At the **Angle or first reference point**... prompt, drag the cursor to the right as shown in the illustration below, and click.

   This establishes the base angle for the rotation.

7. At the **Second reference point**... prompt, drag the cursor up as shown in the illustration below, and click.

   The half cylinder rotates 90 degrees counter-clockwise.
Scale
The Scale commands give you control over the direction of the scale. You can re-size objects uniformly in one, two, or three directions, or scale an object with a different scale factor in each direction.

**Scale the prism**

1. In the same Rotate-Scale model, **select** the red prism shape.

2. On the Transform menu, click **Scale**, and then click **Scale 3-D**.

   *Optional:* Review the Help topic for the **Scale** command in Rhino Help.

3. At the **Base point...** prompt, with the **End** object snap on, click the left corner of the prism as shown in the illustration below.

   This sets the base point from which the object will grow or shrink.

   **Note:** In this simple example, you will first show the object’s original size by picking two points, a base point and a first reference point. Then you will show the object’s new size by picking a second reference point.
4. At the **Scale factor or first reference point**... prompt, click the right corner of the prism as shown in the illustration below.

The distance between the base point and the first reference point sets the original size for the scale operation.

5. At the **Second reference point**... prompt, drag the cursor to the right.

The object grows as you drag the cursor.

6. Click to set the new object size as shown in the illustration below.

---

**Enter a number to set the scale factor**

- To make the object twice its original size, at the **Scale factor**... prompt, in the **Value** box, type **2**.
- To make the object half its original size, at the **Scale factor**... prompt, in the **Value** box type **.5**.

**Scale an object to a specific size**

- To make the prism in this example 2.35 units along the original side, at the **Second reference point**... prompt, in the **Value** box, type **2.35**.
Mirror
In this exercise, you are going to practice another basic editing command: **Mirror**. The **Mirror** command makes a reverse-image copy of the object. Objects are mirrored across a line that you draw in a viewport.

1. Open the tutorial model **Mirror Objects.3dm**.
   
   *(Help menu > Learn Rhinoceros > Tutorials and Samples > User's Guide > Mirror Objects)*

2. On the **Transform** menu, click **Mirror**.
   
   *Optional: Review the Help topic for the Mirror command in Rhino Help.*

3. On the status bar, turn **Ortho on**.

4. **Select** the object.
5. At the **Start of mirror plane**... prompt, in the **Top** viewport, click to the right of the face as shown in the illustration below.

6. At the **End of mirror plane**... prompt, drag the cursor toward the bottom of the screen, and click to end the mirror line.
Rhino offers aids to organize your work. Each method offers a different approach to model organization. These include:

- Layers let you assign a layer designation to objects.
- Groups associate objects so they can be selected as one.
- Blocks let you store and update an association of objects.

### Layers

Layers are a way of grouping objects and applying certain characteristics to all objects that have that layer assignment.

Layer states include a layer name, the color used to display the objects, and the on/off and locked/unlocked status of all the objects on a layer. Objects are always created on the current layer. This layer assignment can be changed later. Objects on layers that are off are not visible in the model. Objects on locked layers cannot be selected but can be snapped to.

### Popup layer list

The popup layer list is a shortcut for the most common tasks related to layers.

**To open the popup layer list**

- In the top panel, click the **Layer** pane.
  - The layer pane displays the current layer.

*Popup layer list.*
In the Popup layer list you can:

- Change the on/off state
- Change the locked/unlocked state
- Change the layer color
- Set the current layer
- Name or rename the layer

In addition, right-click a layer name to perform these actions:

- Select objects on that layer
- Change selected objects to that layer
- Copy objects to that layer

**Layers panel**

Use the **Layers** panel for more detailed layer management.

**To open the Layers panel**

- In the lower section of the right sidebar, click the **Layers** panel icon.

In the **Layers** panel, in addition to the actions you can perform in the Popup layer list, you can also:

- Create new layers and sublayers
- Delete layers
- Move layers up or down in the layer list
- Elevate a sublayer
- Set the layer render material
- Set the layer linetype
- Set the layer print color
- Set the layer print width

Right-click in the Layers panel to display a menu offering additional layer functions.

```
Create new layer
Create new sublayer
Delete layer
Edit layer

Expand all layers
Collapse all layers
Select all layers
Invert selection

Duplicate layer
Duplicate layer and objects

Select objects on layer
Move objects to this layer
Copy objects to this layer
Show only this layer

Show selected layers
Hide selected layers
Lock selected layers
Unlock selected layers

Show columns
```

Review the Help topic for the Layers panel in Rhino Help.

**Groups**

A *group* is a collection of objects that can be selected as one object to be moved, copied, rotated, or other transforms, and to apply properties such as object color. Grouping objects assigns a group name to each object. Objects that have the same group name assigned to them belong to the group. The **Group** command groups objects for selection. A group can contain one or more sub-groups. The **Ungroup** command destroys the group.

When a group is copied, all of the individual objects are copied. Adding copies of each object to the model's database, which increases the model size.

For more information about groups, open the Help topic for the **Group** command.
Blocks

A block is another way of associating various objects together to form a single object. The Block command creates a block definition in the model’s database. Using a block definition uses less memory than using groups.

When you edit the block definition, all instances of the block are changed to match the new definition. Blocks streamline modeling, reduce the model size, and promote standardization of parts and details. Block definitions can be stored outside the model using linked blocks.

Exploding a block instance places the block geometry using the instance location, scale, and rotation.

The Insert command places instances of a block definition in your model. The instance refers to the block definition in the database.

You can scale, copy, rotate, array, and otherwise transform block instances in the model.

To edit geometry in a block definition, double-click a block instance, or use the BlockEdit command.

The BlockManager command displays a dialog box that lists all the block definitions in the model. Use the Block Manager dialog box to view block properties, export a block definition to a file, delete a block definition and all its instances, update a block definition from a file, find out what blocks are nested in other blocks, and count the number of block instances in the model.
10 - Annotation: Dimensions and Text

Rhino's dimension commands let you add annotation features to the model:

- Dimensions
- Annotation Text
- Leaders
- Dots
- Hatching
- Create a 2-D hidden-line drawing
- Notes

## Dimensions

You can dimension objects in your model with your choice of font, units display, decimal precision, text and arrow size, and text alignment.

Dimension commands cover a wide range of dimensioning possibilities:

- Dim - Places horizontal and vertical dimensions depending on the direction you pick the points.
- DimAligned - Creates an aligned dimension.
- DimRotated - Creates a rotated dimension.
- DimAngle - Creates an angular dimension.
- DimRadius - Creates a radius dimension.
- DimDiameter - Creates a diameter dimension.

After dimensions are placed, you can select all dimensions, edit dimension text, turn control points on to move dimension elements, and delete dimensions.
Dimensions are created using the current annotation style. Create new annotation styles to control text size and font, and other annotation properties. Use the settings in Document Settings (File > Settings > Annotation Styles) to create new styles and set the properties of existing styles.

**Note:** Changing your geometry will update the dimensions attached to it. Changing the dimension number will not update the associated geometry.

**Annotation Text**

The Text command places annotation text in your model.

**Leaders**

The Leader command draws an arrow leader with text.
**Dots**

The **Dot** command places a text dot. Dots are always parallel to the view. Dots are displayed in the layer color. Dot size is constant on the screen. As you zoom in and out, the dot displays the same size.

**Hatching**

The **Hatch** command creates a pattern of lines to fill a selected bounding curves.
**Hidden line removal**

The **Make2D** command creates curves from selected objects as silhouettes relative to the active construction plane. The silhouette curves are projected flat and then placed on the world x,y-plane.

The Make2D command options create the 2-D drawings from the current view, current construction plane, create a four-view layout using US or European projection angles, set layers for the hidden lines, and display tangent edges.

---

**Notes**

With the **Notes** command you can store text information in your model file. Type information directly into the **Notes** panel. If you leave the **Notes** panel displayed when you close and save the model file, it will display the next time the file is opened.
11 - Curve and Surface Analysis

Since Rhino is a mathematically accurate NURBS modeler, it includes tools to provide accurate information about the objects.

**Measure distance, angle, and radius**
Some analysis commands provide information about location, distance, angle between lines, and radius of a curve. For example:

- **Distance** displays the distance between two points.
- **Angle** displays the angle between two lines.
- **Radius** displays the radius of a curve at any point along it.
- **Length** displays the length of a curve.

**Direction**
Curves and surfaces have a *direction*. Many commands that use direction information display direction arrows and give you the opportunity to change (*flip*) the direction. Every surface is roughly rectangular. Surfaces have three directions: *u*, *v*, and *normal*. The *u*- and *v*-directions are like the weave of cloth or screen. The *u*-direction is indicated by the red arrow, and the *v*-direction is indicated by the green arrow. The colors match the grid axis colors. The normal direction is indicated by the white arrow. You can think of *u*-*, *v*-, and normal-directions as corresponding to the *x*, *y*, and *z* of the surface. These directions are used when mapping textures and inserting knots.

The **Dir** command displays the direction of a curve or surface. The illustration shows the curve direction arrows. If the direction has not been changed, it reflects the direction the curve was originally drawn. The arrows point from the start of the curve toward the end of the curve. The **Dir** command can also change the direction of a curve.

*Curve direction.*

Surface normals are represented by arrows perpendicular to the surface, and the *u*- and *v*-directions are indicated by arrows pointing along the surface. Closed surfaces always have the surface normals pointing to the exterior.
The Dir command can change the u-, v-, and normal-directions of a surface. This direction can be important if you are applying textures to the surface.

![Surface direction.](image)

**Visual surface analysis**
Visual surface analysis commands let you examine surfaces to determine smoothness. These commands use NURBS surface evaluation and rendering techniques to help you visually analyze surface smoothness with false color or reflection maps so you can see the curvature and breaks in the surface.

![Curvature analysis](image)

**Curvature analysis**
The CurvatureAnalysis command analyzes surface curvature using false color mapping. It analyzes Gaussian curvature, mean curvature, minimum radius of curvature, and maximum radius of curvature.
Environment map

The **EMap** command displays a bitmap on the object so it looks like a scene is being reflected by a highly polished metal. This tool helps you find surface defects and validate your design intent.

The fluorescent tube environment map simulates tube lights shining on a reflective metal surface.

Zebra

The **Zebra** command displays surfaces with reflected stripes. This is a way to visually check for surface defects and for tangency and curvature continuity conditions between surfaces.

Draft angle analysis

The **DraftAngleAnalysis** command displays the draft angle relative to the construction plane that is active when you start the command.

The pull direction for the **DraftAngleAnalysis** command is the z-axis of the construction plane. It also uses false color mapping.
**Edge evaluation**

Geometry problems such as Boolean or join failures can be caused by edges on surfaces that have become broken or edges between surfaces that have been moved through point editing so they create holes. An edge is a separate object that defines the surface’s boundary.

The **ShowEdges** command highlights naked edges, non-manifold edges or all edges of the surface.

![Naked edges](image1) ![Non-manifold edges](image2) ![All edges](image3)

The **Properties** command may tell you that a polysurface is open even though it looks closed. Some operations and export features require closed polysurfaces, and a model using closed polysurfaces is generally higher quality than one with small cracks and slivers.

When a surface is not joined to another surface, it has naked edges. Rhino provides a tool for finding the unjoined or “naked” edges. Use **Properties** command to examine the object details. A polysurface that has naked edges lists as an open polysurface. Use the **ShowEdges** command to display the unjoined edges.

Other edge tools let you split an edge, merge edges that meet end-to-end, or force surfaces with naked edges to join. You can rebuild edges based on internal tolerances. Other edge tools include:

- **SplitEdge** divides a surface edge at a designated point.
- **MergeEdge** merges edges that meet end to end.
- **JoinEdge** forces unjoined (naked) edges to join nearby surfaces.
- **RebuildEdges** redistributes edge control points based on internal tolerances.

**Diagnostics**

Diagnostic tools report on an object’s internal data structure and select objects that may need repair. The output from the **List**, **Check**, **SelBadObjects**, and **Audit3dmFile** commands is normally most useful to a Rhino programmer to diagnose problems with surfaces that are causing errors.
12 - Render

In addition to shaded previews, Rhino provides full-color rendering with lights, transparency, shadows, textures, and bump mapping.

Objects will render white until you add render color, highlight, texture, transparency, and bumps. These attributes are controlled through the Properties and Materials panels.

The process to render scenes consists of four basic steps:

- Add lighting.
- Assign materials.
- Set up the environment and a ground plane.
- Render.

Although the steps do not have to be done in this order, using this method makes setting up a scene more efficient. To improve quality, repeat these steps until the image looks right to you.

Lights

In every Rhino rendering there are light sources that Rhino uses to calculate how objects are illuminated. If you do not add any light sources to your scene, the default light is used. The default light is a directional light, with parallel rays, that acts as though you have a lamp shining over your left shoulder.

Use the SpotlightsDirectionalLight, LinearLight, PointLight, or RectangularLight commands to insert indoor lights. You can also turn on the Sun, a parallel light source, that can be defined by location, date and time.
Materials
Materials specify the color, finish, transparency, texture, and bump for use by the renderer. Set up or import materials in the Materials panel, then assign materials to layers or objects. You can drag materials from the material library and drop them onto objects.

Environment
Environments describe the space around the model. This space is reflected in objects and can provide overall lighting. The rendering properties include environment settings like background color and image.
Ground Plane

The ground plane provides an infinite horizontal platform for the image. The ground plane stretches to the horizon in all directions. Any material can be assigned to the ground plane. Set up a ground plane in the Ground Plane panel.

Render Preview

Preview a rendering by setting a viewport to Rendered viewport mode.
13 - Solids and Transforms - Pull Toy

This tutorial demonstrates using solid primitives and simple transforms.

You will learn how to:

- Enter coordinates and use object snaps to place points precisely.
- Draw a free-form curve and polygon.
- Extrude a curve to create a surface.
- Use a polar array to copy objects in a circular pattern.
- Use Planar and Ortho mode.
- Create a pipe along a curve.

Enter coordinates

When you pick a point with the mouse, the point lies on the construction plane of the active viewport unless you use a modeling aid such as object snap or elevator mode.

(1) The cursor moves on the construction plane. (2) An object snap is active. (3) The Elevator mode.
When Rhino prompts for a point, you can enter x-, y-, and z-coordinates instead of picking a point. Each viewport has its own construction plane on which its x- and y-coordinates lie. The z-coordinate for the active viewport is perpendicular to the x-y plane.

The grid is a visual representation of the construction plane. The intersection of the dark red and green lines is the origin point (x=0, y=0, z=0) of the coordinate system.

Draw the pull toy body
This exercise uses x-, y-, and z-coordinates to place points accurately. When you type the coordinates, type them just as they are shown in this manual. The format is \(x,y,z\). For example, type \(10,5,6\). You must type commas to separate the numbers. These coordinates place the point at \(x=10\), \(y=5\), and \(z=6\) in the active viewport.

Whenever you type coordinates to place a point, look in all the viewports, so you can get an idea of how coordinate entry works.

**Start the model**

1. On the **File** menu, click **New Using Template**.
2. In the screen splash, double-click **Small Objects - Centimeters.3dm** in the template list.

**Draw the body ellipsoid**

1. In the status bar, turn **Ortho** on.
2. On the **Solid** menu, click **Ellipsoid > From Center**.

3. At the **Ellipsoid center...** prompt, move the cursor to the **Top** viewport.
   
   When Rhino prompts for picking a point, moving the cursor to a viewport makes the viewport active/current.

4. Type **0,0,11**, and press **Enter**.
   
   This places the center point of the ellipsoid at \(x=0, y=0, \) and \(z=11\). Look at the point in the **Perspective** viewport.

5. At the **End of first axis...** prompt, type **15**, and press **Enter**.

6. Move the cursor to the right to specify the direction and click.

7. At the **End of second axis** prompt, type **8**, and press **Enter**.

8. Move the cursor up to specify the direction and click.
9. At the **End of third axis** prompt, type 9, and press **Enter**.
   You now have an egg shape that has different dimensions in all three directions.

![Egg Shape](image)

**Draw the axles and wheel hubs**
The axles and wheel hubs are cylinders. The axles are long, thin cylinders, and the wheel hubs are short, fat cylinders. You are going to make one axle and one complete wheel. You will then mirror the complete wheel to the other side. You can then either mirror or copy the complete axle and wheel set to the front of the toy.

**Create the axle**

1. Rotate the perspective viewport so that you are looking along the x-axis as illustrated.
2. Turn on **Shaded** display mode in the **Perspective** viewport.
3. On the **Solid** menu, click **Cylinder**.
4. At the **Base of cylinder...** prompt, move the cursor to the **Front** viewport.
5. Type **9,6.5**, and press **Enter**.
   When you only type x- and y-coordinates, the z-coordinate is automatically 0.
6. At the **Radius...** prompt, type **0.5**, and press **Enter**.

   ![Image of a solid object](image)

7. At the **End of cylinder** prompt, in the command options, check **Both Sides**.

8. Type **10**, and press **Enter**.

   A cylinder 20 centimeters long is created.

---

**Create a wheel hub**

1. On the **Solid** menu, click **Cylinder**.

2. At the **Base of cylinder...** prompt, move the cursor to the **Front** viewport, type **9,6.5,10**, and press **Enter**.

3. At the **Radius...** prompt, type **4**, and press **Enter**.

   ![Image of a wheel hub](image)

4. At the **End of cylinder** prompt, uncheck **Both Sides**.
5. Type **2**, and press **Enter**.
You have created a cylinder that represents a wheel hub.

![Cylinder representing a wheel hub]

**Draw the lug nuts**
You will make the lug nuts by extruding a hexagonal polygon curve.

**Create a hexagon**

1. On the **Curve** menu, click **Polygon > Center, Radius**.
2. At the **Center of inscribed polygon...** prompt, type **6**, and press **Enter**.
   This sets the **NumSides** option to 6.
3. Move the cursor to the **Front** viewport, type **9,8,12**, and press **Enter**.
   This places the polygon on the surface of the wheel hub.
4. At the **Corner of polygon...** prompt, type **0.5**, and press **Enter**.
5. Move the cursor to the right, and click to specify the orientation of the hexagon.

![Hexagon on the surface of a wheel hub]
**Make a solid from the hexagon**

1. In the **Perspective** viewport, select the hexagon you just created.
2. On the **Solid** menu, click **Extrude Planar Curve > Straight**.
3. At the **Extrusion distance...** prompt, in the command options:
   - Uncheck **BothSides**
   - Check **Solid**
   - Check **DeleteInput**
4. Move the cursor away from the wheel hub.
   The extrusion direction in preview defines the positive direction for the next step.
5. Type **0.5**, and press **Enter**.
Array the lug nuts
To create the lug nuts on the first wheel, you are going to use a polar (circular) array. An array is a set of copies of an object. A polar array copies the objects around a central point. The objects are rotated as they are copied.

1. In the Front viewport, select the lug nut.
2. On the Transform menu, click Array > Polar.
3. At the Center of polar array... prompt, in the object snap control, check Center.
4. Move the cursor near the hub edge to until the cursor snaps to the center of the hub and click.
5. At the Number of items... prompt, type 5, and press Enter.
6. At the Angle to fill... prompt, press Enter.
7. At the Press Enter to accept prompt, preview the result and press Enter.
Draw the tires
The tire is a solid form called a torus, which looks like a donut. When you are drawing a torus, the first radius is the radius of a circle around which the “tube” is drawn. The second radius is the radius of the tube itself.
To draw the tire, you will draw the center of the torus tube a bit larger than the diameter of the wheel hub. The tube itself is slightly larger than the hub. This makes it dip into the hub.

Create a torus for the tires
1. On the Solid menu, click Torus.
2. At the Center of torus... prompt, in the Object Snap control, select One shot, and click Between.
3. In the Perspective viewport, move the cursor near an edge of the wheel hub until the Cen tooltip appears and click.
4. Move the cursor near the other edge until the Cen tooltip appears and click.
   This places the center of the torus at the middle of the hub "between" the centers of two circles that make up the edges of the wheel hub.

5. At the Radius... prompt, move the cursor to the Front viewport, type 5, and press Enter.
   This makes the radius of the torus tube one unit bigger than the wheel hub.

6. At the Second radius... prompt, type 1.5, and press Enter.
   This makes the inner dimension of the torus tube 0.5 units smaller than the wheel hub.
Mirror the wheels
Now that you have a whole wheel with tire created, use the **Mirror** command to create the other three.

**Mirror the wheel to the other side**

1. In the **Top** viewport, window select the wheel as illustrated. Be sure to select all the wheel parts.

2. On the **Transform** menu, click **Mirror**.

3. At the **Start of mirror plane...** prompt, at the command line, click the **XAxis** option.
   
   A mirrored copy of the wheel is made across the construction plane x-axis.

**Mirror the front wheels and axle**

1. In the **Top** viewport, window select the wheels and axle as illustrated.

2. On the **Transform** menu, click **Mirror**, or right-click to repeat the command.
3. At the **Start of mirror plane...** prompt, at the command line, click the **YAxis** option.
   A mirrored copy of the wheel set is made across the construction plane y-axis.

**Draw the eyes**
You are going to draw a sphere on the body ellipsoid to represent an eye.

**Create an eye using a sphere**

1. On the **Solid** menu, click **Sphere > Center, Radius**.
2. At the **Center of sphere...** prompt, in the **Object Snap** control, click **On surface**.

   ![Object Snap Control](image)

   - Persistent
   - One shot
   - End
   - Near
   - Point
   - Between
   - On curve
   - On surface
   - On polysurface
   - From point
   - Perpendicular from

3. In the **Perspective** viewport, select the body ellipsoid, and pick a point on the surface as illustrated.
4. At the **Radius...** prompt, type 3, and press **Enter**.

![Image of a toy car with a yellow eye]

---

### Mirror the eye

1. In the **Top** viewport, select the eye.

![Image of a toy car with a yellow eye selected in the top viewport]

2. On the **Transform** menu, click **Mirror**.

3. At the **Start of mirror plane...** prompt, type 0 (this is a shortcut for typing 0,0,0), and press **Enter**.

4. At the **End of mirror plane...** prompt, with **Ortho** on, drag the cursor to the left and click.

A mirrored copy of the eye is created on the opposite side across the x-axis.

![Image showing a mirrored copy of the eye on the opposite side]

---

117
Make the pull cord
To make the cord, you are going to draw a free-form curve using elevator and planar mode. When the curve is complete, use the **Pipe** command to make it a thick solid.

**Set up the view**

1. **Zoom** out in all the viewports; you are going to need some space in front of the body ellipsoid to work.
2. In the top panel, turn **Planar** mode on, and turn **Ortho** off.

![Object Snap control]

3. In the **Object Snap** control, click **Disable** to turn off all object snaps.
   
   In the **Object Snap** control, select **Persistent** and check **Disable all** to turn off all object snaps.

   ![Object Snap control]

**Create the pull cord at the front of the toy**

1. On the **Curve** menu, click **Free-form > Control Points**.
2. At the **Start of curve...** prompt, in the **Top** viewport, hold the **Command** key and click near and inside the front end of the body ellipsoid.
   
   This only activates the **Elevator** mode. You have not placed the start point of the curve yet.
3. Move the cursor to the **Front** viewport, drag the cursor upwards near the end of the ellipsoid, and click.

4. At the **Next point...** prompt, return to the **Top** viewport, move the cursor left and click.

Planar mode keeps successive points at the same construction plane elevation. Elevator mode and object snaps override Planar mode. Watch the curve in the **Front** and **Right** viewports.

5. Place the third point in the **Front** viewport.
6. Turn off Planar mode and click several more points in the Top viewport to create a free-form curve. Press Enter when done.

Notice that the points are placed on the Top construction plane.

---

**Make the cord handle**

Draw a small Ellipsoid to represent a handle at the end of the curve.


2. At the First focus... prompt, hold the Alt key and check End object snap.

Holding the Alt key while clicking an object snap checkbox temporarily enables an object snap when they are all disabled.
3. In the **Top** or **Perspective** viewport, while holding the **Alt** key, snap to the end of the cord curve and click.

4. At the **Second focus...** prompt, drag the cursor along the cord curve direction about 5 units.

   You can see the distance you are dragging the cursor from the last point in the status bar.

   *The status bar displays the distance between the cursor and the previous point.*

5. Click to place the second focus point.

6. Drag the cursor to specify an appropriate size for the handle and click.
Thicken the curve with a pipe

1. **Select** the cord curve.
2. On the **Solid** menu, click **Pipe**.
3. At the **Start radius**... prompt, type **0.2**, and press **Enter**.
4. At the **End radius**... prompt, press **Enter**.
5. At the **Point for next radius**... prompt, press **Enter**.
   
   The pipe will be the same radius for the full length of the curve.
14 - Tutorial: Revolve Curves - Flashlight

Creating surfaces from curves and joining the surfaces together allows you greater freedom for modeling the shape. This tutorial introduces the concept of drawing curves and one method of creating surfaces from those curves.

You will learn how to:
- Add guides to help drawing the profile curves.
- Draw free-form curves.
- Edit control points.
- Revolve curves around an axis to create surfaces.
- Use History.

You will use guides as a frame of reference for drawing the profile curves of the flashlight.

To download the tutorial model
1. On the Rhino Help menu, click Learn Rhinoceros, and then click Tutorials and Samples.
2. In the Tutorials panel, under User’s Guide, double-click the tutorial model file Flashlight.3dm.
Set up the guides
Guides are infinite construction lines that only display when you are picking a point for a command or when you are dragging objects.

Add guides
1. Click anywhere in the Front viewport to make it active.
2. Run the Grid command, and uncheck Show Grid and Show Grid Axes.
   This hides the construction plane grid so you can easily see the guides you are going to add.
3. In the top panel, turn on SmartTrack.

   Note: Guides will not display when SmartTrack or Osnap is off.
4. Hold down Alt, and click on the Point checkbox in the Object Snap control.
   This turns on the Point object snap and turns off all the others.
5. Type AddGuide, and press Enter.
6. Snap to a point, move the cursor vertically or horizontally, and click to add a guide.
   If the cursor cannot move vertically or horizontally, hold down Shift to temporarily enable Ortho mode.
7. Add more guides as illustrated.

Tip: If a guide is not added properly, use the RemoveGuide command to remove the guide.

Draw the body profile curve
You are going to draw a profile curve that you will use to revolve and create the flashlight body.

Draw the body curve
1. In the top panel, click the Layer pane, and click the light bulb of the Points for guides layer to turn it off.

2. On the Curve menu, click Free-Form > Control Points.
3. Set command options to Degree=3 and PersistentClose=Off.
4. At the Start of curve... prompt, in the Front viewport, snap to the lower-left intersection of the guides and click.

Note: When guides display, Intersect and Near object snaps are always turned on.
5. At the **Next point...** prompt, continue placing points as illustrated. Press **Enter** when done.

All the points will be placed either on a guide or at an intersection of two guides.

**Note:** The first and last two points must be placed along the y-axis so the surface created from the curve will be smooth at both ends.

### Draw the lens profile curve

Make another profile curve for the lens.

#### Create the outer lens profile curve

1. On the **Curve** menu, click **Free-Form > Control Points.**
2. At the **Start of curve...** prompt, in the **Front** viewport, hold down **Alt** and place the first point as illustrated.

**Note:** Holding down Alt hides the guides and avoids snapping to the guides.

3. At the **Next point...** prompt, release Alt and place the second point.
4. For the third point, hold down **Shift**, snap to the lowest guide, click, and press **Enter** to end the curve.

![Image](image.png)

**Note:** Holding down **Shift** enables **Ortho** mode. The second and third points are placed along the y-axis.

---

**Offset to create the inner lens profile curve**

1. In the top panel, turn **SmartTrack** off to disable guides.

![Image](image.png)

2. On the **Curve** menu, click **Offset** > **Offset Curve**.

3. At the **Select curve to offset...** prompt, set the command options **Distance=1.5** and **Cap=None**.

4. Select the outer lens profile curve in the **Front** viewport, move the cursor to the left and click.
**Connect the inner and outer lens profile curves**

1. On the **Curve** menu, click **Line > Single Line**.
2. In the **Object Snap** control, check **End**.

3. Snap to the upper ends of the lens profile curves.
   This creates a line to fill the gap.

4. Select the line and the lens profile curves.
5. On the **Edit** menu, click **Join**.
   The curves and line are joined into a polyline.
Build body and lens surfaces
To make the body and lens surfaces, you will revolve the body and lens profile curves 360 degrees. You will use two curve ends to establish the revolve axis.

Create the flashlight body and lens

1. Right-click on the Perspective viewport title, and select **Shaded**.

   ![Perspective viewport settings](image)

   **Note:** The Shaded display mode uses render meshes to display surfaces so you can see the surfaces when they are created.

2. Select the body and lens profile curves.

   ![Selection window](image)

   **Tip:** Drag the cursor from right to left, the dashed rectangle is the crossing selection window. All objects that intersect or are within the rectangle will be selected.

3. In the top panel, click **History**.

   The next command will have History recorded.

4. On the **Surface** menu, click **Revolve**.
5. At the **Start of revolve axis** prompt, snap to an end of the body profile curve and click.

6. At the **End of revolve axis**... prompt, snap to the other end and click.

7. Click **Full Circle** in command options.
Use History
We recorded History when building the flashlight body and lens surfaces. In the next section, we will change the shape of the body profile curve and let History update the body surface.

**Edit the body profile curve**

1. In the **Front** viewport, select the body profile curve.

   The body profile curve and surface are overlapped. The **Choose Objects** menu pops up because Rhino cannot tell what you are going to select. You will have to select **curve** from the list.

   ![Choose Objects Menu](image)

   **Note:** When you select a single curve, its control points turn on automatically. The control points turn off when you deselect the curve. If you need control points to stay on when a curve is deselected, select the curve, and press **F10**.

2. Drag the control points to change the shape of the body profile curve.

   History updates the body surface for you.
15 - Tutorial: Sweep, Loft, and Extrude - Headphones

This tutorial demonstrates how to create surfaces from profile curves.

You will learn how to:

- Use sub-object selection to preselect objects for a command.
- Create a surface from a planar curve.
- Loft, revolve, sweep, and extrude surfaces.
- Cap planar holes to create a solid.
- Draw a helix around a curve.
- Match curve ends.
- Create solid pipes.
- Mirror objects.
- Use layers.
- Use object snaps.

To download the tutorial model

1. On the Rhino Help menu, click Learn Rhinoceros, and then click Tutorials and Samples.
2. In the Tutorials panel, under User's Guide, double-click the tutorial model file Headphone.3dm.
Create the speaker shell
The speaker shell is created using a lofted surface, a one-rail sweep, a solid extrusion of a planar curve, and a surface fillet. The resulting geometry is joined into one solid.
One way to create a surface is to use existing curves as a guide. When lofting through curves, the curves are used as a guide for creating a smooth surface.

Loft curves to create a surface

1. Right-click on the Perspective viewport title, and on the viewport title menu, click Shaded.
   The Perspective viewport is now in the Shaded display mode.
2. Select the three circular curves, with a crossing selection as illustrated.
3. On the Surface menu, click Loft.
4. At the Drag seam point to adjust... prompt, note the display of the curve direction arrows at the seam points.
   In this model, they are nicely lined up, so you do not need to adjust them.
   Press Enter.
5. In the **Loft Options** dialog box, click **Loft** to create the loft.

![Diagram of a lofted surface]

**Sub-object selection**

Hold down **Command ⌘** and **Shift**, and click to select individual object features such as:

- Polysurface faces
- Surface and polysurface edge curves
- Mesh vertices, faces, and edges
- Objects within a group

This action is called *sub-object selection*.

---

**Extrude the surface edge**

Extrude the lofted surface edge in the center to make a magnet housing on the convex side of the speaker shell.

1. Hold down **Command ⌘** and **Shift** to select the surface edge at the center of the lofted surface.

![Diagram of extruding a surface edge]

2. On the **Solid** menu, click **Extrude Planar Curve > Straight**.
3. At the **Extrusion Distance**... prompt, move the cursor to the convex side, type 2, and press **Enter**.

This makes a solid cylinder for the magnet housing that is two units thick and extends from the original surface edge.

**Note:** The cylinder you just created is an extrusion object (solid). The housing cylinder needs to be open on the bottom.

In the next step, you will use *sub-object selection* to remove the bottom face.

---

**Remove the bottom surface**

1. Hold down **Command ⌘** and **Shift**, and click to select the bottom face.

2. Press the **Delete** key.
Fillet or round off the edge of the cylinder surface

1. On the Solid menu, click Fillet Edge > Fillet Edge.
   The current Next Radius setting should be 1.
2. At the Select edges to fillet... prompt, select the edge at the top of the cylinder, and press Enter.

3. At the Select fillet handle to edit... prompt, press Enter.

Surfaces that share an edge can be joined into a polysurface. In the next step, you will join all the surfaces.
**Join the surfaces**

1. Select the surface and the polysurface.
2. On the **Edit** menu, click **Join**.

To join surfaces, you must select surfaces that are adjacent to each other and the edges must match.

**Create the padding and cover**

Sweep a curve around the edge of the speaker cone to create the padding around the edge of the speaker.

**Reset the view**

1. On the **View** menu, click **Zoom > Zoom Extents All**.
   All viewports are zoomed in or out to show all the objects.
2. **Hide** or **Delete** the three curves used for the loft.

**Sweep a curve along one rail**

1. On the **Surface** menu, click **Sweep 1 Rail**.
2. At the **Select rail** prompt, select the loft surface outer edge.
3. At the **Select cross section curves** prompt, select the cross section curve at the top of the speaker as shown, and press **Enter**.

4. In the **Sweep 1 Rail Options** dialog box, enable **Refit rail**, and click **Sweep**.

![Sweep Diagram]

**Make a surface from planar curves**

1. Hold down **Command ⌘** and **Shift**, and click to select the inner edge of the padding as illustrated.

   ![Planar Curves Selection]

2. On the **Surface** menu, click **Planar Curves**.

   ![Planar Curves Result]

   A planar surface is created at the base of the padding.

   This fills the area at the base of the padding with a planar surface created from the edge of the sweep.
Create the mounting bracket
The next part is the bracket that holds the speaker to the headband. Since the speaker unit is complete, you can turn its layer off and make the Bracket layer current.

Reset the layers
1. In the top panel, click the Layer pane where it shows Speaker.
2. Make Bracket the current layer, and turn on the layer Bracket Shape Curves.
3. Turn all other layers off.

Reset the view
- On the View menu, click Zoom > Zoom Extents All to zoom in on the bracket shape curves in all viewports.

Extrude a curve into a solid
1. Select the closed curve.

2. On the Solid menu, click Extrude Planar Curve > Straight.
3. At the Extrusion distance... prompt, move the cursor to the left, type 1, and press Enter.
1. On the **Solid** menu, click **Fillet Edge > Fillet Edge**.
2. At the **Select edges to fillet...** prompt, type **0.2**, and press **Enter**.
3. At the **Select edges to fillet...** prompt, click **Chain Edges**, and select the front edge of the bracket.
   The entire edge of the solid should highlight.
4. Press **Enter** to close that edge selection.

![Image of solid model]

5. At the **Select edges to fillet...** prompt, click **Chain Edges**, and select the back edge of the bracket.
6. Press **Enter** to close that edge selection.

![Image of solid model]

7. Press **Enter** to finish the edge selection.
8. At the **Select fillet handle to edit...** prompt, press **Enter**.

![Image](image.jpg)

This rounds all of the sharp edges.

---

**Create a tubular surface from the shape curves**

1. Select the curve at the top of the bracket.
2. On the **Solid** menu, click **Pipe**.
3. At the **Start radius...** prompt, in the command options, select **Flat** for **Cap** and uncheck **Thick**.
4. Type **0.3**, and press **Enter**.
5. At the **End radius...** prompt, press **Enter**.
6. At the **Point for next radius...** prompt, press **Enter**.

![Image](image.jpg)
For the second tube

1. Select the curve at the bottom of the bracket.
2. On the Solid menu, click Pipe.
3. At the Start radius... prompt, type 0.2, and press Enter.
4. At the End radius... prompt, press Enter.
5. At the Point for next radius... prompt, press Enter.

Create the headband
The headband consists of a series of ellipses swept along a path.

Reset the layers

1. In the top panel, click the Layer pane.
2. Make Headband the current layer, and turn on the layer Headband Shape Curves.
   Turn all other layers off.
Reset the view

- On the View menu, click Zoom > Zoom Extents All to zoom in on the headband shape curves in all viewports.

Create an ellipse perpendicular to a curve

1. Turn Ortho on.
2. On the Curve menu, click Ellipse > From Center.
3. At the Ellipse center... prompt, click Around Curve.
4. Select the curve.
5. At the Center of ellipse prompt, snap to an endpoint of the headband curve and click.

   Use the End object snap.
6. At the End of first axis prompt, type 0.5, and press Enter.
7. At the End of first axis prompt, drag the cursor in the x-direction and click.
8. At the End of second axis prompt, type 2, and press Enter.
9. At the **End of second axis** prompt, drag the cursor in the y-direction and click.

![Image](image1.png)

Array a curve along a path

1. Select the ellipse.
2. On the Transform menu, click **Array > Along Curve**.
3. At the **Select path curve** prompt, select the headband curve.

![Image](image2.png)

4. In the **Array Along Curve Options** dialog box, under **Array Along Curve Method**, set the **Number of items** to **3**.
5. Under **Orientation**, click **Freeform**, and click **Array**.

![Image](image3.png)
1. Select the center ellipse.

2. On the Transform menu, click Scale > Scale 1-D. Scale 1D stretches an object in one direction.

3. At the Base point... prompt, press Enter.

4. At the Scale factor or first reference point... prompt, type 2, and press Enter.

5. At the Scale direction... prompt, drag the cursor in the y-direction and click.

This makes the center ellipse larger.
1 Sweep along one rail

1. On the **Surface** menu, click **Sweep 1 Rail**.
2. At the **Select rail** prompt, select the headband curve.
3. At the **Select cross section curves** prompt select the three ellipses, and press **Enter**.

4. At the **Drag seam point to adjust...** prompt, examine the direction and seam points of the curves to make sure they are not twisted, and press **Enter**.
5. In the **Sweep 1 Rail Options** dialog box, click **Sweep**.
**Round the headband ends**

Use the same ellipse that formed the first cross-section curve for the headband to create a rounded end for the headband. Start by splitting the ellipse in half.

---

### Reset the view

1. On the **View** menu, click **Zoom > Zoom Window**.
2. In the **Perspective** viewport, drag a rectangle to enclose the left end of the headband to zoom in.

---

### Split the ellipse in half

1. In the Object Snap control, hold down **Alt** and click the **Quadrant** object snap. The Quadrant object snap is enabled. All the others are disabled at the same time.
2. On the **Edit** menu, click **Split**.
3. At the **Select objects to split...** prompt, click the **Point** option.
4. At the **Select curve to split** prompt, select the ellipse.
5. At the **Point to split curve** prompts, snap to the two quadrants at the narrow axis of the ellipse and click, and then press **Enter**.

The ellipse is split into two halves.

---

**Create a surface of revolution**

1. Select the left half of the ellipse.

2. On the **Surface** menu, click **Revolve**.
3. At the **Start of revolve axis** prompt, snap to the end of the ellipse half and click.

4. At the **End of revolve axis** prompt, snap to the other end of the ellipse half and click.

5. At the **Start angle...** prompt, snap to the ellipse at the outer edge of the headband and click.
6. At the **Revolution angle** prompt, rotate the view to see the other side.

   Swing the mouse cursor down and snap to the other side of the ellipse and click.

   ![Image](image1)

   A rounded surface is created at the end of the headband.

   ![Image](image2)

---

**Mirror the rounded end**

1. Select the rounded end.

   ![Image](image3)

2. On the **Transform** menu, click **Mirror**.

3. At the **Start of the mirror plane** prompt, type 0, and press **Enter**.
4. At the End of the mirror plane prompt, drag the mirror line in the y-direction as illustrated, and click.

Hold down Shift to help move the cursor in the ortho direction.

Join the surfaces

1. Select the surfaces.
2. On the Edit menu, click Join.

Three surfaces are joined into one polysurface.

Create the speaker wire

Use a separate layer to create the speaker wire.

Reset the layers

1. In the top panel, click the Layer pane.
2. Make Wire Shape Curves the current layer and turn on the layer Wire.

Turn all other layers off.

Reset the view

- On the View menu, click Zoom > Zoom Extents All.
Make the helix

1. On the Curve menu, click Helix.
2. At the Start of axis... prompt, click Around Curve.
3. At the Select curve prompt, select the long free-form curve.
4. At the Radius and start point... prompt, type 1, and press Enter.
   This sets the radius for the helix.
5. At the Radius and start point... prompt, set Turns=30 and Num Points Per Turn=8.
6. At the Radius and start point... prompt, in the Right viewport drag the cursor to the left and click.
   Hold down Shift to help move the cursor in the ortho direction.

Reset the view

1. On the View menu, click Zoom > Window.
2. In the Perspective viewport, zoom in on the left end of the helix you just created.
**Match and join the helix to the end curves**

1. On the **Curve** menu, click **Curve Edit Tools > Match**.

2. At the **Select open curve to change - pick near end** prompt, select near the left end of the helix.

3. At the **Select open curve to match - pick near end...** prompt, select near the lower end of the vertical curve.

4. In the **Match Curve** dialog box, under **Continuity**, click **Tangency**, and enable **Join**.

5. **Repeat** steps 1 through 4 for the other end of the helix.
**Create the speaker wire**

1. On the **Solid** menu, click **Pipe**.
2. At the **Select rail** prompt, select the extended helical curve.
3. At the **Start radius**... prompt, type **0.2**, and press **Enter**.
4. At the **End radius**... prompt, press **Enter**.
5. At the **Point for next radius** prompt, press **Enter**.

![Create the speaker wire](image)

**Create the second wire**

1. Select the curve at the top left.
2. On the **Solid** menu, click **Pipe**.
3. At the **Start radius**... prompt, type **0.1**, and press **Enter**.
4. At the **End radius**... prompt, press **Enter**.
5. At the **Point for next radius** prompt, press **Enter**.

![Create the second wire](image)
**Mirror the headphone parts**
Mirror the parts to create the parts for the other side of the headphones.

<table>
<thead>
<tr>
<th><strong>Reset the layers</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the top panel, click the <strong>Layer</strong> pane.</td>
</tr>
<tr>
<td>2. Turn on all layers.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Reset the view</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>▶ On the <strong>View</strong> menu, click <strong>Zoom &gt; Zoom Extents All</strong>.</td>
</tr>
</tbody>
</table>

**Delete all the shape curves**

1. Press **Esc** to deselect anything currently selected.
2. On the **Edit** menu, click **Select Objects > Curves**.
3. Press the **Delete** key.

<table>
<thead>
<tr>
<th><strong>Mirror the left half of the headphones</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the <strong>Front</strong> viewport, window select the speaker, bracket, small wire, and rotated ellipse as illustrated.</td>
</tr>
<tr>
<td>2. On the <strong>Transform</strong> menu, click <strong>Mirror</strong>.</td>
</tr>
</tbody>
</table>

The **Mirror** command depends on which viewport is active. It uses the construction plane in the active viewport to define the mirror plane. The mirror plane is perpendicular to the construction plane. Two points define the line in this plane about which the selected objects are mirrored.
3. At the **Start of mirror plane** prompt, type 0, and press **Enter**.
This is the first point of the mirror line.

4. At the **End of mirror plane** prompt, turn on **Ortho**, and drag the mirror line straight up and pick.

---

**Learn more**

For a video tutorial showing a more sophisticated modeling method for a headphone set using Rhino’s Gumball feature, see: *Modeling stereo headphones*. 
16 - Tutorial: Loft and Sweep - Boat

This tutorial demonstrates classic boat hull lofting techniques using typical plan and profile curves. The classic hull shape is based on a design from an old *Boat Builder’s Handbook* magazine. Many designs similar to this are available over the Internet.

You will learn how to:

- Simplify the curves.
- Use curvature graph to improve fairness.
- Create 3-D curves from 2-D curves.
- Create surfaces from 3-D curves.

**Marine terms used in this tutorial**

**Sheer**
The fore-and-aft curvature from the bow to the stern of a ship’s deck as shown in side elevation.

**Chine**
The intersection of the bottom and the sides of a flat or v-bottomed boat.

**Transom**
The planking forming the stern of a square-ended boat.

**Fair**
The meaning of *fair* is much debated in the marine industry and not easily defined. Although fairing or smoothing is traditionally associated with hull surfaces, all visible surfaces on any object can benefit from this process. In Rhino, the first cue for fairness in a surface is the spacing of the surface isocurves.

There are other characteristics of fair that curves and surfaces tend to have, although a curve or surface may be fair without exhibiting all of the characteristics. If you keep these characteristics in mind while modeling, you will end up with a better final product.

The guidelines for creating a fair surface include:

- Use the fewest possible control points to get the curve shape.
- Use the fewest possible curves to get the surface shape.
Lay out the hull curves
The hull curves were created by tracing the original plans using a background bitmap. The first step is to check the curves for fairness before creating surfaces from them.

The designer’s curves are illustrated. The sheer and chine are extended at the forward and aft ends to accommodate the lofting process.

To download the tutorial model
1. On the Rhino Help menu, click Learn Rhinoceros, and then click Tutorials and Samples.
2. In the Tutorials panel, under User’s Guide, double-click the tutorial model file Victory.3dm.

   The curves are laid out on the Plan and Profile layers.
Check the curves for fairness
Select each of the designer’s curve pairs in plan and profile and use the CurvatureGraph command to determine if the curves are fair. In this case, the file has the original curves that were traced from the background bitmap. They are not fair. In other words, the curves do not smoothly transition from one end of the sheer to the other. Adjust points on any curve that is not fair. Start with the sheer (the curve at the top of the hull shape). It has the biggest impact on the appearance of the vessel.

Check curvature

1. Select the sheer curve.
2. On the Analyze menu, click Curve > Curvature Graph On to start the CurvatureGraph command.
3. In the Curvature Graph dialog, increase Display scale to exaggerate the curvature variation.
   We can tell that this curve has a poor curvature quality from its curvature graph.
4. Change the Curvature hair color as needed to make the curvature graph stand out from the background.
   The illustration shows the curvature graph applied to the 2-D sheer in profile.
**Note**

The curvature graph should be continuous and exhibit the desired characteristics for the curve.

- When the curve is bending downward, the curvature graph will be above the curve. (1)

![Curvature Graph Example 1](image1)

- Conversely, when the curve is bending upward, the curvature graph will be below the curve. (2)

![Curvature Graph Example 2](image2)

- The point of inflection (where the bending is reversing from one side to the other) is where the curvature graph crosses the curve. (3)

![Curvature Graph Example 3](image3)
Fix the curvature
Before doing any point editing to make a curve fair, you will rebuild the curve to remove excess control points. In general, rebuilding a curve involves using the Rebuild command along with examination with the CurvatureGraph command.

- When using the Rebuild command, do not use more points than you absolutely need.
- Use the CurvatureGraph command to check the curve for fairness after each change. If the curvature graph is still not satisfactory, move the control points until you have a smooth graph.
- Fair all of the curves in the model as needed before creating surfaces from bad curves.

Rebuild the sheer curve
1. Select the sheer curve.
2. On the Edit menu, click Rebuild to start the Rebuild command.
3. In the Rebuild dialog box, change Point count to 6 and Degree to 5.
4. Enable Delete input, and click Rebuild.

The curvature is improved, but it is not good enough. From the curvature graph, we can tell that the black curve in the right illustration is the real shape of the current sheer curve if we overstate it. It bends three times. We will improve the curve further by editing its control points to make it bend only once.
**Improve the curve further**

The fine-tuning curvature of a curve requires moving control points a very short distance. It is not easy to do this with the normal mouse movement, so we can use Nudge Keys, the MoveUVN, or DragStrength commands to reduce moving strength. We will use the DragStrength command in this tutorial.

---

**Drag, move, and nudge control points**

1. Select the sheer curve and press **F10** to turn on its control points.
2. Start the **DragStrength** command.
3. In the **Drag Strength** dialog, set the strength value to 5.

   ![Drag Strength dialog]

   Moving the mouse cursor in a distance on the screen will only move an object 5% of the distance.
4. In the **Front** viewport, select the four control points in the middle.
5. Use **Gumball** to move the control points in the y-axis.

   Make the whole curvature graph below the sheer curve. It can be above the sheer curve if it is the design.

6. Close the **Drag Strength** dialog.

   Drag strength returns to 100% when the dialog is closed.
7. Press **ESC** to turn off the curve control points.
See also
For more information about using Rhino's gumball feature, review the Help topic for the Gumball command.
Two video tutorials also help with learning to use the gumball

- **Hello Gumball!** (https://vimeo.com/84954262)
- **Gumball Advanced** (https://vimeo.com/260472052)
Create the 3-D curves
So far, you have been working with 2-D curves. To loft the surfaces, you will use these planar curves to create 3-D curves. The planar curves can then be discarded.

With the 3D Curves layer current, you will select the profile and plan view representations of each curve. You will use the Crv2View command to create the 3-D curve that combines the x-, y-, and z-coordinates of the 2-D curves. The 2-D curves must be planar for this command to work.

1. Set the 3D Curves layer current.
2. Select the plan and profile representations of the sheer curve.
3. On the Curve menu, click Curve from 2 Views to start the Crv2View command. A 3-D curve is created. It is the intersection of the two surfaces extruded from the two input curves.
4. Repeat the **Crv2View** command for the chine curve.

5. When you are satisfied that the proper curves were created, delete or hide the four input curves of the **Crv2View** command.
Revise the curves
For the lofting process to work on the bottom panel, it cannot come to a point. The lofted shape must be rectangular. This is why the curves are extended beyond the centerline. The curves can be lofted into a rectangular surface that can then be trimmed back. Except for the bottom curve, the sheer and chine curves are already extended.

Trim the centerline

1. Select the centerline and the bow curve.

2. On the Edit menu, click Trim to start the Trim command.
3. Click the centerline near the forward end, and press Enter.
   The centerline is trimmed to the end of the bow curve.
**Extend the centerline**

1. On the **Curve** menu, click **Extend Curve > Extend Curve**.
2. At the **Select boundary objects... Press Enter for dynamic extend** prompt, press **Enter**.
3. At the **Select curve to extend...** prompt, set the command option **Type=Smooth**, and click the centerline near the forward end in the **Top** viewport.

4. At the **End of extension...** prompt, click the command option **ToPoint**.
5. Move the cursor close to the ends of the shear and chine curves, but do not snap to them, click and press **Enter**.
   The bottom curve for lofting is created.

6. Press **ESC** to turn off the curve control points.
Loft the hull surfaces

We have created three edge curves for one side of the hull. A lofted surface will be created from these curves.

1. Make the Hull layer current.
2. On the Surface menu, click Loft.
3. At the Select curves to loft... prompt, select the sheer, chine, and bottom curves in order and near the same ends, and press Enter.
4. In the Loft Options dialog box, in the Style drop-down menu, click Straight sections.
5. Under Cross-section curve options, select Rebuild with, set the control point count to 10, and click Loft.
6. Hide the sheer, chine, and bottom curves.
Create the other side of the hull
We have created one side of the hull. We will mirror the hull to the other side. Use both sides to trim each other. To make the both sides fully intersect, we will to extend the bottom surface before mirroring.

**Extend the bottom surface**

1. On the **Surface** menu, click **Extend Surface**.
2. At the **Select an edge to extend...** prompt, set **Type=Smooth**.
3. Click the bottom edge, move the edge a short distance outward and click.

**Mirror the hull surfaces**

1. In the **Top** viewport, select the hull.
2. On the **Transform** menu, click **Mirror**.
3. At the **Start of mirror plane...** prompt, click **XAxis**.
   
   The hull is mirrored to the opposite side across the CPlane x-axis.
Trim the hull surfaces

1. Select the hull surfaces on both sides.
2. On the Edit menu, click Trim.
3. In the Front viewport, crossing-select the hulls as illustrated, and press Enter.
   Drag the selection rectangle from right to left. Do not cross the blue bow curve.
Build the transom
The transom will be a surface created from a closed planar boundary.

Trim the hull surfaces

1. Select the transom centerline.

2. On the Edit menu, click Trim.

3. At the Select object to trim... prompt, enable Extend Cutting Lines.
   The line will work as an infinite line to trim the hull surfaces.

4. In the Front viewport, crossing select the hull behind the transom centerline.
   The hull surfaces are trimmed to the line.
The transom edges do not form a closed boundary. We will add a line to fill the gap for creating the transom surface.

**Add a line to close the transom area**

1. On the **Curve** menu, click **Line > Single Line**.
2. Pick the two corners with the **End** object snap to create a line.

**Create the transom surface**

1. On the **Surface** menu, click **Planar Curves** to start the **PlanarSrf** command.
2. At the **Select planar curves...** prompt, select the line and the transom edges, and press **Enter**.
3. Select the hull and the transom surfaces.
4. On the **Edit** menu, click **Join**.

The surfaces are joined into a polysurface.
**Check for errors**

1. Select the hull.
2. On the **Analyze** menu, click **Edge Tools > Show Edges**.
   
   The command should report "Found 11 edges total; 3 naked edges, no non-manifold edges."
   
   If your hull has more edges or naked edges, the hull was not built correctly. You should start over and follow the steps carefully.

3. In the **Edge Analysis** dialog, select **Naked Edges**.
   
   The naked edges display as magenta. You should not see any naked edges other than the upper edges of the hull.

4. Close the **Edge Analysis** dialog.
Add the deck
The last step is to create the deck surface. Two curves describe the silhouette of the deck. They will be used as references to create the cross-section curve of the deck. In the end, the deck surface will be created from a curve network.

Compromise between concept and reality
When building a 3-D model from a 2-D concept plan, it is usually the case that the 3-D model cannot exactly match the 2-D plan. How to compromise between a 2-D concept and a 3-D model is one of the modeling skills you will develop. In this case, the deck profile curve does not end at the hull corner. We will move the curve end to the hull corner.

Adjust the control points
1. Select the deck profile curve, press F10 to turn on its control points.

2. Drag the first control point, using the End object snap to move the point to the corner of the hull, and click.

3. Press ESC to turn off the curve control points.
**Project the vertical line on to the hull**

1. On the Curve menu, click Curve from objects > Project.
2. At the Select curves and points to project... prompt, in the Front viewport, select the vertical line, and press Enter.

3. At the Select surfaces... prompt, select the hull, and press Enter.
   The line is projected onto both sides of the hull.

**Draw one half of the cross-section curve**

1. In the top panel, click the Planar to turn on Planar mode.
2. On the Curve menu, click Free-Form > Control Points.
3. In the Right viewport, use the End object snap to place the first point at the end of the deck profile curve (1).
4. Hold down Shift to turn Ortho mode on, move the cursor to the right, and click to place the second point (2).
5. Release Shift and click to place the third point (3).
6. Snap to the upper end of the projected curve on the hull (4), click, and press **Enter** to finish the curve.

![Image](image1.png)

---

**Mirror the half of the cross-section curve**

1. On the **Transform** menu, click **Mirror**.

2. At the **Select objects to mirror** prompt, in the **Right** viewport, select the half cross-section curve, and press **Enter**.

![Image](image2.png)

3. At the **Start of mirror plane...** prompt, click the **YAxis** option or type **Y**, and press **Enter**.

   The curve is mirrored to the other side across the viewport y-axis.

4. Select the two half cross-section curves.

5. On the **Edit** menu, click **Join**.

   The two half cross-section curves are joined into a polycurve.
Create the deck surface from a curve network

The deck cross-section curve (1), the deck profile curve (2), and the upper edges of the hull (3) and (4) form a curve network that will be used to create the deck surface.

1. On the Surface menu, click Curve Network to start the NetworkSrf command.
2. At the Select curves in network... prompt, select the four curves, and press Enter.
3. In the Surface From Curve Network dialog box, under Edge matching, select Position for A, B, and C, and click OK.
   The deck surface is created.

Join the parts

1. Select all of the surfaces.
2. On the Edit menu, click Join to create a polysurface.
17 - Tutorial: Point Editing and Blending - Penguin

This tutorial demonstrates point-editing techniques including moving and scaling control points and adding knots to surfaces to increase control. In addition, you will use blends to create smooth transitions between surfaces.

You will learn how to:

- Rebuild surfaces to add additional control points.
- Insert knots in a surface to add control points in a specific location.
- Edit surface control points to define a shape.
- Scale control points to change the object shape.
- Use object snaps projected to the construction plane.
- Orient an object on a surface.
- Create smooth blends between surfaces.

To download the tutorial model

1. On the Rhino Help menu, click Learn Rhinoceros, and then click Tutorials and Samples.

Rendered with Penguin renderer by Jari Saarinen.
The body
You can open the example model, **Penguin.3dm**, and try to match the shapes of the complete penguin on the hidden **Complete** layer as you are building the model. You can experiment with your own shapes, too.
The body and head are created from one sphere. The shape is formed by moving the control points in the sphere to create the head.

**Draw a sphere**

1. On the **Solid** menu, click **Sphere > Center, Radius**.
2. At the **Center of sphere...** prompt, move the mouse cursor to the **Top** viewport.
3. Type 0, and press **Enter**.
   The center of the sphere is placed at the construction plane origin (0,0,0).
4. At the **Radius...** prompt, type 10, and press **Enter**.
   A sphere with a radius of 10 units is created.
Rebuild the sphere

Use the Rebuild command to add more control points to the sphere.

1. On the Edit menu, click Rebuild.
2. At the Select curves, extrusions or surfaces to rebuild prompt, select the sphere, and press Enter.
3. In the Rebuild Surface dialog box, set the Point count in the U and V directions to 8, and the Degree in the U and V directions to 3.
4. Check Delete input, and click Rebuild.

Turn control points on

- Use the PointsOn command or press F10 to turn on the sphere’s control points. Look in all the viewports at the structure of the control points.
  
The next step will change this structure so that moving the control points does not influence the whole sphere.
Insert knots

Use the InsertKnot command to insert two knots in the sphere in the area where you want the neck.

1. On the Edit menu, click Control Points > Insert Knot.

2. At the Select the curve or surface for knot insertion prompt, select the sphere.

3. At the Point on surface to add knot prompts, set the command option Direction = U.

4. Click on the sphere to insert two knots (isocurves) in the u-direction only as illustrated.

Examine the control point structure after inserting the knot.

You will reposition control points to create the indentation for the neck and to reform the body shape.
Flatten the bottom

1. In the **Front** viewport, window-select the control points near the bottom of the sphere.

2. On the **Transform** menu, click **Set XYZ Coordinates**.

3. In the **Set Points** dialog box, check the **Set Z**, clear the **Set X** and **Set Y** check boxes, select **Align to World**, and click **Set Points**.

4. Drag the selected control points up, and click.

This will align all of the selected control points to the same z-value (up in the **Front** viewport), flattening the surface.
### Move points

1. Window-select the top rows of control points in the **Front** viewport.

![Image of control points in Front viewport]

2. Click **Gumball** in the top panel to turn it on.

3. Drag the green arrow of the **Gumball** widget to move the control points up to shape the body.

![Image of Gumball widget in use]

**See also**

For more information about using Rhino's gumball feature, review the Help topic for the **Gumball** command.

Two video tutorials also help with learning to use the gumball

- **Hello Gumball!** (https://vimeo.com/84954262)
- **Gumball Advanced** (https://vimeo.com/260472052)
**Scale points**

1. In the **Perspective** viewport, hold the **Shift** key and drag the **Gumball scale handle** (the small blue rectangle).
   
The control points are scaled in two directions.

   [Image]
   
   Look at different viewports to see the changes in the body shape as you move the control points closer to and farther from the center.

   Match the example model or use your own shape.

2. Drag the **Gumball scale handle** without holding the **Shift** key.
   
The control points are scaled in one direction. Make the body slightly flatter in the front and back direction near the head.

   [Image]
The eyes
The eye is an ellipsoid shape that is oriented onto the surface.

Create the eye

1. Start the **Ellipsoid** command.
2. In the **Top** viewport, place the center point anywhere.
3. At the **End of first axis** prompt, type **1.1**, and press **Enter**.
   This constrains the distance from the center point to the end of the axis to 1.1 units.
4. Drag the cursor to the right and pick.

5. At the **End of second axis** prompt, type **1.1**, and press **Enter** to constrain the distance.
   Using these constraints will create a circular ellipsoid when it is seen from the top.
6. Drag the cursor up or down in the **Top** viewport and pick.
7. At the **End of third axis** prompt, type **0.5**, and press **Enter**.

---

**Orient the eye on the surface**

1. Select the eye ellipsoid in the **Top** or **Perspective** viewport.
2. On the **Transform** menu, click **Orient > On Surface** to start the **OrientOnSrf** command.
3. At the **Base point**... prompt, in the **Top** viewport, pick the center of the ellipsoid.

4. At the **Reference point for scaling and rotation** prompt, pick any point to the right or left of the eye ellipsoid.
   The exact location is not important.

5. At the **Surface to orient on** prompt, select the penguin body.
6. In the **Orient on Surface** dialog box, click **Orient**.
7. At the **Point on surface to orient to...** prompt, move the cursor onto the head area where you want to place the eye and click.

**Mirror the eye**

1. Start the **Mirror** command.
2. In the **Front** viewport, at the **Start of mirror plane...** prompt, type 0, and press **Enter**.
3. At the **End of mirror plane...** move the mouse cursor along the y-axis with **Ortho** mode and click.
   The second eye is created.
The beak
The beak is another ellipsoid that you can edit to change the shape.

Create the basic beak shape

1. Start the Ellipsoid command.
2. In the Top viewport, place the center point anywhere.
3. At the End of first axis prompt, type 3, and press Enter.
   This constrains the distance from the center point to the end of the axis to three units.
4. Hold the Shift key, drag the cursor to the right, and pick.
5. At the End of second axis prompt, type 2, and press Enter.
   Using these constraints creates a circular ellipsoid when it is seen from the top.
6. Drag the cursor up or down in the Top viewport and pick.
7. At the **End of third axis** prompt, type 1, and press **Enter**.

### Shape the beak

1. Select the beak and press **F10** to turn on the beak's control points.
2. In the **Front** viewport, window-select the upper row of points.
3. Drag the selected points up.

4. Window-select the middle points of the lower rows.
5. Drag the control points up to shape the beak.

**Tip**: You can also try the **Nudge** keys (**Alt + Arrow** direction keys) to nudge the selected points.
Move the beak

- Move the beak into position using **Gumball**.
The feet
The feet are created using another ellipsoid. Knots are added to help create the webbed toes.

Draw the beginning ellipsoid

1. In the Front viewport, start the Ellipsoid command.
2. Place the center point anywhere.
3. At the End of first axis prompt, type 1, and press Enter.
   This constrains the distance from the center point to the end of the axis to one unit.
4. With Ortho on, drag the cursor up, and pick.

5. At the End of second axis prompt, type 3, and press Enter.
6. In the Top viewport, with Ortho on, drag the cursor up, and pick.

7. At the End of third axis prompt, type 3, and press Enter.
### Rebuild the ellipsoid

1. Use the **Rebuild** command to add more control points to the ellipsoid.
2. In the **Rebuild Surface** dialog box, set the **Point count** in the **U** and **V** directions to **8**.
3. Set the **Degree** in the **U** and **V** directions to **3**.
4. Check **Delete input**, and click **Rebuild**.

### Insert knots to create the webbed feet

1. Select the ellipsoid and start the **InsertKnot** command.
2. Enable **Symmetrical** and set **Direction=V**.
3. Insert four knots (isocurves) in the ellipsoid as illustrated, and press **Enter**.

### Scale the points from the center

1. Windows-select the control points on both top and bottom of the ellipsoid as illustrated.
   - Hold the **Alt** key to avoid moving control points.
   - Hold the **Shift** key to add more control points to the selection.
2. Start the **Scale2D** command, and in the **Top** viewport, pick the center point with the **Point** object snap as the **Base point**.

3. Pick another point away from the ellipsoid as the **First reference point**.

4. Drag the points to make the whole foot about twice the size of the original ellipsoid and click.
**Move and rotate the foot into position**

1. Use **Gumball** to move the foot in the **Top** and **Front** viewports under the penguin body.

2. Select the foot in the **Top** viewport.
3. Click Gumball’s blue rotation control, type **-15**, and press **Enter** to rotate the foot 15 degrees.
**Mirror the foot**

1. Select the foot and start the **Mirror** command in the **Front** viewport.
2. Type **0**, and press **Enter** to place the start of the mirror plane at the construction plane origin.
3. Hold the **Shift** key to enable **Ortho** mode, drag the mouse cursor up or down, and click.

**Create a cutting plane**

1. **Select** the feet, on the **Surface** menu, click **Plane > Cutting Plane**.
2. In the **Front** viewport, pick two points to make a planar surface that passes through the feet as illustrated.
   Hold the **Shift** key to enable **Ortho** mode while picking the second point.
Trim and Join the feet and the plane

Trim the bottoms of the feet off with the plane as the cutting object.

1. Select the feet and the cutting plane.
2. On the Edit menu, click Trim.
3. In the Front viewport, click the three positions as illustrated, and press Enter.

4. While the remaining surfaces are still selected, on the Edit menu, click Join.
The surfaces are joined into two closed polysurfaces.
The tail
The tail is another ellipsoid. It is joined to the body with a smooth blend surface.

Create the tail shape

- Draw an Ellipsoid.
  First axis: 4 units (Y in Top view).
  Second axis: 3 units (X in Top view)
  Third axis: 1.5 units (Y in Front view).

Position the tail

- Use Gumball to Move and Rotate the tail into position.
**Union the tail and body**

Combine the tail and the body shapes with a Boolean operation.

1. On the **Solid** menu, click **Union**.
2. At the **Select surfaces or polysurfaces to union** prompt, click the tail and the body, and press **Enter**.

   The tail and body are combined into a single object.

**Smooth the sharp edge between the tail and body**

The transition between the tail and body is rather abrupt; so replace this with a smooth blend surface.

1. On the **Solid** menu, click **Fillet Edge > Blend Edge**.
2. At the **Select edges to blend...** prompt, type 0.6, and press **Enter**.

   The **NextRadius** option is set to 0.6 units.
3. Pick the edge between the tail and body, and press **Enter** twice.
The wings

Create the base wing shape

- Draw an **Ellipsoid**.
  
  First axis: **6.5** units (**Y** in **Front** view).
  
  Second axis: **1.2** units (**X** in **Front** view)
  
  Third axis: **2** units (**Y** in **Top** view).

Bend the wing to the body

1. Move the ellipsoid close to the body in the **Front** viewport.

2. On the **Transform** menu, click **Bend**.

3. At the **Start of spine** prompt, in the **Front** viewport, pick near the bottom of the wing ellipsoid.
4. At the **End of spine** prompt, pick near the top of the wing.

5. At the **Point to bend through...** prompt, drag the top of the wing toward the body to intersect.

6. If further positioning is required, use **Gumball** to place the wing.

---

**Mirror to the other side**

- Use the **Mirror** command to create the opposite wing.
**Boolean Union the wings and the body**

1. Select the body and wings.
2. On the **Solid** menu, click **Union**.
   
   The body and wings are trimmed by each other and joined into a single object.
Finishing touches
To finish the penguin, split the front part of the body so a different material can be applied to it.

Draw a trimming curve
Draw a curve from the beak down to the bottom.
1. On the Curve menu, click Free-Form > Interpolate Curve.
2. In the Right viewport, pick three points as illustrated, and press Enter.

Split the body with the curve
Split the body surface with the curve. This allows a different material for the front of the body.
1. On the Edit menu, click Split.
2. At Select object to split... prompt, select the body, and press Enter.
3. At Select cutting objects... prompt, select the curve, and press Enter.
Add a light and materials
To produce a realistic rendering of your model, materials and lighting will be required.

Set up the light

1. On the Render menu, click Create Point Light.
2. In the Top viewport, click near the location as illustrated.
3. In the Front viewport, move the point light to be higher than the penguin.
Create materials

1. Type Materials and press Enter.
   The Materials panel is opened on the right side.
2. Click the + button, and on the material template list, click Plastic.
3. Replace the name Plastic with the name Body.
4. Under Plastic, click the Color swatch to open the Color dialog.
5. Select a dark gray color.
6. Create three more Plastic materials named Eyes, Beak and Feet, and Belly.
7. Set the Eyes color to black, the Beak and Feet color to orange, and the Belly color to white.
1. Make the **Perspective** viewport current, on the **View** menu, click **Rendered**.
2. Drag the **Body** material from the **Material** panel, and drop it onto the penguin body.
   The material is assigned to a single object.

3. Drag the **Belly** material from the **Material** panel, and drop it onto the front part of the penguin.
4. Select the beak and feet.
5. In the **Material** panel, right-click on the **Beak and Feet** material, and click **Assign to Objects**.
   The material is assigned to multiple objects at once.
6. Select the eyes.
7. In the **Material** panel, right-click on the **Eyes** material, and click **Assign to Objects**.
18 - Tutorial: Trace Images - Dragonfly

This tutorial demonstrates how to get started modeling an object using photographs as reference material.

You will learn how to:

- Trace images to create profile curves.
- Sweep a cross-section along two rails to create the body segments.
- Create the tail from a curve network.
- Use blend surfaces to create the chest.
- Edit control points to change the shape of a surface for the head.

*Starting images.*
**Note:** The top and side views are actually of different specimens of this dragonfly. In the side view, the wings are folded up. We will be using the side view image only to draw the side view curves of the body.

### To download the tutorial files

1. On the Rhino **Help** menu, click **Learn Rhinoceros**, and then click **Tutorials and Samples**.
2. In the **Tutorials** panel, under **User's Guide**, double-click the tutorial image files **Dragonfly Top.jpg** and **Dragonfly Side.jpg**.
Place the reference images

Start the model

1. On the File menu, click New Using Template... to begin a new model.
2. On the Splash screen, in the template list, double-click Small Objects - Millimeters.3dm.

Place the top view image

1. Drag the image file DragonFly Top.jpg from Finder and drop it onto a Rhino viewport.
2. In the Image Options dialog, select Picture, and click Apply.
3. Move the cursor to the Top viewport, type 0, and press Enter.
   This places the first corner at the construction plane origin, 0,0,0.
4. Type 50, and press Enter.
   This sets the length of the Picture plane to 50 mm.
5. Move the cursor above the X axis, and click.
**Place the side view image**

- In the **Front** viewport, use the same steps to place the image file **DragonFly Side.jpg**.

**Align the top view image**

1. On the **Object Snap** panel, check **Midpoint** and **End**.
2. In the **Perspective** viewport, move the cursor near the tail of the top view image and hold the left mouse button.
   
   The **Midpoint** tooltip appears to indicate the middle point of the edge is snapped.
   
   **Note**: Do not release the left mouse button.

3. Drag the Picture plane, snap to the lower-left corner of the other Picture plane, and release the left mouse button.
Align the side view image

1. In the Top panel, turn on Gumball.

2. In the Perspective viewport, select the side view Picture plane.
3. Drag the blue arrow down and align the body in the side view image with the top Picture plane.

4. Turn off Gumball.

More about gumball
For more information about using Rhino's gumball feature, review the Help topic for the Gumball command.

Two video tutorials also help with learning to use the gumball

- Hello Gumball! (https://vimeo.com/84954262)
- Gumball Advanced (https://vimeo.com/260472052)
Reduce visibility of Picture materials

The Picture command creates a Picture material with the selected image as the texture and assigns the material to the Picture plane. Reducing visibility of the Picture material makes tracing the image easier.

Black curves on the full color texture (left) and on a transparent grayscale texture (right).

1. In the Materials panel, two materials have been added by the Picture command.

2. Select both materials in the Materials panel.
   Tip: Select a material, hold Shift, and select the other.

3. In the Texture settings below, check Grayscale.

4. In the Transparency settings, drag the slider to 80%.

Lock Picture planes

Select the two Picture planes and run the Lock command.
(Edit > Visibility > Lock)

This makes it so the Picture planes cannot be selected. Selecting curves on or behind the Picture planes will be easier.
Trace the chest and body

**Draw chest profiles**

1. Start the **Curve** command.
   
   *(Curve > Free-Form > Control Points)*

2. In the **Front** viewport, start the curve at the neck (1).

3. Trace along the upper profile of the chest and end the curve at (2) where the chest and body connect.

   ![Image of chest profile with points 1 and 2 marked]

4. Draw another curve along the lower profile of the chest.
   
   Use the **End** object snap to start and end the curve at the endpoints of the first curve.

   ![Image of chest profile with additional curve]
Create body segment profiles

The body consists of several segments. We only need to draw the profiles of one segment.

1. Start a curve at (1) in the chest and above the ends of the chest profiles.
2. Reference the image and end the curve at the end of the first segment.
   **Tip:** Use five points to draw the curve. Place the last two points close to form a curly end (2).

3. Select the curve, and start the **Mirror** command.
   
   *(Transform > Mirror)*

4. Pick at (1) and then (2) to define the mirror plane.
   **Tip:** The mirrored curve has to intersect with the lower chest profile.
**Duplicate body segment profiles**

1. Select the upper body segment profile, and start the **Orient** command. 
   *(Transform > Orient > 2 Points)*

2. In the command options, check **Copy** and select 1 D for **Scale**.

3. Snap to the right end of the curve, and click to place the first reference point.

4. Snap to the left end of the curve, and click to place the second reference point.

5. Snap to the same end again, and click to place the first target point.

6. Using the image as a reference, click at the end of the second body segment.
7. Snap to the current end, click, and continue duplicating more curves along the upper body profile.

8. Click at the end of the last body segment, and press the **ESC** key to end the command.

9. Use the same procedure to duplicate the other curve along the lower body profile.

---

**Fine-tune body segment profile curves**

The last three lower body segment profile curves do not match the image. We will use control point editing to improve them.

1. Select one of the curves.
   
   Its control points turn on automatically.
2. Move the control points to make the curve match the image.

3. Adjust the other two curves.

4. Select all body segment profile curves, and **Join** them into two polylines.

   *(Edit > Join)*
Create the body segments

Create the body cross-section

1. Start the Circle command to draw a circle from its diameter.
   (Curve > Circle > 2 Points)
2. In the command options, click Vertical.
3. In the Front viewport, snap to the two ends of the body profile curves to create a circle.

Create the body segment surfaces

1. Start the Sweep2 command.
   (Surface > Sweep 2 Rails)
2. In the Perspective viewport, select the two body profile curves (1) and (2), and the cross-section circle (3) in order. Press Enter when done.
3. Press Enter one more time to accept the default seam location.
4. In Swee p 2 Rail Options, set the options as shown below, and click **Sweep** to create the surface.

![Sweep 2 Rail Options](image)

5. On the **Perspective** viewport title menu, click **Shaded** to see the surface.

![Perspective viewport menu](image)
Create the tail

**Draw the side profiles of the tail**

1. Start the **Curve** command.
   
   *(Curve > Free-Form > Control Points)*

2. Use the **Quadrant** object snap to start the curve from the top quadrant point of the body edge.

3. Continue drawing the curve in the **Front** viewport.
   Use four points to create the curve.

4. Create another curve from the bottom quadrant point of the body edge.
5. Continue drawing the curve in the Front viewport.

Create the end cross-section of the tail

1. Create an Ellipse from its diameter.
   
   (Curve > Ellipse > Diameter)

2. In the command options, click Vertical.

3. To draw the ellipse vertical to the Front construction plane, in the Front viewport, use the End object snap to place the first and second points of the ellipse at the ends of the two curves.

4. In the Top viewport, reference the image, and place the third point of the ellipse.
**Draw the top profiles of the tail**

1. Start the **InterpCrv** command.
   
   *(Curve > Free-Form > Interpolate Points)*

2. In the **Perspective** viewport, use the Quad object snap to start the curve from the left quadrant point of the body edge (1).

3. End the curve at the left quadrant point of the ellipse (2).

4. In the **Front** viewport, select the curve, and move the two control points up a small distance.

5. In the **Top** viewport, move the two control points in the vertical direction to make an "S" shape.

**Tip:** To maintain the curve's shape in the Front viewport, move the control points in the Top viewport only in the y-direction.
6. **Mirror** (*Transform > Mirror*) the curve to the other side.

Create the tail surface

Now we have a curve network that we can use to create the tail surface.

1. Start the **NetworkSrf** command.
   (*Surface > Curve Network*)

2. In the **Perspective** viewport, select the four curves, the ellipse, and the body edge, and press **Enter**.

3. In the options dialog, set the options as shown below, and click **OK**.
Clean up the model

1. Use the **SelCrv** command to select all the curves in the model.
   
   *(Edit > Select Objects > Curves)*

2. Hold the **Command** key and click on the two chest profile curves to deselect them.

3. **Hide** all the curves that will not be used in the future.
   
   *(Edit > Visibility > Hide)*
### Join body and tail surfaces

1. Start the **Join** command.
   
   *(Edit > Join)*

2. Select the body and tail surfaces, and press **Enter**.
   
   The body and tail are joined into a single object.

3. While the new body-tail object is still selected, run the **Cap** command.
   
   *(Solid > Cap Planar Holes)*

   A planar surface is added to each open end to make it a closed object.

### Create the trimming cylinder

We will create a cylinder and use it to trim the tail.

1. Start the **Cylinder** command.
   
   *(Solid > Cylinder)*

2. In the command options, check **Solid**, and click **2 Point**.

3. Use the **Quadrant** object snap to place the start (1) and end (2) of the cylinder base at the left and right quadrant points of the tail edge.

4. In the command options, select **None** for **Direction Constraint** and check **Both Sides**.
5. In the **Front** viewport, move the cursor to make the preview cylinder roughly perpendicular to the tail and click.

---

**Trim the tail**

1. Start the **BooleanDifference** command.
   
   *(Solid > Difference)*

2. Select the body-tail object as the object to subtract from, and press **Enter**.

3. Select the cylinder as the object to subtract with, and press **Enter**.
Create the chest

Create the dummy surfaces

We will make two dummy surfaces to help create one side of the chest.

1. Turn on Gumball.
2. Select the two chest profile curves in the Perspective viewport.
3. Drag the small dot on the green arrow of the Gumball widget for a short distance.
   The two curves are extruded into two surfaces. They are the dummy surfaces.
4. While the curves are still selected, run the Hide command.
   *(Edit > Visibility > Hide)*

Create the chest surface

1. Start the BlendSrf command.
   *(Surface > Blend Surface)*
2. Select the two edges of the dummy surfaces.
   Tip: Select the two edges close to the same end.
3. In the options dialog, click the lock icon to link the two sliders.
4. Set the options as shown in the illustration below.

5. Look at the **Top** viewport and drag the sliders to the left until the blend surface profile matches the chest profile in the top image.

6. Click **OK** to create one side of the chest.

7. Delete the two dummy surfaces.
**Mirror the chest surface**

1. Select the chest surface, and start the **Mirror** command.
   
   *(Transform > Mirror)*

2. With the **Perspective** or **Top** viewport active, click the command option **XAxis**.

3. **Join** both sides into a whole chest.
   
   *(Edit > Join)*
Create the head
The head is deformed by control points editing from an ellipsoid.

Start the head from a sphere

1. Start the **Sphere** command.
   
   \[(Solid > Sphere > Center, Radius)\]

2. In the **Front** viewport, pick at (1) for the sphere center and (2) for the radius.

3. In the **Top** viewport, select the sphere, and turn on **Gumball**.

4. Drag the **Y scale handle** (the small green rectangle) down for a short distance. The sphere became an ellipsoid.
1. **Rebuild** the ellipsoid.

   *(Edit > Rebuild)*

2. In the **Rebuild Surface** options dialog, set the options as shown in the illustration below, and click **Rebuild**.

   ![Rebuild Surface Options](image)

---

**Shape the head**

1. Select the head, and press **F10** to turn on its control points.

2. Start the **SelCircular** command.

   *(Edit > Select Objects > Area and Volume Select > Circular)*

3. In the **Front** viewport, as shown below, click at (1) to set the center of the selection circle.

4. Click at (2) between the outermost two rows of control points to define the size of the selection circle.

   ![Shape the head](image)
5. In the **Top** viewport, drag Gumball's **X move control** (the red arrow) to the left.

6. In the **Front** viewport, window-select the control points as illustrated.

7. Drag Gumball's **XY plane control** toward the lower-right.

8. Press **ESC** to turn off control points.
Add the neck
The neck is a blend surface between the head and body. You will first combine the head and body, and then create a blend surface along the edges between them.

**Combine the head, chest, and body**

1. In the **Front** viewport, move the head to enclose the endpoint of the chest as needed.
   If the endpoint of the chest is not inside the head, the neck surface will fail to create.

2. Select the head, chest, and body, and run the **BooleanUnion** command.
   *(Solid > Union)*

3. Start the **BlendEdge** command.
   *(Solid > Fillet Edge > Blend Edge)*

4. Set the command option **NextRadius** to **0.5**, and check **Preview**.

5. Select the edges between the head and chest, and press **Enter**.
6. Preview the result, and press **Enter** to create the neck.
Create the eyes
The eyes are simple ellipsoids.

Start the eye from a sphere

1. Start the **Sphere** command.
   
   *(Solid > Sphere > Center, Radius)*

2. In the **Perspective** viewport, pick two points around the head to create a sphere.
   
   The sphere size does not matter.

3. Tune on **Gumball** and drag the **Z scale handle** (the small blue rectangle) up to squeeze the sphere into an ellipsoid.

4. Turn off **Gumball**.
Position the eye

1. Select the eye ellipsoid and start the **OrientOnSrf** command. *(Transform > Orient > On Surface)*
2. In the **Perspective** viewport, snap to the center of the ellipsoid, and click.

3. Pick another point on the construction plane as the reference point.

4. Select the head as the target surface.
5. In the options dialog, set the options as shown in the illustration below, and click **Orient**.
6. Move the ellipsoid on the surface to a proper location, and click.

7. Disable all object snaps.

8. Move the cursor to define the size of the eye, and click.

---

**Mirror the eye**

1. Select the eye and start the **Mirror** command.

   *(Transform > Mirror)*

2. In the top panel, click **History**.

3. Click the command option **XAxis**.

4. Use **Gumball** to adjust the position, size, and orientation of the first eye.

   History will update the mirrored eye on the other side.
Trace the wings
The wings are solids created from closed planar curves.

Draw the outline curve

1. Hide the body.
   
   *(Edit > Visibility > Hide)*

2. Double-click the Top viewport title to maximize the viewport.

3. Use the Curve command to trace a wing on one side.

   *(Curve > Free-Form > Control Points)*

   **Tip:** Place the last control point at the first control point to make a closed curve.

4. Draw the other wing on the same side.
**Extrude the curves to make solids**

1. Select the two wing curves, and start the **ExtrudeCrv** command.
   
   *(Solid > Extrude Planar Curve > Straight)*

2. In the command options, uncheck **BothSides** and check **Solid**.

3. Set the extrusion distance to **0.1**, and press **Enter**.

Two thin solid wings are created.

---

**Relocate and mirror the wings**

1. Use **Gumball** to move the wings up.

   Place the front wing higher than the back wing.

2. In the **Top** viewport, **Mirror** the wings to the other side.

   *(Transform > Mirror)*

3. **Hide** the solid wings and the outline curves.

   *(Edit > Visibility > Hide)*
Create the legs
The legs are pipes created from polylines with various radii.

**Draw the center polyline**

1. Start the **Polyline** command.
   
   *(Curve > Polyline > Polyline)*

2. In the **Top** viewport, start every polyline close to the center line of the body.

3. Trace down the center line of each leg with four points (three segments).

4. In the **Perspective** viewport, select a polyline, and use **Gumball** to move the control points down.

   **Tip:** Look at the Front viewport to help locate the points.

You will have to use your imagination a little for this since the two pictures do not show the legs of the same dragonfly.
1. Start the **Pipe** command and select a polyline.
   
   *(Solid > Pipe)*

2. Type **0.4**, and press **Enter** for the start radius.

3. Type **0.1**, and press **Enter** for the end radius.

4. Use the **End** object snap to snap to the corner between the first and second segments and click.

5. Type **0.3**, and press **Enter**.

6. Snap to the corner between the second and third segments and click.

7. Type **0.2**, and press **Enter**.
8. Press **Enter** again to create the pipe.

9. Create the other five legs with the same procedure.

---

**Unhide the body and wings**

1. Start the **ShowSelected** command.
   
   *(Edit > Visibility > Show Selected)*

2. Select the body and wings, and press **Enter**.

3. **Unlock** the Picture planes and hide them.
   
   *(Edit > Visibility > Unlock)*

4. Use **Gumball** to rotate the wings slightly to add realism.
19 - Tutorial: Flow Along a Surface - Wrap Text

This tutorial demonstrates wrapping solid text objects onto a mug. These text objects could be used to Boolean with the mug.

You will learn how to:
- Create solid text objects.
- Wrap the text objects onto a surface.

To download the tutorial model
1. On the Rhino Help menu, click Learn Rhinoceros, and then click Tutorials and Samples.
2. In the Tutorials panel, under User's Guide, double-click the tutorial model file Wrap.3dm.
Create the planar reference plane
The CreateUVCrv command generates the planar border and trimmed curves of a surface that can be used as a guide to orient your text objects.

Create the UV curve

1. Start the CreateUVCrv command.
   
   *(Curve > Curve from Objects > Create UV Curves)*

2. Select the side surface of the mug, press Enter.
   
   A rectangle and two circles are created on the Top construction plane starting from the origin. The rectangle represents the side surface boundary. The two circles are where the handle join to the side surface.

Create the planar surface

1. Select the rectangle.

2. Run the PlanarSrf command.
   
   *(Surface > Planar Curves)*

   An untrimmed planar rectangle surface is created.

3. Delete the rectangle curve.
Create text objects to wrap

1. Start the TextObject command.  
   *(Solid > Text...)*
2. Select a font and set Height to 1.0.
3. Type your text.
4. Under Output, select Solids and set Thickness to 0.2.
5. Check Group output.
6. Click Apply and place the text on the planar surface inside the rectangle boundary.

Wrap the text objects onto the mug

1. Select the text object group.
2. In the top panel, click History.
   *(Transform > Flow along Surface)*
4. In the command options, enable Copy and Auto Adjust, and disable Rigid.
5. Select the planar surface near the lower-left corner and close to the lower edge.  
   This is the base surface.
6. Select the mug side surface at the corresponding position.
   This is the target surface.
   The text objects are wrapped onto the mug.

   ![Image showing wrapped text objects on mug]

   If the base or target surface is not selected at the correct corresponding position, the text objects will be wrapped with a wrong orientation. When it happens, undo the command and try again.

---

**Position the text objects**

1. Use **Gumball** to **Move**, **Rotate**, and **Scale** the text objects on the planar surface inside the rectangle boundary.
   Let History update the text objects on the mug.

2. Move the text objects down to intersect with the planar surface.

   ![Image showing text objects moving down]

   History updates the text objects to intersect with the mug.
Boolean the text objects with the mug

Boolean operations will break History connection. Click OK when you see the History Warning.

- Use the **BooleanDifference** command to subtract the text objects from the mug.
  
  *(Solid > Difference)*

- Or, use the **BooleanUnion** command to combine the text objects into the mug.
  
  *(Solid > Union)*
20 - Tutorial: Blocks - Mechanical Part

This example shows how to use Rhino to model a simple mechanical part. You will learn how to:

- Create extrusion objects.
- Boolean-difference shapes.
- Drill holes.
- Create a 2-D line drawing from the 3-D shapes.
- Dimension the 2-D line drawing and modify dimension text.

To download the tutorial model

1. On the Rhino Help menu, click Learn Rhinoceros, and then click Tutorials and Samples.
2. In the Tutorials panel, under User's Guide, double-click the tutorial model file Toolblock.3dm.

Create solid shapes

Start by creating two basic solid shapes from the profile curves on layers Profile-01 and Profile-02.

Set up the layers

- In the Layers panel, confirm that the Profile-01 layer is current.

Extrude the profile curve

1. On the Solid menu, click Extrude Planar Curve > Straight.
2. Turn on the End object snap.
3. At the Select curves to Extrude prompt, select the blue profile curve, and press Enter.
4. At the **Extrusion distance** prompt, in the command options, check **Solid** and uncheck **Delete Input**.

5. Snap to the end of the magenta construction line, and click.

The extruded shape is a solid because it forms a closed volume in space.

### Hide the solid

- Select the solid, on the **Edit** menu click **Visibility > Hide**.

### Set up the layers

- In the **Layers** panel, make layer **Profile-02** current.

### Extrude the profile curve

1. **Select** the red profile curve.

2. On the **Solid** menu, click **Extrude Planar Curve > Straight**.

3. At the **Extrusion distance** prompt, in the command options, check **Solid** and uncheck **Delete Input**.
4. At the **Extrusion distance** prompt, in the **Front** viewport, drag the extrusion above the height of the blue curve and click.

The solid appears on the current red layer Profile-02.

- **Show the solid**
  - On the **Edit** menu click **Visibility > Show**.
**Boolean the two solids**

1. On the **Solid** menu, click **Difference**.
2. At the **Select surfaces or polysurfaces to subtract from** prompt, select the blue solid, and press **Enter**.
3. At the **Select surfaces or polysurfaces to subtract with** prompt, in the command options, check **Delete Input**.
4. **Select** the red solid, and press **Enter**.

   The result will be a new solid or polysurface. A polysurface is a collection of surfaces that can be closed or open. A solid is a collection of surfaces that are closed.
Drill the holes
A construction circle is already in place for creating the first hole.

Make holes in the solid

1. **Select** the blue circle as shown in the illustration below.

2. On the **Solid** menu click **Solid Edit Tools > Holes > Make Hole**.
3. At the **Select a surface or polysurface** prompt, select the gray polysurface.
4. At the **Depth point...** prompt, drag the hole through the upper portion of the object.
5. Pick a point in the **Right** view.
**Copy the holes**

After one hole is drilled, you can copy the others.

1. In the Osnap panel, turn on the **Point** object snap.
2. On the **Solid** menu, click **Solid Edit Tools** > **Holes** > **Copy Hole**.
3. At the **Select holes in one planar surface** prompt, select the first hole, and press **Enter**.
4. At the **Point to copy from** prompt, snap to the point object in the center of the first circle, and click.
5. At the **Point to copy to** prompt, snap to the next point that makes the center of the next hole, and click.
6. Repeat this for the two holes that are on the other side of the part.

Do not use the point in the center of the part.

Create the round hole

The center hole does not pass entirely through the upper part of the blue solid. There is no reference circle to start from.

2. At the Select target surface prompt, select the top surface of the gray solid.
3. At the Center point prompt, set the command options as below:
   - Depth = 0.5
   - Radius = 0.156
   - DrillPointAngle = 180
   - Through = Unchecked
   - Direction = CPlaneNormal
4. Snap to the point object in the middle of the gray solid to finish creating the hole.

Test the solid

The resulting polysurface is a closed solid. A solid defines a closed volume in space. Object properties will report if this part is a closed solid.

1. Select the part.
2. On the Edit menu, click Object Properties (F3).
3. In the Properties panel, click Details.
   In the Object Description window, you will find the listing to confirm that the object is valid and closed.
   Geometry:
   Valid polysurface.
   Closed solid polysurface with 23 surfaces.

Make a 2-D drawing

The Make2D command generates 2-D lines from the 3-D solid.

Create a 2-D line drawing

1. Select the part.
2. On the Dimension menu, click Make 2-D Drawing.
3. In the 2-D Drawing Options dialog box:
   Under Projection, select Third angle projection.
   Under Options, select By output layers, and check the Tangent edges and Hidden lines boxes.
4. Click Apply.
Dimension the 2-D drawing
Using the 2-D drawing, add dimensions to the part.

Set up the layers
1. In the Layers panel, make the Dimensions layer current.
2. Turn off all layers except the Dimensions and Make2D layers.
3. In the Linetype column for the Make2D > Hidden > Curves layer, click Continuous.
4. In the Select Linetype dialog box, select Hidden.

Set up the viewport
- Double-click the viewport title to maximize the Top viewport.

Dimension the part
1. On the Dimension menu, click Linear Dimension.
2. In the Osnap panel, turn on the End object snap; turn off the Point object snap.
3. At the First dimension point prompt, pick the upper left corner of the part.
4. At the Second dimension point prompt, pick the upper right corner of the part.
5. At the Dimension location prompt, pick a location for the dimension line.
6. Repeat to generate a vertical dimension on the right side of the part.
Chain dimension the part horizontally

1. On the **Dimension** click **Linear Dimension**.
2. At the **First dimension point**, in the command options check **Continue**.
   This will generate a chain of dimensions.
   
   **Tip:** If the current dimension continues a previous dimension, click the **NewChain** button.
3. At the **First dimension point** prompt, snap to the lower left corner of the part with the **End** object snap, and click.
4. At the **Second dimension point** prompt, snap to the center of the first circle with the **Center** object snap, and click.

5. At the **Dimension location** prompt, pick below the part.

6. At the next **Dimension location** prompts, continue picking the centers of the circles.
7. Finish by picking the lower right corner of the part, and press **Enter**.

   ![Diagram showing part with dimensions]

**Note:** If the dimension text and arrows do not fit inside the dimension lines, you can fix this later in the dimension Properties. Dimension properties let you specify the location of the text and arrows.

![Dimension Properties dialog box]

---

### Chain dimension the holes vertically

- Repeat the chain dimensions to create vertical dimensions.

  Click the **New Chain** button to start dimensioning.
**Add radial dimensions**

1. On the **Dimension** menu, click **Radial Dimension**.
2. At the **Select curve for radius dimension** prompt, select the circle on the far right.
3. At the **Dimension location** prompt, pick above the part.

4. Double-click the radial dimension text, and in the text edit box, add the text: **Typ. 5 Places.**
21 - Tutorial: Layouts - Title Block

This example shows how to use Rhino to model a simple mechanical part. You will learn to create a layout with a title block for printing.

To download the tutorial model

1. On the Rhino Help menu, click Learn Rhinoceros, and then click Tutorials and Samples.
2. In the Tutorials panel, under User's Guide, double-click the tutorial model file Toolblock_Layout.3dm.
**Layout viewports**

Use a layout to arrange the 2-D lines for the printer.

**Add a layout**

1. On the Viewport control bar, click the Layout button.

2. In the New Layout dialog, select the following and click Apply.

   - **Initial Detail Count=1**
   - **Size=Letter (8.5" x 11")**
   - **Orientation=Landscape**

Page 1 will appear in the Layout window.
**Insert a title block**

In this section you will add a title block and re-size the detail to fit.

<table>
<thead>
<tr>
<th>Set up the layers</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the <strong>Model layers</strong> panel, make the <strong>Title Block</strong> layer current.</td>
</tr>
<tr>
<td>2. Confirm that you are in layout space.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Insert the title block</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. On the <strong>Edit</strong> menu, click <strong>Block &gt; Insert Block Instance</strong>.</td>
</tr>
<tr>
<td>2. From the name list, select <strong>Ansi_A_TB</strong>.</td>
</tr>
</tbody>
</table>
| 3. Under **Insertion point**, clear the **Prompt** box, and click **Apply**.  
   The corner of the title block will be placed at 0,0. |
| 4. **Select** the detail.  
   **Note:** Double-click outside the detail frame to make sure the detail is not active. Click on the detail edge to select it. |
| 5. On the **Edit** menu click **Control Points > Control Points On**. |

6. Drag the corner points to re-size the detail to fit in the title block.
7. Press the **Esc** key to turn off the control points.
Lock the detail view

1. **Select** the detail.
2. In the **Properties** panel on the **Detail** page, under **Scale Value**, set the **inches on page** and **inches in model** to **1.0**.
3. Check the **Locked** box
   This prevents future panning and zooming when the detail view is active so the drawings stay in the correct size.

Add print widths

1. In the **Model layers** panel, click **Default** in the **PrintWidth** column, and set the values to the following:
   - **Dimension**= **0.35**
   - **Title Block**= **0.5**
   - **Make2D > Visible > Curves**= **0.70**

**Note:** On the **View** menu, click **Print Preview** to display print widths in viewports.