Introduction

Modeling in 3‑D is the process of creating a mathematical representation of an object's surfaces. The resulting model is displayed on your screen as a two-dimensional image. Rhino provides tools for creating, displaying, and manipulating these surfaces.

The Rhino interface

The image below illustrates some of the major features of the Rhino window.

Illustration.

Menu (1)

The menus group Rhino commands by function.

History window (2)

The command history window displays the previous commands and prompts.

Command box (3)

The command box displays a typed command. Once the command is accepted, the prompts, options and a Value box appear in this space.

Toolbars (4)

Toolbars contain graphical icons for initiating commands. Many toolbar icons have a second command that you can access by right-clicking the icon. The tooltip that appears when you hover over the icon tells you what the left and right mouse button do.

Note: If you are using a one-button mouse or a track pad, to access the second command, hold the Option key and click.

To access the command on the first line

4 Click the icon with the left mouse button.

To access the command on the second line

4 Click the button with the right mouse button.
4 Hold the Option key and click.

Viewports (5)

Viewports display the Rhino working environment.

Sidebar (6)

The right sidebar contains layers, properties, and other settings.

The left sidebar contains the toolbar and the object snap list.

Rhino commands

Rhino is a command driven program. In other words, all actions are activated by named commands such as Line, Box, or CurvatureAnalysis.

Tip: To read more about a command, click the red, underlined command name link.

Commands are accessed through the menus, or the toolbars, or by typing the command name. In the next sections, you will explore using these methods. You may find one method easier than another. The choice is yours, and there is no preference for one method over another.

In the exercises, you will use Rhino’s commands, navigation tools, shaded modes, render, and use some basic object manipulation.

Tip: To cancel a command any time, press the Esc key.

In this session you will

4 Start a command by choosing from the menu.
4 Start a command by choosing from a toolbar icon.
4 Start a command by typing.

New command iconTo start your first Rhino model

1. Start Rhino.
2. On the File menu, click New.
3. In the Open Template File dialog box, select SmallObjects - centimeters.3dm and click Open.

Start from the menu

Most Rhino commands are arranged in the menus.

Menu iconStart the Cone command

4 On the Solid menu, click Cone.

Draw the cone

1. At the Base of cone… prompt, in the Top viewport, click with the mouse to pick the center point for the base of the cone.

2. At the Radius… prompt, in the Top viewport, drag the mouse and click to draw the cone’s base.

3. At the End of cone prompt, in the Front viewport, drag the mouse and click to draw the cone’s point.

4. Watch what happens in the Perspective viewport.

Start from a toolbar icon

Toolbars provide a graphical interface to the commands.

To display a button tooltip, hover your mouse over the icon

4 The command names that are activated with the left and right mouse click or with the Option key + mouse click display.

Illustration.

Curve command iconStart the Curve command

4 On the toolbar docked on the left side of the Rhino window, click the icon for Control point curve.

Draw the curve

1. At the Start of curve… prompt, in the Top viewport, click the mouse to start the curve.
2. At the Next point... prompts, click a few more points in the Top viewport.

3. At the Next point... prompts, move the mouse into the Front viewport and click a few more points.

4. At the Next point... prompts, move the mouse into the Right viewport and click a few more points.

5. Right-click, press Enter or press the spacebar to complete the curve.
6. Check out the Perspective viewport.

Admire your work

4 Drag with the right mouse button to rotate the Perspective view.

Start from the command line

You can start a command by typing the command name.

Keyboard iconStart the Sphere command by typing

4 Start typing Sphere. Clicking in the command box is not necessary.

When you type the first letters of a command, a list of possible commands appears. The most likely candidate auto-completes.

When the command name Sphere appears, press Enter, or choose Sphere from the list.

The default option for the Sphere command is Center, Radius, so you can simply start drawing the center of the sphere.

Draw the sphere

1. At the Center of sphere… prompt, in the Perspective viewport, click the mouse to pick the center point for the sphere.

2. At the Radius… prompt, in the Perspective viewport, move the mouse away from the center point, and click the mouse to draw the sphere and click.

3. In the Perspective viewport, click the down-arrow on the viewport title, and on the menu, click Shaded.

 

Undo a mistake

If you did something you did not want to do, you can undo your actions.

Undo command iconUndo a command

4 On the Edit menu, click Undo, or press the Command ⌘ and Z keys.

You can undo a series of commands.

You can also Redo the Undo if you go too far.

Redo command iconRedo commands

4 On the Edit menu, click Redo, or press the Shift, Command ⌘, and Z keys.

History panel iconThe history panel

The command window contains the command history.

You can keep a history window open in the right sidebar, or you can click the command history icon in the lower left corner of the screen to open a temporary window.

Illustration.

Command options

Command options change how a command acts. For example, when you draw a circle, the circle is normally drawn on the active construction plane. The Circle command has several options including Vertical and AroundCurve. Command options appear in parentheses at the prompt.

To use a command option, click the option name, or type the underlined letter of the option or the whole option name.

Choose a command option

1. Type Circle.

As soon as you have typed enough letters to uniquely identify the command, the Circle command automatically completes at the prompt. Press Enter or click the command name.

2. The options for the Circle command appear:

Center of circle

Deformable

Vertical

2 Point

3 Point

Tangent

Around Curve

Fit Points

3. To draw a circle vertical to the active construction plane, use the Vertical option.
Click Vertical, or type V.

Repeat the last command

Many tasks in Rhino are repetitive. You might want to move or copy several objects, for example. Methods for repeating commands are provided.

Return/Enter keyTo repeat the last command

4 Press the Enter key when no command is active.
4 In addition to pressing the Enter key on your keyboard, you can press the Spacebar or click the right mouse button in a viewport. These all perform the same function.

Note: Some commands, such as Undo and Delete do not repeat. Instead, the command prior to these commands is repeated. This prevents you from accidentally undoing too many commands or deleting objects accidentally.

In addition, you often want to repeat the command you were using before undoing a mistake. You can define the list of commands that do not repeat to suit your own way of working.

Help command iconGet help any time

The Rhino Help file is the major resource for detailed information on specific commands.

To get help on a specific command

4 Go to Rhino Help for the most up-to-date Help information.
4 Find the answers to frequently asked questions at: Rhino Support.
Tip: For more information about the mathematical principles involved in 3-D modeling, see: www.mathopenref.com.