# Table of Contents

Section I: Working in 3-D ................................................................. 1
Introduction .................................................................................. 3
The Rhino interface ........................................................................ 3
Rhino commands ........................................................................... 4
Start from the menu ...................................................................... 4
Start from a toolbar icon ............................................................... 6
Start from the command line ........................................................ 10
Undo a mistake .............................................................................. 13
The command window ................................................................... 14
Command options .......................................................................... 14
Repeat the last command .............................................................. 14
Get help any time .......................................................................... 15
Rhino Objects ................................................................................ 17
Why NURBS modeling ................................................................... 17
Points ............................................................................................ 17
Curves ............................................................................................ 18
Surfaces ........................................................................................ 18
  Closed and open surfaces .......................................................... 19
  Trimmed and untrimmed surfaces ............................................. 19
  Surface isoparametric and edge curves ...................................... 21
Polysurfaces .................................................................................. 22
Solids ............................................................................................. 22
Light-weight extrusion objects ...................................................... 23
Polygon mesh objects .................................................................... 23
Selecting Objects .......................................................................... 25
Select objects with windows ......................................................... 26
Other ways of selecting .................................................................. 27
Sub-object selection ........................................................................ 29
Navigating Viewports ..................................................................... 31
Viewport projection ........................................................................ 31
Viewport navigation ....................................................................... 31
  Mouse navigation ........................................................................ 32
Viewport display modes ................................................................. 32
  Wireframe .................................................................................. 33
  Shaded ...................................................................................... 33
  Other shaded modes .................................................................. 34
Viewport title ................................................................................ 35
  To activate the viewport title menu .......................................... 35
Accurate Modeling ........................................................................ 37
The Rhino cursor ........................................................................... 37
Snap to the construction plane grid .............................................. 37
Constrain the angle of movement .................................................. 37
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Snap to existing objects</td>
<td>38</td>
</tr>
<tr>
<td>Persistent object snaps</td>
<td>38</td>
</tr>
<tr>
<td>Special case object snaps</td>
<td>39</td>
</tr>
<tr>
<td>Cursor constraints</td>
<td>39</td>
</tr>
<tr>
<td>Distance constraint</td>
<td>39</td>
</tr>
<tr>
<td>Angle constraint</td>
<td>39</td>
</tr>
<tr>
<td>Distance and angle together</td>
<td>40</td>
</tr>
<tr>
<td>Elevator mode</td>
<td>40</td>
</tr>
<tr>
<td>SmartTrack™</td>
<td>40</td>
</tr>
<tr>
<td>Coordinate systems</td>
<td>41</td>
</tr>
<tr>
<td>Cartesian coordinates</td>
<td>41</td>
</tr>
<tr>
<td>Right-hand rule</td>
<td>41</td>
</tr>
<tr>
<td>World coordinates</td>
<td>41</td>
</tr>
<tr>
<td>Construction plane coordinates</td>
<td>41</td>
</tr>
<tr>
<td>Relative coordinates</td>
<td>42</td>
</tr>
<tr>
<td>Create Surfaces from Curves</td>
<td>45</td>
</tr>
<tr>
<td>Edge curves</td>
<td>45</td>
</tr>
<tr>
<td>Extrude curves</td>
<td>46</td>
</tr>
<tr>
<td>Loft curves</td>
<td>48</td>
</tr>
<tr>
<td>Revolve curves</td>
<td>49</td>
</tr>
<tr>
<td>Revolve curves with a rail</td>
<td>52</td>
</tr>
<tr>
<td>Sweep along one rail curve</td>
<td>56</td>
</tr>
<tr>
<td>Sweep along two rail curves</td>
<td>58</td>
</tr>
<tr>
<td>Edit Curves and Surfaces</td>
<td>61</td>
</tr>
<tr>
<td>Join</td>
<td>61</td>
</tr>
<tr>
<td>Explode</td>
<td>61</td>
</tr>
<tr>
<td>Trim and Split</td>
<td>61</td>
</tr>
<tr>
<td>Control-point editing</td>
<td>61</td>
</tr>
<tr>
<td>Control point visibility</td>
<td>61</td>
</tr>
<tr>
<td>Change control point locations</td>
<td>62</td>
</tr>
<tr>
<td>Add, delete, or redistribute control points</td>
<td>62</td>
</tr>
<tr>
<td>Curve and surface degree</td>
<td>62</td>
</tr>
<tr>
<td>Transforms - Move, Copy, Rotate, Scale</td>
<td>65</td>
</tr>
<tr>
<td>Move</td>
<td>65</td>
</tr>
<tr>
<td>Move objects using distance values</td>
<td>65</td>
</tr>
<tr>
<td>Move objects by dragging</td>
<td>66</td>
</tr>
<tr>
<td>Elevator mode</td>
<td>67</td>
</tr>
<tr>
<td>Copy</td>
<td>69</td>
</tr>
<tr>
<td>Rotate</td>
<td>73</td>
</tr>
<tr>
<td>Scale</td>
<td>77</td>
</tr>
<tr>
<td>Mirror</td>
<td>80</td>
</tr>
<tr>
<td>Array</td>
<td>83</td>
</tr>
<tr>
<td>Orient</td>
<td>83</td>
</tr>
<tr>
<td>Curve and Surface Analysis</td>
<td>85</td>
</tr>
<tr>
<td>Measure distance, angle, and radius</td>
<td>85</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Curve and surface direction</td>
<td>85.</td>
</tr>
<tr>
<td>Curvature</td>
<td>86.</td>
</tr>
<tr>
<td>Visual surface analysis</td>
<td>86.</td>
</tr>
<tr>
<td>Environment map</td>
<td>86.</td>
</tr>
<tr>
<td>Curvature analysis</td>
<td>87.</td>
</tr>
<tr>
<td>Draft angle analysis</td>
<td>87.</td>
</tr>
<tr>
<td>Edge evaluation</td>
<td>88.</td>
</tr>
<tr>
<td>Diagnostics</td>
<td>88.</td>
</tr>
<tr>
<td><strong>Organization and Annotation</strong></td>
<td>89.</td>
</tr>
<tr>
<td>Layers</td>
<td>89.</td>
</tr>
<tr>
<td>Groups</td>
<td>90.</td>
</tr>
<tr>
<td>Blocks</td>
<td>90.</td>
</tr>
<tr>
<td>Worksessions</td>
<td>90.</td>
</tr>
<tr>
<td>Dimensions</td>
<td>90.</td>
</tr>
<tr>
<td>Text</td>
<td>91.</td>
</tr>
<tr>
<td>Leaders</td>
<td>91.</td>
</tr>
<tr>
<td>Dots</td>
<td>91.</td>
</tr>
<tr>
<td>Hidden line removal</td>
<td>92.</td>
</tr>
<tr>
<td>Notes</td>
<td>92.</td>
</tr>
<tr>
<td><strong>Render</strong></td>
<td>93.</td>
</tr>
<tr>
<td>Lights</td>
<td>93.</td>
</tr>
<tr>
<td>Materials</td>
<td>94.</td>
</tr>
<tr>
<td>Environment</td>
<td>95.</td>
</tr>
<tr>
<td>Ground Plane</td>
<td>95.</td>
</tr>
<tr>
<td>Render</td>
<td>96.</td>
</tr>
<tr>
<td><strong>Section II: Tutorials</strong></td>
<td>97.</td>
</tr>
<tr>
<td>Pull Toy - Solids and Transforms</td>
<td>99.</td>
</tr>
<tr>
<td>Enter coordinates</td>
<td>99.</td>
</tr>
<tr>
<td>Draw the pull toy body</td>
<td>99.</td>
</tr>
<tr>
<td>Draw the axles and wheel hubs</td>
<td>102.</td>
</tr>
<tr>
<td>Draw the lug nuts</td>
<td>104.</td>
</tr>
<tr>
<td>Array the lug nuts</td>
<td>105.</td>
</tr>
<tr>
<td>Draw the tires</td>
<td>106.</td>
</tr>
<tr>
<td>Mirror the wheels</td>
<td>107.</td>
</tr>
<tr>
<td>Draw the eyes</td>
<td>109.</td>
</tr>
<tr>
<td>Make the pull cord</td>
<td>114.</td>
</tr>
<tr>
<td>Flashlight - Revolve Curves</td>
<td>125.</td>
</tr>
<tr>
<td>Set up the model</td>
<td>125.</td>
</tr>
<tr>
<td>Draw a centerline</td>
<td>127.</td>
</tr>
<tr>
<td>Draw the body profile curve</td>
<td>128.</td>
</tr>
<tr>
<td>Draw the lens profile curve</td>
<td>129.</td>
</tr>
<tr>
<td>Build the flashlight body</td>
<td>130.</td>
</tr>
<tr>
<td>Create the lens</td>
<td>133.</td>
</tr>
<tr>
<td>Headphone - Sweep, Loft, and Extrude</td>
<td>135.</td>
</tr>
<tr>
<td>Create the speaker shell</td>
<td>136.</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Create the padding and cover</td>
<td>140</td>
</tr>
<tr>
<td>Create the mounting bracket</td>
<td>142</td>
</tr>
<tr>
<td>Create the headband</td>
<td>146</td>
</tr>
<tr>
<td>Round the headband ends</td>
<td>151</td>
</tr>
<tr>
<td>Create the speaker wire</td>
<td>157</td>
</tr>
<tr>
<td>Mirror the headphone parts</td>
<td>161</td>
</tr>
<tr>
<td>Learn more</td>
<td>163</td>
</tr>
<tr>
<td>Penguin - Point Editing and Blending</td>
<td>165</td>
</tr>
<tr>
<td>The body</td>
<td>165</td>
</tr>
<tr>
<td>The eyes</td>
<td>173</td>
</tr>
<tr>
<td>The beak</td>
<td>179</td>
</tr>
<tr>
<td>The feet</td>
<td>186</td>
</tr>
<tr>
<td>The tail</td>
<td>196</td>
</tr>
<tr>
<td>The wings</td>
<td>199</td>
</tr>
<tr>
<td>Finishing touches</td>
<td>204</td>
</tr>
<tr>
<td>Render</td>
<td>206</td>
</tr>
<tr>
<td>Boat Hull - Loft and Sweep</td>
<td>207</td>
</tr>
<tr>
<td>Lay out the hull curves</td>
<td>208</td>
</tr>
<tr>
<td>Check the curves for fairness</td>
<td>209</td>
</tr>
<tr>
<td>Fix the curvature</td>
<td>209</td>
</tr>
<tr>
<td>Create the 3-D curves</td>
<td>210</td>
</tr>
<tr>
<td>Revise the curves</td>
<td>212</td>
</tr>
<tr>
<td>Loft the hull surfaces</td>
<td>215</td>
</tr>
<tr>
<td>Trim the bow and bottom</td>
<td>217</td>
</tr>
<tr>
<td>Build the transom</td>
<td>219</td>
</tr>
<tr>
<td>Add the deck</td>
<td>226</td>
</tr>
<tr>
<td>Dragonfly - Trace Images</td>
<td>233</td>
</tr>
<tr>
<td>Draw the body</td>
<td>233</td>
</tr>
<tr>
<td>Draw the head</td>
<td>239</td>
</tr>
<tr>
<td>Blend the head and body</td>
<td>247</td>
</tr>
<tr>
<td>Draw the eyes</td>
<td>249</td>
</tr>
<tr>
<td>Shape the tail</td>
<td>250</td>
</tr>
<tr>
<td>Trace the wings</td>
<td>251</td>
</tr>
<tr>
<td>Draw the legs</td>
<td>253</td>
</tr>
<tr>
<td>Finishing touches</td>
<td>254</td>
</tr>
<tr>
<td>Wrap Text - Flow along surface</td>
<td>255</td>
</tr>
<tr>
<td>Make a surface</td>
<td>255</td>
</tr>
<tr>
<td>Create the objects to wrap</td>
<td>256</td>
</tr>
<tr>
<td>Control the object placement</td>
<td>256</td>
</tr>
<tr>
<td>Mechanical Part - Blocks</td>
<td>261</td>
</tr>
<tr>
<td>Create solid shapes</td>
<td>261</td>
</tr>
<tr>
<td>Drill the holes</td>
<td>265</td>
</tr>
<tr>
<td>Copy the holes</td>
<td>267</td>
</tr>
<tr>
<td>Make a 2-D drawing</td>
<td>270</td>
</tr>
<tr>
<td>Dimension the 2-D drawing</td>
<td>270</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Mechanical Part - Layouts</td>
<td>273</td>
</tr>
<tr>
<td>Layout viewports</td>
<td>274</td>
</tr>
<tr>
<td>Insert a title block</td>
<td>275</td>
</tr>
</tbody>
</table>
Rhinoceros 5 User's Guide
Section I: Working in 3-D
Introduction

Modeling in 3-D is the process of creating a mathematical representation of an object's surfaces. The resulting model is displayed on your screen as a two-dimensional image. Rhino provides tools for creating, displaying, and manipulating these surfaces.

The Rhino interface

The image below illustrates some of the major features of the Rhino window.

Menu (1)
The menus group Rhino commands by function.

History window (2)
The command history window displays the previous commands and prompts.

Command prompt (3)
The command prompt displays prompts for the current command actions, options for the command that you can click, and allows typing command names and options.

Toolbars (4)
Toolbars contain graphical icons for initiating commands. Many toolbar icons have a second command that you can access by right-clicking the icon. The tooltip that appears when you hover over the icon tells you what the left and right mouse button do.

To access the command on the first line
- Click the icon with the left mouse button.

To access the command on the second line
- Click the button with the right mouse button.
**Viewports (5)**
Viewports display the Rhino working environment.

**Panels (6)**
Tabbed panels contains layers, properties, and other settings.

**Rhino commands**
Rhino is a command driven program. In other words, all actions are activated by named commands such as **Line**, **Box**, or **CurvatureAnalysis**.

Tip: To read more about a command, click the red, underlined command name link.

Commands are accessed through the **menus**, or the **toolbars**, or by **typing** the command name. In the next sections, you will explore using these methods. You may find one method easier than another. The choice is yours, and there is no preference for one method over another.

In the exercises, you will use Rhino’s commands, navigation tools, shaded modes, render, and use some basic object manipulation.

Tip: To cancel a command any time, press the **Esc** key.

**In this session you will**
- Start a command by choosing from the menu.
- Start a command by choosing from a toolbar icon.
- Start a command by typing.

**To start your first Rhino model**
1. Start **Rhino**.
2. On the **File** menu, click **New**.
3. In the **Open Template File** dialog box, select **SmallObjects - centimeters.3dm** and click **Open**.

**Start from the menu**
Most Rhino commands are arranged in the menus.

Start the **Cone** command
- On the **Solid** menu, click **Cone**.
**Draw the cone**

1. At the **Base of cone**... prompt, in the **Top** viewport, click with the mouse to pick the center point for the base of the cone.

   ![Start in the Top viewport](image1)

2. At the **Radius**... prompt, in the **Top** viewport, drag the mouse and click to draw the cone's base.

   ![Still in the Top viewport](image2)

   ![Drag the cursor and click to set the base radius](image3)
3. At the **End of cone** prompt, in the **Front** viewport, drag the mouse and click to draw the cone's point.

   - **Set the height in the Front viewport.**
   - **Click anywhere to set the height.**

4. Watch what happens in the **Perspective** viewport.

**Start from a toolbar icon**

Toolbars provide a graphical interface to the commands.

**To display a button tooltip, hover your mouse over the icon**

- The command names that are activated with the left and right mouse clicks display.
Start the Curve command

- On the toolbar docked on the left side of the Rhino window, click the icon for **Control point curve**.
Draw the curve
1. At the **Start of curve**... prompt, in the **Top** viewport, click the mouse to start the curve.
2. At the **Next point**... prompts, click a few more points in the **Top** viewport.

![Top Viewport Diagram]

3. At the **Next point**... prompts, move the mouse into the **Front** viewport and click a few more points.

![Front Viewport Diagram]

4. At the **Next point**... prompts, move the mouse into the **Right** viewport and click a few more points.

![Right Viewport Diagram]

5. Right-click, press **Enter** or press the **spacebar** to complete the curve.
6. Check out the **Perspective** viewport.

Admire your work
- Drag with the right mouse button to rotate the **Perspective** view.

**Start from the command line**
You can start a command by typing the command name.

注视sphere command by typing
- Click at the command prompt, and type **Sphere**.
Draw the sphere
1. At the **Center of sphere...** prompt, in the **Perspective** viewport, click the mouse to pick the center point for the sphere.

2. At the **Radius...** prompt, in the **Perspective** viewport, move the mouse away from the center point, and click the mouse to draw the sphere and click.

3. In the **Perspective** viewport, click the down-arrow on the **viewport title**, and on the menu, click **Shaded**.
**Undo a mistake**

If you did something you did not want to do, you can undo your actions.

- **Undo a command**
  
  On the **Edit** menu, click **Undo**, or press the **Ctrl** and **Z** keys.

- **Redo commands**
  
  On the **Edit** menu, click **Redo**, or press the **Ctrl** and **Y** keys.
The command window

The command window contains the command history and the command prompt. The window is normally docked at the top of the Rhino window, but you can dock it at the bottom of the screen or float it just like any toolbar. It is a good idea to drag the window so it displays at least three lines of text. The command prompt is where you can type command names, set options, enter distances and angles for drawing, and read the prompts for the commands. The command prompt displays options for the command in parentheses. To activate an option, click the option with the mouse or type the option name or the underlined letter in the option. Options give you alternate methods for using the command. Prompts are messages to you to select objects to act on, to enter information, or to enter a point on the screen. As you start to build objects, prompts become increasingly important, since they tell you what to do next.

Command options

Command options change how a command acts. For example, when you draw a circle, the circle is normally drawn on the active construction plane. The Circle command has several options including Vertical and AroundCurve. Command options appear in parentheses at the prompt. To use a command option, click the option name, or type the underlined letter of the option or the whole option name.

Choose a command option

1. At the command prompt, type Circle.
2. The options for the Circle command appear:
   Center of circle (Deformable Vertical 2Point 3Point Tangent AroundCurve FitPoints)
3. To draw a circle vertical to the active construction plane, use the Vertical option.
   Click Vertical, or type V.

Repeat the last command

Many tasks in Rhino are repetitive. You might want to move or copy several objects, for example. Methods for repeating commands are provided.

To repeat the last command

- Press the Enter key when no command is active.
- In addition to pressing the Enter key on your keyboard, you can press the Spacebar or click the right mouse button in a viewport. These all perform the same function.

Note:
Some commands, such as Undo and Delete do not repeat. Instead, the command prior to these commands is repeated. This prevents you from accidentally undoing too many commands or deleting objects accidentally. In addition, you often want to repeat the command you were using before undoing a mistake. You can define the list of commands that do not repeat to suit your own way of working.
Get help any time

The *Rhino Help* file is the major resource for detailed information on specific commands.

**To get help on a specific command**

- To get Help for a command, press **F1** while the command is running.
- On the **Help** menu, click **Command Help**.
  The Rhino **Help** will display in a dockable window.
  Click **Auto-Update** to display the Help topic for the current command.
  The Help window appears with the specific command topic visible.
- Go to *Rhino Help* for the most up-to-date Help information.
- Find the answers to frequently asked questions at: *Rhino Support*.

💡 **Tip:** For more information about the mathematical principles involved in 3-D modeling, see: [www.mathopenref.com](http://www.mathopenref.com).
Rhino Objects

The fundamental geometric objects in Rhino are points, curves, surfaces, polysurfaces, extrusion objects, and polygon mesh objects.

Why NURBS modeling

NURBS (non-uniform rational B-splines) are mathematical representations that can accurately model any shape from a simple 2-D line, circle, arc, or box to the most complex 3-D free-form organic surface or solid. Because of their flexibility and accuracy, NURBS models can be used in any process from illustration and animation to manufacturing.

NURBS geometry is an industry standard for designers who work in 3-D where forms are free and flowing; where both form and function is important. Rhino is used in marine, aerospace, and automobile interior and exterior design. Makers of household and office appliances, furniture, medical and sports equipment, footwear, and jewelry use Rhino to create free-form shapes.

NURBS modeling is also widely used by professional animators and graphic artists. The advantage over using polygon modelers is that there are no facets. The models can be rendered at any resolution. A mesh can be created from the model at any resolution. For more information about the mathematics of NURBS, see What are NURBS?.

Points

Point objects mark a single point in 3-D space. They are the simplest objects in Rhino. Points can be placed anywhere in space. Points are most often used as placeholders.
Curves

A Rhino curve is similar to a piece of wire. It can be straight or wiggled, and can be open or closed. A *polycurve* is several curve segments joined together end to end. Rhino provides many tools for drawing curves. You can draw straight lines, polylines that consist of connected line segments, arcs, circles, polygons, ellipses, helices, and spirals. You can also draw curves using curve *control points* and draw curves that pass through selected points.

![Curves in Rhino](image)

Curves in Rhino include lines, arcs, circles, free-form curves, and combinations of these. Curves can be open or closed, planar or non-planar.

Surfaces

A surface is like a rectangular stretchy rubber sheet. The NURBS form can represent simple shapes, such as planes and cylinders, as well as free-form, sculptured surfaces. All surface creation commands in Rhino result in the same object: a NURBS surface. Rhino has many tools for constructing surfaces directly or from existing curves.

![Surfaces](image)

All NURBS surfaces have an inherently rectangular organization.
Even a closed surface such as a cylinder is like a rectangular piece of paper that has been rolled up so two opposite edges are touching. The place where the edges come together is called the seam. If a surface does not have a rectangular shape, either it has been trimmed or the control points on the edges have been moved.

**Closed and open surfaces**

A surface can be open or closed. An open cylinder is closed in one direction.

A torus (donut shape) is closed in two directions.

**Trimmed and untrimmed surfaces**

Surfaces can be trimmed or untrimmed. A trimmed surface has two parts: a surface that underlies everything and defines the geometric shape, and trimming curves that mark sections of the underlying surface that are trimmed away.

Trimmed surfaces are created with commands that trim or split surfaces with curves and other surfaces. Some commands create trimmed surfaces directly.
The shape of a surface is still defined by a set of control points arranged in a rectangular pattern.

Since it can be important for you to know if a surface is trimmed, the **Properties** command lists the trimmed or untrimmed state of the surface. Some Rhino commands work only with untrimmed surfaces and some software does not import trimmed NURBS surfaces. Trimming curves lie on the underlying surface. This surface may be larger than the trim curves, but you will not see the underlying surface because Rhino does not draw the part of the surface that is outside the trim curves. Every trimmed surface retains information about its underlying surface geometry. You can remove the trimming curve boundaries to make the surface untrimmed with the **Untrim** command.

If you have a trim curve that runs across a surface, the trim curve itself does not have any real relationship to the control point structure of the surface. You can see this if you select such a trimmed surface and turn its control points on. You will see the control points for the whole underlying surface.
If you create a surface from a planar curve, it can be a trimmed surface. The illustrated surface was created from a circle. The control points display shows the rectangular structure of the surface.

The **Untrim** command removes the trimming curve from the surface to get back to the underlying untrimmed rectangular surface.

**Surface isoparametric and edge curves**

In wireframe view, surfaces look like a set of crossing curves. These curves are called *isoparametric curves* or *isocurve*. These curves help you visualize the shape of the surface. Isoparametric curves do not define the surface the way the polygons do in a polygon mesh. They are merely a visual aid that allows you to see the surface on the screen. When a surface is selected, all of its isoparametric curves highlight.

Edge curves bound the surface. Surface edge curves can be used as input to other commands.

*Isocurves (1), Edge curves (2).*
**Polysurfaces**

A *polysurface* consists of two or more surfaces that are joined together. A polysurface that encloses a volume of space defines a solid.

**Solids**

A *solid* is a surface or polysurface that encloses a volume. Solids are created anytime a surface or polysurface is completely closed. Rhino creates single-surface solids, polysurface solids, and extrusion solids.

A single surface can wrap around and join itself. Example commands include *Sphere, Torus*, and *Ellipsoid*. Control points can be displayed on single-surface solids and moved to change the surface.

Some Rhino commands create polysurface solids. *Pyramid, Cone*, and *TCone* are examples of commands that create polysurface solids.

The *SolidPtOn* command turns on grip points for polysurfaces, which act like control points.
Light-weight extrusion objects

Light-weight extrusion objects use only a profile curve and a length as input instead of the network of isocurves normally needed for NURBS objects. The Box, Cylinder, Tube, and ExtrudeCrv commands create extrusion objects. Extrusion objects can be closed with a planar cap or open. These objects will be converted to polysurfaces by some commands if necessary to add additional information for editing.

Polygon mesh objects

Because there are many modelers that use polygon meshes to represent geometry for rendering, animation, stereolithography, visualization, and finite element analysis, the Mesh command translates NURBS geometry into polygonal meshes for export. In addition, the Mesh creation commands MeshSphere, MeshBox, MeshCylinder, etc., draw mesh objects.

Note:

There is no easy way to convert a mesh model into a NURBS model. The information that defines the objects is completely different. However, Rhino has a few commands for drawing curves on meshes and extracting vertex points and other information from mesh objects to assist in using mesh information to create NURBS models.
Selecting Objects

Most operations you will do in Rhino require you to select one or more objects. Objects can be selected by clicking anywhere on the object. Click away from the object to deselect it. This method lets you select one object at a time.

- **Shift** To select additional objects
  - Hold the **Shift** key while clicking the objects.

- **Ctrl** To remove objects from the selection
  - Hold the **Ctrl** key and click the objects again.

- **Esc** To cancel the selection
  - Click away from the objects or press the **Esc** key.

**Practice selecting objects**

1. Open the tutorial model **Select Objects.3dm**.
   - [Download the tutorial models](#).
2. In the **Perspective** viewport, click to select the sphere.
3. Hold the **Shift** key and select the cylinder.
The cylinder is added to the selection.

4. Hold the **Ctrl** key and click the sphere again.
5. Click away from the objects, or press the **Esc** key.
The selection is canceled.

**Select objects with windows**

Another method is to make a *window selection* or a *crossing selection* to select multiple objects in one operation.

You can click in an open area of the screen and drag to create a selection window. To make a window selection click in an open area of the screen and drag to the right. To make a crossing selection click in an open area of the screen and drag to the left.

A window selection, selects all objects completely enclosed by the window. A crossing selection, selects all objects that are enclosed by the window or any object the window crosses.

To add objects, hold the **Shift** key while making a window or crossing selection.
To remove objects, hold the **Ctrl** key while making a window or crossing selection.
Practice window and crossing select

1. In the **Perspective** viewport, click and drag a window around the sphere.

2. In the **Perspective** viewport, hold the **Shift** key then click and drag a window around the box and the cylinder.
   The cylinder and box are added to the selection.

3. In the **Perspective** viewport, hold the **Ctrl** key then click and drag a crossing over the box and cylinder.

Other ways of selecting

Rhino has many commands and methods for selecting objects. You can select object by name, layer, color, type; by capturing with boundaries or crossing fences; by volume shapes, by group name and many others. Review the help topic *Selection commands*. 
**Practice selection by object type**

1. At the command prompt, type `SelAll`.
2. Type `SelNone`.
   This clears the objects from the selection.

![Figure](image.png)
3. Type `SelSrf`.  
   This selects all surfaces. In this case, only the sphere is a surface.

4. Type `SelPolysurface`.  
   This adds all polysurfaces to the selection. In this case, the cylinder and box are polysurfaces.

5. Press the Esc key.  
   This also clears the selection.

**Sub-object selection**

You can select sub-parts of objects for use in commands, for example, select a surface edge to use as input for a Loft or ExtrudeCrv operation. The available parts include polysurface faces; surface and polysurface edge curves; control points; mesh vertices, faces, boundaries, and edges; and objects within a group. Review the help topic for **Sub-object selection**.

**To select parts of objects for use with other commands**

- Press and hold both the Ctrl and Shift keys at the same time and click an object part.
Practice sub-object selection

1. In the Perspective viewport, press the Ctrl and Shift keys and click a face of the box.
2. Press the Delete key.

The face of the box is separated from the box solid and deleted.
Navigating Viewports

The viewport title has some special functions for manipulating the viewport.

- Click the title to make the viewport active without disturbing the view.
- Drag the viewport title to move the viewport.
- Double-click the viewport title to maximize the viewport. Double-click again to restore the size to normal.

Viewport projection

Viewports can have one of three projections: parallel, perspective or two-point perspective.

Right mouse navigation works differently in the two viewport styles. In parallel views, right mouse dragging pans the view. In perspective views, right-mouse dragging rotates the view. In the usual four-viewport layout, there are three parallel viewports and one perspective viewport.

Parallel

Parallel views are also called orthogonal views in some systems. In a parallel view, all the grid lines are parallel to each other, and identical objects look the same size, regardless of where they are in space.

![](image)

Perspective

In a perspective view, grid lines converge to a vanishing point. This provides the illusion of depth in the viewport. Perspective projection makes objects farther away look smaller.

![](image)

Viewport navigation

Rhino's easy navigation helps you to visualize your model.

The simplest way to change the view is to drag the mouse with right button held down. This pans the view in parallel views and rotates the view in perspective views.

You can change your view in the middle of a command to see precisely where you want to select an object or choose a point.

To zoom in and out

- Hold down the \textbf{Ctrl} key and drag up and down with the right mouse button held down.

-tip: If you have a mouse with a wheel, use the wheel to zoom in and out.
Navigating Viewports

<table>
<thead>
<tr>
<th>Command</th>
<th>Key and mouse combinations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pan</td>
<td>In parallel viewports (for example: Top, Front, and Right), <strong>drag</strong> with the right mouse button.</td>
</tr>
<tr>
<td></td>
<td>In perspective viewports, hold the <strong>Shift</strong> key, and <strong>drag</strong> with the right mouse button.</td>
</tr>
<tr>
<td>RotateView</td>
<td>In parallel viewports (for example: Top, Front, and Right), hold the <strong>Ctrl</strong> and <strong>Shift</strong> keys, and <strong>drag</strong> with the right mouse button.</td>
</tr>
<tr>
<td></td>
<td>In perspective viewports, <strong>drag</strong> with the right mouse button.</td>
</tr>
<tr>
<td>Zoom</td>
<td>Hold the <strong>Ctrl</strong> key, and <strong>drag</strong> up and down with the right mouse button, or rotate the mouse wheel.</td>
</tr>
</tbody>
</table>

Mouse navigation

Working in 3-D on a computer requires visualizing three-dimensional objects drawn on a two-dimensional medium—the computer screen. Rhino provides tools to help do this.

Drag with the right mouse button to easily manipulate the views to look model from various angles. Use the right mouse button view manipulations in both wireframe and shaded views.

**To pan in a viewport**

- In the **Top** viewport, drag the mouse with the right mouse button held down to pan the view.

**Restore a view**

If you get lost, there are several ways to get yourself reoriented:

- Press the **Home** key to step back through your view changes.
- Press the **End** key to step forward through your view changes.
- To set your view so you are looking straight down on the construction plane, use the **Plan** command.
- To bring all your objects into view, use the **Zoom** command **Extents** option.

**Practice rotating the view**

1. Click the left mouse button in the **Perspective** viewport to make it active.
   An active viewport is the viewport where all your commands and actions take place. The active viewports title highlights so you can easily see which viewport is active.
2. In the **Perspective** viewport, drag the mouse with the right mouse button held down to rotate the view and see the objects from a different angle.

Viewport display modes

You can view your model in a variety of ways that depend on your own needs. Wireframe mode usually offers the fastest display speed, shaded modes offer the ability to view surfaces and solids with shading to help you visualize the shapes.

Standard and customized shaded modes allow easier visualization of surfaces and solids.
**Wireframe**

In **Wireframe** mode, surfaces look like a set of crossing curves. These curves are called *isoparametric curves* or *isocurves*.

Isocurves do not define the surface the way the polygons do in a polygon mesh. They are merely a visual aid.

![Wireframe Image]

**To set wireframe mode**

1. Click a mouse button in the **Perspective** viewport to make it active. An active viewport is the viewport where all your commands and actions take place.
2. On the viewport title menu, click **Wireframe**.

---

**Shaded**

The **Shaded** modes, (for example, Shaded, Rendered, Artistic, and Pen) display surfaces and solids with the surfaces shaded using their layer, object, or custom color. You can work in any of the shaded modes. The surfaces are opaque or transparent.
To set shaded mode

1. On the viewport title menu, click Shaded.

Rotate your view by holding down the right mouse button and dragging from the bottom of the view toward the top.
You are now under the objects looking up.
The construction plane grid helps you stay oriented. If the objects are behind the grid, you are looking at the bottom of the construction plane.

2. Press the Home key to undo your view changes.

Rendered

Rendered mode shows the objects with lighting and render materials applied.

Other shaded modes

Other display modes and custom settings are described in the Rhino Help.

Artistic (left) and Pen (right) display modes.
Viewport title

The viewport title has some special functions for viewport control.

- Click the title to make the viewport active without disturbing the view.
- Drag the viewport title to move the viewport.
- Double-click the viewport title to maximize the viewport. 
  Double-click again to restore the size to normal.

To activate the viewport title menu

- Right-click the viewport title or click the down-arrow on the menu to display the viewport title menu. 
  From the viewport title menu you can maximize the viewport, pan, rotate, zoom, set one of the 
  standard views, set a construction plane, set the camera and target locations, choose a shading 
  option, set the grid, and open the Viewport Properties dialog box.
Accurate Modeling

The cursor can always move freely in space, but chances are, you will want to relate your modeling elements to the construction plane grid, existing objects, or coordinates in space. You can restrict the cursor’s movement to the grid, enter specific distances and angles from a point, snap to specific locations on existing objects, and enter Cartesian coordinates to locate points in 2-D or 3-D space.

The Rhino cursor

There are two parts of the cursor: the cursor (1) and the marker (2). The cursor always follow the mouse movement.

The marker sometimes leaves the center of the cursor because of some constraint on it such as grid snap or ortho. The marker is a dynamic preview of the point that will be picked when the left mouse button is clicked. When the marker is constrained, in elevator mode, for example, a tracking line (3) also displays.

Constraints move your marker to a specific point in space or make its movement track according to the constraint so you can model accurately.

Snap to the construction plane grid

Grid snap constrains the marker to an imaginary grid that extends infinitely. You can set the snap spacing to any value.

Click the Grid Snap pane on the status bar to turn grid snap on and off.

Tip: To read more about a command, click the red, underlined command name link.

Constrain the angle of movement

Ortho mode constrains the marker movement or object dragging to a specific set of angles. By default, this is parallel to the grid lines, but you can change this. Ortho is similar to the axis lock function found in drawing or animation programs.

Click the Ortho pane on the status bar to turn ortho on and off. Press and hold the Shift key to temporarily toggle the ortho mode.

Another common use for ortho is to constrain object dragging to a specific axis.
Ortho is active after the first point for a command. For example, after picking the first point for a line, the second point is constrained to the ortho angle.

Ortho off (left); Ortho on (right).

If you only need a different angle for a single operation, angle constraint is faster to use. Enter a specific angle for one operation instead of changing the ortho angle and then changing it back.

**Snap to existing objects**

Object snaps constrain the marker to specific points on an object. When Rhino asks you to specify a point, you can constrain the marker to specific parts of existing geometry. When an object snap is active, moving the cursor near a specified point on an object causes the marker to jump to that point.

Object snaps can persist from pick to pick, or can be activated for one pick only. Multiple persistent object snaps can be set from the status bar. All object snaps behave similarly, but snap to different parts of existing geometry. In addition, there are special object snaps that work for one pick only.

**Persistent object snaps**

Use persistent objects snaps to maintain an object snap through choosing several points. Since persistent object snaps are easy to turn on and off, you can set them and leave them on until they get in your way. You can then set a different one or just disable them.

Sometimes object snaps interfere with each other and with grid snap or ortho. Object snaps normally take precedence over grid snap or other constraints.

There are other situations where object snaps work in conjunction with other constraints. You will see examples of this in this chapter. For more information including video demonstrations, see the Rhino help topic Object snaps.

**The Osnap control**

The Osnap control is usually docked at the bottom of the screen.

- If the Osnap control is not open, click the Osnap pane in the status bar.
- Click a check box to turn on an object snap.
- Right click a check box to turn an object snap on and turn off all other object snaps.
- When an object snap is active, moving the cursor near an eligible point on an object causes the marker to jump to that point and a tooltip to appear.

The check boxes in the Osnap control allow single-use overrides for the persistent object snaps.

**To suspend all persistent object snaps**

- In the Osnap control, click the Disable button.

**To clear all persistent object snaps**

- In the Osnap control, click Disable with the right mouse button.
To turn on one object snap and turn all others off with one click

- In the Osnap control, right-click the object snap you want to turn on.

Special case object snaps
Complex object snaps that allow selecting multiple reference points or add other advanced controls. See the Rhino help topic Object snaps for more information.
These are also available from the Osnap control.

To turn on complex object snaps

- Hold the Ctrl key and hover over the Osnap control.
  An alternate set of controls appears.
  ![Alternate controls](image)

Cursor constraints
When entering points, you can constrain the marker to a distance or angle from the previous point. Once you have set the distance, drag the line around to any angle. You can also use further snaps to point the line in a specific direction.

Distance constraint
During any command that requires two points, such as the Line command, place the first point. Then at the next prompt, type a distance and press Enter.
The marker will be constrained to the specified distance from the previous point. Drag the cursor around the first point and then pick a point.

Angle constraint
Angle constraint is similar to ortho, but you can set any angle and it is a one-time setting.
The < symbol is used because it is similar to the symbol used in geometry to indicate an angle.
The marker will be constrained to lines radiating from the previous point separated by the specified angle, where the first line is the specified number of degrees counterclockwise from the x-axis. If you enter a negative number, the angle will be clockwise from the x-axis.
**Distance and angle together**

Distance and angle constraints can be used at the same time.

1. At the command prompt, type the distance, and press **Enter**.
2. At the next command prompt, type the `<` character and the angle value, and press **Enter**.

**Elevator mode**

Pick a second point to specify the z-coordinate of the desired point. It is easiest to see this in a different viewport or use the Perspective viewport. Drag the mouse cursor around to see the marker move vertically from the base point along the tracking line.

Pick the point with the mouse or type the height above the construction plane. Positive numbers are above the construction plane; negative numbers are below it. You can use further constraints like coordinates, object snaps or grid snap for the first point, and you can use object snaps for the height.

To move the marker in the construction plane z-direction, hold the **Ctrl** key and click a point on the construction plane, and then drag vertically from the construction plane and click to pick a point.

This constraint is called elevator mode. Using elevator mode to move your pick point vertically from the construction plane lets you work more in the Perspective viewport.

**SmartTrack™**

SmartTrack is a system of temporary reference lines and points that is drawn in the Rhino viewport using implicit relationships among various 3-D points, other geometry in space, and the coordinate axes directions. Temporary infinite lines (tracking lines) and points (smart points) are available to object snaps very much like real lines and points.
You can snap to intersections of the tracking lines, perpendiculants, and directly to smart points as well as intersections of tracking lines and real curves. The tracking lines and smart points are displayed for the duration of a command.

Coordinate systems
Rhino uses two coordinate systems: construction plane coordinates and world coordinates. World coordinates are fixed in space. Construction plane coordinates are defined for each viewport.

Cartesian coordinates
When Rhino prompts you for a point, if you type x and y Cartesian coordinates, the point will lie on the construction plane of the current viewport. For more information about coordinate systems and numeric constraints, see www.mathopenref.com/coordinates.

Right-hand rule
Rhino follows what is called the right-hand rule. The right-hand rule can help you determine the direction of the z-axis. Form a right angle with the thumb and forefinger of your right hand. When your thumb points in the positive x-direction, your forefinger points in the positive y-direction, and the palm of your hand faces in the positive z-direction.

World coordinates
Rhino contains one world coordinate system. The world coordinate system cannot be changed. When Rhino prompts you for a point, you can type coordinates in the world coordinate system.
The arrow icon in the lower left corner of each viewport displays the direction of the world x-, y-, and z-axes. The arrows move to show the orientation of the world axes when you rotate a view.

Construction plane coordinates
Each viewport has a construction plane. A construction plane is like a tabletop that the cursor moves on unless you use coordinate input, elevator mode, or object snaps or a few other instances where input is constrained. The construction plane has an origin, x- and y-axes, and a grid. The construction plane can be set to any orientation. By default, each viewport’s construction plane is independent of those in other viewports.
The construction plane represents the local coordinate system for the viewport and can be different from the world coordinate system.

Rhino’s standard viewports come with construction planes that correspond to the viewport. The default **Perspective** viewport, however, uses the world Top construction plane, which is the same construction plane that is used in the Top viewport.

The grid lies on the construction plane. The dark red line represents the construction plane x-axis. The dark green line represents the construction plane y-axis. The red and green lines meet at the construction plane origin.

To change the direction and origin of a construction plane, use the **CPlane** command. Preset construction planes (World Top, Right, and Front) give you quick access to common construction planes. In addition, you can save and restore named construction planes and import named construction planes from another Rhino file.

### 2-D construction plane coordinates

- At a command prompt, type the coordinates in the format $x, y$ where $x$ is the x-coordinate and $y$ is the y-coordinate of the point.

### 3-D construction plane coordinates

- At a command prompt, type the coordinates in the format $x, y, z$ where $x$ is the x-coordinate, $y$ is the y-coordinate, and $z$ is the z-coordinate of the point.
- To place a point 3 units in the x-direction, 4 units in the y-direction, and 10 units in the z-direction from the construction plane origin, type $3, 4, 10$ at the prompt.

**Tip:** If you enter only x- and y-coordinates, the point will lie on the construction plane.

### Relative coordinates

Rhino remembers the last point used, so you can enter the next point relative to it. Relative coordinates are useful for entering a list of points where the relative locations instead of absolute locations of the points are known. Use relative coordinates to locate points according to their relationship to the previous active point.

**To use relative coordinates**

- At a command prompt, type the coordinates in the format $rx, y$ where $r$ signifies that the coordinate is relative to the previous point.

**For example**

1. Start the **Line** command.
2. At the **Start of line...** prompt, click to place the first end of the line.
3. At the **End of line...** prompt, type **r2,3**, and press **Enter**. The line is drawn to a point 2 units in the x-direction and 3 units in the y-direction from the last point.
Create Surfaces from Curves

A common way of working in 3-D is to draw curves that represent edges, profiles, cross-sections, or other surface features and then to use surfacing commands to create surfaces from those curves.

Edge curves

You can create a surface from three or four curves that form the sides of the surface.

Create a surface from edge curves

1. Open the tutorial model EdgeSrf.3dm.
   Download the tutorial models.
2. On the Surface menu, click Edge Curves.

   Tip: Open the Help panel to review the help topic for the EdgeSrf command.

3. Select the four curves.

   Objects change to yellow when you select them.
   A surface is created from the curves that form its edges.
Extrude curves

Extruding creates surfaces by tracing the path of a curve in a straight line.

1. Open the tutorial model Extrude.3dm.
2. On the Surface menu, click Extrude Curve, and then click Straight.

Tip: Open the Help panel to review the help topic for the ExtrudeCrv command.
3. **Select** the curve (1).

4. At the **Extrusion distance** prompt, drag a distance with your mouse and click.
Create Surfaces from Curves

Loft curves

Lofting creates a smooth surface that blends between selected shape curves. This surface looks similar to the Sweep a curve with two rails example, but is created without rail curves. Instead, the edges of the surface are created by fitting smooth curves through the shape curves.

Create a lofted surface

1. Open the tutorial model **Loft.3dm**.
   - Download the tutorial models.
2. On the **Surface** menu, click **Loft**.
   - Tip: Open the Help panel to review the help topic for the **Loft** command.
3. **Select** the three curves (1), (2), and (3), and press **Enter**.
4. In the **Loft Options** dialog box, click **OK**.
5. Try some of the **Style** options and then click **Preview** to see the various loft styles.
Revolve curves

Revolving a curve creates a surface by revolving a profile curve about an axis. This is sometimes called *lathing*.

Create a revolved surface

1. Open the tutorial model Revolve.3dm.
2. In the status bar, click Osnap.
3. In the Osnap control, click End.
4. On the Surface menu, click Revolve.

Tip: Open the Help panel to review the help topic for the Revolve command.
5. Select the profile curve (1) and press Enter.
6. At the **Start of revolve axis** prompt, snap to one end of the axis line (2).

7. At the **End of revolve axis** prompt, snap to the other end of the axis line (3).

8. At the **Start angle...** prompt, select the **FullCircle** option.
Revolve curves with a rail

Rail revolve creates a surface by revolving a profile curve around an axis while at the same time following a rail curve. This is basically the same as **Sweep Along 2 Rails**, except one of the rails is a central point.

**Create a revolved surface with a rail curve**

1. Open the tutorial model *RailRev.3dm*.
   - Download the tutorial models.
2. On the **Surface** menu, click **Rail Revolve**.

**Tip**: Open the **Help** panel to review the help topic for the **RailRevolve** command.
3. **Select** the profile curve (1).
4. At the **Select rail curve...** prompt, select the rail curve the revolve will follow (2).
5. At the **Start of RailRevolve axis** prompt, snap to an endpoint of the axis line (3).

6. At the **End of RailRevolve axis** prompt, snap to the other end of the axis line (4).
Sweep along one rail curve

Sweeping creates a surface with cross sections that maintain the initial orientation of the shape curve(s) to the path curve.

Create a sweep surface

1. Open the tutorial model Sweep1.3dm.
   - Download the tutorial models.
2. On the Surface menu, click Sweep 1 Rail.

Tip: Open the Help panel to review the help topic for the Sweep1 command.
3. **Select** the rail curve (1).

4. At the **Select cross section curves** ... prompt, select the cross-section curve (2), and press **Enter**.

5. In the **Sweep 1 Rail Options** dialog box, click **OK**.
Sweep along two rail curves

Using two rails for a sweep creates a smooth surface through two or more shape curves that follow two curve rails. The rails also affect the overall shape of the surface. Use this command when you want to control the location of the edges of the surface.

Create a sweep surface with two rail curves

1. Open the tutorial model Sweep2.3dm.
   Download the tutorial models.
2. On the Surface menu, click Sweep 2 Rail.

   Tip: Open the Help panel to review the help topic for the Sweep2 command.

3. Select the first rail curve (1).
4. At the **Select second rail...** prompt, select the second rail curve (2).

5. At the **Select cross section curves** prompt, select the two cross-section curves (3) and (4), and press **Enter**.

6. In the **Sweep 2 Rails Options** dialog box, click **OK**.
Edit Curves and Surfaces

The editing operations in this section break objects apart, cut holes in them, and put them back together. Some of these commands connect curves to curves or surfaces to surfaces or polysurfaces and break a composite curve or polysurface into its components.

The commands: **Join, Explode, Trim, and Split** apply to curves, surfaces, and polysurfaces.

The **Rebuild, ChangeDegree, and Smooth** commands alter the shape of a curve or surface by changing its underlying control point structure.

In addition, objects have properties that are assigned to them such as color, layer, rendering material, and other attributes depending on the object. The **Properties** command manages these properties.

### Join

The **Join** command connects curves or surfaces together into one object. For example, a polycurve can consist of straight-line segments, arcs, polylines, and free-form curves. The **Join** command also connects adjacent surfaces into a polysurface.

### Explode

The **Explode** command removes the connection between joined curves or surfaces. For polysurfaces, this is useful if you want to edit each individual surface with control points.

### Trim and Split

The **Trim** and **Split** commands are similar. The difference is when you trim an object, you select the parts to remove and they are deleted. When you split an object, all parts are left.

The **Split** command will split a surface with a curve, surface, polysurface, or its own isoparametric curves.

The **Untrim** command removes a surface's trimming curve, with an option to keep the curve so you can reuse it.

### Control-point editing

You can make subtle changes in the shape of a curve or surface by moving the location of its control points. Rhino offers many tools for editing control points. Some commands such as **Rebuild, Fair**, and **Smooth** offer some automated solutions for redistributing control points over a curve or surface. Other commands, such as control point dragging and nudging, **MoveUVN**, and **HBar** let you manually control the location of individual or groups of control points.

### Control point visibility

To edit curves and surfaces by manipulating control points, use the **PointsOn** command to turn the control points on.

When you are finished with control-point editing, use the **PointsOff** command or press **Esc** to turn them off.
Control points of polysurfaces cannot be turned on for editing. Editing the control points of polysurfaces could separate the edges of the joined surfaces creating "leaks" in the polysurface.

Change control point locations
When you move control points, the curve or surface changes, and Rhino smoothly redraws it. The curve or surface is not drawn though the control points rather it is attracted to the new positions of the control point. This allows the object to be smoothly deformed. When control points are on, Rhino’s transform commands can manipulate the points. You can also rebuild surfaces to add control points and redistribute them.

Add, delete, or redistribute control points
Adding control points to a curve gives you more control over the shape of the curve. Manipulating control points also lets you remove kinks, make curves uniform, and add or subtract detail. The Delete key erases curve control points. This changes the shape of the curve.

Curve and surface degree
A polynomial is a function like \( y = 3x^3 - 2x + 1 \). The "degree" of the polynomial is the largest power of the variable. For example, the degree of \( 3x^3 - 2x + 1 \) is 3; the degree of \(-x^5 + x^2\) is 5, and so on. NURBS functions are rational polynomials and the degree of the NURBS is the degree of the polynomial. From a NURBS modeling point of view, the \((\text{degree} - 1)\) is the maximum number of "bends" you can get in each span.

For example:
A degree-1 curve must have at least two control points.
A line has degree less than 1. It has zero bends.
A degree-2 curve must have at least three control points. A parabola, hyperbola, arc, and circle (conic section curves) have degree less than 2. They have one bend.

A degree-3 curve must have at least four control points. A cubic Bézier has degree less than 3. If you arrange its control points in a zig-zag shape, you can get two bends.
Transforms - Move, Copy, Rotate, Scale

Transforms change the location, rotation, number and shape of whole objects by moving, mirroring, arraying, rotating, scaling, shearing, twisting, bending, and tapering. The transform commands do not break the objects into pieces or cut holes in them.

**Note**: For all of the following exercises, the images were captured using Shaded mode display.

**Move**

Use the Move command when you want to move an object a certain distance or if you want to use object snaps to place an object accurately.

**Move objects using distance values**

The **Move** command requires a *from* and to location.

You can pick these locations on the screen or type coordinates at the command prompt.

---

**Practice moving objects**

The object of this exercise is to move an object from a specific location on the object to a location in the coordinate system.

1. Start a new model using any template.
2. Draw a **Sphere** of any size anywhere on the screen.
3. Select the sphere.
4. Start the **Move** command.
5. At the **Point to move from** prompt, with the **Center** object snap on, move the mouse around the edge of the sphere until the **Cen** tooltip displays and click.

![Center object snap](image)

6. At the **Point to move to** prompt, type **0,0,0**.
   The sphere moves to the 0,0,0 coordinate point.

![Sphere moving to 0,0,0](image)

**Tip**: Simply typing **0** is a shortcut for the coordinates **0,0,0**.

**Move objects by dragging**

The quickest way is to click the object and drag it. Rhino provides tools for making dragging objects accurate. You can drag objects in any viewport. Object snaps will help align objects to each other.

**Practice dragging objects**

1. Open the tutorial model **Drag Objects.3dm**.
   ![Download the tutorial models](image)

2. In the **Osnap** control, turn on the **Center** object snap.
3. In the **Perspective** viewport, click the cone at the bottom edge and pause until the **Center** object snap tooltip displays.

4. Drag the cone until the center of the cone's base lines up with the top surface of the cylinder and the **Center** object snap for the cylinder's top face displays.

5. Release the mouse button to place the cone.

6. In the **Front** viewport, drag the cone to the top of the cylinder.

   Watch what happens in the **Perspective** viewport.

   There are many times when you have to watch what is happening in other viewports to accurately place your objects.

**Elevator mode**

You can press the **Ctrl** key to move objects in the z-direction. This is called **elevator mode**. **Elevator mode** is like **Ortho**, except the movement is vertical to the active construction plane.

To practice using the **Ctrl** key to move vertically, you are going to move the box to a location 5 units above the center of the sphere.

Using elevator mode to move objects vertically lets you work more in the **Perspective** viewport.
Move the box vertically

Note:
For the following images, Shade-highlight selected surfaces and polysurfaces has been turned on.
(Options > View > Display Modes > Shaded > Objects > Selection)

1. Turn Ortho off.
2. On the Transform menu, click Move.
3. In the Perspective viewport, rotate the view so the sphere is toward the front, and select the box.

4. At the Point to move from... prompt, turn on the End object snap and click a corner of the box.

5. At the Point to move to prompt, turn on the Center object snap, hold down the Ctrl key, and click the center of the sphere.
6. Release the mouse button and the Ctrl key and start to drag the box.
7. At the command prompt, type 5.
Copy

The Copy command makes copies of objects. Some transform commands like Rotate, Rotate3D, and Scale have a Copy option. This lets you create a copy of the object as you rotate or scale it.
Practice copying objects
1. On the Transform menu, click **Copy**.
2. In the Perspective viewport, use a crossing window to **Select** the cone and the cylinder.

3. At the **Point to copy from** prompt, click anywhere in the Top viewport.

4. At the **Point to copy to** prompt, click where you want the first copy. Zoom in or out if you like.
5. At the next **Point to copy** prompts, click other places to make some copies of the box. When you have enough copies, press **Enter** to end the command.
Rotate

The **Rotate** command rotates an object in relation to the construction plane around a center point.

**Rotate an object**

1. Open the tutorial model **Rotate-Scale.3dm**.  
   ![Download the tutorial models](image)

2. On the Transform menu, click **Rotate**.
3. In the **Top** viewport, select the green half-cylinder as shown in the illustration below.
4. At the **Center of rotation**... prompt, with the **End** object snap on, click the lower left corner of the box.

5. At the **Angle or first reference point**... prompt, check to see that **Ortho** is turned on, drag the cursor to the right and click.

6. At the **Second reference point**... prompt, toggle **Ortho** on or off depending on whether you want to rotate the box in 90-degree increments or to rotate it freely.
7. Drag the cursor up to rotate the box as shown in the illustration below, and click.
Scale

The Scale commands give you control over the direction of the scale. You can re-size objects uniformly in one, two, or three directions, or scale an object with a different scale factor in each direction.

1. Select the prism shape.

2. On the Transform menu, click Scale, and then click Scale 3-D.
3. At the **Origin point** prompt, click the corner of the prism as shown in the illustration below.

The origin point is the base point from which the object will be scaled. It is like an anchor point. The object will grow or shrink around this point.

To scale an object, you must first show an original size, and then show a new size. Drag the cursor and click another point on the object to show the original size, and then drag the cursor and click again to show the new size.
4. At the **Scale factor or first reference point**... prompt, click the corner of the prism as shown in the illustration below. This establishes the first reference point.

![Diagram of a prism with a corner selected](image)

5. At the **Second reference point**... prompt, drag the cursor. The object grows the amount you drag the cursor.

6. Click to set the second reference point.

---

**Enter a number to set the scale factor**

- To make the object twice its original size, at the command prompt, type **2**.
- To make the object half its original size, at the command prompt, type **0.5**.

**Scale an object to a specific size**

- To make the prism in this example 2.35 units along the original side, at the **Second reference point** prompt, at the command prompt, type **2.35**.
Mirror

In this exercise, you are going to practice another basic editing command: **Mirror**. The **Mirror** command makes a reverse-image copy of the object. Objects are mirrored across a line that you draw in a viewport.

Mirror an object

1. Open the tutorial model **Mirror Objects.3dm**.
2. On the Transform menu, click **Mirror**.
3. On the status bar, turn **Ortho** on.
4. **Select** the object.
5. At the **Start of mirror plane**... prompt, in the **Top** or **Front** viewport, click to the right of the face as shown in the illustration below.

6. At the **End of mirror plane**... prompt, drag the line toward the bottom of the screen, and click to end the mirror line.
**Array**

The **Array** commands copy objects into evenly spaced rows and columns or around a circle.

**Orient**

The **Orient** commands combine move or copy, scale, and rotate operations to help you position and size objects in one command.
Curve and Surface Analysis

Since Rhino is a mathematically accurate NURBS modeler, tools that provide accurate information about the objects are provided.

Measure distance, angle, and radius

Some analysis commands provide information about location, distance, angle between lines, and radius of a curve. For example:

- **Distance** displays the distance between two points.
- **Angle** displays the angle between two lines.
- **Radius** displays the radius of a curve at any point along it.
- **Length** displays the length of a curve.

Curve and surface direction

Curves and surfaces have a direction. Many commands that use direction information display direction arrows and give you the opportunity to change (flip) the direction.

The **Dir** command displays the direction of a curve or surface and lets you change the direction.

The illustration shows the curve direction arrows. If the direction has not been changed, it reflects the direction the curve was originally drawn. The arrows point from the start of the curve toward the end of the curve.

The **Dir** command also displays surface u-, v-, and normal direction. Surface normals are represented by arrows perpendicular to the surface, and the u- and v-directions are indicated by arrows pointing along the surface. Closed surfaces always have the surface normals pointing to the exterior.

The **Dir** command can change the u-, v-, and normal-directions of a surface. This direction can be important if you are applying textures to the surface.
Curve and Surface Analysis

**Curvature**

Curve analysis tools let you turn on a graph showing the direction perpendicular to the curve at a point and the amount of curvature, display a curvature circle, test the continuity between two curves and the intervals of overlap between the two curves.

The **CurvatureGraph** command displays a curvature graph on curves and surfaces. The lines on the graph represent a direction perpendicular to the curve at that point. The length of the line indicates the curvature.

**Visual surface analysis**

Visual surface analysis commands let you examine surfaces to determine smoothness as determined by its curvature, tangency, or other surface properties. These commands use NURBS surface evaluation and rendering techniques to help you visually analyze surface smoothness with false color or reflection maps so you can see the curvature and breaks in the surface.

**Environment map**

The **EMap** command displays a bitmap on the object so it looks like a scene is being reflected by a highly polished metal. This tool helps you find surface defects and validate your design intent.

The fluorescent tube environment map simulates tube lights shining on a reflective metal surface.
Curvature analysis
The CurvatureAnalysis command analyzes surface curvature using false-color mapping. It analyzes Gaussian curvature, mean curvature, minimum radius of curvature, and maximum radius of curvature.

The Zebra command displays surfaces with reflected stripes. This is a way to visually check for surface defects and for tangency and curvature continuity conditions between surfaces.

Draft angle analysis
The DraftAngleAnalysis command displays by false-color mapping the draft angle relative to the construction plane that is active when you start the command. The pull direction for the DraftAngleAnalysis command is the z-axis of the construction plane.
Geometry problems such as Boolean or join failures can be caused by edges on surfaces that have become broken or edges between surfaces that have been moved through point editing so they create holes. An edge is a separate object that is part of the surface’s boundary representation. The ShowEdges command highlights all the edges of the surface.

A polysurface may look closed, but the Properties command may tell you that it is open. Some operations and export features require closed polysurfaces, and a model using closed polysurfaces is generally higher quality than one with small cracks and slivers.

Rhino provides a tool for finding the unjoined or "naked" edges. When a surface is not joined to another surface, it has naked edges. Use Properties command to examine the object details. A polysurface that has naked edges lists as an open polysurface. Use the ShowEdges command to display the unjoined edges.

Other edge tools let you split an edge, merge edges that meet end-to-end, or force surfaces with naked edges to join. You can rebuild edges based on internal tolerances. Other edge tools include:

- **SplitEdge** splits an edge at a point.
- **MergeEdge** merges edges that meet end to end.
- **JoinEdge** forces unjoined (naked) edges to join nearby surfaces.
- **RebuildEdges** redistributes edge control points based on internal tolerances.

**Diagnostics**

Diagnostic tools report on an object’s internal data structure and select objects that may need repair. The output from the List, Check, SelBadObjects, and Audit3dmFile commands is normally most useful to a Rhino programmer to diagnose problems with surfaces that are causing errors.
Organization and Annotation

Rhino offers aids to organizing your work:

- Layers
- Groups
- Blocks
- Worksessions

Each method offers a different approach to model organization. Using layers lets you assign a layer designation to objects. Groups associate objects so they can be selected as one. Blocks let you store and update an association of objects. Worksessions let you work on a part of a project while using other models in the project as references.

Rhino also provides the ability to add notation to your model. These appear as objects in the model.

- Dimensions
- Leaders
- Text blocks

A different form of notation always displays facing towards the view plane.

- Annotation dots
- Arrowheads

In addition, you can add Notes to the model. Notes do not appear in the model, but display in a separate window.

Layers

Layers are a way of grouping objects and applying certain characteristics to all objects that have that layer assignment. There are two "mental models" you can use when you think of layers—they can be thought of either as a "storage location" for the objects or as a way to assign a set of characteristics or properties to objects.

Layer states include a layer name, the color used to display the objects, and the on/off and locked/unlocked status of all the objects on a layer. Objects on layers that are off are not visible in the model. Objects on locked layers cannot be selected but can be snapped to. Objects are always created on the current layer. This layer assignment can be changed later.

To accomplish the most common tasks related to layers, click the Layer pane in the status bar to display the popup layer list. You can set the current layer; change the on/off, locked/unlocked state; and the layer color. In addition, right-click the layer name to create a new layer, rename a layer, delete the selected layer, select objects on the selected layer, change objects to the selected layer, and copy objects to the selected layer.

Accomplish more detailed layer management with the Layers panel. Right-click the Layer pane to open the Layers panel. The Layers panel sets the current layer, locks and unlocks layers, turns layers on and off, changes the layer color and sets the layer render material. You can create new layers, delete layers, move layers up or down in the layer list, filter the layer list, set the current layer to match an object in the model, change objects to a selected layer, select all layers, and invert the selection.

The SelLayer command selects all objects on a layer.
## Groups

A **group** is a collection of objects that select as one for moving, copying, rotating, or other transforms and applying properties such as object color. Grouping objects assigns a group name to each object that is displayed as a part of its properties. Objects with the same group name belong to the same group.

- **Group** groups objects for selection. A group can contain one or more sub-groups.
- **Ungroup** destroys the group.
- **SetGroupName** changes the name assigned by default. Naming different groups to the same name combines those groups into one.
- **AddToGroup** and **RemoveFromGroup** add and remove objects from groups.
- **SelGroup** selects groups by name.

## Blocks

A block is another way of associating objects together to form a single object. The **Block** command creates a block definition in the current model. The **Insert** command places instances of this block definition in your model. You can scale, copy, rotate, array, and otherwise transform block instances in the model. If you edit the block definition, all instances of the block are changed to this new definition. Blocks can streamline modeling, reduce model size, and promote standardization of parts and details.

Multiple instances of a block can be located, scaled, and rotated into a model with the **Insert** command. Block definitions are created with the **Block** or **Insert** command. Materials and other object properties on block instances are determined by the component objects.

Exploding a block instance places the block geometry using the instance location, scale, and rotation. To redefine a block, use the **BlockEdit** command, to edit the geometry.

The **BlockManager** command displays a dialog box that lists all the block definitions in the model. Use the **Block Manager** dialog box to view block properties, export a block definition to a file, delete a block definition and all its instances, update a block definition from a file, find out what blocks are nested in other blocks, and count the number of block instances in the model.

## Worksessions

The **Worksession** command lets many users work on a large project by managing many files. Each user can edit a different file in the project and at the same time see the related portions of the project. By refreshing as needed, each user can see the current version of the related files in the projects. Only one user can have a file open for editing, but many users can see it.

Rhino worksessions let you attach external files to your current work environment. Attached geometry cannot be edited (**Move, Scale**), but it can be used for input to creation commands (**Copy, ExtrudeCrv**).

## Dimensions

You can dimension objects in your model, with your choice of font, units display, decimal precision, text and arrow size, and text alignment. After dimensions are placed, you can select all dimensions, edit dimension text, turn control points on to move dimension elements, and delete dimensions. You can place horizontal, vertical, aligned, rotated, radial, diameter, and angle dimensions, text blocks, leaders, and create a 2-D hidden line drawing.

Dimensions are not associative. Changing your geometry will not update the dimension unless the dimension was drawn with history enabled. Changing the dimension will not update your geometry.

The **Dim** command places horizontal and vertical dimensions depending on the direction you pick the points.
Dimensions are created using the current dimension style. Create new dimension styles to control text size and font, and other dimension properties. Use the settings in the Document Properties window to create new styles and set the properties of existing styles.

**Text**

The Text command places annotation text in your model.

**Leaders**

The Leader command draws an arrow leader.
**Dots**

The **Dot** command places a text dot. Dots are always parallel to the view. Dots are displayed in the layer color. Dot size is constant on the screen. As you zoom in and out, the dot displays the same size.

**Hidden line removal**

The **Make2D** command creates curves from the selected objects as silhouettes relative to the active view. The silhouette curves are projected flat and then placed on the world x,y-plane. The command options create the 2-D drawing from the current view, current construction plane, create a four-view layout using US or European projection angles, set layers for the hidden lines, and display tangent edges.

**Notes**

The **Notes** command provides a means of storing text information in your model file. You can type information directly into the **Notes** text box. If you leave the **Notes** box displayed when you close the model file, it will display the next time the file is opened.
Render

In addition to shaded previews, Rhino provides full-color rendering with lights, transparency, shadows, textures, and bump mapping. Objects will render white until you add render color, highlight, texture, transparency, and bumps. These attributes are controlled through the Properties panel, Material page.

The process needed to render scenes consists of four basic steps:

- Add lighting
- Assign materials
- Set up the environment and ground plane
- Render

Although the steps do not have to be done in this order, using this method seems to make setting up a scene more efficient. To improve quality, repeat these steps until the image looks right to you.

Lights

In every Rhino rendering there are light sources that Rhino uses to calculate how the objects are to be illuminated. If you do not add any light sources to your scene, the default light is used. The default light is a directional light with parallel rays that acts as though you have a lamp shining over your left shoulder.
Add indoor lights or Sun

- Insert Spotlights, Directional Lights, Linear Lights, Point Lights, or Rectangular Lights.
- Or turn on the Sun.

Materials

Materials specify the color, finish, transparency, texture, and bump for use by the renderer.

Assign materials to layers

1. In the Layers panel, select one or more layer names, and click in the Material column.
2. In the Layer Material dialog box, set up material properties.

Assign materials to objects

1. Select an object.
2. On the Edit menu, click Object Properties.
3. In the Properties panel, Material page, set up material properties.
Environment

Environments describe the space around the model. This space is reflected in objects and can provide overall lighting.

Set up the rendering environment

The rendering properties include environment settings like background color and image.

1. Open the Environment Editor panel.
2. Set up environment properties.

Ground Plane

The ground plane provides an infinite horizontal platform for the image that stretches to the horizon in all directions positioned at a defined elevation. A ground plane renders much faster than using a surface as a background. Any material can be assigned to the ground plane.

Turn on a ground plane

1. Open the Ground Plane panel.
2. Set up ground plane properties.
Render

Render and save an image.

1. On the Render menu, click Render.
2. In the Render Window, on the File menu, click Save As.
Rhinoceros 5 User's Guide
Section II: Tutorials
Pull Toy - Solids and Transforms

This tutorial demonstrates using solid primitives and simple transforms. You will learn how to:

- Enter coordinates to place points exactly.
- Draw a free-form curve and polygon.
- Create a pipe along a curve.
- Use a polar array to copy objects in a circular pattern.
- Extrude a curve to create a surface.
- Use planar mode.

### Enter coordinates

When you pick a point with the mouse, the point lies on the construction plane of the active viewport unless you use a modeling aid such as object snap or elevator mode. When Rhino prompts for a point, you can enter x-, y-, and z-coordinates instead of picking a point. Each viewport has its own construction plane on which its x- and y-coordinates lie. The z-coordinate for the active viewport is perpendicular to the x-y plane.

The grid is a visual representation of the construction plane. The intersection of the dark red and green lines shows the location of the origin point (x=0, y=0, z=0) of the coordinate system.

### Draw the pull toy body

This exercise uses x-, y-, and z-coordinates to accurately place points. When you are to type coordinates, type them just as they are shown in the manual. The format is \( x, y, z \). For example, type \( 1,1,4 \). You must type the commas. This sets the point at \( x=1, y=1, \) and \( z=4 \) in the active viewport.

Whenever you type points, look in all viewports at where the point is placed so you can start getting an idea of how coordinate entry works.

💡 Tip: Pay close attention to the viewport required in each instruction.
Start the model
1. Begin a New model.
2. In the Open Template File dialog box, select Small Objects - Centimeters.3dm, and click Open.

Draw an ellipsoid
1. Turn on Ortho.
2. On the Solid menu, click Ellipsoid > From Center.
3. With the Top viewport active, at the Ellipsoid center... prompt, type 0,0,11, and press Enter. This places the center point of the ellipsoid at x=0, y=0, and z=11. Look at the point in the Perspective viewport.
4. At the End of first axis... prompt, type 15, and press Enter.
5. Move the cursor to the right to show the direction and click.

6. At the End of second axis prompt, type 8, and press Enter.
7. Move the cursor up to show the direction and click. This sets the width of the ellipsoid.

8. At the **End of third axis** prompt, type **9**, and press **Enter**. You now have an egg shape that has different dimensions in all three directions.

9. Rotate the perspective viewport so you are looking along the x-axis as illustrated. Turn on **Shaded** display mode in the **Perspective** viewport.
Draw the axles and wheel hubs

The axles and wheel hubs are cylinders. The axles are long, thin cylinders, and the wheel hubs are short, fat cylinders. You are going to make one axle and one complete wheel. You will then mirror the complete wheel to the other side. You can then either mirror or copy the complete axle and wheel set to the front of the toy.

Create the axle

1. On the Solid menu, click Cylinder.
2. With the Front viewport active, at the Base of cylinder... prompt, for the location of the cylinder's center, type 9,6.5,10, and press Enter.

3. At the Radius... prompt, type .5, and press Enter.
4. At the End of cylinder prompt, type -20, and press Enter.
Create a wheel hub

1. On the Solid menu, click **Cylinder**.
2. With the Front viewport active, at the Base of cylinder... prompt, type $9, 6.5, 10$, and press Enter.
3. At the Radius... prompt, type $4$, and press Enter.
4. At the End of cylinder prompt, type $2$, and press Enter.
**Draw the lug nuts**

You will make the lug nuts by extruding a hexagonal polygon curve.

---

### Create a hexagon

1. **On the Curve menu, click** Polygon > Center, Radius.
2. **At the Center of inscribed polygon (NumSides=4...) prompt,** type 6, and press Enter.
3. **In the Front viewport,** at the Center of inscribed polygon... prompt, type 9,8,12, and press Enter.
   - This will place the polygon right on the surface of the wheel hub.
4. **At the Corner of polygon... prompt,** type .5, and press Enter.
5. **In the Front viewport** drag the cursor as illustrated, and click to position the hexagon.

---

### Make a solid from the polygon

1. **In any viewport,** select the hexagon you just created.
2. **On the Solid menu,** click Extrude Planar Curve > Straight.
3. **At the Extrusion distance prompt,** notice the command-line options. Set the options as follows:
   
   ```
   Direction - use default
   BothSides=No
   Solid=Yes
   DeleteInput=Yes
   ToBoundary - use default
   SplitAtTangents=No
   SetBasePoint - use default
   ```
   
   If the option is not set as listed above, click the option to change it.
4. At the **Extrusion Distance**... prompt, type `-0.5` (Notice the negative number. If you type a positive number at this point, the nuts will be buried in the wheel hub. You want them to stick out.), and press **Enter**.

**Array the lug nuts**

To create the lug nuts on the first wheel, you are going to use a polar (circular) array. An array is a set of copies of an object. You control how the copies are made. A polar array copies the objects around a central point. The objects are rotated as they are copied.

1. **Select** the lug nut.
2. On the **Transform** menu, click **Array > Polar**.
3. With the **Front** viewport active, at the **Center of polar array** prompt, use the **Cen** object snap to snap to the center of the hub.

4. At the **Number of elements**... prompt, type `5`, and press **Enter**.
5. At the **Angle to fill <360>** prompt, press **Enter**.
6. At the **Press Enter to accept** prompt, check the preview, and press **Enter**.

**Draw the tires**

The tires are a solid form called a torus, which looks like a donut. When you are drawing a torus, the first radius is the radius of a circle around which the “tube” is drawn. The second radius is the radius of the tube itself.

To draw the tires, you will draw the center of the torus tube a bit larger than the diameter of the wheel hub. The tube itself is slightly larger than the hub. This makes it dip into the hub.
Create a torus for the tires

1. On the Solid menu, click Torus.
2. In the Front viewport, at the Center of torus... prompt, type 9,6.5,11, and press Enter. This places the center of the torus at the same point as the center of the wheel hub.
3. At the Radius... prompt, type 5, and press Enter. This makes the radius of the torus tube one unit bigger than the wheel hub.
4. At the Second radius... prompt, type 1.5, and press Enter. This makes the inner dimension of the torus tube .5 units smaller than the wheel hub.

Mirror the wheels

Now that you have a whole wheel created, you can use the Mirror command to create the other three.

Mirror the wheel to the other side

1. In the Top viewport, use a window to select the wheel as illustrated.
2. On the Transform menu, click Mirror.
3. At the **Start of mirror plane...** prompt, type \(0,0,0\), and press **Enter**.

4. At the **End of mirror plane...** prompt, with **Ortho** on, drag to the right in the **Top** viewport as illustrated and click.

---

**Mirror the front wheels and axle**

1. In the **Top** viewport, use a window to select the wheels and axle as illustrated.
2. On the **Transform** menu, click **Mirror**.
3. At the **Start of mirror plane...** prompt, type 0,0,0, and press **Enter**.

4. At the **End of mirror plane...** prompt, with **Ortho** on, drag down in the **Top** viewport as illustrated and click.

**Draw the eyes**

You are going to draw a sphere for an eye and a smaller sphere for the pupil.
Create an eye using a sphere

1. On the Solid menu, click **Sphere > Center, Radius**.
2. At the **Center of sphere**... prompt, in the **Top** viewport, type **-12,-3,14**, and press **Enter**.
3. At the **Radius...** prompt, type **3** and press **Enter**.
Create the eye pupil

1. Repeat the **Sphere** command.
2. At the **Center of sphere...** prompt, in the **Top** viewport, type `-13,-4,15`, and press **Enter**.
3. At the **Radius...** prompt, type **2** and press **Enter**.
Mirror the eye

1. In the Top viewport, use a window to select the eye as illustrated.
2. On the Transform menu, click Mirror.

3. At the Start of mirror plane... prompt, type 0 (this is a shortcut for typing 0,0,0), and press Enter.
4. At the **End of mirror plane...** prompt, with **Ortho** on, drag to the left in the **Top** viewport as illustrated and click.
Make the pull cord

To make the cord, you are going to draw a freehand curve using elevator and planar mode. When the curve is complete, use the **Pipe** command to make it a thick solid.

**Set up the view**

1. **Zoom** out in all the viewports; you are going to need some space to work.
2. On the status bar, turn **Planar** mode on, and turn **Ortho** off.
3. In the **Osnap** control, click **Disable** to turn off all object snaps.
Create the pull cord at the front of the toy
1. On the **Curve** menu, click **Free-form > Control Points**.
2. At the **Start of curve**... prompt, in the **Top** viewport, hold the **Ctrl** key to activate elevator mode and click near the front end of the body ellipsoid.
3. Move the cursor to the **Front** viewport, drag the marker near the end of the ellipsoid, and click.
4. At the **Next point...** prompt, click to the left of the ellipsoid in the **Top** viewport.

Planar mode keeps successive points at the same construction plane elevation. Planar mode can be overridden with elevator mode or object snaps. Watch the curve in the **Top** and **Front** viewports.
5. At the **Next point**... prompt, use elevator mode to add another point in the **Top** viewport.

![Image of points in Top viewport with elevator mode]

6. At the **Next point**... prompts, turn off **Planar** mode and click several more points in the **Top** viewport to create a curved line.

![Image of curved line created in Top viewport]

Notice that the points are projected to the **Top** construction plane.
Make the cord handle

1. Draw an **Ellipsoid** with the **Diameter** option to represent a handle at the end of the curve.
2. At the **Start of first axis** prompt, use the **End** object snap to pick the end of the cord curve.
3. At the **End of first axis** prompt, type **10** to set the length, and press **Enter**.
4. Drag the direction so it lines up with the cord curve and click to set the direction. This does not have to be very accurate.

5. At the End of second axis prompt, type 4, press Enter, and drag to set the direction.

6. At the End of third axis prompt, type 2, and press Enter.
Thicken the curve with a pipe

1. **Select** the curve you just made at the front of the pull toy.
2. On the **Solid** menu, click **Pipe**.
3. At the **Start radius...** prompt, type .2, and press **Enter**.
4. At the **End radius...** prompt, press **Enter**.
5. At the **Point for next radius** prompt, press **Enter**.
   The pipe will be the same diameter for the full length of the curve.
Creating surfaces from curves and joining the surfaces together allows you much greater freedom. This tutorial introduces the concept of drawing curves and one method of creating surfaces from those curves.

You will learn how to:
- Draw free-form curves based on an existing object.
- Edit control points.
- Revolve surfaces around an axis.

Revolving curves is a good method for creating tubular shapes like vases, wineglasses, and chair legs. You are going to use a basic flashlight as a guide for drawing the curves you will need for the new model. Using the basic flashlight gives you a frame of reference for deciding about the size and shape of the object.

**To get started**
- Open the tutorial model file **Flashlight.3dm**.
- Download the tutorial models.

**Set up the model**
You are going to trace around the old flashlight. To make this easier, you will lock the objects. When objects are locked, you can see them and snap to them, but you cannot select them. This keeps the objects from interfering when you want to select things close by. You can still use object snaps to snap to locked objects. You will then create some curves and revolve them to make the new flashlight.
Lock the flashlight objects

1. **Select** all the objects.
   Press the **Ctrl** and **A** keys to select all the objects in the model.

2. On the **Edit** menu, click **Visibility > Lock**.
**Draw a centerline**

Draw a construction centerline through the center of the old flashlight.

---

**Draw the construction centerline**

1. On the Curve menu click **Line > Single Line**.
2. At the **Start of line**... prompt, use the **Center** object snap to place the start of the line at the center of the flashlight base.
3. At the **End of line**... prompt, turn **Ortho** on, and draw the line through the exact center of the old flashlight.
**Draw the body profile curve**

You are going to draw a *profilecurve* that you will use to revolve to create the flashlight body. A profile curve defines a cross-section of one half of the part.

**Draw the body curve**

1. On the status bar, click the **Layer** pane and make the layer **Free Form Body** current.
2. On the **Curve** menu, click **Free-Form > Control Points**.
3. At the **Start of curve...** prompt, in the **Front** viewport, start drawing a curve around the flashlight body as illustrated.

Use the **End** object snap to start the curve at the end of the construction center line.

Use the **Near** object snap to end the curve on the construction center line.

Starting and ending the curve exactly on the line is important so that later when you revolve the curve to create a solid, there will be no gaps or overlapping parts.

When drawing the curve, use **Ortho** to control the first two (1 and 2) points and the last two points (3 and 4) on the curve. If the first two points and the last two points are placed in a straight line, the curve will start and end tangent to that line.

4. When you have placed the last control point, press **Enter** to finish drawing the curve.

To place the last two points in a straight line with each other, use **Grid Snap, Ortho**, or **Perpendicular** object snap.
**Draw the lens profile curve**

Make another profile curve for the lens.

---

### Create the lens

1. On the Curve menu, click **Free-Form > Control Points**.
2. At the **Start of curve...** prompt, in the Front viewport, place the first control point of the lens profile.

   Use the **Near** object snap to start and end the curve on the construction centerline.

   Place control points in the upper part of the lens curve so it crosses the body profile curve.

---

### Get the old flashlight out of your way

1. On the Edit menu, click **Visibility > Unlock**.
2. Select all the objects except the two profile curves you just drew and the switch sphere.
3. On the Edit menu, click **Visibility > Hide**.
Build the flashlight body

To make the body, you will revolve the profile curve 360 degrees. You will use the endpoint of the curve and ortho to establish the rotation axis.
Create the flashlight body
1. On the **Surface** menu, click **Revolv**e.
2. At the **Select curve to revolve** prompt, select the body profile curve.
3. At the **Start of revolve axis** prompt, use the **End** snap to snap to one end of the profile curve.

4. At the **End of revolve axis** prompt, turn **Ortho** on, and specify the revolve axis line as illustrated.

5. In the **Start angle**... prompt, click the **FullCircle** option.
Create the lens

Now revolve the lens profile curve in the same way as the body.

Revolve the lens profile curve

1. On the Surface menu, click Revolve.
2. At the Select curve to revolve prompt, select the lens profile curve.
3. At the **Start of revolve axis** prompt, use **End** object snap to locate the endpoint of one of the curve profiles.

4. At the **End of revolve axis** prompt, turn **Ortho** on, and draw the revolve axis line as illustrated.

5. In the **Start angle...** prompt, click the **FullCircle** option.
Headphone - Sweep, Loft, and Extrude

This tutorial demonstrates creating surfaces from profile curves using lofts, sweeps, and extrudes.

You will learn how to:

- Use sub-object selection to pre-select objects for a command.
- Create a surface from a planar curve.
- Loft, revolve, sweep, and extrude surfaces.
- Cap planar holes to create a solid.
- Draw a helix around a curve.
- Match curve ends.
- Create solid pipes.
- Mirror objects.
- Use layers.
- Use object snaps.

To open the headphone model:

1. Open the tutorial model file Headphone.3dm.
2. Download the tutorial models.
Create the speaker shell

The speaker shell is created using a lofted surface, a one-rail sweep, a solid extrusion of a planar curve, and a surface fillet. The resulting geometry is joined into one solid.

Loft curves to create a surface

One way to create a surface is to use existing curves as a guide. When lofting through curves, the curves are used as a guide for creating a smooth surface.

1. Turn on Shaded mode in the Perspective viewport.
2. Select the three circular curves, with a crossing selection as illustrated.

3. On the Surface menu, click Loft.
4. At the Drag seam point to adjust... prompt, note the display of the curve direction arrows at the seam points, and press Enter.

In this model, they are nicely lined up for you, so you do not need to adjust them.
5. In the **Loft Options** dialog box, click **OK** to create the loft.

---

**Extrude the surface edge**

Extrude the lofted surface edge in the center to make a magnet housing.

1. Hold the **Ctrl** and **Shift** keys to select the surface edge at the center of the lofted surface.

   **Tip:**
   Selecting objects with the **Ctrl** and **Shift** keys is called *sub-object selection*.

   Hold the **Ctrl** and **Shift** keys, and click to select polysurface faces; surface and polysurface edge curves; control points; mesh vertices, faces, boundaries, and edges; and objects within a group.

2. On the **Solid** menu, click **Extrude Planar Curve > Straight**.

3. At the **Extrusion Distance**... prompt, type `-2` (notice the negative number) and press **Enter**.

   This makes a solid cylinder for the magnet housing that is two units thick and extends in the negative direction from the original surface edge.

---

**Extract the bottom surface**

The cylinder you just created is an extrusion object (solid). To remove the bottom, extract the face.
1. Hold the Ctrl and Shift keys, and click to select the bottom face.
2. On the Solid menu, click Extract Surface.
3. At the Select surfaces to extract... prompt, select the surface as illustrated and press Enter.
4. Press the Delete key.
Fillet the edge of the cylinder surface

1. On the **Solid** menu, click **Fillet Edge > Fillet Edge**.
   The current radius setting should be **1**.

2. At the **Select edges to fillet...** prompt, select the edge at the top of the cylinder press **Enter**.

3. At the **Select fillet handle to edit** prompt, press **Enter**.
Join the surfaces

Surfaces that share an edge can be joined into a polysurface. You will join all the surfaces. Since the faces are sometimes hard to see, use two viewports to select them all.

1. **Select** the surface and the polysurface.
2. On the **Edit** menu, click **Join**.

To join surfaces, you must select surfaces that are adjacent to each other and the edges must match.

Create the padding and cover

Sweep a curve around the edge of the speaker cone to create the padding around the edge of the speaker.

Reset the view

1. On the **View** menu, click **Zoom > Zoom Extents All**.
2. **Hide** or **Delete** all of curves used for the loft.

Sweep a curve along one rail

1. Hold the **Ctrl** and **Shift** keys, and click to select the loft surface outer edge.
2. Hold the **Shift** key and select the rail curve at the top of the speaker as shown.
3. On the **Surface** menu, click **Sweep 1 Rail**.

4. In the **Sweep 1 Rail Options** dialog box, click **OK**.
Make a surface from planar curves

Fill the area at the base of the padding with a planar surface created from the edge of the sweep.

1. Hold the Ctrl and Shift keys, and click to select the surface edge of the speaker cone as illustrated.
2. On the Surface menu, click Planar Curves.
   A planar surface is created at the base of the padding.

Create the mounting bracket

The next part is the bracket that holds the speaker to the headband. Since the speaker unit is complete, you can turn its layer off and make the Bracket layer current.

Reset the layers

1. On the status bar, click the Layer pane.
2. Make Bracket the current layer and turn on Bracket Shape Curves.
   Turn all other layers off.

Reset the view

- On the View menu, click Zoom > Zoom Extents All to zoom in on the bracket shape curves in all viewports.

Extrude a curve into a solid

Use a planar curve to create a solid shape.
1. **Select** the closed curve.
2. On the **Solid** menu, click **Extrude Planar Curve > Straight**.

3. At the **Extrusion distance**... prompt, type `-1` and press **Enter**.

---

**Fillet the edges**

Round the sharp edges with a fillet.

1. On the **Solid** menu, click **Fillet Edge > Fillet Edge**.
2. At the **Select edges to fillet**... prompt, type `.2` and press **Enter**.
3. At the **Select edges to fillet**... prompt, click **ChainEdges** and select the front edge of the bracket. The entire edge of the solid should highlight.
4. Press **Enter** to close that edge selection.

5. At the **Select edges to fillet...** prompt, click **ChainEdges** and select the back edge of the bracket.

6. Press **Enter** to close that edge selection.

7. Press **Enter** to finish the edge selection.

8. At the **Select fillet handle to edit** prompt, press **Enter**.
Create a tubular surface from the shape curves

1. **Select** the curve at the top of the bracket.
2. On the **Solid** menu, click **Pipe**.
3. At the **Starting radius...** prompt, type .3 and press **Enter**.
   Before typing the radius, set the command-line options to **Cap=Flat** and **Thick=No**.
4. At the **End radius...** prompt, press **Enter**.
5. At the **Point for next radius** prompt, press **Enter**.

For the second tube

1. **Select** the curve at the bottom of the bracket.
2. On the **Solid** menu, click **Pipe**.
3. At the **Starting radius...** prompt, type .2, and press **Enter**.
4. At the **End radius...** prompt, press **Enter**.
5. At the **Point for next radius** prompt, press **Enter**.

---

**Create the headband**

The headband consists of a series of ellipses swept along a path.

---

**Reset the layers**

1. On the status bar, click the **Layer** pane.
2. Make **Headband** the current layer and turn on **Headband Shape Curves**. Turn all other layers off.

---

**Reset the view**

- On the **View** menu, click **Zoom > Zoom Extents All** to zoom in on the headband shape curves in all viewports.

---

**Create an ellipse perpendicular to a curve**

1. Turn **Ortho** on.
2. On the **Curve** menu, click **Ellipse > From Center**.
3. At the **Ellipse center...** prompt, click **AroundCurve**.

4. At the **Ellipse center** prompt, snap to an endpoint of the headband curve. Use the **End** object snap.

5. At the **End of first axis** prompt, type **0.5**, and press **Enter**.

6. At the **End of first axis** prompt, drag the cursor in the x-direction and click.

7. At the **End of second axis** prompt, type **2**, and press **Enter**.
8. At the **End of second axis** prompt, drag the cursor in the y-direction and click.

Array a curve along a path

1. **Select** the ellipse.
2. On the **Transform** menu, click **Array > Along Curve**.
3. At the **Select path curve** prompt, select headband curve.

4. In the **Array Along Curve Options** dialog box, under **Method**, set the **Number of items** to 3.
5. Under **Orientation**, click **Freeform**, and click **OK**.

---

**Scale the ellipse**

Scale the center ellipse to make it larger.

1. **Select** the center ellipse.

2. On the **Transform** menu, click **Scale > Scale 1-D**.  
   **Scale1D** stretches an object in one direction.

3. At the **Origin point...** prompt, in the **Perspective** viewport, snap to the center of selected ellipse.

4. At the **Scale factor or first reference point...** prompt, type **2**, and press **Enter**.
5. At the **Scale direction**... prompt, drag the cursor in the y-direction and click.
**Sweep along one rail**

1. **Select** the curves.
2. On the **Surface** menu, click **Sweep 1 Rail**.
3. At the **Drag seam point to adjust...** prompt, examine the direction and seam points of the curves to make sure they are not twisted, and press **Enter**.
4. In the **Sweep 1 Rail Options** dialog box, click **OK**.

**Round the headband ends**

Use the same ellipse that formed the first cross-section curve for the headband to create a rounded end for the headband. Start by splitting the ellipse in half.

**Reset the view**

1. On the **View** menu, click **Zoom > Window**.
2. In the **Perspective** viewport, zoom in on the left end of the headband you just created.

**Split the ellipse in half**

1. **Select** the ellipse.
2. On the **Edit** menu, click **Split**.
3. At the **Select cutting objects**... prompt, click the **Point** option.
4. Turn on **Quadrant** object snap.
5. At the **Point to split curve** prompts, snap to the two quadrants at the narrow axis of the ellipse.

6. At the **Point to split curve** prompt, press **Enter**.
   The ellipse is split into two halves.
Create a surface of revolution

1. **Select** left half of the ellipse.

2. On the **Surface** menu, click **Revolve**.
3. At the **Start of revolve axis** prompt, snap to the end of the ellipse half.

4. At the **End of revolve axis** prompt, snap to the other end of the ellipse half.

5. At the **Start angle**... prompt, type **0**, press **Enter**.

6. At the **Revolution angle**... prompt, type **180**, press **Enter**.
   A rounded surface is created at the end of the headband.

7. Repeat these steps for the other side of the headband.
Mirror the rounded end

1. Select the rounded end.

2. On the Transform menu, click Mirror.

3. At the Start of the mirror plane prompt, type 0.

4. At the End of the mirror plane prompt, drag the mirror line in the y-direction as illustrated.
Join the surfaces

1. **Select** the surfaces.
2. On the **Edit** menu, click **Join**.
   Three surfaces join into one polysurface.
Create the speaker wire

Use a separate layer to create the speaker wire.

**Reset the layers**

1. On the status bar, click the Layer pane.
2. Make Wire Shape Curves the current layer and turn on Wire.
   Turn all other layers off.

**Reset the view**

- On the View menu, click Zoom > Zoom Extents All.

**Make the helix**

1. On the Curve menu, click Helix.
2. At the Start of axis... prompt, click AroundCurve.
3. At the Select curve prompt, select the long free-form curve.

4. At the Radius and start point... prompt, type 1 and press Enter.
   This sets the radius for the helix.
5. At the Radius and start point... prompt, set Turns=30 and NumPointsPerTurn=8.
6. At the **Radius and start point...** prompt, in the **Right** viewport drag the cursor to the left and click.

![](image)

**Reset the view**

1. On the **View** menu, click **Zoom > Window**.
2. In the **Perspective** viewport, zoom in on the left end of the helix you just created.

**Match and join the helix to the end curves**

1. On the **Curve** menu, click **Curve Edit Tools > Match**.

![](image)

2. At the **Select open curve to change - pick near end** prompt, select near the left end of the helix.
3. At the **Select open curve to match - pick near end...** prompt, select near the lower end of the vertical curve.

4. In the **Match Curve** dialog box, under **Continuity**, click **Tangency**, under **Preserve other end**, click **Position**, and click **Join**.
5. **Repeat** steps 3 through 6 for the other end of the helix.

**Create the speaker wire**

1. **Select** the extended helical curve.
2. On the **Solid** menu, click **Pipe**.
3. At the **Starting radius...** prompt, type `.2` and press **Enter**.
4. At the **End radius**... prompt, press **Enter**.
5. At the **Point for next radius** prompt, press **Enter**.

---

**Create the second wire**

1. **Select** the curve at the top left.
2. On the **Solid** menu, click **Pipe**.
3. At the **Starting radius**... prompt, type **0.1** and press **Enter**.
4. At the **End radius**... prompt, press **Enter**.
5. At the **Point for next radius** prompt, press **Enter**.

---

**Mirror the headphone parts**

Mirror the parts to create the parts for the other side of the headphones.

---

**Reset the layers**

1. On the status bar, click the **Layer** pane.
2. Turn on all layers.
Reset the view

On the View menu, click **Zoom > Zoom Extents All.**

Delete all the shape curves

1. Press **Esc** to deselect everything.
2. On the Edit menu, click **Select Objects > Curves.**
3. Press the **Delete** key.

Mirror the left half of the headphones

1. In the Front viewport, window select the objects as illustrated.
   (Select the speaker, bracket, small wire, and rotated ellipse.)

2. On the Transform menu, click **Mirror.**
   
   The **Mirror** command depends on which viewport is active. It uses the construction plane in the active viewport to define the mirror plane. The mirror plane is perpendicular to the construction plane. Two points define the line in this plane about which the selected objects are mirrored.
3. At the **Start of mirror plane** prompt, type **0,0**.
This is the first point of the mirror line.

4. At the **End of mirror plane** prompt, turn on **Ortho**, and drag the mirror line straight up and pick.

---

**Learn more**

For a video tutorial showing a more sophisticated modeling method for a headphone set using Rhino's Gumball feature, see: *Modeling stereo headphones.*
Penguin - Point Editing and Blending

This tutorial demonstrates point-editing techniques including moving and scaling control points and adding knots to surfaces to increase control. In addition, you will use blends to create smooth transitions between surfaces.

You will learn how to:

- Rebuild surfaces to add additional control points.
- Insert knots in a surface to add control points in a specific location.
- Edit surface control points to define a shape.
- Scale control points to change the object shape.
- Use object snaps projected to the construction plane.
- Orient an object on a surface.
- Create smooth blends between surfaces.

The body

If you like, open the example model, Penguin.3dm, and try to match the shapes as you are building the model. Experiment with your own shapes, too.

Download the tutorial models.

The body and head are created from one sphere. The shape is formed by moving the control points in the sphere to create the head.
**Draw a sphere**

- In the Top viewport, use the **Sphere** command to draw a sphere with a radius of **10** units.

![Sphere](image1)

**Rebuild the sphere**

- Use the **Rebuild** command to add more control points to the sphere.
  
  In the **Rebuild Surface** dialog box, set the **Point count** in the **U** and **V** directions to **8** and the **Degree** in the **U** and **V** directions to **3**.
  
  Check **Delete input**.
  
  Click **OK**.

![Rebuilt Sphere](image2)
**Turn control points on**

- Use the **PointsOn (F10)** command to turn on the sphere’s control points. Look in all the viewports at the structure of the control points.
  
The next step will change this structure so the influence of moving the control points does not extend over the whole sphere.
Insert knots

- Use the **InsertKnot** command to insert two knots in the sphere in the area where you want the neck.
  
  Insert the knots in the u-direction only as illustrated.

Examine the control point structure after inserting the knot.

Reposition control points to create the indentation for the neck and to reform the body shape.
Flatten the bottom

1. In the Front viewport, select all the control points in the lowest rows of the sphere.

Use the SetPt command to match them to the bottom pole point in the world z-direction only.

2. In the Set Points dialog box, check Set Z, clear the Set X and Set Y check boxes, and click World.
3. Drag the selected control points up.

This will align all of the selected control points to the same z-value (up in **Front** viewport), flattening the surface.
Drag points

- **Select** rows of control points with a window and drag them up or down in the **Front** viewport to shape the body.

Use **WireFrame** display mode if you find it easier to select control points in wireframe views.
Scale points

1. **Select** rows of control points with a window in the **Front** viewport.
2. In the **Top** viewport, use the **Scale2D** command to move them closer or farther away from the central point.

   To pick the base point for the **Scale2D** command use the **Point** object snap with **Project** turned on. This will scale the points parallel to the construction plane. Watch the **Front** viewport to see the changes in the body shape as you move the control points closer to and farther from the center.

Experiment with the **Project** setting in the **Osnap** control to see how it works.

You will be able to see the tracking line projected to the construction plane in the viewports.

Match the example model or use your own shape.
3. Drag individual groups of control points to make the body slightly flatter in the front near the neck as illustrated.

The eyes
The eye is an ellipsoid shape that is oriented onto the surface.
Create the eye
1. In the **Top** viewport, start the **Ellipsoid** command.
   Place the center point anywhere.
2. At the **End of first axis** prompt, type **1.1** to constrain the distance from the center point to the end of the axis to 1.1 units.

Drag the cursor to the right and pick.
3. At the **End of second axis** prompt, type **1.1** to constrain the distance. Using these constraints has created a circular ellipsoid when seen from the top. Drag the cursor up or down in the **Top** viewport and pick.

4. At the **End of third axis** prompt, type **.5**, press **Enter**.

---

**Orient the eye on the surface**

1. **Select** the eye ellipsoid in the **Top** or **Perspective** viewport.
2. Start the **OrientOnSrf** command.
3. At the Base point... prompt, in the Top viewport, pick the center of the ellipsoid.

4. At the Reference point for scaling and rotation prompt, pick any point to the right or left of the eye ellipsoid.
   The exact location is not important.

5. At the Surface to orient on prompt, select the penguin body/head.

6. In the Orient on Surface dialog box, click OK.
7. At the **Point on surface to orient to**... prompt, move the cursor onto the head to where you want to place the eye and click.

![Image of a penguin's head with a cursor on it]

**Mirror the eye**

- Use the **Mirror** command in the **Front** viewport to create the second eye.

![Image of a penguin's head with the second eye mirrored]

**The beak**

The beak is another ellipsoid that you can edit to change the shape.
Create the basic beak shape
1. In the **Top** viewport, start the **Ellipsoid** command. Place the center point anywhere.
2. At the **End of first axis** prompt, type **3** to constrain the distance from the center point to the end of the axis to three units.

Drag the cursor to the right and pick.
3. At the **End of second** axis prompt, type **2** to constrain the distance. Using these constraints creates a circular ellipsoid when seen from the top. Drag the cursor up or down in the **Top** viewport and pick.

4. At the **End of third axis** prompt, type **1**, press **Enter**.
Shape the beak
1. Turn on the beak’s control points (F10).
   In the Front viewport, select the lower row of points and drag them up.
2. **Select** the row of points in the top center and drag them down to shape the beak. Try using the **Nudge** keys (Alt + Arrow direction keys) to nudge the selected points.

![Image of beak being shaped](image)

**Move the beak**

- **Move** the beak into position.

![Image of penguin with beak positioned](image)

**The feet**

The feet are created using another ellipsoid. Knots are added to help create the webbed toes.
Draw the beginning ellipsoid
1. In the **Front** viewport, start the **Ellipsoid** command.
   Place the center point anywhere.
2. At the **End of first axis** prompt, type **1** to constrain the distance from the center point to the end of
the axis to one unit.
Drag the cursor up and pick.

3. At the **End of second axis** prompt, type **3** to constrain the distance.
In the **Top viewport**, drag the cursor up and pick.

4. At the **End of third axis** prompt, type **3**, press **Enter**.
Rebuild the ellipsoid

- Use the Rebuild command to add more control points to the ellipsoid.
  - In the Rebuild Surface dialog box, set the Point count in the U and V directions to 8 and the Degree in the U and V directions to 3.
  - Check Delete input.

Insert knots to create the webbed feet

- Use the InsertKnot command to insert four knots in the ellipsoid as illustrated.
  - Set the Symmetrical=On.
  - Insert the knots in the V-direction.
Scale the points from the center
1. **Select** control points as illustrated.

Use window and crossing selections to select the control points on both the top and bottom of the ellipsoid.

2. Use the **Scale2D** command to scale the control points out from the center of the foot.
Use the **Point** object snap to set the base point of the scale to the center point of the ellipsoid.
Drag the points to make the whole foot about twice the size of the original ellipsoid.
**Move the foot into position**

- Use the **Move** command to move the foot under the penguin body.

**Rotate the foot out**

- Use the **Rotate** command to rotate the foot out slightly.

**Mirror the foot**

- Use the **Mirror** command to create the second foot.
Create a cutting plane

1. **Select** the feet.
2. In the **Front** viewport, use the **CutPlane** command to make a planar surface that passes through the feet as illustrated.

   ![Diagram of a cutting plane](image1)

The **CutPlane** command makes a plane that passes through the selected surfaces along the line you draw.

Trim and **Join** the feet and the plane

1. **Trim** the bottoms of the feet off with the plane as the cutting object.
2. Trim the excess plane from outside the feet.
3. **Join** the plane parts and the feet.
The tail

The tail is another ellipsoid. It is joined to the body with a smooth blend surface.

Create the tail shape

- Draw an **Ellipsoid** that is 4 units long, 3 units wide (**Top** viewport), and 1.5 units tall (**Front** viewport).

Position the tail

- **Move** and **Rotate** the tail in position.

Union the tail and body

- Use the **BooleanUnion** command to trim and join the tail and the body shapes.
  
The transition between the tail and body is rather abrupt; so replace this with a smooth blend surface.
  
  To do this, you must first create a gap between the two parts for the blend surface to fill.
**Pipe the intersection**

- Use the **Pipe** command to create a circular surface around the edge between the body and tail.
  
  At the **Select curve to create pipe around** prompt, select the edge between the tail and the body.
  
  At the **Radius for closed pipe** prompt, type **.4**.
Trim the body and tail with the pipe

1. Use the **Trim** command to trim both the body and the tail surfaces inside the pipe.
2. At the **Select cutting objects** prompt, select the pipe, and press **Enter**.

3. At the **Select object to trim** prompt, select the body/tail, and press **Enter**.

**Tip:** Pick on the *isocurve* or *edge* that you can see inside the pipe.

**Tip:**
With the **SetObjectDisplayMode** command, set the pipe to a *wireframe* or *ghosted* display mode so you can see the edge between the body and the tail. If you select the wrong part, undo within the **Trim** command and try again.
Blend between the tail and body

- Use the `BlendSrf` command to create a smooth surface between the tail and the body.

Join the body and tail

- Join the blend and tail to the body

The wings
Create the base wing shape

- Draw an **Ellipsoid** that is 2 units long, 2 units wide (Top viewport), and **6.5** units tall (Front viewport).
Rebuild the wing

1. Use the Rebuild command to add more control points to the ellipsoid.
   In the Rebuild Surface dialog box, set the **Point count** in the U and V directions to 8 and the **Degree** in the U and V directions to 3.
   Check Delete input.

2. Drag control points to create the shape.
Bend the wing to the body

1. Use the Bend command in the Front viewport to bend the top of the wing shape toward the body.
   At the Start of spine prompt, in the Front viewport, pick near the bottom of the wing.
   At the End of spine prompt, pick near the top of the wing.
   At the Point to bend through... prompt, drag the top of the wing toward the body.

2. If further positioning is needed, use the Rotate and Move commands to place the wing.
**Mirror to the other side**

- Use the **Mirror** command to create the opposite wing.

**Boolean Union the wings and the body**

- To trim the wing holes and the wing, select both wings and the body and use the **BooleanUnion** command.

**Pipe the intersection**

- Use the **Pipe** command to create a circular surface around the edge between the body and each wing.

  At the **Select curve to create pipe around** prompt, select the edge of the hole in the body or the edge of the wing surface.

  At the **Radius for closed pipe** prompt, use a radius of about 0.6.
Trim the body and wing

1. Use the **Trim** command to trim the body and wing surfaces inside the pipe surfaces.
2. **Delete** the pipe surfaces.

Blend between the body and wings

- Use the **BlendSrf** command to create a smooth surface between each wing and the body.

Join the body and wings

- **Join** the blends and wings to the body

Finishing touches

To finish the penguin, split the front part of the body so a different material can be applied to it.
**Draw a trim curve**

- In the Right viewport, draw a **Curve** from the beak down to the bottom as illustrated.

**Split the body with the curve**

- Use the **Split** command to split the body surface with the curve.

This allows a different color for the front of the body.
Join the body parts

- Use the Join command to join the body (except the front), the tail, and the wings.

Render

Rendering creates a realistic picture of your model with colors you assign. These render colors are different from the layer colors you might be using, which control the display in wireframe and shaded modes.

Set up the view

- Use the Rendered display mode to set the viewport rendered mode.

Assign materials

1. Select the body.
2. Start the Properties command.
3. In the Properties window, click the Material icon.
4. Set Assign material by, to Object.
5. Under Basic Settings, click the Color swatch.
6. In the Select Color dialog box, select a color for the body.
7. Set the Gloss finish to about 40.
8. Select the other parts and apply materials in the same way.
Boat Hull - Loft and Sweep

This tutorial demonstrates classic boat hull lofting techniques using typical plan and profile curves. The classic hull shape is based on a design from an old Boat Builder's Handbook magazine. Many designs similar to this are available over the Internet.

You will learn how to:

- Create 3-D curves from a 2-D lines drawing.
- Rebuild and simplify the curves.
- Use analytical techniques to ensure fairness.
- Loft surfaces from the curves.

Rhino is used by marine designers in many segments of the industry. For more tutorials and information about marine design, see the Rhino website at www.rhino3d.com.

Note:
The images in this tutorial use a display setting to change the color of the back of the surfaces.

Front face (1), backface (2). Yellow arrows indicate surface normal direction, and green color indicates surface backface. This lets you see which way the normal direction of the object faces. Search the Rhino Help for Backface settings.
**Marine Terms Used in this Tutorial**

**Sheer**
- The fore-and-aft curvature from the bow to the stern of a ship’s deck as shown in side elevation.

**Chine**
- The intersection of the bottom and the sides of a flat or v-bottomed boat.

**Transom**
- The planking forming the stern of a square-ended boat.

**Fair**
The meaning of “fair” is much debated in the marine industry. No one can define it, but they know when they see it. Although fairing a surface is traditionally associated with hull surfaces, all visible surfaces on any object can benefit from this process. In Rhino, the first cue for fairness in a surface is the spacing of the surface display isocurves.

There are other characteristics of fair curves and surfaces. Although a curve or surface may be fair without exhibiting all of the characteristics, they tend to have these characteristics. If you keep these in mind while modeling, you will end up with a better final product.

The guidelines for creating a fair surface include:
- Use the fewest possible control points to get the curve shape.
- Use the fewest possible curves to get the surface shape.

**Lay out the hull curves**
The hull lines were created by tracing the original plans using a background bitmap. The first step is to check the lines for fairness before creating surfaces from them.

The designer’s lines are illustrated. The sheer and chine have been extended at the forward and aft ends to accommodate the lofting process.
Start the Model

- Open the tutorial model file Victory.3dm.
- Download the tutorial models.

The lines are laid out on the Plan layer and the Profile layer.

Check the curves for fairness

Select each of the designer’s curve pairs in plan and profile and use the CurvatureGraph command to determine if the curves are "fair." In this case, the file has the original curves that were traced from the background bitmap. They are not "fair." In other words, the curves do not smoothly transition from one end of the sheer to the other. If any curve is not fair, adjust points to make it fair. Start with the sheer (the curve at the top of the hull shape). It has the biggest impact on the appearance of the vessel.

Check curvature

1. Select the curves you want to check.
2. Use the CurvatureGraph command to display its curvature graph.

The illustration shows the curvature graph applied to the two-dimensional sheer in profile.

The curvature graph should be continuous and exhibit the characteristics desired for the curve. When the curve is concave downward, the graph will be above the curve. Conversely, concave upward curves will have their graphs below them. The point of inflection (where the curve is neither concave upward nor downward) is indicated where the graph crosses the curve.

Fix the curvature

Before doing any point editing to make the curves fair, rebuild the curves to remove excess control points. Select each curve and use the Rebuild command to reduce the number of points and set the degree. Do not use more points than you absolutely need.

Use the CurvatureGraph command to check the curves again for fairness. If the curvature graph is still not satisfactory, move the control points until you have a smooth graph. Proceed with the rest of the curves in the model to be certain they are fair before beginning to surface the model.

Rebuild the curves

1. Select the sheer curve.
2. Start the Rebuild command.
3. In the Rebuild Curve dialog box, change the Point count to 6 and the Degree to 5.

Create the 3-D curves

So far, you have been working with two-dimensional curves. In order to loft the surfaces, these planar curves will be used to create to three-dimensional curves and the planar curves can be discarded.

With the 3D Lines layer current, select the profile and plan view representations of each curve. Use the Crv2View command to create the three-dimensional curve that combines the x-, y-, and z-coordinates of the two-dimensional curves. The two-dimensional curves must be planar for this command to work.
Create the three-dimensional curves

1. Set the **3D Lines** layer current.
2. **Select** the plan and profile representations of the sheer curve.

3. Start the **Crv2View** command.
   The three-dimensional representation of that curve will be created.

4. When you are satisfied that the proper curve was created, delete or **Hide** the two-dimensional representations.
5. Repeat the **Crv2View** command for the chine curve.

---

**Revise the curves**

For the loft process to work on the bottom panel, it cannot come to a point. The lofted shape must be rectangular. This is why the curves are extended beyond the centerline. The curves can be lofted into a rectangular surface that can then be trimmed back. The curves in the Victory model are already extended for you except for the bottom centerline curve.

---

**Copy the centerline curve**

We are going to use a copy of the centerline to create a new extended curve for lofting the hull bottom.

1. **Copy** the centerline using the **InPlace** option.
2. **Hide** the centerline.

---

**Shorten the centerline**

1. Select the centerline.
2. Start the **SubCrv** command.
3. At the **Start of curve** prompt, using the **End** object snap, click the aft end of the centerline.

![End object snap](image1)

4. At the **End of curve...** prompt, using the **Midpoint** object snap, click the middle of the curve.

![Midpoint object snap](image2)

---

**Extend the centerline**

1. Start the **Extend** command, and at the **Select boundary objects...** prompt, press **Enter** for **dynamic extend**.

2. At the **Select curve to extend...** prompt, set the **Type** to **Smooth** and select the centerline near the forward end.
3. Draw the curve so it aligns nicely with the chine and sheer curves in the plan view as illustrated.

This creates a new bottom curve to use for the surface loft.
4. Turn on the control points (F10) to check the curve.

**Loft the hull surfaces**

Now that you have created a set of edge curves for the side and bottom, create lofted surfaces from these curves. Start by lofting the bottom surface. Once you have finished it, use its upper edge as the curve from which to loft the side panel.

To loft the bottom panel, select the two edges (chine and centerline) and use the **Loft** command. In this case, be sure to select the new centerline you created in the previous step.

**Loft chine and centerline**

1. Select the chine and centerline.
2. Start the **Loft** command.
3. In the **Loft Options** dialog box, under **Cross-section curve options**, select **Rebuild with...**, and set the control point count to 15, click **OK**.
Loft the side and bottom

1. Select the surface edge and the sheer curve.

   Tip: Hold Ctrl + Shift to select the upper edge of the loft surface.

2. Repeat the Loft for the side panel.
3. In the **Loft Options** dialog box, under **Cross-section curve options**, select **Rebuild with...**, and set the control point count to **15**, click **OK**.

**Trim the bow and bottom**

When you have successfully created both the side and bottom surfaces, construct a buttock one-half inch off the centerline and trim both surfaces to this buttock. To do this, in the **Top** viewport, draw a line longer than the hull and one-half inch to the right of centerline.
**Draw a trim line**

1. In the **Top** viewport, draw a **Line** along the centerline (x-axis) that is longer than the hull.

   ![Diagram showing a line along the centerline](image)

   This creates a curve that will be used in the next step. We want a small gap down the center of the boat between the two halves for a keel.

2. In the **Top** viewport, offset the line 1/2 inch toward the hull surfaces.

   ![Diagram showing offset line](image)
**Trim the side and bottom to the trim line**

- Using the **offset curve**, **Trim** the bottom (1) and side (2) as illustrated.

**Build the transom**

Like all surfaces in this tutorial, the transom will be built with a surface larger than the finished surface and then trimmed to the hull.

To make sure there is enough surface area to trim, **Extend** the transom centerline by a foot or two both above the sheer and below the centerline. **Trim** the hull surfaces with the transom centerline.
1. With the Profile layer on, start the Extend command.
2. At the Select boundary objects or enter extension length. Press Enter for dynamic extend prompt, press Enter.
3. At the Select curve to extend... prompt, in the Front viewport, set the Type to Natural, and select near the top of the transom centerline.

4. At the End of extension prompt, select a point above the current top of the transom centerline.

5. At the next Select curve to extend... prompt, select near the bottom of the transom centerline.
6. At the End of extension prompt, select a point below the current bottom of the transom centerline, press Enter.
Trim and Join the hull surfaces

1. **Select** the transom centerline.

2. Start the **Trim** command.
3. Set **UseApparentIntersections=Yes**.
4. In the **Front** viewport, at the **Select object to trim...** prompt, select the hull side and bottom surfaces aft of the transom centerline.

5. **Join** the hull bottom and side.

Mirror the hull surfaces

In the **Right** or **Top** viewport, **Mirror** the two hull surfaces about the centerline. Use the **EdgeSrf** command to create surfaces between the two hull halves.

1. **Select** the two hull surfaces.
2. Start the **Mirror** command.
3. In the **Top** viewport, at the **Start of mirror plane...** prompt, type **0**, press **Enter**.
4. At the **End of mirror plane** prompt, with **Ortho** on, drag the mirror plane along the x-axis, and click.
Create the keel surface

1. Start the \texttt{EdgeSrf} command.
2. At the \texttt{Select 2, 3, or 4 curves} prompt, select the two inner edges of the hull bottom along the keel.

3. Repeat the \texttt{EdgeSrf} command.
4. At the \texttt{Select 2, 3, or 4 curves} prompt, select the two inner edges of the hull sides along the keel at the bow.

\textbf{Tip:} The order you select the surface edges determines what direction the keel surface faces.

Extrude the surface

To create the transom surface, \texttt{Extrude} the transom centerline.
1. In the **Front** viewport, select the extended transom centerline.

2. Start the **ExtrudeCrv** command.

3. At the **Extrusion distance** prompt, set the command-line option `BothSides=Yes`.

4. In the **Perspective**, **Top**, or **Right** viewport, drag the extension beyond the hull surface.

---

**Trim the transom**

Trim the transom surface with the hull and a line from the hull edges.
1. Draw a line between the two aft hull top edges.

2. Start the **Trim** command.

3. At the **Select cutting objects** prompt, select all of the hull surfaces, including the keel surface and the line at the top of the hull, press **Enter**.

4. At the **Select object to trim...** prompt, select the transom surface outside of the hull lines and surfaces, press **Enter**.

The transom is now complete.
Check for errors

1. **Join** all of the surfaces.
2. Use the **ShowEdges** command to check that the join was successful.
   
   Display the *naked* edges. Naked edges are surface edges that are not joined to other surfaces. In this case, the only naked edges should be the ones you expect around the outside of the hull surfaces – not those between the surfaces.

   When you have your surfaces built and joined, and have no unjoined edges, look at the surface with the curvature analysis tools.

Add the deck

The last step is to create the deck surface. In the profile lines, two curves describe the silhouette of the deck curve. You will use this curve to create the deck.

Use the **Project** command to project the vertical line to the side of the hull. This line will act as a marker for the end of the curve. In the **Front** viewport, draw a curve from the end of the deck centerline curve to the end of the projected curve on one side of the hull. Use **Planar** mode to keep the curve planar. Place the first three control points using **Ortho** to keep them lined up at the center.
Project the vertical deck edge to the hull

1. **Select** the hull and the vertical line.
2. In the **Front** viewport, use the **Project** command to project the curve to the hull.
   The curve will project to both sides of the hull, so you can draw your cross-section curve on either side.
Draw the cross-section curve

1. Click the Planar pane in the status bar to turn on Planar mode.
2. In the Right viewport, use the Curve command to draw a control point curve from the top end of the deck centerline curve to the top of the curve projected to the hull.
   Use Ortho to place the first three control points in a straight line.

   ![Diagram](image1)

   Use the End object snap to place the last point at the top of the projected curve on the hull.
3. Use the CurvatureGraph command to check the curve.

   ![Diagram](image2)
Create the deck surface

1. Use the **Sweep2** command to create the deck surface.
2. At the **Select rail curves** prompts, select the centerline curve and the hull edge.
3. At the **Select cross section curves...** prompt, select the cross-section curve you created from the deck centerline curve to the projected curve on the hull, press **Enter**.
**Mirror the deck**

1. Use the **Mirror** command to copy the deck surface to the other side.
   At the **Start of mirror plane...** prompt, in the **Top** viewport, type **0**, press **Enter**.
2. At the **End of mirror plane...** prompt, in the **Top** viewport, drag the mirror plane with **Ortho** on.

**Fill in the missing surface**

- Use the **EdgeSrf** command to create the small triangular surface at the tip of the bow.
Join the parts

- Select all of the surfaces and use the Join command to create a single polysurface.
Dragonfly - Trace Images

This tutorial demonstrates how to get started modeling an object using photographs as reference material. You will learn how to:

- Trace an image to create profile curves.
- Create cross-section curves for lofting the profiles.
- Edit control points to change a surface shape.

Starting images.

Finished model.

Note: The top and side views are actually of different specimens of this dragonfly. In the side view, the wings are folded up. We will be using the side view image only to draw the side view curves of the body.

Draw the body

Since the dragonfly is symmetrical in the top view, and the model is not going to be a scientific reproduction, trace one side of the dragonfly and mirror the curve to the other side. For the side view, draw two curves since the profile is not symmetrical. Then we will loft cross section curves to make the body. The head will be made separately.

The tail and body will all be made in one piece. The tail is actually several segments that flex. If you were making an animation or a scientific model, you probably would want to divide the dragonfly into smaller surfaces.
Start the model

1. Begin a **New** model.
2. In the Template File dialog box, select **Small Objects - Millimeters.3dm**, and click **Open**.

Draw a reference line

- In the Top viewport, use the **Line** command to draw a reference line **50 millimeters** long starting at **0,0,0**.

Place the top view image

1. Start **PictureFrame** command.
2. Find the image file **DragonFly Top.jpg**, and place the image in the Top viewport.

   ![Download the tutorial models](download_tutorial_models)

   Use the reference line to set the length of the picture frame image.

Move the image into place

- Use object snaps to **Move** the image from the midpoint of the left side (**Mid**) to the construction plane origin at **0,0,0**.
**Place the side view image**

1. Start **PictureFrame** command.
2. Find the image file **DragonFly Side.jpg**, and place the image in the **Front** viewport. Use the reference line to set the length of the picture frame image.

3. Using **Ortho**, drag the image down in the **Front** viewport until the reference line matches the center of the dragonfly body.

**Prepare the view**

- **Hide** the side view picture frame.


**Draw the outline curve**

- In the **Top** viewport, use the **Curve** command to draw an outline of the top half of the dragonfly body.
  - Use as many control points as you think are necessary for the detail.
  - Draw only up to the neck. You will be creating the head another way.

![Outline Curve](image1)

**Mirror the curve**

- In the **Top** viewport, use the **Mirror** command to copy the curve around the reference line.
  - The photograph shows that the dragonfly is not symmetrical about its center line. However, since your dragonfly will be stylized, it does not matter in this case. You can choose the level of accuracy you need.

![Mirror Curve](image2)

**Show the side view image**

- Use the **Show** command to show the side-view picture frame object.
**Bend the curve**

- In the **Front** viewport, use the **Bend** command to bend the curves down at the tail to match the bend in the body curve in that view.

**Trace side-view body**

- In the **Front** viewport, use the **Curve** command to trace the body outline using two curves, one above the reference line and one below the reference line.
  
  Maximize the viewport and zoom in. Pick as many points as you need to create the curves. Use more points when rounding a corner and fewer points for a straight section.

**Prepare the view**

- **Hide** the picture frame objects and the reference line.
Create the body surface

- Use the **CSec** command to create cross-section profile curves through the top, bottom, and side curves.

  Draw as many cross-section curves as you need to maintain the detail. You will be able to see whether you have enough curves when you loft the surface in the next step. If you do not have enough curves to maintain the shape in an area, add more and retry the surface loft.

Loft the body

1. **Select** all the cross-section curves you just created.
2. Use the **Loft** command to create a surface through the cross-section profiles.
**Draw the head**

Draw the head with an ellipsoid and move the control points around to deform the head. The eyes are also ellipsoids. The neck is a surface blend.
Draw the head
1. Use the **Ellipsoid** command with the **Diameter** option to start the ellipsoid in the **Front** viewport.
2. Use **Elevator Mode** to position the first point.
   
   At the **Start of first axis** prompt, press and hold the **Ctrl** key and in the **Top** viewport click near the side of the head.
3. In the **Front** viewport, move the cursor up to the center of the head in the side view and click.
4. At the **End of first axis** prompt, turn on **Ortho** in the **Top** viewport, click at the other side of the head.
5. At the **End of second axis** prompt, draw pick a point in the **Front** viewport to establish the head size from front to back. Watch the preview in the **Top** viewport to check the overall size.

6. At the **End of third axis** prompt, pick a point in the **Front** viewport at the top of the head.

**Note:** Drawing the ellipsoid in this order and using these viewports is important to get the poles of the ellipsoid in the right place for the next step.
- **Rebuild the ellipsoid**

  Use the **Rebuild** command to add more control points to the ellipsoid. Set the point count to 16 in the u-direction and 10 in the v-direction.
Drag control points to shape the head

1. Use the PointsOn command to turn on control points for the ellipsoid.

2. In the Top viewport, select and drag points on both sides of the ellipsoid toward the back to deform the head.

3. In the Right viewport, drag the middle two rows of points down.

Blend the head and body

The neck is a blend surface between the head shape and the body. First, you are going to trim the head shape to make an opening.
**Trim the neck**

- In the **Front** viewport, draw lines as illustrated, and use the **Trim** command to trim the head and body shapes with the lines.

**Blend the neck and body**

- Use the **BlendSrf** command to make a blend surface between the head and body. Be sure the seams are aligned and the direction arrows point the same way.
Draw the eyes

The eyes are simple ellipsoids.

- **Draw the base ellipsoid**
  - Use the Ellipsoid command to draw the eye.
  - Base the size and position on the images.

- **Position the eye**
  - Use the Orient command or the Move and Rotate commands to adjust the position of the eye.

- **Mirror the other side.**
  - Use the Mirror command to copy the eye to the other side.
Shape the tail

The end of the tail has a rounded shape cut out of it. Use a Boolean to make this shape.

Cap the body

1. If necessary, extend the tail section by turning on the control points and dragging them to match the bitmap.
2. Use the Cap command to make the body into a solid.

Draw a cutting cylinder

- Use the Cylinder command to draw a solid cylinder so it cuts through the tail as illustrated.

Boolean the tail

- Use the BooleanDifference command to cut the end out of the tail.
Trace the wings

The wings are solids created from closed curves. The legs are created by tracing a polyline down the center of a leg and using a pipe surface to make a series of tubes around the polyline.

Draw the outline curve

- In the Top viewport, use the Curve command to trace the wings on one side of the dragonfly.

Extrude the curve to make a solid

- Make the curves into thin solids with the ExtrudeCrv command.
  Set the command-line option Solid=Yes to Yes.
**Move the wings into position**

- Position the wings on the back with the **Move** command.
  Consult the side view image of the dragonfly. The front wing is slightly higher than the back wing.

**Mirror the wings to the other side**

- Use the **Mirror** command to copy the wings to the other side.
**Draw the legs**

The legs are piped polylines with different radii at the start and end of the pipes.

1. **Draw the base polyline**
   - In the Top viewport, use the *Polyline* command to trace down the center of the legs.
   - Edit the control points to position the legs in the Top and Front viewports.
     You will have to use your imagination a little for this since the two pictures do not show the legs of the same insect.

2. **Pipe the legs**
   - Use the *Pipe* command to draw the legs around the polylines.
   - Refer to the background picture to determine the starting and ending diameter of the pipe.

3. **Mirror the legs**
   - Use the *Mirror* command to copy the legs to the other side, or draw different legs for the other side.
Finishing touches

For added realism, add color, reflectivity, and transparency.

Render the model

- Add materials and textures and render.
Wrap Text - Flow along surface

This tutorial demonstrates wrapping text solids and other objects on a cylinder. These objects could be used to trim holes in the cylinder.

You will learn how to:
- Create text as solid objects.
- Wrap the objects to a surface.

Make a surface

For this example, create a simple cylinder. Once you have learned the basic technique, you will be able to use other types of surfaces. Remember that trimmed surfaces maintain their basic rectangular shape. This underlying shape will affect the placement of the text.

Create a cylinder

> In the Perspective viewport, use the Cylinder command with the Vertical option to create a solid cylinder.
Create the objects to wrap

These solid objects will be wrapped on the cylinder surface.

Create the text

1. Use the TextObject command to create your text using Solids.
   Choose a font that is fairly large and blocky rather than one with many holes and details.
   Set the Height at about 1.5 units.
   Set the Solid thickness to .1 units.
2. Place the text on the construction plane near the cylinder. The location is not important.

Control the object placement

The CreateUVCrv command generates the planar border curves of a surface that can be used as a guide to orient your text. Use the border rectangle to lay your text out before re-applying it to the cylinder. The rectangle then is used as a reference to guide the placement of the other objects.
Create the UV curve

1. Use the CreateUCrv command on the cylinder side to create curves that represent the border of the surface on the construction plane.
2. Select the side of the cylinder.
   A rectangle is created starting at 0,0 on the Top construction plane.

Position the text objects

- Use Move, Rotate, and Scale or other transforms to arrange the text objects inside the rectangle just the way you want them to appear on the cylinder.
  Add any other decoration curves you want to use.

Create a reference surface

- Use the PlanarSrf command to make the rectangle into a surface.
  You will use this surface later as a reference object for the FlowAlongSrf command.

Extrude the decoration curves

1. If you have created other curves, select these.
2. Use the ExtrudeCrv command to thicken the decorations to match the letters.
3. At the **Extrusion Distance**... prompt, set **Solid=Yes**.
4. At the **Extrusion distance**... prompt, type **.1**.

![Diagram of Wrap Text - Flow along surface]

**Wrap the lettering on the cylinder**

1. Select the lettering and the decoration.
2. Start the **FlowAlongSrf** command.
3. At the **Base surface**... prompt, set **Rigid=No**.
4. Click the **rectangular plane** near the "lower-left" corner as illustrated.

5. At the **Target surface...** prompt, click the cylinder near the lower edge of the seam as illustrated.

The text and decoration solids wrap around the cylinder.

Now you can use the letters to cut the cylinder or Boolean the objects together.
Mechanical Part - Blocks

This example shows how to use Rhino to model a simple mechanical part. You will learn to

- Create extrusion objects.
- Boolean difference shapes.
- Drill holes.
- Create a 2-D line drawing from the 3-D shapes.
- Dimension the 2-D line drawing and modify dimension text.

Open the tutorial model

1. Open the tutorial model file Toolblock.3dm and then click Open.

Create solid shapes

Start by creating two basic solid shapes from the profile curves on layers Profile-01 and Profile-02.

Set up the layers

1. In the Layers panel, confirm that the Profile-01 layer is current.

Extrude the profile curve

1. On the Solid menu, click Extrude Planar Curve > Straight.
2. Turn on the End object snap.
3. At the **Select curves to Extrude** prompt, select the blue profile curve, and press **Enter**.

4. At the **Extrusion distance** prompt, set the command-line **Solid** and the **DeleteInput** options to **Yes**.

5. Click the end of the magenta construction line.

The extruded shape is a solid because it forms a closed volume in space.

- **Hide the solid**
  - **Select** the solid, on the **Edit** menu click **Visibility > Hide**.

- **Set up the layers**
  - In the **Layers** panel, make layer **Profile-02** current.
**Extrude the profile curve**

1. **Select** the red profile curve.

2. On the **Solid** menu, click **Extrude Planar Curve > Straight**.

3. At the **Select curves to Extrude** prompt, set the command-line **Solid** and the **DeleteInput** options to **Yes**.

4. At the **Extrusion distance** prompt, in the **Front** viewport, drag the extrusion above the height of the blue curve and click.

The solid appears on the current red layer Profile-02.
Show the solid

- On the **Edit** menu click **Visibility > Show**.

Boolean the two solids

1. On the **Solid** menu, click **Difference**.
2. At the **Select surfaces or polysurfaces to subtract from** prompt, select the blue solid, and press **Enter**.
3. At the **Select surfaces or polysurfaces to subtract with** prompt, set the command-line **DeleteInput** option to **Yes**.
4. **Select** the red solid, and press **Enter**.
   - The result will be a new solid or polysurface. A polysurface is a collection of surfaces that can be closed or open. A solid is a collection of surfaces that is closed.
Drill the holes

A construction circle is already in place for creating the first hole.

Make holes in the solid

1. **Select** the green circle as shown.

2. On the **Solid** menu click **Solid Edit Tools > Holes > Make Hole**.

3. At the **Select a surface or polysurface** prompt, select the blue polysurface.
4. At the **Cut depth point** prompt, drag the hole through the upper portion of the object.

5. Pick a point in **Front** view.
Copy the holes

After one hole is drilled, you can copy the others.

1. In the Osnap control, turn on the Point object snap.

Note: Copy Holes is actually the MoveHole command with the command-line Copy option set to Yes.

3. At the Select holes in one planar surface prompt, select the first hole, and press Enter.

4. At the Point to copy from prompt, pick the point object in the center of the first circle.
5. At the **Point to copy to (Copy=Yes)**: prompt, pick the point that makes the center of the next hole.

6. Repeat this for the two holes that are on the other side of the part.

**Note:** Do not use the point in the center of the part.

---

**Create the round hole**

The center hole is different in that it does not pass entirely through the upper part of the blue solid. There is no reference circle to start from.

1. On the **Solid** menu, click **Solid Edit Tools > Holes > Round Hole**.
2. At the **Select target surface** prompt, select the top surface of the blue solid.
3. At the **Center point** prompt, set the command-line options as follows:
   - Depth = 0.5
   - Diameter = 0.312
   - DrillPointAngle = 180
   - Through = No
   - Direction = CPlaneNormal

4. Click the point object in the middle of the blue solid to finish creating the hole.

---

**Test the solid**

The resulting polysurface is a closed solid. A solid defines a closed volume in space. The **Properties** command will report if this part is a closed solid. The **Properties** command will give you information about the open/closed status of the object.

1. **Select** the part.
2. On the **Edit** menu, click **Object Properties (F3)**.
3. In the **Properties** panel, click **Details**.
   - In the **Object Description** window, you will find the listing to confirm that the object is valid and closed.
     - Geometry:
     - Valid polysurface.
     - Closed solid polysurface with 23 surfaces.
Make a 2-D drawing

The **Make2D** command generates 2-D lines from the 3-D solid.

Create a 2-D line drawing

1. **Select** the part.
2. On the **Dimension** menu, click **Make 2D**.
3. In the **2-D Drawing Options** dialog box, under **Drawing layout** click **4 view (USA)**.
   Under **Options**, check the **Show tangent edges** and **Show hidden lines** boxes.
4. Click **OK**.

Dimension the 2-D drawing

Using the 2-D drawing, add dimensions for the part.

Set up the layers

1. In the **Layers** panel, make **Dimensions** layer current.
2. Turn off all layers except **Dimensions** and the **Make2D** layers.
3. In the **Linetype** column for the **Make2D > hidden > lines** layer, click **Continuous**.
4. In the **Select Linetype** window, select **Dashed**.

Set up the viewport

- Double-click the viewport title to maximize the **Top** viewport.

Dimension the part

1. On the **Dimension** menu, click **Linear Dimension**.
2. In the **Osnap** control, turn on the **End** object snap; turn off the **Point** object snap.
3. At the **First dimension point** prompt, pick the upper left corner of the part.
4. At the **Second dimension point** prompt, pick the upper right corner of the part.
5. At the **Dimension location** prompt, pick a location for the dimension line.
6. Repeat to generate a vertical dimension on the right side of the part.

---

**Chain dimension the part horizontally**

1. On the **Dimension** click **Linear Dimension**.
2. At the **First dimension point** set the command-line **Continue** option to **Yes**. This will generate a chain of dimensions.
3. At the **First dimension point** prompt, pick the lower left corner of the part.
4. At the **Second dimension point**, prompt turn on the **Center** object snap and pick the center of the first circle.
5. At the **Dimension location** prompt, pick below the part.
6. At the next **Dimension location** prompts, continue picking the centers of the circles.
7. Finish by picking the lower right corner of the part, press **Enter**.
Chain dimension the holes vertically

- Repeat the chain dimensions to create vertical dimensions.

Add radial dimensions

2. At the Select curve for radius dimension prompt, select the hole on the far right.
3. At the Dimension location prompt, pick above the part.
4. Double click the radial dimension text, and in the text edit box, add the text Typ. 5 Places.
Mechanical Part - Layouts

This example shows how to use Rhino to model a simple mechanical part. You will learn to create a layout with a title block for printing.

Open the tutorial model

- Open the tutorial model file Toolblock.3dm and then click Open. 

Download the tutorial models.
Layout viewports

Use a layout to arrange the 2-D lines for printer.

**Add viewport tabs**

1. On the Viewport tabs, click the Add new tab (+) icon.
2. On the menu, click New Layout.

3. In the New Layout window, select the following:
   - Orientation = Landscape
   - Width = 11 inches
   - Height = 8.5 inches
   - Initial Detail Count = 1
   Page 1 will appear in the viewport tabs.
Insert a title block

In this section you will add a title block and re-size the detail to fit.

Set up the layers

1. In the Layers panel, make the Title Block layer current.
2. Confirm that you are in layout space.

Insert the title block

1. On Edit menu, click Block > Insert Block Instance.
2. From the name list, select Ansi_A_TB.
3. Under Insertion point, check the Prompt box, and click OK.
4. Select the detail.

Note: Click on the detail edge to select it. Make sure the detail is not active.

5. On the Edit menu click Control Points > Control Points On (F10).

6. Drag the control point in the lower left corner to re-size the detail to fit in the title block.
7. Press the Esc key to turn off the control points.

Lock the detail view

1. Select the detail.
2. On the Edit menu, click Object Properties (F3).
3. In the Properties panel on the Detail page, under Scale, set the inches on page and inches in model to 1.0.
4. Check the Locked box
   This prevents future panning and zooming so the details stays the correct size.
Add print widths

1. In the status bar, right-click the Layer pane to open the Layer panel.
2. Click Default in the PrintWidth column, and set the values to the following:
   - Dimension = .35
   - Title Block = .5
   - Make2D > visible > lines = .70

The layout view displays a preview of the print widths as they will appear on the printed page.